Subject: [domainrep] I-D Action: draft-ietf-repute-query-http-00.txt

From: [email-masked]
Date: Sat, 19 Nov 2011 22:23:09 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Reputation Services Working Group of the IETF.

	Title           : Reputation Data Interchange using HTTP and XML
	Author(s)       : Nathaniel Borenstein
                          Murray S. Kucherawy
	Filename        : draft-ietf-repute-query-http-00.txt
	Pages           : 9
	Date            : 2011-11-19

   This document defines a mechanism to conduct queries for reputation
   information using the Domain Name System.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-repute-query-http-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-repute-query-http-00.txt

---

From: "Mykyta Yevstifeyev (М. Євстіфеєв)" <[email-masked]>
Date: Sun, 20 Nov 2011 14:13:52 +0200

Some comments on this draft:

What will be the format of the template received using 
/.well-known/repute_template?  The document doesn't mandate, but I 
suppose it should be text/plain.  Also, in Section 4, that *is* IANA's 
function to track well-known URIs (see 
http://tools.ietf.org/html/rfc5785#section-5.1).

The XML representation of application/reputon.  How will it affect the 
text representation defined in the other doc?  And are there more 
representations to occur?  And shouldn't the finite (or one of them) 
representation be defined?

When specifying an XML schema, you should have a reference to XSD spec., 
I think.

And, again, how one should identify RFCxxxx?  (Please excuse for third 
mentioning of this.)

Mykyta Yevstifeyev

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 20 Nov 2011 11:47:05 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of "Mykyta Yevstifeyev (?. ?????????)"
> Sent: Sunday, November 20, 2011 4:14 AM
> To: [email-masked]
> Subject: Re: [domainrep] I-D Action: draft-ietf-repute-query-http-00.txt
> 
> What will be the format of the template received using /.well-
> known/repute_template?  The document doesn't mandate, but I suppose it
> should be text/plain.

Yes, and that's the default as well.

> Also, in Section 4, that *is* IANA's function to
> track well-known URIs (see http://tools.ietf.org/html/rfc5785#section-
> 5.1).

Yes, but that's not an action for IANA created by this document.  Rather, this memo's publication generates a well-known URI registration request that goes to Designated Expert(s), who forward the request to IANA on approval.

We could include the registration request for completeness.

> text representation defined in the other doc?

The current plan is to replace the plain text one in the media-type document with the XML (or JSON) form, moving it from this document to that one.

> And are there more representations to occur?

It's unclear how the lightweight query decision will be made, so it's hard to say at this point.

> And shouldn't the finite (or one of them) representation be defined?
>
> When specifying an XML schema, you should have a reference to XSD
> spec., I think.

Yes, we'll have to generate one of those, though I imagine it's better to wait on that until we've settled on a format.

> And, again, how one should identify RFCxxxx?  (Please excuse for third

Fixed.

-MSK

---

From: "Mykyta Yevstifeyev (М. Євстіфеєв)" <[email-masked]>
Date: Mon, 21 Nov 2011 13:54:07 +0200

> Yes, and that's the default as well.

So you should discuss this in the spec.

> Yes, but that's not an action for IANA created by this document.  Rather, this memo's publication generates a well-known URI registration request that goes to Designated Expert(s), who forward the…

But that's an IANA action anyway.  Also, this is what the current specs 
follow (see eg. http://tools.ietf.org/html/rfc6415#section-6.1).

> The current plan is to replace the plain text one in the media-type document with the XML (or JSON) form, moving it from this document to that one.

Yes, it would be good to separate reputon format and the other docs.

> It's unclear how the lightweight query decision will be made, so it's hard to say at this point.

I actually like some single format, XML probably.

Mykyta Yevstifeyev

> _______________________________________________
> domainrep mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/domainrep
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 21 Nov 2011 11:49:16 -0800

> Sent: Monday, November 21, 2011 3:54 AM
> To: [email-masked]
> >> known/repute_template?  The document doesn't mandate, but I suppose
> >> it should be text/plain.
> > 

I'm not keen on the idea of repeating in our specs what's defined elsewhere, but I could instead say that the server SHOULD return a text/plain reply.

> >> Also, in Section 4, that *is* IANA's function to track well-known
> >> URIs (see http://tools.ietf.org/html/rfc5785#section-
> >> 5.1).
> >
> > Yes, but that's not an action for IANA created by this document.
> > Rather, this memo's publication generates a well-known URI registration
> > request that goes to Designated Expert(s), who forward the request to
> > IANA on approval.
> 

OK, I'm fine with following precedent.  But it seems strange when it's the Designated Expert who creates the IANA action, and not the publication of this document.

> Yes, it would be good to separate reputon format and the other docs.

This document currently specifies the XML format.  That will be moved to the media-type document soon, with an XSD added, and replace the simple text format that's in there now.  That's a better division; one document specifies transport, and the other specifies payload.

However, some separate thread will debate whether or not we stick with XML or change to JSON.

> I actually like some single format, XML probably.

You can debate that in the other thread.  :-)

-MSK