Subject: [domainrep] Fwd: repute minutes

From: Dave CROCKER <[email-masked]>
Date: Wed, 16 Nov 2011 23:44:49 +0800

Folks,

Here's the draft of notes that John took for today's meeting in Taipei.

Please comment on any changes you'd like.

d/

-------- Original Message --------
Subject: repute minutes
Date: 16 Nov 2011 16:09:18 +0800
From: John R. Levine <[email-masked]>
To: Dave Crocker <[email-masked]>

REPUTE WG, IETF 82, Weds 1510

* Note Well

* Status of drafts (Murray)

Murray: Authentication stuff in http draft not intended to be definitive

Model, media type, http query, vocab-email drafts: fairly strong hum in favor

Murray: reputation-model should die since it's based on a misunderstanding,

    ACTION:  hum favors letting it die

Document about management: worry about it later

* URI Templates

Dave,John: do we need the complexity of templates?

John: templates put complexity into clients, fixed syntax puts complexity into 
servers

Andrew Sullivan: Where are costs of complexity greater?  Don't put it
there.

    ACTION:  Decide on the list

* DNS vs. UDP

Dave: list has no support for UDP

Alexander Mayrhofer: could use COAP instead

Peter St Andre: COAP intended for constrained environments, e.g.,
switch to light socket. This would be an unanticipated use.

    ACTION:  Try and figure out what the requirements for lightweight
             transport are, on the list

* JSON vs. XML

Dave: arguments seemed to be about preference rather than technical advantage

Leif: if you want to sign, JSON better than XML

Alexander: XML signing is tough

Jeff Hodges: if you don't need the wild generality of XML, don't use it

Dave's summary: people with experience with both say that JSON is simpler
and easier to sign

Richard Barnes: is this about data formats or security around the data?  Dave:
about the data.

Hum: mild for JSON, none for XML, stronger for don't know enough

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Dave CROCKER <[email-masked]>
Date: Sat, 19 Nov 2011 07:56:11 +0800

Folks,

Please take 2 minutes (well, ok, maybe 3) to scan the minutes and post some +1s 
or suggested changes.

d/

-- 

   Dave Crocker

---

From: "Rolf E. Sonneveld" <[email-masked]>
Date: Sat, 19 Nov 2011 21:58:07 +0100

On 11/19/11 12:56 AM, Dave CROCKER wrote:
> Folks,
>
> Please take 2 minutes (well, ok, maybe 3) to scan the minutes and post 
> some +1s or suggested changes.
>
> d/
>

Someone (can't remember who) reacted that we should not discard XML in 
advance because of the mere fact that signing is tough c.q. there's not 
much experience with it. We don't even know whether we will need signed 
reputons.

>> Hum: mild for JSON, none for XML, stronger for don't know enough

One addition for the notes:

There was no time to discuss the extra topics (item 7. of the agenda). 
Discussion of them was moved to the list.

Thanks John, for taking the notes, IMV it's a good summary of what's 
been said.

/rolf

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sat, 19 Nov 2011 22:29:27 -0800

Those look right to me.  So, +1.

-MSk

---

From: Leif Johansson <[email-masked]>
Date: Mon, 21 Nov 2011 09:19:57 +0100

On 11/19/2011 12:56 AM, Dave CROCKER wrote:
> Folks,
> 
> Please take 2 minutes (well, ok, maybe 3) to scan the minutes and
> post some +1s or suggested changes.
> 

+1