Subject: [Dots] Gap analysis - SNMP

From: Daniel Migault <[email-masked]>
Date: Thu, 9 Apr 2015 10:58:39 -0400

Hi,

I would like to discuss how to position DOTS with SNMP.

DOTS defines that alert should be sent when some flow/cpu loads reach
certain level. This looks very similar to an SNMP alert. How do you think
DOTS shoud lposition toward SNMP?

BR,
Daniel

-- 
Daniel Migault
Ericsson

---

From: Russ Housley <[email-masked]>
Date: Thu, 9 Apr 2015 16:56:15 -0400

I see interest in SNMP for managers to pull status information, but little else.  YANG is the big focus in the OPS Area.

Russ

On Apr 9, 2015, at 10:58 AM, Daniel Migault wrote:

> DOTS defines that alert should be sent when some flow/cpu loads reach certain level. This looks very similar to an SNMP alert. How do you think DOTS shoud lposition toward SNMP?
> 
> BR, 
> Daniel 
> 
> -- 
> Daniel Migault
> Ericsson
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: Scott Barvick <[email-masked]>
Date: Thu, 9 Apr 2015 21:32:17 +0000

There is no overlap here.  SNMP (and NETCONF(YANG)) are operational
protocols and would at most be used by the higher level semantics that are
trying to communicate (IMO they are not the right ones, but we have to
have the discussion).  Of course, we will clearly need to utilize
mechanisms for transporting, authenticating, describing that exist so that
we don¹t try to invent something out of scope and already existing.

Scott

On 4/9/15, 4:56 PM, "Russ Housley" <[email-masked]> wrote:

>I see interest in SNMP for managers to pull status information, but
>little else.  YANG is the big focus in the OPS Area.
>
>Russ
>
>
>>certain level. This looks very similar to an SNMP alert. How do you
>>think DOTS shoud lposition toward SNMP?
>> 
>> BR, 
>> Daniel 
>> 
>> -- 
>> Daniel Migault
>> Ericsson

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 9 Apr 2015 18:21:41 -0400

I agree that there is no overlap and have gone down that path already (RID was pretty similar when it came into the IETF and I was asked to change it to SNMP, it came out something completely different through additional IETF transforms, not solving the same problem).  I don't want to see this work morph to fit exiting standards that are not a good fit for what is being done.  

Sent from my iPhone

> On Apr 9, 2015, at 5:32 PM, Scott Barvick <[email-masked]> wrote:
> 

Other options are better suited to the requirements of exchanging telemetry data and doing so in conditions that exist while undergoing a DoS attack.  There's a reason both proposals used IPFIX.

I agree with the points Russ made as well.

Thanks,
Kathleen
(Individual)