Subject: [Dots] Alignment with architecture document

From: "Roman D. Danyliw" <[email-masked]>
Date: Thu, 21 Jul 2016 09:39:04 +0000

Hello WG!

Chair hat off ...

In an attempt to validate the current thinking on the DOTS architecture, I reviewed the four individual solutions drafts [2][3][4][5] currently discussed by the WG to see whether the messaging they describe aligned with the text in the newly published (thanks Andrew, Flemming, Tiru, Chris and Rich) WG architecture document [1].  I found:

(1) The protocol drafts [2], [3] and [5] express their messaging in architecture terms described in [1].  Specifically:

** [2], [3] and [5] delineate that messages are sent by or to a DOTS server, client or gateway/relay per Section 2.2 of [1]
** [2] defines signal and data channel communications; and [3] and [5] define signal channel communication per Figure 2 of [1]
** [5] references an older version of [1]; and [2] and [3] do not reference [1].

(2) The protocol draft [4] does not express messaging in terms of the components (i.e., DOTS server, client or gateway) or interfaces (i.e., signal and data channels) described in [1].

The lack of alignment in [4] is the finding that is most interesting for me.  Does this draft [4] suggest we need new components or interfaces in the architecture? New use cases?

Regards,
Roman 

[1] draft-ietf-dots-architecture-00
[2] draft-reddy-dots-transport-05
[3] draft-francois-dots-ipv6-signal-option-00
[4] draft-fu-dots-ipfix-extension-01
[5] draft-nishizuka-dots-inter-domain-mechanism-01

---

From: "Teague, Nik" <[email-masked]>
Date: Thu, 21 Jul 2016 15:02:34 +0000

>The lack of alignment in [4] is the finding that is most interesting for me.  Does this draft [4] suggest we need new components or interfaces in the architecture? New use cases?

IMHO - No

I’m struggling to see the relevance here - And I’d be happy if someone could elaborate and explain what it is I’m missing.

Slide 2 of <https://www.ietf.org/proceedings/96/slides/slides-96-dots-2.pdf> shows routers sending flow (I presume, marked in red) to a DOTS client also labeled ‘flow analysis’ - I get that - what I don’t understand is the further red line between the DOTS client and server - why would the flow analyser then forward this to the controller (the DOTS server)?

Wouldn’t the DOTS client just speak DOTS to the DOTS server for those particular red lines?