Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-19.txt

From: [email-masked]
Date: Tue, 10 Apr 2018 06:39:53 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Specification
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-signal-channel-19.txt
	Pages           : 86
	Date            : 2018-04-10

Abstract:
   This document specifies the DOTS signal channel, a protocol for
   signaling the need for protection against Distributed Denial-of-
   Service (DDoS) attacks to a server capable of enabling network
   traffic mitigation on behalf of the requesting client.

   A companion document defines the DOTS data channel, a separate
   reliable communication layer for DOTS management and configuration
   purposes.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Signal Channel Specification";

   o  "| [RFCXXXX] |"

   o  reference: RFC XXXX

   Please update TBD statements with the port number to be assigned to
   DOTS Signal Channel Protocol.

   Also, please update the "revision" date of the YANG module.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-signal-channel-19
https://datatracker.ietf.org/doc/html/draft-ietf-dots-signal-channel-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-signal-channel-19

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Tue, 10 Apr 2018 13:47:48 +0000

Re-,

This version addresses the comments raised during the WGLC, in particular:  
- (Clarification) Indicate that only one hop-limit is included
- Specify the loop diagnostic payload 
- (Clarification) Indicate explicitly that GET messages with 'sid' are allowed
- Update the redirect behavior. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : mardi 10 avril 2018 15:40
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] I-D Action: draft-ietf-dots-signal-channel-19.txt
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "Jon Shallow" <[email-masked]>
Date: Wed, 11 Apr 2018 19:36:07 +0100

Hi Med,

Thanks for this.

Only one very minor issue seen so far (it was an issue in previous draft for
ttl) - alt-server-ttl is integer in some places (which is correct), and
unsigned integer in other places (YANG model / YANG tree / CBOR mapping)
which need to be corrected to integer (or int32).

General question - where are we with the port allocation and all the other
IANA requests for allocation?

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 10 April 2018 14:48
To: [email-masked]
Subject: Re: [Dots] I-D Action: draft-ietf-dots-signal-channel-19.txt

Re-,

- (Clarification) Indicate explicitly that GET messages with 'sid' are
allowed

Cheers,
Med

> [email-masked] Envoyé : mardi 10 avril 2018 15:40 À : 
> [email-masked] Cc : [email-masked] Objet : [Dots] I-D Action: 
> draft-ietf-dots-signal-channel-19.txt
> 
> 
>         Title           : Distributed Denial-of-Service Open Threat
Signaling
> (DOTS) Signal Channel Specification
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at
tools.ietf.org.

---

From: <[email-masked]>
Date: Thu, 12 Apr 2018 06:15:45 +0000

Hi Jon, 

Fixed those in the tree, YANG, and CBOR mapping table. Thank you for catching those. 

I don't have any update to share about the port allocation.

Cheers,
Med

> De : Jon Shallow [mailto:[email-masked]]
> Envoyé : mercredi 11 avril 2018 20:36
> À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
> Objet : RE: [Dots] I-D Action: draft-ietf-dots-signal-channel-19.txt
> 
> Hi Med,
> 
> Thanks for this.
>