Subject: Re: [Dots] FW: New Version Notification for draft-ietf-dots-use-cases-11.txt

From: "Jon Shallow" <[email-masked]>
Date: Mon, 2 Apr 2018 20:11:14 +0100

Hi Daniel,

This is looking good to me.  

Several nits

Nit #1

3.1

   o  On the other hand, the ITP may identify an enterprise network as

      the source of an attack and send a mitigation request for the

      enterprise to mitigate this at the source.

Who is the mitigation request sent to?

- perhaps ".. send a mitigation request to the enterprise DMS to mitigate
.."

Nit #2

3.1

       The DOTS Server signals

   the DOTS Client that it can serve this request, and mitigation is

   initiated on the ITP network by the DMS.

Perhaps for clarity ".. on the ITP network by the ITP's DMS." to clarify the
DMS referred to.

Nit #3

3.1

   The current scenario describes the case where the DDoS Target is in

   the enterprise network while the DMS is provided by the upstream ITP.

As the DMS term is used for both the enterprise and ITP in 3.1, which DMS
does this refer to?

- It would be assumptive to say that the enterprise DMS is (implied always)
provided by the upstream ITP as this may not be the case

- perhaps ".. while the secondary DMS is provided by the ...." to keep the
focus on the ITP, or

- perhaps ".. while the secondary DDoS Mitigation is provided by the
upstream ITP."

Nit #4

3.2

      In order to

   steer the traffic to the DDoS Mitigation Service Provider, some

   network configuration are required.

" some network configuration are" does not parse

- perhaps "some network configuration changes are"

Nit #5

3.2 Figure 3

     |                  |        | Provider         |

     |      +--------+  |        |             DDoS Attack

     |      | DDoS   |  |<----------------+         | ++====

     |      | Target |  |        |        |         | || ++=

     |      +--------+  |        |        |         | || ||

It is not immediately clear that the "cleansed" traffic is the now the upper
single dotted line between the ITP and Enterprise.

- perhaps the addition of the word Mitigated just above the arrow as per

     |                  |        | Provider         |

     |      +--------+  |  Mitigated               DDoS Attack

     |      | DDoS   |  |<----------------+         | ++====

     |      | Target |  |        |        |         | || ++=

     |      +--------+  |        |        |         | || ||

Nit #6

3.2

   requesting Enterprise Network DOTS Client sends a DOTS DDoS

   Mitigation termination requests to the DDoS Mitigation Service

   Provider.

- perhaps singular "..Mitigation termination request to the DDoS.."

Nit #7

3.3

   interface.  If the network administrator decides to start the

   mitigation, she orders through her web interface a DOTS Client to

   send a request for DDoS mitigation.  This request is expected to be

Female?

- perhaps "..mitigation, they order through their web interface a DOTS
Client .."

Nit #8

3.3

   Orchestration of the DDoS mitigation systems works similarly as

   described in Section XXX.  The Orchestrator indicates with its status

   whether the DDoS Mitigation is effective.

- perhaps ".. described in Section 3.1.  The .."

Nit #9

4.

       The DOTS protocol MUST be

   designed for minimal data transfer to address the blocking risk.

Is the MUST relevant to Use Cases?

- perhaps "The DOTS protocol is designed for .."

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of Daniel Migault
Sent: 28 March 2018 15:24
To: [email-masked]
Subject: [Dots] FW: New Version Notification for
draft-ietf-dots-use-cases-11.txt

Hi everyone!

Please find the draft-ietf-dots-use-cases-11 [1]. In order to meet the
aggressive schedule agreed during the session in London, we would greatly
appreciate your feed backs by the end of the week ! 

The current document is limited to 3 use cases described over 10ish pages.
We believe the current document addresses the feed backs and comments we
received from the London session. If you believe otherwise, feel free to
bring this on the mailing list.

We expect to publish version 12 on Tuesday April 3. This version is expected
to address the received comments and be ready to WGLC. 

Comments can be addressed directly to the mailing list or using github pull
requests on the mkd version [2]. If you believe some discussions are needed,
please consider discussing those on the mailing list. 

Yours, 

Daniel

[1]  <https://datatracker.ietf.org/doc/draft-ietf-dots-use-cases/>
https://datatracker.ietf.org/doc/draft-ietf-dots-use-cases/

[2]
<https://github.com/dotswg/dots-use-cases/blob/master/draft-ietf-dots-use-ca
ses.mkd>
https://github.com/dotswg/dots-use-cases/blob/master/draft-ietf-dots-use-cas
es.mkd

---

From: Daniel Migault <[email-masked]>
Date: Mon, 2 Apr 2018 20:08:30 -0400

Hi Jon,

Thank you very much for the feed backs. I will add them in the next version!

Yours,
Daniel

On Mon, Apr 2, 2018 at 3:11 PM, Jon Shallow <[email-masked]>
wrote:

> Perhaps for clarity ".. on the ITP network by the ITP's DMS." to clarify
> the DMS referred to.
>
>
>
> Nit #3
>
> 3.1
>
> - It would be assumptive to say that the enterprise DMS is (implied
> always) provided by the upstream ITP as this may not be the case
>
> It is not immediately clear that the "cleansed" traffic is the now the
> upper single dotted line between the ITP and Enterprise.
>
> - perhaps singular “..Mitigation termination request to the DDoS..”
>
>
>
> Nit #7
>
> 3.3
>
> - perhaps “..mitigation, they order through their web interface a DOTS
> Client ..”
>
>
>
> Nit #8
>
> 3.3
>
> - perhaps “.. described in Section 3.1.  The ..”
>
>
>
> Nit #9
>
> 4.
>
> - perhaps “The DOTS protocol is designed for ...”
>
>
>
> Regards
>
>
>
> Jon
>
>
>
> We expect to publish version 12 on Tuesday April 3. This version is
> expected to address the received comments and be ready to WGLC.
>
>
>
> Comments can be addressed directly to the mailing list or using github
> pull requests on the mkd version [2]. If you believe some discussions are
> needed, please consider discussing those on the mailing list.
>
>
>
> Yours,
>
> Daniel
>
> [1] https://datatracker.ietf.org/doc/draft-ietf-dots-use-cases/
>
> [2]  https://github.com/dotswg/dots-use-cases/blob/master/
> draft-ietf-dots-use-cases.mkd
>
>
>
>
>
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots
>
>

---

From: "Xialiang (Frank, Network Integration Technology Research Dept)" <[email-masked]>
Date: Wed, 4 Apr 2018 07:46:25 +0000

Hi Daniel,
Thanks for pushing forward this document. In general, this document is in a very good shape now, which I hardly find any technical issues, in addition to some nits as below:

Section 1:
/ as well as to illustrate the purpose of goals / as well as to illustrate the goals /

Section 2.2:
/ DDoS Mitigation Service: designates a service provides to a customer.  Services usually involves Service Level Agreement (SLA) that have to be met. / DDoS Mitigation Service: designates a service provided to a customer.  Services usually involve Service Level Agreement (SLA) that has to be met. /

Section 3.1:
/ which threaten to overwhelm their transit link bandwidth / to mitigate the attack which threaten to overwhelm their transit link bandwidth /

/ Note also that the DOTS Clients that sends / Note also that the DOTS Clients that send /

Section 3.2:
/ in figure 2, the traffic does not not / in Figure 2, the traffic does not /

/ in order to ensure that sufficient DDoS mitigation capacity and/or capabilities / in order to ensure that sufficient DDoS mitigation capabilities

One more comment for Figure 3:
Should it add one more link to represent the re-injecting traffic from DDoS mitigation service provider to enterprise network?

Thanks!

B.R.
Frank

-----邮件原件-----
发件人: Dots [mailto:[email-masked]] 代表 Daniel Migault
发送时间: 2018年3月28日 22:24
收件人: [email-masked]
主题: [Dots] FW: New Version Notification for draft-ietf-dots-use-cases-11.txt

Hi everyone!

Please find the draft-ietf-dots-use-cases-11 [1]. In order to meet the aggressive schedule agreed during the session in London, we would greatly appreciate your feed backs by the end of the week ! 

The current document is limited to 3 use cases described over 10ish pages. We believe the current document addresses the feed backs and comments we received from the London session. If you believe otherwise, feel free to bring this on the mailing list.

We expect to publish version 12 on Tuesday April 3. This version is expected to address the received comments and be ready to WGLC. 

Comments can be addressed directly to the mailing list or using github pull requests on the mkd version [2]. If you believe some discussions are needed, please consider discussing those on the mailing list. 

Yours, 
Daniel
[1] https://datatracker.ietf.org/doc/draft-ietf-dots-use-cases/
[2]  https://github.com/dotswg/dots-use-cases/blob/master/draft-ietf-dots-use-cases.mkd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, March 28, 2018 10:04 AM
To: Kaname Nishizuka <[email-masked]>; Nik Teague <[email-masked]>; Daniel Migault <[email-masked]>; Robert Moskowitz <[email-masked]>; Stefan Fouant <[email-masked]>; [email-masked]; Roland Dobbins <[email-masked]>; Liang Xia <[email-masked]>; Liang Xia <[email-masked]>
Subject: New Version Notification for draft-ietf-dots-use-cases-11.txt

A new version of I-D, draft-ietf-dots-use-cases-11.txt has been successfully submitted by Daniel Migault and posted to the IETF repository.

Name:		draft-ietf-dots-use-cases
Revision:	11
Title:		Use cases for DDoS Open Threat Signaling
Document date:	2018-03-28
Group:		dots
Pages:		14
URL:            https://www.ietf.org/internet-drafts/draft-ietf-dots-use-cases-11.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-dots-use-cases/
Htmlized:       https://tools.ietf.org/html/draft-ietf-dots-use-cases-11
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-dots-use-cases
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-use-cases-11

Abstract:
   The DDoS Open Threat Signaling (DOTS) effort is intended to provide a
   protocol to facilitate interoperability across disparate DDoS
   mitigation solutions and services.  This document presents use cases
   which describe the interactions expected between the DOTS components
   as well as DOTS messaging exchanges.  The purpose of describing use
   cases is to identify the interacting DOTS components, how they
   collaborate and what are the types of information to be exchanged.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 4 Apr 2018 08:42:41 +0000

Hi Daniel, all, 

FWIW, you may find some comments to the -11 at: 

PDF: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/draft-ietf-dots-use-cases-11-rev%20Med.pdf 
DOC: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-ietf-dots-use-cases-11-rev%20Med.doc 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Daniel Migault
> Envoyé : mercredi 28 mars 2018 16:24
> À : [email-masked]
> Objet : [Dots] FW: New Version Notification for draft-ietf-dots-use-cases-
> 11.txt
> 
> Hi everyone!
> 
> The current document is limited to 3 use cases described over 10ish pages. We
> believe the current document addresses the feed backs and comments we
> To: Kaname Nishizuka <[email-masked]>; Nik Teague <[email-masked]>;
> Daniel Migault <[email-masked]>; Robert Moskowitz <[email-masked]
> consult.com>; Stefan Fouant <[email-masked]>; dots-
> [email-masked]; Roland Dobbins <[email-masked]>; Liang Xia
> <[email-masked]>; Liang Xia <[email-masked]>
> A new version of I-D, draft-ietf-dots-use-cases-11.txt has been successfully
> submitted by Daniel Migault and posted to the IETF repository.
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Daniel Migault <[email-masked]>
Date: Wed, 4 Apr 2018 08:58:51 -0400

Thank you Mohamed for the comments. We will address your comments on the
next version. I have a small clarification regarding comment 7 on figure 2.
I understand the figure is misleading as the figure seems to indicate a
dedicated link between the DDoS target and the DMS. In the next version I
am planning to have a figure when that specific communication goes though
the transit provider. I think that would address your concern, but if not,
please let me know.

Yours,
Daniel

On Wed, Apr 4, 2018 at 4:42 AM, <[email-masked]> wrote:

> PDF: https://github.com/boucadair/IETF-Drafts-Reviews/blob/
> master/draft-ietf-dots-use-cases-11-rev%20Med.pdf
> DOC: https://github.com/boucadair/IETF-Drafts-Reviews/raw/
> master/draft-ietf-dots-use-cases-11-rev%20Med.doc
>
> Cheers,
> Med
>
> > The current document is limited to 3 use cases described over 10ish
> pages.. We
> expected
> pull
> > To: Kaname Nishizuka <[email-masked]>; Nik Teague <[email-masked]
> >;
> > URL:            https://www.ietf.org/internet-
> drafts/draft-ietf-dots-use-
> > cases-11.txt
> > Htmlized:       https://datatracker.ietf.org/
> doc/html/draft-ietf-dots-use-
> > cases
> > Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-use-
> cases-
> > 11
> >
> > Abstract:

---

From: <[email-masked]>
Date: Wed, 4 Apr 2018 13:24:44 +0000

Daniel,

Sounds like a good plan. Thanks.

Cheers,
Med

De : [email-masked] [mailto:[email-masked]] De la part de Daniel Migault
Envoyé : mercredi 4 avril 2018 14:59
À : BOUCADAIR Mohamed IMT/OLN
Cc : [email-masked]
Objet : Re: [Dots] New Version Notification for draft-ietf-dots-use-cases-11.txt

Thank you Mohamed for the comments. We will address your comments on the next version. I have a small clarification regarding comment 7 on figure 2. I understand the figure is misleading as the figure seems to indicate a dedicated link between the DDoS target and the DMS. In the next version I am planning to have a figure when that specific communication goes though the transit provider. I think that would address your concern, but if not, please let me know.
Yours,
Daniel

On Wed, Apr 4, 2018 at 4:42 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Daniel, all,

Cheers,
Med

> De : Dots [mailto:[email-masked]<mailto:[email-masked]>] De la part de Daniel Migault
> À : [email-masked]<mailto:[email-masked]>
> The current document is limited to 3 use cases described over 10ish pages.. We
> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> To: Kaname Nishizuka <[email-masked]<mailto:[email-masked]>>; Nik Teague <[email-masked]<mailto:[email-masked]>>;
> Daniel Migault <[email-masked]<mailto:[email-masked]>>; Robert Moskowitz <[email-masked]
<mailto:[email-masked]%0b>> consult.com<http://consult.com>>; Stefan Fouant <[email-masked]<mailto:[email-masked]>>; dots-
> [email-masked]<mailto:[email-masked]>; Roland Dobbins <[email-masked]<mailto:[email-masked]>>; Liang Xia
> <[email-masked]<mailto:[email-masked]>>; Liang Xia <[email-masked]<mailto:[email-masked]>>
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> The IETF Secretariat
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dots