Subject: [Dots] Question: SignalChannel Mitigation using Mitigator with asynchronous

From: Takahiko Nagata <[email-masked]>
Date: Sun, 10 Feb 2019 16:30:36 +0900

Hi all,

I confirmed latest(-28 version) SignalChannel and I have questions.
I would like to use Mitigator with asynchronous request/response.

In success case is OK:
1. DOTS Server recieve Mitigation request.
2. DOTS Server response with status=1
   (Attack mitigation setup is in progress)
3. Call Mitigator with asynchronous
4. If success mitigation, DOTS Server response(via observe)
   with status=2
   (2: Attack is being successfully mitigated)

But in failure case:
1. DOTS Server recieve Mitigation request.
2. DOTS Server response with status=1
   (Attack mitigation setup is in progress)
3. Call Mitigator with asynchronous
4. If failure mitigation, DOTS Server response(via observe)
   with status=7?
   (7: Attack mitigation is withdrawn (by the DOTS server))

(Question1) status=7(withdrawn) is correct in this case?
(Question2) How to notify reason of withdrawn to DOTS client?

Best Regards,
Takahiko Nagata

---

From: <[email-masked]>
Date: Mon, 11 Feb 2019 08:07:46 +0000

Re-,

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Takahiko Nagata
> Envoyé : dimanche 10 février 2019 08:31
> À : [email-masked]
> Objet : [Dots] Question: SignalChannel Mitigation using Mitigator with
> asynchronous
> 
> Hi all,
> 

[Med] If the failure is not due to an exceed capacity (which supposes likely a status transition to 2 and then 4), returning 7 is correct here.   

> (Question2) How to notify reason of withdrawn to DOTS client?

[Med] Transitioning from 1 to 7 is clear enough that the problem is related to the completion of the mitigation setup. Isn't it?

We have defined the signal channel model so that it can be fed automatically with new values that can be registered in the "Status Codes Sub-Registry". 

> 
> 
> Best Regards,
> Takahiko Nagata
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots