Subject: Re: [Dots] [boucadair/filter-control] Use of acl-* should be acl-name in most cases in the text (#2)

From: <[email-masked]>
Date: Thu, 25 Apr 2019 11:14:33 +0000

acl-name cannot be included without including acl-list.

acl-type is optional since acl-name is sufficient to identify an ACL. Including it would be valid, but it is completely fine to recommend against including acl-type by replacing acl-* with "acl-list and acl-name".

Cheers,
Med

De : mrdeep1 [mailto:[email-masked]]
Envoyé : jeudi 25 avril 2019 10:56
À : boucadair/filter-control
Cc : Subscribed
Objet : [boucadair/filter-control] Use of acl-* should be acl-name in most cases in the text (#2)

acl-name is the only acl-* that a client can send in a request to a server - the others are only used for conflict responses.

E.g.
A DOTS client may include acl-* attributes in a mitigation request

should be

A DOTS client may include the acl-name attribute in a mitigation request

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://github.com/boucadair/filter-control/issues/2>, or mute the thread<https://github.com/notifications/unsubscribe-auth/ADXR6V36OM77RQSD7P6GLQLPSFWYZANCNFSM4HILBZNQ>.

---

From: "Jon Shallow" <[email-masked]>
Date: Thu, 25 Apr 2019 12:23:32 +0100

Hi Med,

"acl-list and acl-name" works for me, and keeps things clear should any new acl-* definition appear in the future.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of [email-masked]
Sent: 25 April 2019 12:15
To: [email-masked]
Subject: Re: [Dots] [boucadair/filter-control] Use of acl-* should be acl-name in most cases in the text (#2)

Cheers,

Med

E.g.

should be

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub <https://github.com/boucadair/filter-control/issues/2> , or mute the thread <https://github.com/notifications/unsubscribe-auth/ADXR6V36OM77RQSD7P6GLQLPSFWYZANCNFSM4HILBZNQ> .  <https://github.com/notifications/beacon/ADXR6VZBXOZ57W7HF5CKWTTPSFWYZANCNFSM4HILBZNQ.gif>

---

From: <[email-masked]>
Date: Thu, 25 Apr 2019 11:27:02 +0000

Re-,

Great.

That is now fixed in https://github.com/boucadair/filter-control/blob/master/draft-ietf-dots-signal-filter-control-01.txt.

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Jon Shallow
Envoyé : jeudi 25 avril 2019 13:24
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Objet : Re: [Dots] [boucadair/filter-control] Use of acl-* should be acl-name in most cases in the text (#2)

Hi Med,

Regards

Jon

Cheers,
Med

E.g.

should be

—