Subject: [drinks] DRINKS open numbering plan use-case text

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 5 May 2010 16:05:04 -0400

Howdy,
During the interim meeting today, I was asked to submit a use-case for open-numbering plan.  I propose the following:

[begin]
Open numbering plans: In several countries, an "open numbering plan" is used, which is such that the carrier-of-record does not in fact know the complete number, but instead only knows a portion of the E.164 number.
The rest of the digits are handled by a PBX off of that carrier-of-record, and even the number of those digit is not fixed.  For example, an SSP can be the carrier-of-record for "+123456789", and is also the carrier-of-record for every possible expansion of that number such as "+12345678901" and "+123456789012", even though the SSP does not know what those expansions could be, because the PBX decides that.  This can be described as the carrier-of-record effectively being authoritative for a "prefix".
[end]

-hadriel

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 6 May 2010 12:40:42 +0200

An "open numbering plan" is not synonymous with "carrier-of-record does not in fact know the complete number". The prevalance of one may cause the other.

For example, the UK has an open numbering plan, but UK carriers build that numbering plan into their exchanges so that in the majority of cases they know the length of number. However most US carriers routeing calls to the UK will probably only know the minimum length of UK numbers, and will not know the length from then on.

The key to the length problem is that certain countries allow the length of the number to be arbitrarily extended by a enterprise networks itself providing telephony services. Which would leave me with the question as to whether the SSP or the enterprise is the "carrier of record" used in your definition, because even in such a form of open numbering plan, the enterprise in all likelihood knows the length of all numbers in the numbering plan; it is the public carrier attempting to send the call to that enterprise that does not.

Also please note that in numbering circles, "prefix" has a very specific meaning, so please do not use it as part of a definition where it has a very different meaning.

regards

Keith

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
> Sent: Wednesday, May 05, 2010 9:05 PM
> To: IETF DRINKS WG
> Subject: [drinks] DRINKS open numbering plan use-case text
> 
> Howdy,
> During the interim meeting today, I was asked to submit a 
> use-case for open-numbering plan.  I propose the following:
> 
> [begin]
> Open numbering plans: In several countries, an "open 
> numbering plan" is used, which is such that the 
> carrier-of-record does not in fact know the complete number, 
> but instead only knows a portion of the E.164 number.
> The rest of the digits are handled by a PBX off of that 
> carrier-of-record, and even the number of those digit is not 
> fixed.  For example, an SSP can be the carrier-of-record for 
> "+123456789", and is also the carrier-of-record for every 
> possible expansion of that number such as "+12345678901" and 
> "+123456789012", even though the SSP does not know what those 
> expansions could be, because the PBX decides that.  This can 
> be described as the carrier-of-record effectively being 
> authoritative for a "prefix".
> [end]
> 
> -hadriel
> _______________________________________________
> drinks mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/drinks
>

---

From: "PFAUTZ, PENN L (ATTCORP)" <[email-masked]>
Date: Thu, 6 May 2010 08:33:20 -0400

Keith:
Re your question as to whether the SSP or enterprise is Carrier of
Record, RFC5067 says:

The "carrier-of-record" is:

   o The Service Provider to which the E.164 number was allocated for
   end user assignment, whether by the National Regulatory Authority
   (NRA) or the International Telecommunication Union (ITU), for
   instance, a code under "International Networks" (+882) or "Universal
   Personal Telecommunications (UPT)" (+878) or,

   o if the number is ported, the service provider to which the number
   was ported, or

   o where numbers are assigned directly to end users, the service
   provider that the end user number assignee has chosen to provide a
   Public Switched Telephone Network/Public Land Mobile Network (PSTN/
   PLMN) point-of-interconnect for the number.

   It is understood that the definition of carrier-of-record within a
   given jurisdiction is subject to modification by national
   authorities.

So I think the SSP is likely still CoR per this definition. I agree with
your comment re the need for careful use of the term "prefix"

Penn Pfautz
AT&T Access Management
+1-732-420-4962
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of DRAGE, Keith (Keith)
Sent: Thursday, May 06, 2010 6:41 AM
To: Hadriel Kaplan; IETF DRINKS WG
Subject: Re: [drinks] DRINKS open numbering plan use-case text

An "open numbering plan" is not synonymous with "carrier-of-record does
not in fact know the complete number". The prevalance of one may cause
the other.

For example, the UK has an open numbering plan, but UK carriers build
that numbering plan into their exchanges so that in the majority of
cases they know the length of number. However most US carriers routeing
calls to the UK will probably only know the minimum length of UK
numbers, and will not know the length from then on.

The key to the length problem is that certain countries allow the length
of the number to be arbitrarily extended by a enterprise networks itself
providing telephony services. Which would leave me with the question as
to whether the SSP or the enterprise is the "carrier of record" used in
your definition, because even in such a form of open numbering plan, the
enterprise in all likelihood knows the length of all numbers in the
numbering plan; it is the public carrier attempting to send the call to
that enterprise that does not.

Also please note that in numbering circles, "prefix" has a very specific
meaning, so please do not use it as part of a definition where it has a
very different meaning.

regards

Keith

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 6 May 2010 14:40:27 +0200

I have no issue with the definition you supply.

I just wanted to ensure that noone assumed that the "carrier of record" had any relationship with the domain name that might be used in a "phone-context" or in the SIP encoded form of the tel URI.

regards

Keith

> From: PFAUTZ, PENN L (ATTCORP) [mailto:[email-masked]] 
> Sent: Thursday, May 06, 2010 1:33 PM
> To: DRAGE, Keith (Keith); Hadriel Kaplan; IETF DRINKS WG
> Subject: RE: [drinks] DRINKS open numbering plan use-case text
> 
> Keith:
> Re your question as to whether the SSP or enterprise is 
> Carrier of Record, RFC5067 says:
> 
> So I think the SSP is likely still CoR per this definition. I 
> agree with your comment re the need for careful use of the 
> term "prefix"
> 
> Penn Pfautz
> AT&T Access Management
> +1-732-420-4962
> [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
> An "open numbering plan" is not synonymous with 
> "carrier-of-record does not in fact know the complete 
> number". The prevalance of one may cause the other.
> 
> For example, the UK has an open numbering plan, but UK 
> carriers build that numbering plan into their exchanges so 
> that in the majority of cases they know the length of number. 
> However most US carriers routeing calls to the UK will 
> probably only know the minimum length of UK numbers, and will 
> not know the length from then on.
> 
> The key to the length problem is that certain countries allow 
> the length of the number to be arbitrarily extended by a 
> enterprise networks itself providing telephony services. 
> Which would leave me with the question as to whether the SSP 
> or the enterprise is the "carrier of record" used in your 
> definition, because even in such a form of open numbering 
> plan, the enterprise in all likelihood knows the length of 
> all numbers in the numbering plan; it is the public carrier 
> attempting to send the call to that enterprise that does not.
> 
> Also please note that in numbering circles, "prefix" has a 
> very specific meaning, so please do not use it as part of a 
> definition where it has a very different meaning.
> 
> regards
> 
> Keith
> 
> use-case for 
> > open-numbering plan.  I propose the following:
> > 
> > [begin]
> numbering plan" 
> > is used, which is such that the carrier-of-record does not in fact 
> > know the complete number, but instead only knows a portion of the 
> > E.164 number.
> > carrier-of-record, and even the number of those digit is 
> not fixed.  
> > For example, an SSP can be the carrier-of-record for 
> "+123456789", and 
> > is also the carrier-of-record for every possible expansion of that 
> > number such as "+12345678901" and "+123456789012", even 
> though the SSP 
> > does not know what those expansions could be, because the 
> PBX decides 
> > that.  This can be described as the carrier-of-record effectively 
> > being authoritative for a "prefix".
> > [end]
> > 
> > -hadriel

---

From: "PFAUTZ, PENN L (ATTCORP)" <[email-masked]>
Date: Thu, 6 May 2010 08:54:30 -0400

Keith:
The domain name used will depend on the nature of the implementation: In
a "carrier" or "infrastructure" ENUM deployment per RFC 5067, the domain
name would likely belong to the CoR since what is being encoded in the
URI are the carrier network ingress points. In End User/Enterprise ENUM
deployments per RFC 3761 the domain name would likely be that of the
enterprise. The focus of Drinks has probably been closer to the former
than the latter.

Cheers,

Penn Pfautz
AT&T Access Management
+1-732-420-4962

-----Original Message-----
From: DRAGE, Keith (Keith) [mailto:[email-masked]] 
Sent: Thursday, May 06, 2010 8:40 AM
To: PFAUTZ, PENN L (ATTCORP); Hadriel Kaplan; IETF DRINKS WG
Subject: RE: [drinks] DRINKS open numbering plan use-case text

I just wanted to ensure that noone assumed that the "carrier of record"
had any relationship with the domain name that might be used in a
"phone-context" or in the SIP encoded form of the tel URI.

regards

Keith

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 6 May 2010 14:04:56 -0400

> Subject: RE: DRINKS open numbering plan use-case text
> 
> not in fact know the complete number". The prevalance of one may cause the
> other.

The statement did not say they were synonymous - it's not defining what an open numbering plan means in terms of a definition; instead, it's defining what the consequence of an open numbering plan is, as a DRINKS use-case.  This is not a terminology statement, it's a use-case.  The statement: "which is such that" in the text was meant to mean "which results in a scenario whereby".  Would that be clearer?

> For example, the UK has an open numbering plan, but UK carriers build that
> numbering plan into their exchanges so that in the majority of cases they
> know the length of number. However most US carriers routeing calls to the
> UK will probably only know the minimum length of UK numbers, and will not
> know the length from then on.

Right, but that's not germane to the use-case issue is it?  The use-case is that there are CoR's who do not know the exact numbers, even including the length.  Of course there are some who do know the length, so I guess your point is that should be included as a variation of the use-case?  Right?

> providing telephony services. Which would leave me with the question as to
> whether the SSP or the enterprise is the "carrier of record" used in your
> definition, because even in such a form of open numbering plan, the

I _think_ the SSP is still the CoR for it, based on the definition we have for CoR. 

> meaning, so please do not use it as part of a definition where it has a

Good point - it is confusing to use that word, because there are multiple meanings in common use for it.  Can you think of some better word?  Or are you thinking we should just delete that last sentence?

-hadriel