Subject: [drinks] Rough Notes and AI list from the call on 10/7

From: Sumanth Channabasappa <[email-masked]>
Date: Thu, 7 Oct 2010 10:34:00 -0600

IETF DRINKS DESIGN TEAM CALL 
============================
10/7/2010, 10:00a-10:45a (Eastern)/8:00a-8:45a (Mountain)

Participants
============
- Ken Cartwright
- David Schwartz
- Syed Ali
- Jean-Francois Mule (latter part of the call)

- Sumanth Channabasappa 

ACTION ITEMS 
============
[Tokens for editing the protocol I-D]
(Syed) Today (10/7) 
(Jean-Francois) Tomorrow (10/8)

[Authors]
Submit a revision with the recent changes this week/weekend

AGENDA
======
1. Updates from the authors (Ken, Syed, Jean-Francois) 
2. Submission plans for the next version of the protocol I-D 
3. Open issues

NOTES
=====

1/ Updates from the authors (Ken, Syed, Jean-Francois) 
- Ken is done with his updates, which he shared last week and earlier this week
- Syed has made most of his changes, but requested another day to complete it

2/ Submission plans for the next version of the protocol I-D 
- Once Syed and Jean-Francois make their changes, we will be submitting this over the weekend

3/ Open issues

+ We discussed a couple of topics
- [Syed] asked if he should work on separating the delete operations, which are now within sub-sections. Based on Ken's explanation there will be no change.
- [Ken] raised the question of the Open Numbering Plan, which resulted in a few discussions, mostly around whether the prefix should be considered a special case of a TN Range (as authored today) or should we look at an alternative approach (e.g., see Otmar's recommendation from 9/15). In the end we agreed that the specific solution did not matter. However, we will go ahead and submit it as written in the document today and we can have further discussions after the submission.  
- We ([David], [Jean-Francois]) also briefly discussed Penn's proposed I-D that was shared with the design team yesterday. This is due to be submitted soon (according to Penn).

---

From: Sumanth Channabasappa <[email-masked]>
Date: Thu, 14 Oct 2010 09:34:17 -0600

IETF DRINKS DESIGN TEAM CALL 
============================
10/14/2010, 10:00a-10:40a (Eastern)/8:00a-8:40a (Mountain)

Participants
============
- Jean-Francois Mule
- Ken Cartwright
- Syed Ali

- Sumanth Channabasappa 

ACTION ITEMS 
============
+ [Authors] Review the I-D and see if it requires any changes;
  - [Syed] Make progress regarding the TNPrefix data structure 
- [Ken] Submit a revision to the transport-specific I-D 

AGENDA
======
1. What did not make it into the current revision (Ken, Syed, Jean-Francois) 
2. Next steps and plan for Beijing

NOTES
=====

1. What did not make it into the current revision (Ken, Syed, Jean-Francois) 

+ The following are items we still need to discuss
   a) [Ken] Data validation rules for the specified data elements
   b) [Ken] File based protocol
   c) [Syed] Support for Global SPID 
   d) [Syed] TNPrefix (see email exchange between Syed and Otmar)

   Discussions led to the following agreements:
   - a) and b) can be independent of the current I-D
   - Nothing needs to be done about c) at this point in time
   - We should discuss and resolve d) (Syed volunteered to complete this; expect follow-up emails on the DRINKS mailing list)

2. Next steps and plan for Beijing
 
- The next step for the protocol document is for the authors to see if there are any final changes (in addition to #d, above) and produce a revision. After this, the design team may request WGLC
- Alex has made changes to the use cases document to incorporate comments received thus far. Sumanth to collaborate on this, and submit an update before the cutoff
- Sumanth requested agenda items for Beijing; the general recommendation was to make the protocol work the primary focus

---

From: Sumanth Channabasappa <[email-masked]>
Date: Thu, 21 Oct 2010 11:03:12 -0600

IETF DRINKS DESIGN TEAM CALL 
============================
10/21/2010, 10:00a-10:30a (Eastern)/8:00a-8:30a (Mountain)

Participants
============
- Syed Ali
- Jean-Francois Mule
- Manjul Maharishi
- Ken Cartwright

- Sumanth Channabasappa 

ACTION ITEMS 
============
- [Syed]    Submit updated protocol I-D
- [Ken]     Submit a revision to the transport-specific I-D 
- [Sumanth] Submit a revision to the use cases I-D 

AGENDA
======

1. Final changes to the protocol (see the email from Syed on 10/18 related to the TNPrefix)
2. Update regarding Beijing

NOTES
=====

1. Final changes to the protocol (see the email from Syed on 10/18 related to the TNPrefix)

   = Syed presented the following changes related to the TNPrefix discussion on the mailing list.

      - Introduced the TN prefix definition called TNPType in the schema. The name is consistent with the choice for TN range as TNRType.
      - Updated the model diagram to show "TNP" as well.
      - TNPType extends PubIdType and its only mandatory member is "tnPrefix" of type xs:string.
      - TNRType extends PubIdType as well and the start tn of the TN range is called "startTn".
      - Pub ID operations section has been modified to include TN prefix description. The TN range references have been updated as well.
      - The TNRType examples in the examples sections are updated to reflect the change from element name <tn> to <startTn>.
      - A new example is added to show use of TNPType.

	Resolution: The design team agreed with the changes, Syed will also present this on the mailing list for any further comments.

   = Syed questioned the removal of svcs field from the egress route object
      -  Ken explained the changes from a few weeks ago (see notes from 9/30), where we associated egress routes directly with the record routes, removing the necessity for the svcs field. 
      -  Based on the explanation, this is not an issue.

        Resolution: No changes

2. Update regarding Beijing
   = The WG meeting will be held on WED, as shared on the WG mailing list
   = The design team plans to discuss presentations, review feedback and such in the weekly calls leading up to the meeting.