Subject: Re: [drinks] TN / TNRange / TNPrefix

From: "Ali, Syed Wasim" <[email-masked]>
Date: Fri, 8 Oct 2010 01:44:27 -0400

Otmar,

Thanks for your suggestion and a quick follow-up on the action item. On
yesterday's call, we caught up on this issue and had a lively discussion.
Introducing a new type TNPrefix will make it clear that the included "tn"
parameter is a fragment and not a subscriber number. This is potentially
useful for not only ONP, but also for regions or national significant
numbers that qualify for closed number plan (e.g. TNPrefix={+1201} ).

Another option that we discussed was to re-use TNRange for this purpose and
make the 'endTn' parameter optional. And while this will do the job, the
TNPrefix makes the intent clear and IMHO a better way to go.

If we do adopt the new TNPrefix, the only update to the XML schema will be
the definition of the new structure as below,

  <complexType name="TNPrefix">
    <complexContent>
      <extension base="spppb:PubIdType" />
    </complexContent>
  </complexType>

thanks,

-Syed

On 9/15/10 4:39 PM, "Otmar Lendl" <[email-masked]> wrote:

> 
> 
> I just picked up an action item during the interim:
> 
> We were talking about how to denote prefixes (esp. for open numbering
> plan), and David and I suggested that it's better and less likely to cause
> confusion if there were an explicit prefix object, and not just a TNRange
> with some attribute to flag it's actually a prefix.
> 
> Here is an off-the-cuff xsd proposal:
> 
>   <complexType name="TNType">
>     <complexContent>
>       <extension base="spppb:PubIdType">
>         <sequence>
>           <element name="tn" type="string"/>
>         </sequence>
>       </extension>
>     </complexContent>
>   </complexType>
> 
>   <complexType name="TNRType">
>     <complexContent>
>       <extension base="spppb:PubIdType">
>         <sequence>
>           <element name="startTn" type="string"/>
>           <element name="endTn" type="string"/>
>         </sequence>
>       </extension>
>     </complexContent>
>   </complexType>
> 
>   <complexType name="TNPType">
>     <complexContent>
>       <extension base="spppb:PubIdType">
>         <sequence>
>           <element name="prefix" type="string"/>
>           <element name="minLen" type="integer" minOccurs="0" />
>           <element name="maxLen" type="integer" minOccurs="0" />
>         </sequence>
>       </extension>
>     </complexContent>
>   </complexType>
> 
> cheers,
> 
> otmar
> --
> // Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 //
> _______________________________________________
> drinks mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/drinks

---

From: "Ali, Syed Wasim" <[email-masked]>
Date: Thu, 21 Oct 2010 11:14:23 -0400

Otmar,

Just a quick update on where things stand at the moment. The following
changes went through a review in the design team and they will be part of
the next spprov revision.

- Introduced the TN prefix definition called TNPType in the schema. The name
is consistent with the choice of name for TN range as TNRType.

  <complexType name="TNPType">
    <complexContent>
      <extension base="spppb:PubIdType">
        <sequence>
          <element name="tnPrefix" type="string"/>
          <element name="corInfo" type="spppb:CORInfoType"
            minOccurs="0"/>
        </sequence>
      </extension>
    </complexContent>
  </complexType>

- Based on earlier consensus (from Denver interim meeting f2f), TNRType now
extends PubIdType and not TNType.

- Pub ID operations section now has coverage for TNPType

- The TNRType examples in the examples sections are updated to reflect the
change from element name <tn> to <startTn>.

- A new example is added to show use of TNPType.

thanks,

-Syed