Subject: [drinks] SMS Route and Calling Name Parameter in SPPP

From: "Khan, Sohel" <[email-masked]>
Date: Wed, 10 Nov 2010 06:17:18 +0000

First, I do not have any intention to slow down the work of SPPP and I will support my best to complete the SPPP standard development.

My main intention is to include SMS route and Calling Name Parameter in SPPP.

In the following write up I will use "SPID" as SMS route parameter and "CNAM" as Calling Name parameter.

To stress my neuatrality of the paramters chosen, I would like to agree that there are implementations apart from SPID and CNAM.

>From today's IETF/DRINKS meeting in Beijing, I understand that current WG document SPPP includes fileds (either as opaque or transparent extensible field) that "may" be used to provision LRN/RN, SPID, and CNAM.

For example, in the page 12 SPPP date model draft, it clearly identifies RN/LRN as public Identifier. (See below).  In the Figure 3, the draft depicts RN (see below).

However, no parameter clearly identifies SPID and CNAM. My request is to clearly depict/exemplify/identity parameters that can be used for SPID and CNAM.  There can be three types of SPIDs used to route SMS today:  SPID, Alt-SPID, and Private-SPID. Please depict/exemplify/identity  parameters that can be used for SPID, Alt-SPID, and Private-SPID.

Again, I am using term SPID and CNAM to exemplify complex structure of each parameter. We can chose different names.

In conlcusion, if SMS and Calling Name parameters are not included, will it be possible to include these parameters?

---

From: "PFAUTZ, PENN L (ATTCORP)" <[email-masked]>
Date: Wed, 10 Nov 2010 08:52:54 -0500

Sohel:
Let's be very careful in use of the term SPID. There are multiple
efforts to define a global SPID in progress.  Some may be more or less
suitable for SMS routing. I would not want to identify the generic term
SPID in drinks with the US NPAC SPID. 

Penn Pfautz
AT&T Access Management
+1-732-420-4962

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Khan, Sohel
Sent: Wednesday, November 10, 2010 1:17 AM
To: [email-masked]
Subject: [drinks] SMS Route and Calling Name Parameter in SPPP

First, I do not have any intention to slow down the work of SPPP and I
will support my best to complete the SPPP standard development.

My main intention is to include SMS route and Calling Name Parameter in
SPPP.

In the following write up I will use "SPID" as SMS route parameter and
"CNAM" as Calling Name parameter.

To stress my neuatrality of the paramters chosen, I would like to agree
that there are implementations apart from SPID and CNAM.

>From today's IETF/DRINKS meeting in Beijing, I understand that current
WG document SPPP includes fileds (either as opaque or transparent
extensible field) that "may" be used to provision LRN/RN, SPID, and
CNAM.

For example, in the page 12 SPPP date model draft, it clearly identifies
RN/LRN as public Identifier. (See below).  In the Figure 3, the draft
depicts RN (see below).

However, no parameter clearly identifies SPID and CNAM. My request is to
clearly depict/exemplify/identity parameters that can be used for SPID
and CNAM.  There can be three types of SPIDs used to route SMS today:
SPID, Alt-SPID, and Private-SPID. Please depict/exemplify/identity
parameters that can be used for SPID, Alt-SPID, and Private-SPID.

Again, I am using term SPID and CNAM to exemplify complex structure of
each parameter. We can chose different names.

In conlcusion, if SMS and Calling Name parameters are not included, will
it be possible to include these parameters?

_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks

---

From: "Khan, Sohel" <[email-masked]>
Date: Thu, 11 Nov 2010 01:42:33 +0000

The term "SPID" is portrayed as a need for a parameter to indicate SMS route aggegate.
Whether the term is  "SPID", "SMSURI", or "SMS-ROUTE_VECTOR", we will simply need to add something for SMS. We can have any name or a generic name of the attribute.

Let us assume, we name it as "SMS-ROUTE-VECTOR" (!!! Again, we can chose some other name as per the IETF concensus).

The "SMS-ROUTE_VECTOR" route vector needs to meet following use case (Please add more use cases if needed):

Use case #1:
A provider "Alpha" has two SMS networks:  NtwkA and NtwkB.
Each network has two SMS peering "gateway/smsc/aggegate": GtwyX and GtwyY
A SMS-ROUTE-VECTOT tuple for a customer in GtwyY in NtwkB is as follows in URI:
{"TN", sms, gateway, network, provider} = {TN.sms.GtwyY.NtwkB.Alpha.com}

Use case #2
A provider "2222"" has two SMS networks: "4444" and "5555"
Each Network has two SMS peering "gateway/smsc/aggegate": "8888" and "9999"
A SMS-ROUTE-VECTOR tuple for a customer in gateway "8888" in network "5555" is as follows in "number set":
{"TN", sms,  gateway, network, provider} = {"TN", sms, 8888, 5555, 2222}

I wrote this in a hurry so there may be some mistakes. So, please instead of debating my mistakes, please add more use case and solutions.

Thanks,

Sohel
________________________________________
From: [email-masked] [[email-masked]] on behalf of PFAUTZ, PENN L (ATTCORP) [[email-masked]]
Sent: Wednesday, November 10, 2010 6:52 AM
To: Khan, Sohel; [email-masked]
Subject: Re: [drinks] SMS Route and Calling Name Parameter in SPPP

Sohel:

Penn Pfautz
AT&T Access Management
+1-732-420-4962