Subject: [eap] Re: "MIC"

From: [email-masked] ([email-masked])
Date: Fri, 7 Mar 2003 10:46:24 +0200

Sounds reasonable. Should we add this to terminology section?

MIC terminoloy
Submitter name: Pasi Eronen
Submitter email address: [email-masked]
Date first submitted: March 7th, 2003
Reference:=20
Document: RFC2284bis
Comment type: Editorial
Priority: 2=20
Section: 1.2
Rationale/Explanation of issue:

Add the following to terminology list:

  Message Integrity Code (MIC): A keyed hash function used to protect
  integrity of data. This is usually called a Message Authentication=20
  Code (MAC), but IEEE 802 specifications (and this document) use the=20
  acronym MIC to avoid confusion with Medium Access Control.

Best regards,
Pasi

> -----Original Message-----
> From: ext Bernard Aboba [mailto:[email-masked]]
> Sent: Friday, March 07, 2003 3:02 AM
> To: [email-masked]
> Subject: [eap] Re: "MIC"
>=20
>=20
> I believe that MAC is the recommended usage. However, EAP is=20
> often used
> in layer 2 authentication, where the term "MAC" could easily=20
> be confused
> with terms like "MAC address", "MAC layer", etc.
>=20
> For this reason, IEEE 802.1X and IEEE 802.11i have adopted=20
> the term "MIC"
> to refer to a message integrity check, rather than MAC. Since=20
> it is likely
> that one or more IEEE 802 groups will be referencing RFC 2284bis and
> 2869bis, we are respecting their choice of terms and are also=20
> using the
> term "MIC" instead of "MAC".

---

From: [email-masked] (Jari Arkko)
Date: Fri, 07 Mar 2003 10:48:39 +0200

Ok.

> Reference: 
> Priority: 2 
>   integrity of data. This is usually called a Message Authentication 
>   Code (MAC), but IEEE 802 specifications (and this document) use the

---

From: [email-masked] (Henrik Levkowetz)
Date: Fri, 7 Mar 2003 16:19:57 +0100

On Fri, 7 Mar 2003 10:46:24 +0200
<[email-masked]> wrote:

Yes, I think this would be good.

> > I believe that MAC is the recommended usage. However, EAP is 
> > often used
> > in layer 2 authentication, where the term "MAC" could easily 
> > be confused
> > For this reason, IEEE 802.1X and IEEE 802.11i have adopted 
> > the term "MIC"
> > to refer to a message integrity check, rather than MAC. Since 
> > it is likely
> > 2869bis, we are respecting their choice of terms and are also 
> > using the
> _______________________________________________
> eap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/eap

	Henrik

-- 
  Natural laws have no pity.