Subject: [eap] EAP-SIM

From: [email-masked] (Narendar Goel)
Date: Tue, 4 Mar 2003 14:33:16 -0500

Hi All,
 Recently draft draft-haverinen-pppext-eap-sim-10.txt was posted at IETF.
Does someone have a list of major differences from Draft 8?
I am also looking for test vectors to validate EAP-SIM implementation.
Someone please suggest how to get the test vectors for EAP-SIM.
Best Regards,
-Narender

---

From: [email-masked] (Joseph Salowey)
Date: Tue, 4 Mar 2003 14:38:43 -0800

There have been no wire protocol changes since Draft 6.  The major
differences are in the following areas:

1. Security considerations section has been reworked to be more in line
with what is required by 2284bis.

2. The handling and requesting of identity and pseudonyms has been
clarified.  

3. There were some modications to the terminology in the key derivation
section (this may change again).

I don't think anyone has had a chance to work on test vectors yet.

Joe

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Narendar Goel
> Sent: Tuesday, March 04, 2003 11:33 AM
> To: [email-masked]
> Subject: [eap] EAP-SIM
> 
> 
> Hi All,
>  Recently draft draft-haverinen-pppext-eap-sim-10.txt was
> posted at IETF. Does someone have a list of major differences 
> from Draft 8? I am also looking for test vectors to validate 
> EAP-SIM implementation. Someone please suggest how to get the 
> test vectors for EAP-SIM. Best Regards, -Narender
> 
> 
> _______________________________________________
> eap mailing list
> [email-masked] http://mail.frascone.com/mailman/listinfo/eap
>

---

From: [email-masked] (Narendar Goel)
Date: Tue, 4 Mar 2003 17:48:39 -0500

Joe,
 Thanks. Can you suggest any commercially/freely available eap-sim client
adaptors which can be used to do interoperability testing for EAP-SIM
protocol? Or is anyone planning inter operability testing/bakeoff for
eap-sim.
Best Regards,
-Narender

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Joseph Salowey
Sent: Tuesday, March 04, 2003 5:39 PM
To: 'Narendar Goel'; [email-masked]
Subject: RE: [eap] EAP-SIM

Joe

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: [email-masked] (Joseph Salowey)
Date: Tue, 4 Mar 2003 15:37:22 -0800

Someone just remided me that there was a somewhat significant change in
one of the previous drafts. The order of the keys sent in the RADIUS
attributes changed to line up with what is done in EAP-TLS.  

Right now I don't know of any freely/commercially available
implementations that are up to the current draft, but perhaps some
vendors on the list have implementations available.  

Does anyone know if there are any inter operability testing/bakeoff
events for EAP,  perhaps EAP-SIM testing could be done in conjunction
with this?

Joe

> From: Narendar Goel [mailto:[email-masked]] 
> Sent: Tuesday, March 04, 2003 2:49 PM
> To: Joseph Salowey; [email-masked]
>  Thanks. Can you suggest any commercially/freely available 
> eap-sim client adaptors which can be used to do 
> interoperability testing for EAP-SIM protocol? Or is anyone 
> planning inter operability testing/bakeoff for eap-sim. Best 
> Regards, -Narender
> 
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of > Joseph Salowey
> 
> There have been no wire protocol changes since Draft 6.  The 
> major differences are in the following areas:
> 
> 1. Security considerations section has been reworked to be 
> more in line with what is required by 2284bis.
> 
> 2. The handling and requesting of identity and pseudonyms has 
> been clarified.
> 
> 3. There were some modications to the terminology in the key 
> derivation section (this may change again).
> 
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Narendar Goel
> 
> >  Recently draft draft-haverinen-pppext-eap-sim-10.txt was posted at 
> > IETF. Does someone have a list of major differences from 
> Draft 8? I am 
> > also looking for test vectors to validate EAP-SIM implementation. 
> > Someone please suggest how to get the test vectors for 
> EAP-SIM. Best 
> > Regards, -Narender
> >
> >