Subject: [eap] Re: Issue 92: Integrity Protection

From: [email-masked] (Bernard Aboba)
Date: Wed, 5 Mar 2003 05:03:07 -0800 (PST)

Since the EAP Failure and Success messages don't have a built-in integrity
check, it would appear that this change makes the Integrity Protection
claim impossible to satisfy. Am I missing something?

-------------------------------------------------------------------------

Issue 92: Integrity Protection
Submitter name: John Vollbrecht
Submitter email address: [email-masked]
Date first submitted: March 3, 2003
Document: EAP-01
Comment type: Technical
Priority: 2
Section: 1.2
change:

"Integrity protection
This refers to per-packet authentication and integrity
protection of EAP packets, including EAP Requests and
Responses, and method-specific success and failure
indications.
When making this claim, a method specification
MUST describe the fields within the EAP packet that are
protected."

to:
"Integrity protection
This refers to per-packet authentication of all EAP packets,
including EAP Requests and Responses. When making this claim,
a method specification MUST describe the fields within the EAP
packet that are authenticated."

---

From: [email-masked] (John Vollbrecht)
Date: Wed, 05 Mar 2003 19:10:30 -0500

> claim impossible to satisfy. Am I missing something?

I think you are correct.  It is impossible to have integrity check on 
success and failure messages.  My understanding is that these are claims 
made for a method, not for eap as a whole.

> _______________________________________________
> eap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/eap

---

From: [email-masked] (Bernard Aboba)
Date: Wed, 5 Mar 2003 15:58:30 -0800 (PST)

> made for a method, not for eap as a whole.

Right. But since the claims can't be made for Success and Failure packets,
why change the text to say "all EAP packets" instead of just "EAP Requests
and Responses"?

---

From: [email-masked] (John Vollbrecht)
Date: Wed, 05 Mar 2003 22:14:15 -0500

> why change the text to say "all EAP packets" instead of just "EAP Requests
I agree.  take "all" out -  how about changing the text to

"Integrity protection
This refers to per-packet authentication of EAP Requests and Responses. 
When making this claim, a method specification MUST describe the messages 
in the Method and the fields in the messages that are authenticated."

-- John

---

From: [email-masked] (Bernard Aboba)
Date: Wed, 5 Mar 2003 21:50:41 -0800 (PST)

> [Joe] does this refer to requests and responses that are part of the
> method? Does it include the identity request and response?  I don't
> think you can protect the initial identity request/response either
> (although you may be able to protect subsequent ones)

Right. You can't protect Identity Request/Response or Nak, because it's
too early. You can't protect Notification Request/Response, Success and
Failure, because they they don't have room for a MIC.

That means that you're left with method requests and responses, which is,
after all, all a method can affect :)

---

From: [email-masked] (Henrik Levkowetz)
Date: Thu, 6 Mar 2003 15:52:43 +0100

On Wed, 05 Mar 2003 22:14:15 -0500
> in the Method and the fields in the messages that are authenticated."

Mmm, the original text talks about both authentication and integrity
protection; why remove integrity protection and have this only talk about
authentication?

Yes, providing message authentication without integrity protection is rather
meaningless, but do we gain anything by taking out integrity protection
from this paragraph?

We could omit mentioning "method-specific success and failure indications",
and get this:

  A)         "This refers to per-packet authentication and integrity
             protection of EAP packets, including EAP Requests and
             Responses. When making this claim, a method specification
             MUST describe the fields within the EAP packet that are
             protected."

We could also explicitly limit this to EAP requests and responses, as in
the following (but that would seem to ignore the possibility of methode-
specific integrity protection carried in requests and responses also
covering previous non-protected messages):

  B)         "This refers to per-packet authentication and integrity
             protection of EAP Requests and Responses.  When making this
             claim, a method specification MUST describe the fields
             within the EAP packet that are protected.

If we want to change this paragraph, I'd propose that we use 'A' above.

	Henrik

> -- John

	Henrik

-- 
  Never try to outstubborn a cat.

---

From: [email-masked] (Bernard Aboba)
Date: Thu, 6 Mar 2003 09:19:50 -0800 (PST)

> If we want to change this paragraph, I'd propose that we use 'A' above.

I'd agree. I'd also add the following:

"This refers to per-packet authentication and integrity
protection of EAP packets, including EAP Requests and
Responses. When making this claim, a method specification
MUST describe the EAP packets and fields within the EAP packet
that are  protected."

---

From: [email-masked] (Joseph Salowey)
Date: Wed, 5 Mar 2003 20:59:10 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of John Vollbrecht
> Sent: Wednesday, March 05, 2003 7:14 PM
> To: Bernard Aboba
> Cc: [email-masked]
> Subject: Re: [eap] Re: Issue 92: Integrity Protection
> 
> 
> 
> 
> > > I think you are correct.  It is impossible to have 
> integrity check 
> > > on success and failure messages.  My understanding is 
> that these are 
> > > claims made for a method, not for eap as a whole.
> >
> > Right. But since the claims can't be made for Success and Failure 
> > packets, why change the text to say "all EAP packets" 
> instead of just 
> > "EAP Requests and Responses"?
> >

> -- John
> >
> > >
> > > > 
> ------------------------------------------------------------------
> > > > ---
> > > > ----
> > > >
> > > >
> > > >
> protection 
> > > > of EAP packets, including EAP Requests and Responses, and 
> > > > method-specific success and failure indications.
> > > > including EAP Requests and Responses. When making this claim, a 
> > > > method specification MUST describe the fields within the EAP 
> > > > [email-masked] http://mail.frascone.com/mailman/listinfo/eap
> > >
> > >
> >
> > [email-masked] http://mail.frascone.com/mailman/listinfo/eap
> 
>

---

From: [email-masked] (Nick Petroni)
Date: Fri, 7 Mar 2003 12:52:41 -0500 (EST)

> (although you may be able to protect subsequent ones)
Since the text requires the method to describe which packets are
protected, and the Identity method makes no such claims, I think this case
is adequately covered by the wording. I have no problem with an explicit
statement about identity/notification, however. On a related note,
Identity messages could be included in mutliple-message MICs by a
particular method if an implementation allowed it, although I am not sure
I would consider this equivalent to integrity protection on those packets
themselves.