Subject: RE: [eap] Proposed Resolution of Issue 188: Packet ordering

From: <[email-masked]>
Date: Wed, 29 Oct 2003 17:38:13 +0200

Lauri Tarkkala wrote:
> Am I missing something here, but the bis specification
> is currently stating that EAP is a lock-step protocol.
> 
> In this case, assuming nobody is doing optimizations
> based on predicting peer responses, there should
> be no need for an ordering guarantee. 
> 
> That said, requiring that the lower layer provides
> an ordering guarantee is a good idea considering the
> heritage of EAP. I do not however see this as much
> of an issue for new (or upto-date) implementations,
> which we would be talking about here.

Lower layer ordering guarantees are needed because the 
Identifier field is not required to be ordered. If messages
can be reordered, the peer can't necessarily distinguish
a new EAP Request from a reordered retransmission of an
old request.

See http://www.ietf.org/internet-drafts/draft-ietf-pana-pana-02.txt,
Appendix A for a concrete example.

Best regards,
Pasi
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Lauri Tarkkala <[email-masked]>
Date: Wed, 29 Oct 2003 21:03:02 +0200

> a new EAP Request from a reordered retransmission of an

It is not required to be ordered by the specification, 
but this does not mean that an implementation can not place
additional constraints upon it.  Because the protocol is
lock-step, the authenticator is the party driving the 
protocol and is free to e.g. place a partial order
upon the (<EAP type>, <Identifier>) pair.

Like I previously said, considering the heritage of EAP,
it probably is a good idea to require EAP transports
to provide ordering guarantees. IF the historical
baggage were not to exist, I do feel that freeing
the authenticator implementor from thinking about
these issues by requiring a total order on all packets
might be a bit heavy-handed... ;-)

Lauri

-- 
Lauri Tarkkala
SSH Communications Security Corp
http://www.ssh.com/
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Jari Arkko <[email-masked]>
Date: Wed, 29 Oct 2003 20:20:59 +0200

> to provide ordering guarantees. IF the historical

Agreed.

> might be a bit heavy-handed... ;-)

Absolutely. If we didn't have the baggage, the protocol
would indeed look different ;-) But we do, so...

--Jari