Subject: [eap] Proposed resolution of Issue 194: Standalone Authenticator SM review

From: <[email-masked]>
Date: Fri, 28 Nov 2003 13:10:28 +0200

Hi,

Here's my proposal for issue 194:

- Move prototype of m.getTimeout as proposed.

The other points don't IMHO need any changes:

- The packet is handed over using variables (eapReq/eapReqData),
  so no function calls are needed.

- As I mentioned in issue 195, respMethod is not a plain 
  integer, so the authenticator can already tell them apart.

Best regards,
Pasi

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Bernard Aboba
> Sent: Monday, November 10, 2003 2:32 PM
> To: [email-masked]
> Subject: [eap] Issue 194: Standalone Authenticator SM review
> 
> 
> Issue 194: Standalone Authenticator SM review
> Submitter name: Bernard Aboba
> Submitter email address: [email-masked]
> Date first submitted: Nov 8, 2003
> Reference:
> Document: SM-01
> Comment type: T
> Priority: S
> Section: 5, 5.1
> Rationale/Explanation of issue:
> pp. 17, page 52
> 
> m.getTimeout prototype should be after the paragraph
> explaining what m.buildReq does, not before.
> 
> pp. 15, Figure 4
> 
> Shouldn't there be a function in SEND_REQUEST state
> to actually hand the packet over to the lower layer?
> 
> The Type code for NAK and EXPANDED_NAK
> are the same, so that the definition of
> respMethod should probably be modified.
> 
> _______________________________________________
> eap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/eap
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Jari Arkko <[email-masked]>
Date: Fri, 28 Nov 2003 15:30:28 +0200

>   integer, so the authenticator can already tell them apart.

Agreed.

--Jari