Subject: [eap] Issue 194: Standalone Authenticator SM review

From: Bernard Aboba <[email-masked]>
Date: Mon, 10 Nov 2003 04:31:32 -0800 (PST)

Issue 194: Standalone Authenticator SM review
Submitter name: Bernard Aboba
Submitter email address: [email-masked]
Date first submitted: Nov 8, 2003
Reference:
Document: SM-01
Comment type: T
Priority: S
Section: 5, 5.1
Rationale/Explanation of issue:
pp. 17, page 52

m.getTimeout prototype should be after the paragraph
explaining what m.buildReq does, not before.

pp. 15, Figure 4

Shouldn't there be a function in SEND_REQUEST state
to actually hand the packet over to the lower layer?

The Type code for NAK and EXPANDED_NAK
are the same, so that the definition of
respMethod should probably be modified.

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Jari Arkko <[email-masked]>
Date: Mon, 10 Nov 2003 15:57:59 +0200

> explaining what m.buildReq does, not before.

Right. Just split the paragraph into the two sentences and
put the m.getTimeout in between.

> to actually hand the packet over to the lower layer?

I think the style of the specification is that you
just set a variable, and the lower layer magically reads
it.

> respMethod should probably be modified.

Yes.

--Jari