Subject: [eap] review of draft-salowey-eap-key-deriv-02.txt

From: Jari Arkko <[email-masked]>
Date: Sun, 09 Nov 2003 01:48:34 +0200

Joe, Pasi,

I took a look at your draft draft-salowey-eap-key-deriv-02.txt.
It looks quite reasonable to me -- thanks for working on it! --
though I do have some comments:

Substantial:

1. The goal of the draft. Is there an intent that some of this
    should be discussed in the eap-keying document? Or would this
    be a later extension to that? Or just for our information?

2. If the security ADs wanted us to name current keys generated
    from EAP, I think its likely that they will require AMSKs
    be named as well. A discussion of the naming is missing, though
    the EMSK itself is named in the document.

3. I'm not sure I like the idea of EMSK Name being derived from
    KDF(EMSK), if there are alternatives. Would it be possible to
    name the EMSK by the EAP SA Name defined in eap-keying (derived
    from nonces), concanated with, say, "EMSK". Similarly, we could
    name each AMSK as the name of the EMSK, concatenated with "AMSK"
    and the key label and application data?

4. Section 3.1, what is the unit of "O"? Bytes or bits?

5. Section 3.3 fails to discuss that if EMSK is going to be
    useful, there's probably going to be some state kept in
    the AAA server.

Editorial:

1. Section 1.2, last paragraph. Missing "." at the end.

2. Section 2.1, s/MSUT/MUST/

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: "Joseph Salowey" <[email-masked]>
Date: Wed, 19 Nov 2003 09:16:02 -0800

Hi Jari,

Thanks for the review, comments below:

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Saturday, November 08, 2003 3:49 PM
> To: Joe Salowey; Pasi Eronen
> Cc: [email-masked]
> Subject: review of draft-salowey-eap-key-deriv-02.txt
> 
> 
> 
> Joe, Pasi,
> 
> It looks quite reasonable to me -- thanks for working on it! 
> -- though I do have some comments:
> 
> Substantial:
> 
[Joe] I'll be submitting issues to incorporate most of the content into
the key framework document.

>     the EMSK itself is named in the document.
[Joe] Yes, more of a discussion of naming is needed.  

>     and the key label and application data?

[Joe] I don't like the proposal either.  The problem is that the EAP SA
name is not concretely defined.  I'm not sure you can define this for
all methods in general.  We need to place a requirement on methods that
if they are going to generate additional keys they must also export an
EAP-SA name.

> 4. Section 3.1, what is the unit of "O"? Bytes or bits?
[Joe] Should be bytes
 
>     useful, there's probably going to be some state kept in
[Joe] true

---

From: Jari Arkko <[email-masked]>
Date: Wed, 19 Nov 2003 21:46:12 +0200

> if they are going to generate additional keys they must also export an

Yes, that's right. Ok, I'll settle for your current text then on
that.

--Jari