Subject: Re: [eap] network discovery & selection: problem definition

From: Alper Yegin <[email-masked]>
Date: Wed, 10 Dec 2003 17:18:57 -0800

> The primary network discovery and selection issue
> is routing within the AAA infrastructure, giving
> access to the user from the right home AAA and via
> the right AAA proxies.

I'd say network selection also impacts "data traffic routing",
which should not have to be hard-bound to the AAA routing (or, my home AAA
server). For example, I might want to select ISPx among several, and let
it charge my [email-masked] account.

...

> 
>     However, if the access network supports two different
>     intermediaries, it becomes necessary to figure out
>     which intermediary handles the domain given in a NAI.

Sure this is important. If we are strictly talking about how AAA routing
takes place (not data traffic routing) then I'd ask if this is something
that the client hosts should be dealing with? Maybe this AAA intermediary
selection is not for the hosts but for the access networks to deal with.

>  o  For commercial reasons, intermediaries want
>     to participate the AAA transaction.
> 
>     Question: Is there a need for someone else than
>     the access network to control the routing to go
>     via a special intermediary? This is not very
>     clear to me.

Yes, this is what I'm questioning as well.

> 
> During the discussion of solutions for these problems,
> it has become apparent that there are some additional
> constraints that may have to be placed on solutions.
> Some of the possible constraints are listed below:
> 
>  o  Solution can be adopted for the whole network
>     without requiring changes to the largest base
>     of installed devices -- access points and
>     clients.

Good objective. But we should also identify what we could do if we didn't
have this constraint. This is useful at least for future updates of the
relevant protocols.

Alper

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Jari Arkko <[email-masked]>
Date: Thu, 11 Dec 2003 09:54:43 +0200

> which should not have to be hard-bound to the AAA routing (or, my home AAA

Yes, this is a good point, thanks for bringing it up! Here's a
question for you: do you expect some mechanism which allows you
to control data traffic routing, or is the requirement simply that
it is not hard-bound to the AAA routing? Currently, there is no
user-level way to control routing (and probably shouldn't be). But
access, intermediate, and home networks can control routing to
an extent e.g. through mandatory tunneling.

> it charge my [email-masked] account.

Hmm... wouldn't visa.com then be your home network, and the selected
ISP just an access (or intermediate) network?

--Jari

---

From: Alper Yegin <[email-masked]>
Date: Thu, 11 Dec 2003 10:45:32 -0800

> to control data traffic routing,

I don't expect the host to control end2end routing of its data packets. But
its ISP selection will determine how the packets are routed eventually. [I'm
thinking of the scenario where a NAP - network access provider - is
providing service for multiple ISPs]

> or is the requirement simply that

Yes, "visa.com" would be my home network in the AAA sense, but not in IP
routing sense (my data packets don't have to go through the network domain
where AAA servers reside).

Alper