Subject: [eap] limits of protected result indications

From: Jari Arkko <[email-masked]>
Date: Thu, 05 Feb 2004 21:57:41 +0200

One limit of the protected result indications is that
you can not protect the indications until you have
generated a key. Here's another limitation by Pasi that
applies to all methods:

Lets assume that we are at a point where a key has
been generated and both sides have exchanged protected
success indications. And we are at the last message pair.
Now, lets assume the response (and its retransmissions)
get lost. The peer has received and sent all messages
of the protocol and is expecting Success. The server
on the other hand is missing the last message. Eventually
it will give up and is forced to disconnect and not
grant access.

In a variation of this scenario there is an attacker
who creates this situation by blocking the last response.
The result is DoS where the peer ends up in a lengthy
timeout while the server performs a disconnect.

Conclusion? As Hannes pointed out also, protected result
indications can never provide complete assurance that the
parties are in sync.

--Jari

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 05 Feb 2004 12:24:56 -0800

> it will give up and is forced to disconnect and not

This is equivalent to the case where physical connectivity is lost
while sending the last response.  We need a timeout mechanism
regardless of whether protected indication is supported or not.  I
think this should not be viewed as a limitation.

> timeout while the server performs a disconnect.

The same as above.

> indications can never provide complete assurance that the

I think protected result indication can help improve robustness
against DoS attacks from off-path attackers.  If attackers are on the
path between communicating entities, nothing can help, and discussing
such a case does not make sense.  What we need is to identify what
kind of DoS attacks are important for us, IMHO.

Yoshihiro Ohba

---

From: Jari Arkko <[email-masked]>
Date: Fri, 06 Feb 2004 22:13:35 +0200

Hi Yoshihiro,

> regardless of whether protected indication is supported or not.  I

I agree.

> think this should not be viewed as a limitation.

Well, at least we should not attempt to fix it. (There
may still be a reason to understand what our protocols
can and can not do.)

> such a case does not make sense. 

Yes. Of course, there can be some differences in what the specific
schemes can accomplish, but perhaps the conclusion for issues 217,
218 is that we should realize there are inherent limits in all of
them, and formulate our claims about in the document accordingly.

--Jari