Subject: [eap] 3GPP identifiers in draft-haverinen-pppext-eap-sim-12.txt

From: "McCann, Stephen" <[email-masked]>
Date: Wed, 31 Mar 2004 10:28:17 +0100

Apologies if this is somewhat off topic.

I've been asked to verify whether 3GPP MSISDNs can be supported
by the EAP-SIM Authentication method, as this does not appear
to be entirely clear from the draft-haverinen-pppext-eap-sim-12.txt
document.

I see that IMSIs are supported, but could the passed IMSI field be
equivalent to the MSISDN of the terminal (UE) ?

BTW : I know this has been discussed within 3GPP, but I've not been
      following that thread, so I apologise if this offends anyone.

Kind regards

Stephen McCann
Siemens Roke Manor
United Kingdom
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: <[email-masked]>
Date: Wed, 31 Mar 2004 17:07:02 +0300

Hello Stephen,

The format of the username portion of the permanent 
identity is specified in section 4.2.1, and the 
subsection "Format of the Permanent Username". If the
permanent username is based on the IMSI, then the exact format
given in the draft must be used, to ensure interoperability.
In this case the username must be based on the IMSI rather
than on the MSISDN.

The same section also specifies: "Alternatively, an 
implementation MAY choose a permanent username that is not 
based on the IMSI. In this case the selection of the username, 
its format, and its processing is out of the scope of this 
document."

So it would be OK to specify separately how to derive the
permanent username from the MSISDN. In EAP-SIM terminology,
that would be a permanent username that is not based on the IMSI.
Obviously, both the peer and the server would have to support 
this specification in order for them to interoperate.

Best regards,
Henry

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext McCann, Stephen
> Sent: 31 March, 2004 12:28
> To: [email-masked]'
> Subject: [eap] 3GPP identifiers in 
> draft-haverinen-pppext-eap-sim-12.txt
> 
> 
>