Subject: [eap] sm-02 nits

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Mar 2004 09:36:38 +0200

- Title should expand "EAP" per RFC editor
   requirements.

- Abstract should expand AAA and replace
   RADIUS with AAA so that it doesn't have to be
   expanded also.

- Move the second last paragraph after the text
   that talks about the switch.

- Delete last paragraph of the abstract,
   it is in part duplication and in part contain
   temporary status information about the document.

- Section 2, s/out of scope for/outside the scope of/
   I think, English is not my native language...

- For some reason, the bottom page heading is right on
   the next line after text ends. E.g. Section 4.1.
   I find this a bit confusing, it takes a moment to
   realize that your eyes have read into the heading and
   not a continuation of the paragraph. If you can change
   this easily, please do. If not, don't worry about it...

- Inconsistent capitalization of the sentences explaining
   variables, see e.g. Sections 4.1.1 vs 4.1.2.

- s/wasn't/was not/
   s/don't/do not/
   s/can't/can not/
   s/hasn't/has not/

- In Section 5.2, I think it would be useful to add
   the following just before "m.init": "In the following
   we will discuss procedure calls that the state machine
   can make to methods."

- As discussed with the RFC editor and in IETF-59,
   we need a .txt version with the state machine
   as a table.

--Jari

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Nick Petroni <[email-masked]>
Date: Thu, 18 Mar 2004 08:59:09 -0500 (EST)

Jari, thanks for the comments. I have 2 questions and a couple comments
inline...

> - Title should expand "EAP" per RFC editor
ok, fixed.

>    RADIUS with AAA so that it doesn't have to be
fixed.

>    that talks about the switch.
I don't quite understand this request. Which paragraph moved where?

>    temporary status information about the document.
done.

>    I think, English is not my native language...
agreed. changed.

>    this easily, please do. If not, don't worry about it...
This is a LaTeX-ism, worst case I will fix it by hand.

>    variables, see e.g. Sections 4.1.1 vs 4.1.2.
Which do you prefer? start with caps or no?

>    s/hasn't/has not/
ewww, yeah. done.

>    we will discuss procedure calls that the state machine
done with slight word smithing.  "The following describes the interaction
between the state machine and EAP methods."

Also made this change in 4.2. Furthermore, I made the order of "IN",
"OUT", and "IN/OUT" consistent between these two sections.

>    we need a .txt version with the state machine
Working on that now... should have something to show tonight or tomorrow.

Thanks!
nick

---

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Mar 2004 16:06:22 +0200

Thanks for your quick response Nick. Inline some

> I don't quite understand this request. Which paragraph moved where?

    This document describes a state machine based on an EAP "Switch"
    model. This model includes  events and actions for the interaction
    between the EAP Switch and EAP methods. The State Machine and
    associated model are informative only. Implementations may achieve
    the same results using different methods.

    A brief description of the EAP "Switch" model is given in the
    Introduction section.

=>

    This document describes a state machine based on an EAP "Switch"
    model. This model includes  events and actions for the interaction
    between the EAP Switch and EAP methods. A brief description of
    the EAP "Switch" model is given in the Introduction section.

    The State Machine and associated model are informative only.
    Implementations may achieve the same results using different
    methods.

> This is a LaTeX-ism, worst case I will fix it by hand.

Ok. Don't worry about it.

> Which do you prefer? start with caps or no?

Caps, and I think you have it everywhere else except
4.1.1.

> "OUT", and "IN/OUT" consistent between these two sections.

Very good.

> Working on that now... should have something to show tonight or tomorrow.

Great, thanks!

--Jari

---

From: Nick Petroni <[email-masked]>
Date: Fri, 19 Mar 2004 00:13:43 -0500 (EST)

Jari et al.,

I have created a -03b to address these issues. Please take a look and
provide feedback so we can produce a -03. 03b can be found at
http://www.cs.umd.edu/~npetroni/EAP/.

Thanks to Pasi, we now have an appendix with an ASCII table of the
state machine.

Please *do* note format issues, but I will likely not fix them all until
we get closer to a final version -- it's a pain to do. I do want to keep
a list though so we get them all.

Thanks,
nick

Nick L. Petroni, Jr.
Graduate Student, Computer Science
Maryland Information Systems Security Lab
University of Maryland
http://www.cs.umd.edu/~npetroni