Subject: [eap] a few small issues from eap-keying-02_c

From: Jari Arkko <[email-masked]>
Date: Fri, 07 May 2004 14:20:26 +0300

I'm am looking at the current EAP keying framework
document, found at:

http://www.drizzle.com/~aboba/EAP/draft-ietf-eap-keying-02_c.txt

First I'd like to say that I find the new organization
in the document much better than what we had in -01.
Also, resolutions for issues 235, 236, and 237 look good.
Thanks.

Three new small issues, however:

Issue nnn: AAA-Key missing from Figure 5
Submitter name: Jari Arkko
Submitter email address: [email-masked]
Date first submitted: 5/7/2004
Reference: http://www.drizzle.com/~aboba/EAP/draft-ietf-eap-keying-02_c.txt
Document: Keying-02_c
Comment type: T/E
Priority: S
Section: 2.2, Figure 5
Rationale/Explanation of issue:

The "peer" box in Figure 5 does not list
AAA-Key, it only lists MSK, EMSK, and TSKs.
Compare this to Figure 4, where AAA-Key is
listed.

Suggested resolution: add AAA-Key to the list
of keys in the "peer" box.

Issue nnn: Various nits
Submitter name: Jari Arkko
Submitter email address: [email-masked]
Date first submitted: 5/7/2004
Reference: http://www.drizzle.com/~aboba/EAP/draft-ietf-eap-keying-02_c.txt
Document: Keying-02_c
Comment type: E
Priority: S
Section: Multiple
Rationale/Explanation of issue:

- Abstract: s/Extensible Authenticaton Protocol/
               Extensible Authentication Protocol/
- 1.3.3: s/capabilties/capabilities/
- 1.4.1: s/transproted/transported/
- 2.4, bullet "[b]": s/identifies/identities/
- 2.4: s/port identifer/port identifier/
- 3.5.1: s/authentiator/authenticator/
- 3.6.2: s/Identitites/Identities/
- 4.5: s/persistant/persistent/
- Appendix A: s/fascilitate/facilitate/
- RFC2284bis reference lists just one
   author, but there are many. Is this an
   xml2rfc database bug? I've seen those
   sometimes... have to edit manually.

Issue nnn: Reference issues
Submitter name: Jari Arkko
Submitter email address: [email-masked]
Date first submitted: 5/7/2004
Reference: http://www.drizzle.com/~aboba/EAP/draft-ietf-eap-keying-02_c.txt
Document: Keying-02_c
Comment type: T
Priority: S
Section: Normative references
Rationale/Explanation of issue:

I'm not sure the reference [IEEE802] needs to
be normative. As far as I can see, its used
as an example in the text. But I may have missed
something.

RFC 1321 is not used anywhere in the text, but
its in the informative references section. Same
for RFC 2230, 2402, 2406, 2782, 3079, 3394, and
FIPS197, FIPS.180-1.1995, EAPAPI, and IEEE80211F.
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 7 May 2004 08:23:30 -0700 (PDT)

> Three new small issues, however:

I've added the issues to the Issues list and addressed them in an updated
strawman -02_c.
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap