Subject: RE: [eap] RE: Comments on draft-adrangi-eap-network-discovery-07.txt

From: "Bari, Farooq" <[email-masked]>
Date: Mon, 14 Feb 2005 08:51:27 -0800

Hi Eugene,

All I can say is that you are not catching up on your weekend emails but on last two years worth of discussions in EAP WG :)) on the draft. It is difficult  for me to understand why IESG has these rules that practically reset everything that has happened with the draft since it got introduced long time back and require authors to satisfy everyone again from the very beginning on  fundamental questions that were dealt with longtime back and are hard to explain/resolve/convey over emails...................

A very brief response (which I am sure can not staisfy you and obviously can not because discussion on this topic is something that has always taken a long time to converge) is, the draft does not mandate anything on  the part of the service provider. It is about ABNF. The information on roaming partners is just a hint for the client device about hotspot operators own roaming partners, and no where does it say it has to be an exhaustive list of all of its roaming partners roaming partners partner etc..IT is not tryin g to solve world hunger problem.  The service provider, can also choose not to advertise any of its partners, a couple of them or all of them if there are a handful. This draft is NOT trying to address your  thousands of roaming coprorate partners scenarios but is to be used by 3GPP SPs. Again this roaming partner information is just a hint and I am not sure why people expect this draft to solve everyone's roaming issues and problems with all the scalability to handle n possible mediating partners etc. ...... to be honest I am not sure if some one can design such a solution that satisfies everyone's roaming dreams.

BR,

Farooq

> -----Original Message-----
> From: Eugene Chang [mailto:[email-masked]]
> Sent: Monday, February 14, 2005 7:46 AM
> To: [email-masked]; Bari, Farooq; 'Adrangi, Farid'; [email-masked]
> Cc: 'Lortz, Victor'; [email-masked]; [email-masked]
> Subject: RE: [eap] RE: Comments on draft-adrangi-eap-network-discovery-07.txt
> 
> Farid,
> I am sorry to be catching up with the weekend mail.
> Glen points out an example that is often overlooked. There are many cases
> where the "home AAA" is the enterprise and not a public provider. This
> provides a significant increase in the number of home AAA. Further, the
> enterprises that fall into this category provide a large number of roaming
> users so we should not be minimizing this scenario.
> 
> I really would like to see an explanation of how this the network discovery
> scheme works in a global context. I can understand how it works with a small
> set of bilateral arrangements but I thing the scheme does not scale.
> 
> Gene
> 
> 
> ---------------------------------
> Eugene Y. Chang
> Funk Software
> voice   1-617-497-6339 x244
> fax     1-617-547-1031
> mobile  1-781-799-0233
> AIM     gene02421
> Skype   gene02421
> email   [email-masked]
> email   [email-masked]
> ---------------------------------
> 
> 
> -----Original Message-----
> From: Glen Zorn (gwz) [mailto:[email-masked]]
> Sent: Saturday, February 12, 2005 11:46 AM
> To: [email-masked]; 'Bari, Farooq'; 'Adrangi, Farid'; [email-masked]
> Cc: 'Lortz, Victor'; [email-masked]; [email-masked]
> Subject: RE: [eap] RE: Comments on
> draft-adrangi-eap-network-discovery-07.txt
> 
> Glen Zorn (gwz) <mailto:[email-masked]> supposedly scribbled:
> 
> > OK, now that we've established that the security properties of
> WLANs
> > are identical to those of cellular networks (I wish that Farooq
> had
> > pointed this out several years ago -- it would have saved a lot of
> > time in 802.11i), I guess we can dispense with any further
> discussion
> > of such things.  Furthermore, no enterprise networks will be
> listed
> > in the hints, just SPs.  Suppose, then, that Bigco.com contracts
> with
> > Consort.com to provide remote access for Bigco's employees when
> they
> > are traveling.  Suppose also that Consort.com is a roaming partner
> of
> > Megatel.com, which operates hotspots in coffeehouses around the
> > world.  A Bigco employee walks into a Megatel hotspot and tries to
> > access the network.
> 
> Should have mentioned, using her Bigco.com user ID.
> 
> >How does that work?  Does it work at all?
> 
> BTW, this example is from Real Life -- the names have been changed
> to protect the innocent -- and is the simplest example of enterprise
> roaming/remote access I can think of.  There are _much_ more complex
> examples, also from Real Life.
> 
> Hope this helps,
> 
> ~gwz
> 
> Why is it that most of the world's problems can't be solved by
> simply
>   listening to John Coltrane? -- Henry Gabriel
> _______________________________________________
> eap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/eap
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: "Glen Zorn (gwz)" <[email-masked]>
Date: Mon, 14 Feb 2005 11:31:12 -0800

Bari, Farooq <> supposedly scribbled:

> Hi Eugene,
> 
> All I can say is that you are not catching up on your weekend
emails
> but on last two years worth of discussions in EAP WG :)) on the
> draft. It is difficult  for me to understand why IESG has these
rules
> that practically reset everything that has happened with the draft
> since it got introduced long time back and require authors to
satisfy
> everyone again from the very beginning on  fundamental questions
that
> were dealt with longtime back and are hard to
explain/resolve/convey
> over emails...................       
> 
> A very brief response (which I am sure can not staisfy you and
> obviously can not because discussion on this topic is something
that
> has always taken a long time to converge) is, the draft does not
> mandate anything on  the part of the service provider. It is about
> ABNF. 

Here are some ideas: put the ABNF on a billboard in Times Square;
buy full-page ads in the New York Times, Der Spiegel, etc.  There
are more, none of which involves using the IETF as little more than
a medium for announcement.

> The information on roaming partners is just a hint for the
> client device about hotspot operators own roaming partners, 

No. it's not; it's a command.  If the client doesn't accept your
"hint" it will be disconnected, right?  Further, the fact that the
AAA proxy or EAP server or whatever is capable of providing a useful
hint at all means that it knows a route to the home network.  Why
send a hint at all, then, instead of just forwarding the message?  

...

Hope this helps,

~gwz