Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

From: "Stastny Richard" <[email-masked]>
Date: Tue, 2 Aug 2005 15:38:11 +0200

Thanks Brian,
 
we also saw another problem here: If we populate
the DNS down to the full streetname, we eventually will
overrun the DNS domainname and label lenght restrictions,
because we have to use IDN.
 
We need to check this.
 
-richard

________________________________

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Di 02.08.2005 15:29
An: Stastny Richard; 'ECRIT'
Betreff: RE: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

This has to do with the ability to start up, vs the ability to validate
street addresses for dispatch.

When you start, you don't HAVE to load all the data down to street address
to be able to map (route) emergency calls.  You can populate enough of the
database to get the correct mapping needed, and that's all.  You can use a
wildcard to allow a query to a fully specified location, without a fully
specified database.  An example would be if you have a PSAP NAPTR wildcard
for *.bergen.nj.us.sos.arpa, then a query to 123.main.bergen.nj.us.sos.arpa
would return that PSAP NAPTR.

You can later go in and populate the data below that level.  When you do,
you need to put the actual NAPTR in the leaf nodes (123.main...). You then
get the ability to validate.

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Tuesday, August 02, 2005 8:12 AM
To: Brian Rosen; ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

Hi Brian,

in your presentation today you mentioned that the DNS does not need
to fillid up fully to the street and number level, you can stop earlier
and use a wildcard NAPTR to the PSAP URI

We had a discussion on this afterwards and the question came up
how a device is then able to check the validity of an address.?

So if a device wants to validate an address, how is this done
in your proposal? Via a separate database?

The other possibility is to fill up the DNS always down to the
street and housenumber level even it contains the same PSAP URI

regards
Richard

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 2 Aug 2005 09:40:55 -0400

I mentioned this.  If you can exceed the length limit, you need to
(consistently) use abbreviations.

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2005 9:38 AM
To: Brian Rosen; ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

Thanks Brian,

We need to check this.
 
-richard

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Tuesday, August 02, 2005 8:12 AM
To: Brian Rosen; ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

Hi Brian,

regards
Richard