Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

From: "Stastny Richard" <[email-masked]>
Date: Tue, 2 Aug 2005 14:12:28 +0200

Hi Brian,
 
in your presentation today you mentioned that the DNS does not need
to fillid up fully to the street and number level, you can stop earlier
and use a wildcard NAPTR to the PSAP URI
 
We had a discussion on this afterwards and the question came up
how a device is then able to check the validity of an address.?
 
So if a device wants to validate an address, how is this done
in your proposal? Via a separate database?
 
The other possibility is to fill up the DNS always down to the
street and housenumber level even it contains the same PSAP URI
 
regards
Richard

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 2 Aug 2005 09:29:38 -0400

This has to do with the ability to start up, vs the ability to validate
street addresses for dispatch.

When you start, you don't HAVE to load all the data down to street address
to be able to map (route) emergency calls.  You can populate enough of the
database to get the correct mapping needed, and that's all.  You can use a
wildcard to allow a query to a fully specified location, without a fully
specified database.  An example would be if you have a PSAP NAPTR wildcard
for *.bergen.nj.us.sos.arpa, then a query to 123.main.bergen.nj.us.sos.arpa
would return that PSAP NAPTR.

You can later go in and populate the data below that level.  When you do,
you need to put the actual NAPTR in the leaf nodes (123.main...). You then
get the ability to validate.

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2005 8:12 AM
To: Brian Rosen; ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

Hi Brian,

 

regards
Richard

---

From: Andrew Newton <[email-masked]>
Date: Tue, 2 Aug 2005 09:47:48 -0400

> would return that PSAP NAPTR.

I don't think this answers the question.

If there is a wildcard *.bergen.nj.us.sos.arpa, for validation  
purposes how do you distinguish between a correct answer for the  
query of:

                        123.main.bergen.nj.us.sos.arpa
    and
         this-is-obviously-bogus.bergen.nj.us.sos.arpa

-andy

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 2 Aug 2005 10:01:14 -0400

You don't.  If there is no validation data, any location is a valid
location, and in particular, if you put in any address in the range of the
wildcard, validation will pass.  Mapping will pass.  That is as it should be
I think.

If you are really concerned about the ability of the client to know if
validation data is available, I can propose a solution.

Brian

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2005 9:48 AM
To: Brian Rosen
Cc: 'Stastny Richard'; 'ECRIT'
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

-andy

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 2 Aug 2005 10:10:24 -0400

I reread this and wondered if I misunderstood the question.

If you DO have validation data, you DON'T have a wildcard.

So if the question was how do I distinguish a valid location from an invalid
one if I there is validation data, then the answer is there is no wildcard,
and a request to validate would return no RRs.

If the question was how do you distinguish between a good location and an
obviously bad location when there is no validation data, then the answer is
that you can't.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Brian Rosen
Sent: Tuesday, August 02, 2005 10:01 AM
To: 'Andrew Newton'
Cc: 'Stastny Richard'; 'ECRIT'
Subject: RE: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

Brian

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2005 9:48 AM
To: Brian Rosen
Cc: 'Stastny Richard'; 'ECRIT'
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

-andy