Subject: AW: [Ecrit] High-Level Requirements section (<draft-schulzrinne-ecrit-requirements-01.txt>)

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 9 Aug 2005 15:48:09 +0200

hi henning, 

i haven't seen these discussions.... a reference is just fine. 

ciao
hannes

> > # what is the difference between 'conversational text' and 'instant
> > messaging' in this context?  
> 
> Let's not restart this one. The difference has been well explored (to 
> say the least) on the SIPPING mailing list, in at least 893 
> messages...
> 
> Conversational text is shown as you type it, letter by 
> letter, while IM 
> is message-oriented (type + hit return => whole message gets sent).
> 
> See the ToIP drafts, which should probably be cited here.
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 11 Aug 2005 15:46:12 +0200

hi ted, 

what about the following text:

> -----Ursprüngliche Nachricht-----
> Von: Ted Hardie [mailto:[email-masked]] 
> Gesendet: Dienstag, 9. August 2005 21:59
> An: Tschofenig, Hannes; [email-masked]
> Betreff: Re: [Ecrit] High-Level Requirements section 
> (<draft-schulzrinne-ecrit-requirements-01.txt>)
> 
> 
> At 11:19 AM +0200 8/9/05, Tschofenig, Hannes wrote:
> >   R6.  Incremental Deployment The output of the ECRIT 
> mapping protocol
> >      will be one or more URIs that can be used as the target of an
> >      emergency communication.  These must be usable by an 
> appropriately
> >      capable device even if that device has no knowledge of 
> the mapping
> >      protocol.  As an example, if the mapping protocol returns a SIP
> >      URI any SIP-capable phone should be able to use it as 
> a target of
> >      the call; no special extension to SIP should be required.
> >
> >
> ># R6 does not seem to be a requirement or it is, at the moment, not
> >phrased as one.
> >
> 
> The requirement is that what the mapping protocol returns be in
> the standard format for the communication protocol; that is, 
> it should return
> something in a SIP context that *any* SIP capable phone would 
> be able to use--it
> should not have special purpose URIs or schemes as its output, since
> those would not be understood by "legacy" SIP devices.  I 
> think it is reasonably
> clear on that point.  In some sense it is a constraint rather 
> than a requirement,
> but I think it is important to capture somewhere.
> 			regards,
> 				Ted Hardie
> 
> 
>

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 11 Aug 2005 22:06:49 +0200

hi ted, 

you are right. here is another try: 

"
R6.  Incremental Deployment:

The ECRIT mapping protocol MUST return URIs that 
are useable by a standard signaling protocol (i.e., without 
special emergency extensions) unless an error is returned. 
"

ciao
hannes

> At 3:48 PM +0200 8/11/05, Tschofenig, Hannes wrote:
> >hi ted,
> >
> >what about the following text?
> >
> >"
> >R6.  Incremental Deployment:
> >
> >The ECRIT mapping protocol MUST return at least one URI that 
> is useable by a standard signaling protocol (i.e., without 
> special emergency extensions) unless an error is returned. 
> 
> I think this changes the sense.  I still believe we're saying 
> "the URIs returned should
> require no knowledge of special emergency extensions"; why 
> should we say
> only one of the URIs returned must have this property?
> 
> 			regards,
> 				Ted
> 
> >Motivation:
> >
> >The format of the output returned by the mapping protocol 
> is, for example, a URI that can be used by any SIP capable 
> phone. Special purpose URIs would not be understood by 
> "legacy" SIP devices since they do not have knowledge about 
> the mapping protocol.
> >"
> >
> >ciao
> >hannes
> >
> >