Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

From: "Stastny Richard" <[email-masked]>
Date: Wed, 3 Aug 2005 10:11:14 +0200

Hi Brian, 
 
we may run here in a similar problem with DNS wildcards
(considered harmful by some ;-) like in ENUM e.g with
pilotnumbers.
 
On one side we have:
 
 L6.  Validation of civic location: It MUST be possible to validate an
      address prior to its use in an actual emergency call.
 
emphasis on prior
 
on the other hand the mapping protocol MUST return
a valid PSAP URI even with an invalid or partially valid
location during the emergency call (there is no time during
the emergency call to start hazzling the subscriber with a
wrongly entered housenumber or misspelled streetname
 
So there is a requirement for the mapping database:
If you query the database with a wrong (not existing)
civil location, the return MUST contain
there most appropriate PSAP URI
(e.g. the state default PSAP)
AND an indication that the location infromation
provided is not existing.
 
In the examples given if you enter
 this-is-obviously-bogus.bergen.nj.us.sos.arpa
 
and there is a 
 
123.main.bergen.nj.us.sos.arpa

you get back NXDOMAIN
but not a proper NAPTR at all
 
You have then to walk up the tree
e.g. using the indication of the
enclosing zone to find the default
NAPTR for the street or county, etc
This default NAPTR is NOT a 
wildcard

-richard

________________________________

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Di 02.08.2005 17:11
An: 'Andrew Newton'
Cc: Stastny Richard; 'ECRIT'
Betreff: RE: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

So, I answered this
If there is 123.main.bergen...., then you have validation data loaded in the
DNS, in which case you do not have a wildcard.  You would only have the
wildcard if there was not any data below Bergen.nj.us.sos.arpa.

Brian

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]]
Sent: Tuesday, August 02, 2005 10:50 AM
To: Brian Rosen
Cc: 'Stastny Richard'; 'ECRIT'
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

On Aug 2, 2005, at 10:10 AM, Brian Rosen wrote:

> I reread this and wondered if I misunderstood the question.

Perhaps I asked the question incorrectly.  Let me try again.

If there is:
                                *.bergen.nj.us.sos.arpa
    and
                         123.main.bergen.nj.us.sos.arpa

How do you validate (or invalidate):

          this-is-obviously-bogus.bergen.nj.us.sos.arpa

-andy

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 3 Aug 2005 04:33:25 -0400

In North America, "walking up the tree" may not get you the right PSAP.
There is a notion of a "default route", but it's typically more complex then
walking up the tree.

First of all are you suggesting a new requirement? If so, please state it.

Then, are you suggesting that the mechanism has to return the "longest
prefix match" equivalent?  Is it acceptable that the client do more work if
the presented location does not produce a route?

We could put a PSAP NAPTR at, say bergen.nj.us.sos.arpa, which a client
could query for.  That's not a wildcard.  If we put a wildcard for
*.bergen.nj.us.sos.arpa, it would match 
this-is-obviously-bogus.bergen.nj.us.sos.arpa.  It's not clear to me this is
desirable.

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Wednesday, August 03, 2005 4:11 AM
To: Brian Rosen; Andrew Newton
Cc: ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

Hi Brian, 

On one side we have:

emphasis on prior

 
 
and there is a 

you get back NXDOMAIN

-richard

So, I answered this

Brian

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]]
Sent: Tuesday, August 02, 2005 10:50 AM
To: Brian Rosen
Cc: 'Stastny Richard'; 'ECRIT'
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

If there is:
                                *.bergen.nj.us.sos.arpa
    and

-andy