Subject: RE: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

From: "Schwarzbauer, Hanns Juergen" <[email-masked]>
Date: Tue, 2 Aug 2005 15:44:37 +0200

just another "international" issue

support of DNS names using unicode has to be considered

greetings

HannsJuergen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Stastny Richard
Sent: Tuesday, August 02, 2005 3:38 PM
To: Brian Rosen; ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

Thanks Brian,
 
we also saw another problem here: If we populate
the DNS down to the full streetname, we eventually will
overrun the DNS domainname and label lenght restrictions,
because we have to use IDN.
 
We need to check this.
 
-richard

________________________________

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Di 02.08.2005 15:29
An: Stastny Richard; 'ECRIT'
Betreff: RE: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt 

This has to do with the ability to start up, vs the ability to validate
street addresses for dispatch.

When you start, you don't HAVE to load all the data down to street
address
to be able to map (route) emergency calls.  You can populate enough of
the
database to get the correct mapping needed, and that's all.  You can use
a
wildcard to allow a query to a fully specified location, without a fully
specified database.  An example would be if you have a PSAP NAPTR
wildcard
for *.bergen.nj.us.sos.arpa, then a query to
123.main.bergen.nj.us.sos.arpa
would return that PSAP NAPTR.

You can later go in and populate the data below that level.  When you
do,
you need to put the actual NAPTR in the leaf nodes (123.main...). You
then
get the ability to validate.

Brian

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Tuesday, August 02, 2005 8:12 AM
To: Brian Rosen; ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

Hi Brian,

in your presentation today you mentioned that the DNS does not need
to fillid up fully to the street and number level, you can stop earlier
and use a wildcard NAPTR to the PSAP URI

We had a discussion on this afterwards and the question came up
how a device is then able to check the validity of an address.?

So if a device wants to validate an address, how is this done
in your proposal? Via a separate database?

The other possibility is to fill up the DNS always down to the
street and housenumber level even it contains the same PSAP URI

regards
Richard

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 3 Aug 2005 10:53:04 +0200

Brian wrote:
>In North America, "walking up the tree" may not get you the right PSAP.
>There is a notion of a "default route", but it's typically more complex then
>walking up the tree.

I talked about a "default" PSAP and not the "right" PSAP.
IMHO it is a local matter to define always a "default" PSAP
for such cases. It may be a neighboring PSAP or in worst case
the state default PSAP.

>First of all are you suggesting a new requirement? If so, please state it.

Yes, will do, I just have to check the existing requirements if it
is an addition to an existing requirement or a new one.

>Then, are you suggesting that the mechanism has to return the "longest
>prefix match" equivalent?  Is it acceptable that the client do more work if
>the presented location does not produce a route?

The requirement has to be formulated implementation neutral.
If this requires more work on the client or not is dependant
on the implementation e.g. in DNS it may require a second query
by the client.

>We could put a PSAP NAPTR at, say bergen.nj.us.sos.arpa, which a client
>could query for.  That's not a wildcard.  If we put a wildcard for
>*.bergen.nj.us.sos.arpa, it would match
>this-is-obviously-bogus.bergen.nj.us.sos.arpa.  It's not clear to me this is
>desirable.

Its either or. If there is no more detail below bergen.nj.us.sos.arpa.  
you put in a wildcard, If there is more detail, wildcards will not work
and you have to put in a normal NAPTR. You see this NAPTR
only if you query directly for bergen.nj.us.sos.arpa.  

-richard

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Wednesday, August 03, 2005 4:11 AM
To: Brian Rosen; Andrew Newton
Cc: ECRIT
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

Hi Brian,

we may run here in a similar problem with DNS wildcards
(considered harmful by some ;-) like in ENUM e.g with
pilotnumbers.

On one side we have:

 L6.  Validation of civic location: It MUST be possible to validate an
      address prior to its use in an actual emergency call.

emphasis on prior

on the other hand the mapping protocol MUST return
a valid PSAP URI even with an invalid or partially valid
location during the emergency call (there is no time during
the emergency call to start hazzling the subscriber with a
wrongly entered housenumber or misspelled streetname

So there is a requirement for the mapping database:
If you query the database with a wrong (not existing)
civil location, the return MUST contain
there most appropriate PSAP URI
(e.g. the state default PSAP)
AND an indication that the location infromation
provided is not existing.

In the examples given if you enter
 this-is-obviously-bogus.bergen.nj.us.sos.arpa

and there is a

you get back NXDOMAIN
but not a proper NAPTR at all

You have then to walk up the tree
e.g. using the indication of the
enclosing zone to find the default
NAPTR for the street or county, etc
This default NAPTR is NOT a
wildcard

-richard

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Di 02.08.2005 17:11
An: 'Andrew Newton'
Cc: Stastny Richard; 'ECRIT'
Betreff: RE: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

So, I answered this
If there is 123.main.bergen...., then you have validation data loaded in the
DNS, in which case you do not have a wildcard.  You would only have the
wildcard if there was not any data below Bergen.nj.us.sos.arpa.

Brian

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]]
Sent: Tuesday, August 02, 2005 10:50 AM
To: Brian Rosen
Cc: 'Stastny Richard'; 'ECRIT'
Subject: Re: [Ecrit] FW: I-D ACTION:draft-rosen-dns-sos-02.txt

On Aug 2, 2005, at 10:10 AM, Brian Rosen wrote:

> I reread this and wondered if I misunderstood the question.

Perhaps I asked the question incorrectly.  Let me try again.

If there is:
                                *.bergen.nj.us.sos.arpa
    and

How do you validate (or invalidate):

          this-is-obviously-bogus.bergen.nj.us.sos.arpa

-andy