Subject: [Ecrit] RE: [Sipping] Re: A proposal for closing the gap between i2 and i3

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 24 Aug 2005 14:31:56 -0400

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juha Heinanen
> Sent: Wednesday, August 24, 2005 1:08 AM
> To: Brian Rosen
> Cc: 'Stastny Richard'; 'sipping'; [email-masked]
> Subject: RE: [Sipping] Re: A proposal for closing the gap 
> between i2 and i3
> 
> Brian Rosen writes:
> 
>  > Where is the location information coming from?  In i2, it 
> initially comes  > from a self reported location = a website 
> the VoIP carrier runs.  
> 
> right now community information comes from whatever the user 
> has configured in his proxy as his community using a web 
> page.  so this seems to match what you have.
> 
>  > That's a
>  > poor answer, but it's the only one we can do in a short 
> time frame.  What  > you want is automatic location 
> reporting, and that takes a bunch of work in  > the access 
> network, and the phones and/or the call servers.  Is the  > 
> government going to run the website?  
> 
> the only thing i have proposed is that each mobile operator 
> is MANDATED to have a web site accessible via xml-rpc, for 
> example, that contains coordinates of their mobile base 
> stations.  

Competitively, no mobiel carrier will do that.

Security-wise, why not mail this to terrorist organizations while you
are at it.

sip phone having mobile network access, can then 
> calculate its location that can be mapped to community code 
> by another xml-rpc call.  gps would be another choice, but 
> not a very good one, because it seems to work only outside 
> and even then takes long time to initialize.
> 
>  > Then you need to decide if PSTN routing from a gateway, is 
> appropriate.
>  > Most emergency call systems I know about don't do this; 
> they have special  > routing directly from the end office 
> serving the subscriber to the PSAP (or  > to the special 
> tandem in North America).  
> 
> this is not the case in many countries outside of n.a.
> 
>  > Then you have the problem of Denial of Service.  If you 
> make it real easy to  > "bomb" the emergency service with 
> lots of calls with no authentication, they  > will not be happy.
> 
> today it is possible to make emergency calls with a cell 
> phone without a sim card.  so the same problem exists 
> already.  the question is, which is more important:  
> possibility to make emergency call anonymously or not to be 
> able to make the call at all.
> 
> -- juha

Ummm, what is the cost of doing that many prank calls from cell phones,
versus using a bot-net to do this via the Internet?

Mike

> 
> _______________________________________________
> Sipping mailing list  https://www1.ietf.org/mailman/listinfo/sipping
> This list is for NEW development of the application of SIP 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments of core SIP
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 24 Aug 2005 22:02:19 +0300

> Competitively, no mobiel carrier will do that.

so you don't care about p2p sip users being able to tell where they are
when they make emergency call?  there is always a trade-off and i don't
consider competition good enough reason to prevent emergency calling
with location information.

 > Security-wise, why not mail this to terrorist organizations while you

it is easy to anyone to figure out where the base stations in any
particular area are.  we could use the community to post that
information to an unofficial web site (each collecting the information
in the area where they live), but i would prefer to do it officially.

looks like in the u.s. anything is now terrorist related.  i think you
should cool down a bit and perhaps choose better leaders next time.

 > versus using a bot-net to do this via the Internet?

you can buy a smart cell phone and program it to make as many anonymous
emergency calls as you like.

-- juha