Subject: RE: [Ecrit] Wireline vs wireless routing

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 3 Feb 2006 18:12:05 -0500

So, if a phone switches from wireline (WiFi) to wireless (GSM) or vice
versa, do the PSAPs have to change also?

I know some are suggesting that the call can not switch networks when on
911, but the alternative is when one moves beyond radio coverage the
call gets dropped.  Redialing the call will go to a different PSAP.

So, I guess you get two [fill in your emergency responder here] sent to
your location.  I think that will last as long as the emergency
organizations have money to burn.

Mike

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Brian Rosen
> Sent: Friday, February 03, 2006 5:30 PM
> To: [email-masked]; 'Henning Schulzrinne'; 'Rollender, 
> Douglas Harold (Douglas)'
> Cc: [email-masked]; 'ECRIT'
> Subject: RE: [Ecrit] Wireline vs wireless routing
> 
> Sorry, dropped a "'t".  I meant to say that you CAN'T route a 
> wireless call with the wireline polygon set.
> 
> Brian
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Brian Rosen
> Sent: Friday, February 03, 2006 5:19 PM
> To: 'Henning Schulzrinne'; 'Rollender, Douglas Harold (Douglas)'
> Cc: [email-masked]; 'ECRIT'
> Subject: RE: [Ecrit] Wireline vs wireless routing
> 
> I do not agree.
> 
> While you can argue that the route is wrong it IS the route, 
> and you can't
> say "but I can send it to the right place".   
> 
> The reality is that there is a set of wireline polygons and a 
> set of wireless polygons, and they are different.  Wishing 
> they were not isn't helpful.  You can route a wireless call 
> with the wireline polygon set.
> 
> Eventually, this situation will resolve itself, but I think 
> we will deploy before it does.
> 
> Brian
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Henning Schulzrinne
> Sent: Friday, February 03, 2006 4:57 PM
> To: Rollender, Douglas Harold (Douglas)
> Cc: [email-masked]; ECRIT
> Subject: Re: [Ecrit] Wireline vs wireless routing
> 
> The conclusion, however, seems to be that routing is, in all 
> cases, based on currently-available location information, 
> just that a wireless call may end up in the wrong place 
> initially due to the limitations of that initial location 
> fix. This seems to indicate that no new mechanisms in the 
> mapping protocol are required.
> 
> Rollender, Douglas Harold (Douglas) wrote:
> > Reply to follow-up questions from Gojo attached.
> > 
> > Gojo,
> > 
> > Thanks for further clarification on difference in routing between 
> > wireless
> and wireline.  Not sure how ECRIT may use the information 
> except we can anticipate needing to support the same routing 
> scenarios for voice and data and the same location functions 
> and performance characteristics in future access networks.
> > 
> > Doug
> > 
> > Douglas Rollender
> > Lucent Technologies
> > Wireless Standards Development and Industry Relations
> > TN=973 386-4560, FAX=973 386-4555, Mobile=908-963-7965
> > 
> > 
> > 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf 
> > Of Rollender, Douglas Harold (Douglas)
> > Sent: Friday, February 03, 2006 10:58 AM
> > To: Abbott, Nadine B; ECRIT
> > Subject: RE: [Ecrit] Wireline vs wireless routing
> > 
> > 
> > Follow up questions for Gojo on the NJ scenario -
> > 
> > 1) How does the county PSAP know which local PSAP is to receive the 
> > call
> if the caller location data is not available from the ESME to 
> the state/county PSAP until after the call arrives?
> > 
> > 2) Is it really safer and faster to deliver the call initially to a
> state/county PSAP without the location data and then transfer 
> the call to the town PSAP after the either (a) data message 
> arrives from the ESME to the state/county PSAP or (b) the 
> caller is asked to provide the location information verbally, 
> the state/county PSAP call taker does a "manual" data look-up 
> and then signals a call transfer?  
> > 
> > 3) Does the call data (ESME data as well as interview information 
> > entered
> manually such as caller location) automatically follow the 
> call, is it sent separately, "pulled" by the local call taker 
> from a central data source after the call arrives at the 
> local PSAP or not delivered at all?  If data is sent 
> separately, how is data delivery ensured to the same call 
> taker that receives the call?
> > 
> > Doug
> > 
> > Douglas Rollender
> > Lucent Technologies
> > Wireless Standards Development and Industry Relations
> > TN=973 386-4560, FAX=973 386-4555, Mobile=908-963-7965
> > 
> > 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf 
> > Of Abbott, Nadine B
> > Sent: Friday, February 03, 2006 9:29 AM
> > To: ECRIT
> > Subject: FW: [Ecrit] Wireline vs wireless routing
> > 
> > 
> > Some clarifications
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, February 02, 2006 8:44 PM
> > To: Abbott, Nadine B; [email-masked]; Winterbottom, 
> James; Brian 
> > Rosen
> > Cc: [email-masked]; [email-masked]; STOFFELS, PAUL R (AIT)
> > Subject: RE: [Ecrit] Wireline vs wireless routing
> > 
> > This is just an "application of terminology" problem.
> > 
> > Its not that PSAP routing is intentionally different for 
> wireline vs 
> > wireless, it has to do with how granular you can get in 
> your routing 
> > decisions. The PSAP that dispatches emergency services is 
> the same for 
> > both callers, but the PSAP that gets the call initially may be 
> > different.
> > 
> > NJ is a good example of how this plays out. NJ has 230 
> PSAPs covering 
> > the 21 counties. Many PSAPs serve a single municipality and several 
> > counties in NJ have more than 20 PSAPs with no county-level PSAP. 
> > Let's say I place a cell tower on the roof of 4 Skiles Ave in 
> > Piscataway. The street address for that tower is 4 Skiles 
> Ave which, 
> > according to the MSAG, would be routed to the Piscataway PD PSAP. 
> > Unfortunately, the cell tower, with a 5 mile serving radius, serves 
> > callers in 4 or 5 neighboring towns as well as Piscataway.
> > 
> > I need to route calls from this cell to a County or State 
> Police PSAP 
> > that is set up to answer from a wider area. To do that, we 
> created the 
> > State of XX in the MSAG, so that 4 Skiles Ave, Piscataway, 
> XX could be 
> > assigned a different ESN and be routed to a different PSAP.
> > 
> > If the caller turns out to be in Piscataway, the call is 
> transferred 
> > from the County/State PSAP to Piscataway PD for 
> dispatching. The point 
> > is that the wireless caller may be routed to a different 
> PSAP out of 
> > necessity, but the call will ultimately end up at the PSAP 
> serving the 
> > caller's location.
> > 
> > Why not route the call based on the caller's actual 
> location? Because, 
> > generally speaking, the location data is not derived or 
> delivered fast 
> > enough to be usable for routing. We'd have to place the caller in 
> > queue and play cheesy elevator music until the location could be 
> > derived, delivered and translated to an ESN. That probably 
> wouldn't be popular.
> > Wireless callers already have to wait longer to reach 9-1-1 than 
> > wireline callers simply because wireless calls take longer 
> to set up, 
> > particularly if RF channels are not immediately available. 
> Over time, 
> > as the technology matures, routing on location will become the norm 
> > and the need to route differently will go away.
> > 
> > I hope no one considers this type of routing a viable 
> option for VoIP.
> > We did it for wireless because we had to, not because we wanted to.
> > 
> > Gojo
> > 
> > Robert K. Gojanovich, ENP
> > Director
> > iXP Corporation
> > 609-406-7625 Direct Dial
> > 215-435-0703 Mobile
> > 609-406-7699 Fax
> > [email-masked]
> > www.ixpcorp.com
> > iXP Corporation... Problem Solved
> > 
> > -----Original Message-----
> > From: Abbott, Nadine B [mailto:[email-masked]]
> > Sent: Thursday, February 02, 2006 7:31 PM
> > To: [email-masked]; Winterbottom, James; Brian Rosen
> > Cc: [email-masked]; [email-masked]; STOFFELS, PAUL R (AIT); 
> > Gojanovich, Robert
> > Subject: RE: [Ecrit] Wireline vs wireless routing
> > 
> > Brian,
> > 
> > Perhaps you can clarify with some examples of what you mean about 
> > different routing of wireline and wireless callers?  I've 
> never heard 
> > before that for the very same location, emergency calls routed to a 
> > given PSAP would be dispatched differently, with different 
> emergency 
> > responders for wireline and wireless.
> > 
> > However, I have heard of examples of different routing to different 
> > answering points/PSAPs for wireless calls  based on access type and 
> > location, like the following.
> > In California, wireless calls used to be routed to the 
> Highway Patrol, 
> > but this began phasing out several years ago.  Likewise, in other 
> > states, like NJ, wireless calls were routed to a central 
> PSAP because 
> > of the high volumes and the need to handle the traffic slightly 
> > differently, at least partly because of location-related 
> concerns. But 
> > I believe that these kind of arrangements are being phased 
> out as most 
> > areas are at least moving toward implementation of Wireless Phase I 
> > and Phase II, and are enabling wireless calls to be appropriately 
> > routed to a PSAP based on location.  However, wireless calls may be 
> > routed based on primary PSAP serving area, because the granularity 
> > (down to information that identifies the appropriate emergency 
> > resources to be dispatched, i.e., ESZ) may not be available 
> for wireless p-ANIs.
> >   
> > As Delaine mentions, there are sometimes different trunk 
> groups to the 
> > PSAP also for wireline and wireless, but I think that this 
> is to help 
> > the PSAP ensure that volumes and bursts of calls from mobiles won't 
> > swamp out emergency service to wireline callers, not 
> because they were 
> > routed differently?
> >   
> > Nadine
> > 
> > P.S. I added Ric Atkins, Tom Breen, Bob Gojanovich, and 
> Paul Stoffels 
> > to this thread because they have a wealth of experience to 
> add to this 
> > discussion, I expect.
> >  
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Delaine M Arnold ENP
> > Sent: Thursday, February 02, 2006 6:28 PM
> > To: 'Winterbottom, James'; 'Brian Rosen'; [email-masked]
> > Subject: RE: [Ecrit] Wireline vs wireless routing
> > 
> > I've heard some numbers from various PSAPs indicating their 
> wireless 
> > call volume continues to increase and is more than their wireline 
> > volume.  I've heard 45-50% wireless in some areas.  Many PSAPs have 
> > separate trunks for wireline and wireless. This is not a 
> small problem.
> > 
> > Delaine M. Arnold, ENP
> > Independent Consultant
> > Chair, NENA Data Technical Committee
> > Voice:  813-960-1698
> > Fax:     309-412-7821
> > Email:  [email-masked]
> >  
> > "The finish line is just the beginning."
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Winterbottom, James
> > Sent: Thursday, February 02, 2006 4:57 PM
> > To: Brian Rosen; [email-masked]
> > Subject: RE: [Ecrit] Wireline vs wireless routing
> > 
> > Ooopss... I meant to add whether this was a 5% outlying 
> problem, or a 
> > significant proportion of jurisdictions?
> > 
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]] On 
> >> Behalf
> > Of
> >> Brian Rosen
> >> Sent: Friday, 3 February 2006 8:17 AM
> >> To: [email-masked]
> >> Subject: [Ecrit] Wireline vs wireless routing
> >>
> >> A subtle problem that may give rise to another requirement 
> is that in 
> >> some areas a true moble client has different routing than 
> a wireline 
> >> client.  The psap service boundaies are different depending on what
> > you
> >> are calling on.  It may be that this difference fades over 
> time, but
> > its
> >> clearly different in some areas today.
> >>
> >> Brian
> >>
> >> _______________________________________________
> >> Ecrit mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> > 
> ----------------------------------------------------------------------
> > --
> > ----
> > --------------------
> > This message is for the designated recipient only and may contain 
> > privileged, proprietary, or otherwise private information.
> > If you have received it in error, please notify the sender 
> immediately 
> > and delete the original.  Any unauthorized use of this email is 
> > prohibited.
> > 
> ----------------------------------------------------------------------
> > --
> > ----
> > --------------------
> > [mf2]
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> > 
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> > 
> > 
> > 
> ----------------------------------------------------------------------
> > --
> > 
> > Subject:
> > NJ Questions
> > From:
> > "Gojanovich, Robert" <[email-masked]>
> > Date:
> > Fri, 3 Feb 2006 13:46:44 -0500
> > To:
> > "Rollender, Douglas Harold (Douglas)" <[email-masked]>
> > 
> > To:
> > "Rollender, Douglas Harold (Douglas)" <[email-masked]>
> > CC:
> > "Abbott, Nadine B" <[email-masked]>
> > 
> > 
> > Doug,
> > 
> > Nadine forwarded me your questions (I am not on the ecrit 
> list server).
> Answers below.
> > 
> > Follow up questions for Gojo on the NJ scenario -
> > 
> > 1) How does the county PSAP know which local PSAP is to receive the 
> > call
> if the caller location data is not available from the ESME to 
> the state/county PSAP until after the call arrives?  Gojo: It 
> doesn't. Until the call is answered and the location arrives 
> or is provided by the caller, no one knows where the call came from.
> > 
> > 2) Is it really safer and faster to deliver the call initially to a
> state/county PSAP without the location data and then transfer 
> the call to the town PSAP after the either (a) data message 
> arrives from the ESME to the state/county PSAP or (b) the 
> caller is asked to provide the location information verbally, 
> the state/county PSAP call taker does a "manual" data look-up 
> and then signals a call transfer?  Gojo: You have no caller 
> location until after the call is answered. This is the legacy 
> of NCAS thinking. The original design in J-Std-036 called for 
> the location information to be sent as a TCAP message over 
> SS7 as part of the call setup. Three things, unfortunately, 
> were missing: 1) ALI databases are not SCPs and are not on 
> the SS7 network, 2) most 9-1-1 networks did not support SS7 
> at the time, and
> 3) The location technology can't derive location that fast. 
> In wireline compatibility mode deployments, it is possible 
> for the MPC to receive some locations fast enough to affe ct!
> >   (ESRK selection) routing (at least, that is what they 
> claim), but NJ
> implemented CAS for Phase 1 and NCAS (J-std terminology, 
> formerly called
> HCAS) for Phase 2.
> > 
> > The NJ system does have the potential to route on location. The
> architecture includes a data link between the SR and the ALI. 
> When a wireless call hits the SR, a message containing the 
> ESRD and CBN is sent to the ALI. The ALI immediately launches 
> a query to the MPC. It was designed so that when the 
> coordinate routing feature was implemented, the SR would wait
> 2-3 seconds before completing the call to the PSAP. In that 
> time, the ESME would query the MPC, acquire the coordinates 
> and translate to the precise ESN. The ESN would be sent to 
> the SR to be used for routing. If the ALI did not respond in 
> 2-3 seconds, say, the SR would go ahead and route the call 
> based on the ESRD (cell sector). Since the PDEs can't deliver 
> fast enough on a consistent basis, the State hasn't yet 
> bought the feature.
> > 
> > You have two choices: Route the call to the County/State or 
> route the 
> > call
> to the municipality where the cell is located. Either way 
> will result in some number of transfers. The municipal PSAPs, 
> for the most part, are too small to deal with a high volume 
> of calls from outside their jurisdiction and don't want calls 
> unless they belong to them. Unless it can be determined with 
> some certainty that the caller is within their jurisdiction, 
> they will refuse to answer the calls. This forces the call to 
> the next wrung on the ladder, be it County or State.
> > 
> > It is no more unsafe to send the call to the County for 
> them to screen 
> > and
> transfer to the appropriate PSAP, than it is to send the call 
> to the municipal PSAP where it still has to be screened and, 
> in many cases, transferred. Sending all calls to the County 
> provides for consistency and some predictability. It also 
> allows the County to screen out redundant and non-emergency 
> calls that the local PSAPs are too small to handle in many, 
> many cases.
> > 
> > 3) Does the call data (ESME data as well as interview information 
> > entered
> manually such as caller location) automatically follow the 
> call, is it sent separately, "pulled" by the local call taker 
> from a central data source after the call arrives at the 
> local PSAP or not delivered at all?  If data is sent 
> separately, how is data delivery ensured to the same call 
> taker that receives the call? Gojo: The data delivered 
> through the ESME will follow the call, sort of, and will 
> often be updated. The PSAP that receives the transfer does 
> not get ALI data from the first PSAP, it does its own dip to 
> the ALI database using the ESRK, ESRD or CBN. This dip will 
> generate a new position request to the MPC, so the location 
> data received at the second PSAP may be different than that 
> received by the first PSAP. The Phase 1 data will be the same 
> but the lat/long may be different.
> > 
> > Ancillary information acquired from the caller is usually 
> given to the
> second PSAP verbally. Very few PSAPs have links between CAD 
> systems to do that automatically. Most of that data flow is verbal.
> > 
> > Gojo
> > 
> > Robert K. Gojanovich, ENP
> > Director
> > iXP Corporation
> > 
> > 609-406-7625 Direct Dial
> > 
> > 215-435-0703 Mobile
> > 
> > 609-406-7699 Fax
> > 
> > [email-masked]
> > 
> > www.ixpcorp.com
> > 
> > iXP Corporation... Problem Solved
> > 
> > 
> > 
> > 
> ----------------------------------------------------------------------
> > --
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Fri, 3 Feb 2006 18:20:39 -0500

If the call is up, it stays up.  No one is suggesting you drop it.
Yes, redialing might change the route.  Moving and redialing might change
the route.

The end result is the same responders go; you don't get two responders for
one actual location.  It definitely is the case that if you move, you may
get beyond the range of the responder dispatched, although in most cases
they know how to get the right thing to happen.

This IS the reality today.  The only thing we really get to do is to bet on
whether the differences will disappear before we deploy the ecrit mechanism.
I'd say, not a good thing to bet that they will.

Brian

-----Original Message-----
From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: Friday, February 03, 2006 6:12 PM
To: [email-masked]; Henning Schulzrinne; Rollender, Douglas Harold
(Douglas)

Mike