Subject: RE: [Ecrit] [issue3] List all Services Functionality

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 7 Jun 2006 12:09:09 -0400

Request clarification:  Immediate children or grand-children,
great-grand-children, etc.?

It might be best to only return one level at a time, given that there
could in the long run be many levels (the infinite option :)

Mike

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Tuesday, June 06, 2006 3:47 PM
> To: [email-masked]
> Subject: [Ecrit] [issue3] List all Services Functionality
> 
> 
> Hannes Tschofenig <[email-masked]> added the comment:
> 
> TENTATIVE SUMMARY:
> 
> The functionality of a service listing will be supported by 
> returning the child elements of a given URN.
> 
> __________________________________________________
> LoST Issue Tracker <[email-masked]> 
> <http://www.tschofenig.priv.at:8080/lost/issue3>
> __________________________________________________
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 07 Jun 2006 19:22:31 +0200

Hi Mike,

Returning the child elements only seems to be appropriate to me.

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 07 Jun 2006 19:40:15 +0200

I am referring to immediate child elements only.

A query for 'urn:service:sos' would return

* urn:service:sos.ambulance
* urn:service:sos.animal-control
* urn:service:sos.fire
....
* urn:service:sos.suicide

(based on 
http://www.ietf.org/internet-drafts/draft-ietf-ecrit-service-urn-03.txt

Ciao
Hannes

Hannes Tschofenig wrote:
>>> From: Hannes Tschofenig [mailto:[email-masked]] Sent: 
>>> Tuesday, June 06, 2006 3:47 PM
>>> To: [email-masked]
>>> The functionality of a service listing will be supported by returning 
>>> the child elements of a given URN.
>>>