Subject: RE: [Ecrit] [issue2] Is it allowed to specify civicand geospatialinfointo the query?

From: "Roger Marshall" <[email-masked]>
Date: Wed, 7 Jun 2006 13:13:35 -0700

Tom:
I don't restrict the LoST client to be end device (UA).  As discussed,
LoST queries could be done node by node.  As an example, LoST clients
could take the form of near or far proxies (ESRPs) for stepwise
location-to-uri resolution, whether done in a by-value or by-reference
model, or the PSAP UA (CPE), in case of PSAP transfer, etc.

I guess my main point is that (in many cases) this notion of LoST client
decision making is a client-heavy approach, done in an environment where
clients outnumber servers by 4-1 (um=orders of magnitude!).

Roger.

>-----Original Message-----
>From: Tom-PT Taylor [mailto:[email-masked]] 
>Sent: Wednesday, June 07, 2006 12:23 PM
>To: Roger Marshall
>Cc: Hannes Tschofenig; [email-masked]
>Subject: Re: [Ecrit] [issue2] Is it allowed to specify 
>civicand geospatialinfointo the query?
>
>You seem to be assuming that the LoST client is the user 
>terminal, and at the same time assuming that it has to parse 
>PIDF-LO. This doesn't make sense to me -- won't it be the 
>originator of the PIDF-LO and have the raw data in hand?
>
>Roger Marshall wrote:
>> I admit that this theme is somewhat of a tangent to the subject, but 
>> can the authors of LoST help me understand the reasons for not using 
>> the PIDF-LO.
>> 
>> Is it the overhead?  Is the PIDF-LO not adequate to convey location 
>> some how?
>> 
>> As an example, if the PIDF-LO format is changed 
>significantly in some 
>> way, it will mandate a s/w change to ~10^8 clients vs. only ~10^2 - 
>> 10^4 server instances.
>>  
>> It seems to me that as the PIDF-LO undergoes changes over time, that 
>> the choice between having to modify client software vs. server 
>> software instances represents a huge difference in effort.
>> 
>> 
>> Roger Marshall
>> 
>> 
>>> -----Original Message-----
>>> From: Hannes Tschofenig [mailto:[email-masked]]
>>> Sent: Monday, June 05, 2006 2:24 PM
>>> To: Roger Marshall
>>> Cc: Brian Rosen; [email-masked]
>>> Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic and 
>>> geospatialinfointo the query?
>>>
>>> Hi Roger,
>>>
>>> Roger Marshall wrote:
>>>> Hannes: Thanks for clarifying.  
>>>>
>>>> I think it's a bad idea to withold location information from
>>> the LoST
>>>> server.
>>>>
>>>> To suggest that we restrict the client, allowing only one to
>>> be sent,
>>>> sounds to me like we're placing a constraint on the PIDF-LO,
>>> saying it
>>>> can't have both (assuming LoST reuses the PIDF-LO).  I 
>don't think we
>>>> can get away with that.   If the PIDF-LO has both, how is it 
>>> that we can
>>>> glibly strip one out?  To do so would be unreasonable.
>>> To clarify:
>>>
>>> * You can send as many queries as you want but not with the same 
>>> message. Different location information => different query
>>>
>>> * We don't use a PIDF-LO in LoST. We use the raw location info.
>>>
>>>> Since the client can have both civic and geo in the 
>PIDF-LO, it can 
>>>> also send both to the server.  What am I missing?
>>> None of the proposals ever used a PIDF-LO as input; just 
>location info.
>>>
>>>> It's the LoST server's job to pick one, not the client's.
>>> At the PSAP and the emergency routing proxy I agree with you.
>>>
>>>> So, the requirement I would support is as follows:
>>>>
>>>> Rx' LoST client SHALL query with either civic or geo.
>>> That's fine.
>>>
>>>
>>>> Ry' LoST client SHOULD query with *both* civic and geo.  When LoST 
>>>> server receives both civic and geo, the server SHOULD try 
>to use the 
>>>> geo first.  The LoST server response SHALL indicate which data was 
>>>> used (either geo or civic).
>>> I guess you will not support for this one based on the 
>response I saw 
>>> on the list so far.
>>>
>>> Ciao
>>> Hannes
>>>
>>>> -roger.
>>>>
>>>>
>>>>
>>>>> -----Original Message-----
>>>>> From: Hannes Tschofenig [mailto:[email-masked]]
>>>>> Sent: Monday, June 05, 2006 1:50 PM
>>>>> To: Roger Marshall
>>>>> Cc: Brian Rosen; [email-masked]
>>>>> Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic and 
>>>>> geospatialinfointo the query?
>>>>>
>>>>> Hi Roger,
>>>>>
>>>>> I think the current suggestion is that the LoST client just picks 
>>>>> whatever he wants and then uses the mapping protocol to 
>trigger the 
>>>>> resolution.
>>>>>
>>>>> Using geo and civic might be, from a certain point of view,
>>> just be an
>>>>> optimization. The LoST client can always trigger separate
>>> queries with
>>>>> all the location info it has.
>>>>>
>>>>> Ciao
>>>>> Hannes
>>>>>
>>>>> Roger Marshall wrote:
>>>>>
>>>>>> I don't disagree that we ask the LoST server to pick one and
>>>>> use it.  
>>>>>
>>>>>> We need to be consistent though, and so therefore, I propose
>>>>> that the
>>>>>
>>>>>> LoST server always picks the geo over the civic and returns
>>>>> a flag in
>>>>>
>>>>>> the response stating that the geo was used to perform mapping.
>>>>>>
>>>>>> Roger.
>>>>>>
>>>>>>
>>>>>>
>>>>>>> -----Original Message-----
>>>>>>> From: Hannes Tschofenig [mailto:[email-masked]]
>>>>>>> Sent: Monday, June 05, 2006 1:39 PM
>>>>>>> To: Brian Rosen
>>>>>>> Cc: [email-masked]
>>>>>>> Subject: Re: [Ecrit] [issue2] Is it allowed to specify 
>civic and 
>>>>>>> geospatialinfointo the query?
>>>>>>>
>>>>>>> It seems that we closed this issue.
>>>>>>>
>>>>>>> Everyone seems to be in favor for a civic OR geospatial.
>>>>>>> Extensions possible for future applications.
>>>>>>>
>>>>>>> Ciao
>>>>>>> Hannes
>>>>>>>
>>>>>>> Brian Rosen wrote:
>>>>>>>
>>>>>>>
>>>>>>>> I think this is the issue.  There is no guidance we 
>can give the 
>>>>>>>> server to tell it how to resolve what to do when  both
>>>>> locations are
>>>>>
>>>>>>>> valid but the URI for the geo does match the URI for the civic.
>>>>>>>>
>>>>>>>> This happens a lot when you are near boundaries because the
>>>>>>> precision
>>>>>>>
>>>>>>>
>>>>>>>> and accuracy of the two methods differ.
>>>>>>>>
>>>>>>>> I think you pick ONE and use it.
>>>>>>>>
>>>>>>>> Even if you send more than one along, the PSAP has to know
>>>>> which one
>>>>>
>>>>>>>> you used to route.  It's going to continue to use that
>>>>> until a human
>>>>>
>>>>>>>> says otherwise.
>>>>>>>>
>>>>>>>> Brian
>>>>>>>>
>>>>>>>> -----Original Message-----
>>>>>>>> From: Henning Schulzrinne [mailto:[email-masked]]
>>>>>>>> Sent: Monday, June 05, 2006 3:55 PM
>>>>>>>> To: Andrew Newton
>>>>>>>> Cc: [email-masked]
>>>>>>>> Subject: Re: [Ecrit] [issue2] Is it allowed to specify 
>civic and 
>>>>>>>> geospatialinfo into the query?
>>>>>>>>
>>>>>>>> At the PSAP, we have a human that can look at this
>>> information and
>>>>>>>> make decisions (and maybe even ask if there's a
>>> discrepancy). That
>>>>>>>> seems a stretch for the LoST server.
>>>>>>>>
>>>>>>>> Andrew Newton wrote:
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>> On Jun 5, 2006, at 2:53 PM, Henning Schulzrinne wrote:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> In all of these dual-information cases, I don't see how 
>>>>>>>>>> anybody except the seeker can make any determination which 
>>>>>>>>>> type of information is better, more accurate, more 
>recent, etc.
>>>>>>>>> Would we want the seeker to determine which information it
>>>>> feels is
>>>>>
>>>>>>>>> best to provide to the PSAP?  I've always heard that the
>>>>>>> answer would be no:
>>>>>>>
>>>>>>>
>>>>>>>>> provide both to the PSAP.  So why then would we not
>>>>> provide the same
>>>>>
>>>>>>>>> information when determining which PSAP to contact?
>>>>>>>>>
>>>>>>>>> -andy
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Ecrit mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www1.ietf.org/mailman/listinfo/ecrit
>>>>>>>>
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Ecrit mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www1.ietf.org/mailman/listinfo/ecrit
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> Ecrit mailing list
>>>>>>> [email-masked]
>>>>>>> https://www1.ietf.org/mailman/listinfo/ecrit
>>>>>>>
>>>>>>
>>>>>>
>>>>
>>>
>> 
>> _______________________________________________
>> Ecrit mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/ecrit
>> 
>
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 7 Jun 2006 16:55:28 -0500

I agree with Roger here.
In the immediate future, and I suspect that for quite some time, routing
decisions based on location will come from centralized call server
implementations. If the call server gets a PIDF-LO it will, at best,
simply grab everything in every location-info element and send it
upwards, unless you are suggesting that the call server make the
decision about which location to use. I would argue that the call-server
is in an even less good position to make this decision than the LoST
server. At least the LoST server is already required to have some rules
and information with regards to making routing decisions.

Cheers
James

> From: Roger Marshall [mailto:[email-masked]]
> Sent: Thursday, 8 June 2006 6:14 AM
> To: Tom-PT Taylor
> Cc: [email-masked]
> Subject: RE: [Ecrit] [issue2] Is it allowed to specifycivicand

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Shida Schubert <[email-masked]>
Date: Wed, 07 Jun 2006 16:08:18 -0700

I am really LoST here and I hope I am the only one.

Is PIDF-LO used for LoST query or not and if not where is
this written?

Anyhow, I think we are saying that LoST client whether it's
UAC or Proxy needs to decide on the best suited location to be
used for querying LoST server. This best suited location will vary
depending on the implementation and deployment scenario.

For example, if UAC doesn't support the LoST protocol, and it's
the proxy that needs to query the LoST server on behalf of
the UAC If there is a PIDF-LO inside the INVITE, the proxy needs
to strip one of the location element in PIDF-LO if more than one
is present and query the LoST server to obtain the PSAP URI to
route a call.

I think if UAC can't make the decision, proxy will generally have a
better chance of knowing which location is more accurate for
UAC (Of course there are a lot of corner cases to this.. VPN + client
not supporting location etc.) than the LoST server as proxy will
have a better idea of where the call has been routed thus far.

I understand that the LoST server only gets service-URN and
location. It does not receive any via header or route header to help
aid with the decision of which location might be more appropriate.
(If PIDF-LO with "provided-by" is present via/route header might
be used to prioritize the location used.)

Regards
Shida

Winterbottom, James wrote:
>> I guess my main point is that (in many cases) this notion of LoST
>>     
> client
>   
>> decision making is a client-heavy approach, done in an environment
>>     
> where
>   
>>>> I admit that this theme is somewhat of a tangent to the subject,
>>>>         
> but
>   
>>>> can the authors of LoST help me understand the reasons for not
>>>>         
> using
>   
>>>> the PIDF-LO.
>>>>
>>>> It seems to me that as the PIDF-LO undergoes changes over time,
>>>>         
> that
>   
>>>>>> Ry' LoST client SHOULD query with *both* civic and geo.  When
>>>>>>             
> LoST
>   
>>>>>> geo first.  The LoST server response SHALL indicate which data
>>>>>>             
> was
>   
>>>>>>> I think the current suggestion is that the LoST client just
>>>>>>>               
> picks
>   
>>>>>>>>>> valid but the URI for the geo does match the URI for the
>>>>>>>>>>                     
> civic.
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 07 Jun 2006 19:32:07 -0400

If I were a programmer faced with making such a decision in the call 
server, I would always choose the first location I found in the PIDF-LO. 
That's simple enough.

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 7 Jun 2006 19:55:36 -0400

In many cases, the call server (I assume you mean SIP proxy) might at  
least have obtained the information, so it has a better clue where it  
came from (subscriber record? user entered?) and thus might have a  
chance to pick the "best" one.

As likely as Tom's predicted outcome is the other one: programmers  
will pick whatever they feel like it or make it configurable, so that  
the outcome will depend on which version of the resolver software a  
particular site is running and the answers may differ as you change  
ISPs.

We need to remember that the location information will invariably be  
split after the first resolver, since the hierarchy for geo and civic  
may differ. I just don't see a corporate LoST resolver doing much  
informed thinking about the merits of different location formats,  
particularly since there's nothing concrete and algorithmic to go by  
to guide the choice when it reaches the resolver.

On Jun 7, 2006, at 7:32 PM, Tom-PT Taylor wrote:

> If I were a programmer faced with making such a decision in the  
> call server, I would always choose the first location I found in  
> the PIDF-LO. That's simple enough.

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 7 Jun 2006 18:58:07 -0500

Shida,

The problem is, as Martin pointed out, one of cardinality. In a single
PIDF-LO I and have multiple tuples, and in each tuple I can have
multiple geopriv objects, and in each location-info element within a
geopriv tuple I can have multiple location representations. Which do I
choose?

The provided-by component does not help at all in the last case since
the provided-by element applies to the whole geopriv component.

I think that if the representation is legal inside a location-info
element, then the LoST server needs to handle it rather than expecting
other nodes to dissect the location down to something that it thinks
that the LoST MIGHT be able to handle.

Cheers
James

> From: Shida Schubert [mailto:[email-masked]]
> Sent: Thursday, 8 June 2006 9:08 AM
> To: Winterbottom, James
> Cc: Roger Marshall; Tom-PT Taylor; [email-masked]
> Subject: Re: [Ecrit] [issue2] Is it allowed to specifycivicand
------------------------------------------------------------------------
> ------------------------
------------------------------------------------------------------------
> ------------------------