Subject: RE: [Ecrit] [issue2] Is it allowed to specify civic and geospatialinfo into the query?

From: "Jean-Francois Mule" <[email-masked]>
Date: Mon, 5 Jun 2006 08:51:48 -0600

This may depend on the scope of LoST.

In the context of emergency context resolution
(ecrit::<service>urn:service:sos</service>), I agree with Brian and
Henning: no, it is not useful to allow both civic and geospatial
information in a query. 

But LoST draft-00 does explicitly have a broader scope of service URNs
that just service:sos and this is where we might need to allow more
flexibility.

Should this question be coupled with the capability to have multiple
requests per mapping query?

Jean-Francois 

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]]
> Sent: Monday, June 05, 2006 8:26 AM
> To: Henning Schulzrinne
> Cc: [email-masked]
> Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic and
> geospatialinfo into the query?
> 
> Not that I disagree with what you are saying, but wouldn't we want to
> put the decision as to which is the best PSAP to call based on the
> two sets of information in the hands of the LoST server and not at
> the client?
> 
> Also, in the scenario you have given, how does the seeker determine
> whether the civic or geo location is best?
> 
> -andy
> 
> On Jun 5, 2006, at 9:45 AM, Henning Schulzrinne wrote:
> 
> > The problem with having both is that the answers may differ, thus
> > creating a new error condition. As far as I can tell, the same
> > result can be achieved by querying sequentially, starting with
> > whatever location information the querier deems best and falling
> > back to the other if needed.
> >
> > Since the querier can issue two queries in parallel if time is
> > important, there is no real performance hit, except for some modest
> > additional packet overhead.
> >
> > Thus, in the spirit of keeping things simple and predictable, I'd
> > say: no.
> >
> > On Jun 5, 2006, at 9:28 AM, Hannes Tschofenig wrote:
> >
> >>
> >> Hannes Tschofenig <[email-masked]> added the comment:
> >>
> >> Currently, a query (LosT client to LoST server) can either contain
> >> civic OR
> >> geospatial location information. It cannot contain both. Would it
> >> be useful to
> >> allow both to be included in the query?

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 05 Jun 2006 19:29:51 +0200

Hi Jean-Francois,

> that just service:sos and this is where we might need to allow more

That's a good point. Since the query type is extensible I think we can 
get away by using a separate query for geospatial, civic and later, if 
needed, for the combination of both.

> requests per mapping query?
If this is useful then most likely in a non-emergency environment. 
Hence, I would also like to push it towards an extension.

Ciao
Hannes