Subject: RE: [Ecrit] [issue2] Is it allowed to specify civic and geospatialinfointo the query?

From: "Roger Marshall" <[email-masked]>
Date: Mon, 5 Jun 2006 13:44:10 -0700

I don't disagree that we ask the LoST server to pick one and use it.  

We need to be consistent though, and so therefore, I propose that the
LoST server always picks the geo over the civic and returns a flag in
the response stating that the geo was used to perform mapping.

Roger.

>-----Original Message-----
>From: Hannes Tschofenig [mailto:[email-masked]] 
>Sent: Monday, June 05, 2006 1:39 PM
>To: Brian Rosen
>Cc: [email-masked]
>Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic 
>and geospatialinfointo the query?
>
>It seems that we closed this issue.
>
>Everyone seems to be in favor for a civic OR geospatial.
>Extensions possible for future applications.
>
>Ciao
>Hannes
>
>Brian Rosen wrote:
>> I think this is the issue.  There is no guidance we can give the 
>> server to tell it how to resolve what to do when  both locations are 
>> valid but the URI for the geo does match the URI for the civic.
>> 
>> This happens a lot when you are near boundaries because the 
>precision 
>> and accuracy of the two methods differ.
>> 
>> I think you pick ONE and use it.
>> 
>> Even if you send more than one along, the PSAP has to know which one 
>> you used to route.  It's going to continue to use that until a human 
>> says otherwise.
>> 
>> Brian
>> 
>> -----Original Message-----
>> From: Henning Schulzrinne [mailto:[email-masked]]
>> Sent: Monday, June 05, 2006 3:55 PM
>> To: Andrew Newton
>> Cc: [email-masked]
>> Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic and 
>> geospatialinfo into the query?
>> 
>> At the PSAP, we have a human that can look at this information and 
>> make decisions (and maybe even ask if there's a discrepancy). That 
>> seems a stretch for the LoST server.
>> 
>> Andrew Newton wrote:
>> 
>>>On Jun 5, 2006, at 2:53 PM, Henning Schulzrinne wrote:
>>>
>>>>In all of these dual-information cases, I don't see how anybody 
>>>>except the seeker can make any determination which type of 
>>>>information is better, more accurate, more recent, etc.
>>>
>>>Would we want the seeker to determine which information it feels is 
>>>best to provide to the PSAP?  I've always heard that the 
>answer would be no:
>>>provide both to the PSAP.  So why then would we not provide the same 
>>>information when determining which PSAP to contact?
>>>
>>>-andy
>> 
>> 
>> _______________________________________________
>> Ecrit mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/ecrit
>> 
>> 
>> _______________________________________________
>> Ecrit mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/ecrit
>> 
>> 
>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 05 Jun 2006 22:49:44 +0200

Hi Roger,

I think the current suggestion is that the LoST client just picks 
whatever he wants and then uses the mapping protocol to trigger the 
resolution.

Using geo and civic might be, from a certain point of view, just be an 
optimization. The LoST client can always trigger separate queries with 
all the location info it has.

Ciao
Hannes