Subject: [Ecrit] [issue3] List all Services Functionality

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 05 Jun 2006 14:28:36 +0000

New submission from Hannes Tschofenig <[email-masked]>:

Do we need the capability to list all services supported by the LoST server? 
Would this feature be useful if the service list is constraint to a certain 
branch of the tree?

----------
assignedto: hannes
messages: 5
nosy: ecrit, hannes
priority: critical
status: unread
title: List all Services Functionality

__________________________________________________
LoST Issue Tracker <[email-masked]>
<http://www.tschofenig.priv.at:8080/lost/issue3>
__________________________________________________

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 05 Jun 2006 17:00:56 -0400

> Do we need the capability to list all services supported by the LoST server?

I don't think every server needs to support this, but it does seem useful.

> Would this feature be useful if the service list is constraint to a certain 

By the current design, each top-level service can have a different LoST 
server, so I suppose the only question is whether only

(1) urn:service:sos

or also

(2) urn:service:sos.fire [all servies

and more deeply-nested URNs should be a query input. My inclination is 
to support both, although I could easily be convinced that keeping it 
simple and only supporting one type of query (as in (1)) is sufficient.

Henning

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 5 Jun 2006 19:17:01 -0500

My thought on the topic was that you can query for

  urn:service:sos.*

This can either result in a sub-tree, or just a list of the immediate children of that node.  I don't see any particularly strong reason for either (make your own trade-off).

However, to be clear, I think that a query for "urn:service:*" is impractical and potentially dangerous.

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, 6 June 2006 7:01 AM
> To: LoST Issue Tracker
> Cc: [email-masked]
> Subject: Re: [Ecrit] [issue3] List all Services Functionality
> 
> 
> 
> Hannes Tschofenig wrote:

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 5 Jun 2006 20:21:34 -0400

On Jun 5, 2006, at 8:17 PM, Thomson, Martin wrote:

> This can either result in a sub-tree, or just a list of the  
> immediate children of that node.  I don't see any particularly  
> strong reason for either (make your own trade-off).

I can agree with that. If we go with that approach, queries for any  
subtree must also be possible, so that the client can recurse if the  
server didn't.

> impractical and potentially dangerous.

Agreed. To be clear as well, I don't think this equivalent of "ls -R"  
cannot be supported in general, given the issue that different top- 
level services may have completely different LoST server hierarchies.