Subject: RE: [Ecrit] [issue1] Do we need a default service URN for the LoSTquery?

From: "Roger Marshall" <[email-masked]>
Date: Mon, 5 Jun 2006 09:39:17 -0700

The LoST server must support a default, so that if it receives a query
which contains location, but no emergency service identifier, then it
can still provide an answer.

The worst case of having this happen is that clients always get an
emergency context associated, location-relevant PSAP URI when they query
with location only.  The server would then return this "default" ESI so
that the client would have it from then on.

I think the LoST protocol requirements for query including an ESI is a
SHOULD, and a response msg. to include an ESI is a MUST.

Roger Marshall.

>-----Original Message-----
>From: Hannes Tschofenig [mailto:[email-masked]] 
>Sent: Monday, June 05, 2006 7:26 AM
>To: [email-masked]
>Subject: [Ecrit] [issue1] Do we need a default service URN for 
>the LoSTquery?
>
>
>Hannes Tschofenig <[email-masked]> added the comment:
>
>A LoST query contains location information and a service URN. 
>Do we want to make the service URN element/attribute optional 
>by indicating a default value? 
>Hence, if someone specifies a query that does not contain a 
>service URN element/attribute then the default value is chosen. 
>
>I think the service URN attribute/element should be mandatory.
>
>----------
>nosy: +ecrit
>status: unread -> chatting
>
>__________________________________________________
>LoST Issue Tracker <[email-masked]> 
><http://www.tschofenig.priv.at:8080/lost/issue1>
>__________________________________________________
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 05 Jun 2006 19:20:57 +0200

Hi Roger,

> can still provide an answer.

We can also write the protocol in such a way that the emergency service 
is a mandatory field. Hence, the LoST client always has to provide a 
service URN.

I prefer this approach.

> SHOULD, and a response msg. to include an ESI is a MUST.

Ciao
Hannes

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 05 Jun 2006 13:47:05 -0400

> can still provide an answer.

I don't see that as necessary or helpful. Why can't the client always 
insert a service URN? This seems a trivial thing to do for a client and 
avoids problems of trying to guess what the client really wanted. 
(Remember that LoST may well be used for non-emergency services, too.)

I don't think "you know what I mean" protocol features are a good way 
forward.

---

From: Shida Schubert <[email-masked]>
Date: Mon, 05 Jun 2006 15:56:10 -0700

I strongly agree with Henning here for the exact reason
Henning expressed.

Default service, from the importance will likely be the emergency
service, and this will lead to unintended emergency call if we
support this default service.

It may be a possibility that requesting without the service identifier
will result with a response containing list of services the LOST server
supports.

Regards
Shida

Henning Schulzrinne wrote:
> insert a service URN? This seems a trivial thing to do for a client
> and avoids problems of trying to guess what the client really wanted.