Subject: RE: [Ecrit] [issue2] Is it allowed to specify civic and geospatialinfointo the query?

From: "Roger Marshall" <[email-masked]>
Date: Mon, 5 Jun 2006 14:07:40 -0700

Hannes: Thanks for clarifying.  

I think it's a bad idea to withold location information from the LoST
server.

To suggest that we restrict the client, allowing only one to be sent,
sounds to me like we're placing a constraint on the PIDF-LO, saying it
can't have both (assuming LoST reuses the PIDF-LO).  I don't think we
can get away with that.   If the PIDF-LO has both, how is it that we can
glibly strip one out?  To do so would be unreasonable.

Since the client can have both civic and geo in the PIDF-LO, it can also
send both to the server.  What am I missing?  

It's the LoST server's job to pick one, not the client's.

So, the requirement I would support is as follows:

Rx' LoST client SHALL query with either civic or geo.  
Ry' LoST client SHOULD query with *both* civic and geo.  When LoST
server receives both civic and geo, the server SHOULD try to use the geo
first.  The LoST server response SHALL indicate which data was used
(either geo or civic). 

-roger.

>-----Original Message-----
>From: Hannes Tschofenig [mailto:[email-masked]] 
>Sent: Monday, June 05, 2006 1:50 PM
>To: Roger Marshall
>Cc: Brian Rosen; [email-masked]
>Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic 
>and geospatialinfointo the query?
>
>Hi Roger,
>
>I think the current suggestion is that the LoST client just 
>picks whatever he wants and then uses the mapping protocol to 
>trigger the resolution.
>
>Using geo and civic might be, from a certain point of view, 
>just be an optimization. The LoST client can always trigger 
>separate queries with all the location info it has.
>
>Ciao
>Hannes
>
>Roger Marshall wrote:
>> I don't disagree that we ask the LoST server to pick one and 
>use it.  
>> 
>> We need to be consistent though, and so therefore, I propose 
>that the 
>> LoST server always picks the geo over the civic and returns 
>a flag in 
>> the response stating that the geo was used to perform mapping.
>> 
>> Roger.
>> 
>> 
>>>-----Original Message-----
>>>From: Hannes Tschofenig [mailto:[email-masked]]
>>>Sent: Monday, June 05, 2006 1:39 PM
>>>To: Brian Rosen
>>>Cc: [email-masked]
>>>Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic and 
>>>geospatialinfointo the query?
>>>
>>>It seems that we closed this issue.
>>>
>>>Everyone seems to be in favor for a civic OR geospatial.
>>>Extensions possible for future applications.
>>>
>>>Ciao
>>>Hannes
>>>
>>>Brian Rosen wrote:
>>>
>>>>I think this is the issue.  There is no guidance we can give the 
>>>>server to tell it how to resolve what to do when  both 
>locations are 
>>>>valid but the URI for the geo does match the URI for the civic.
>>>>
>>>>This happens a lot when you are near boundaries because the
>>>
>>>precision
>>>
>>>>and accuracy of the two methods differ.
>>>>
>>>>I think you pick ONE and use it.
>>>>
>>>>Even if you send more than one along, the PSAP has to know 
>which one 
>>>>you used to route.  It's going to continue to use that 
>until a human 
>>>>says otherwise.
>>>>
>>>>Brian
>>>>
>>>>-----Original Message-----
>>>>From: Henning Schulzrinne [mailto:[email-masked]]
>>>>Sent: Monday, June 05, 2006 3:55 PM
>>>>To: Andrew Newton
>>>>Cc: [email-masked]
>>>>Subject: Re: [Ecrit] [issue2] Is it allowed to specify civic and 
>>>>geospatialinfo into the query?
>>>>
>>>>At the PSAP, we have a human that can look at this information and 
>>>>make decisions (and maybe even ask if there's a discrepancy). That 
>>>>seems a stretch for the LoST server.
>>>>
>>>>Andrew Newton wrote:
>>>>
>>>>
>>>>>On Jun 5, 2006, at 2:53 PM, Henning Schulzrinne wrote:
>>>>>
>>>>>
>>>>>>In all of these dual-information cases, I don't see how anybody 
>>>>>>except the seeker can make any determination which type of 
>>>>>>information is better, more accurate, more recent, etc.
>>>>>
>>>>>Would we want the seeker to determine which information it 
>feels is 
>>>>>best to provide to the PSAP?  I've always heard that the
>>>
>>>answer would be no:
>>>
>>>>>provide both to the PSAP.  So why then would we not 
>provide the same 
>>>>>information when determining which PSAP to contact?
>>>>>
>>>>>-andy
>>>>
>>>>
>>>>_______________________________________________
>>>>Ecrit mailing list
>>>>[email-masked]
>>>>https://www1.ietf.org/mailman/listinfo/ecrit
>>>>
>>>>
>>>>_______________________________________________
>>>>Ecrit mailing list
>>>>[email-masked]
>>>>https://www1.ietf.org/mailman/listinfo/ecrit
>>>>
>>>>
>>>
>>>
>>>_______________________________________________
>>>Ecrit mailing list
>>>[email-masked]
>>>https://www1.ietf.org/mailman/listinfo/ecrit
>>>
>> 
>> 
>> 
>
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 05 Jun 2006 17:18:07 -0400

The problem is that in some cases, your algorithm would not work, as 
civic information might be more recent or accurate (e.g., Skyhook geo 
information might only have 200' accuracy).

I see no loss in functionality, and gains in expressiveness, to have the 
client choose which information it wants the server to use. If it wants 
to get information for both, it can query twice.

Having both just adds more special cases, error conditions, processing 
rules.

Anything with a SHOULD in it means that we'll have some servers behave 
differently, i.e., making the behavior unpredictable. In my view, 
SHOULDs SHOULD be avoided at all cost :-)

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 05 Jun 2006 23:24:02 +0200

Hi Roger,

> glibly strip one out?  To do so would be unreasonable.

To clarify:

* You can send as many queries as you want but not with the same 
message. Different location information => different query

* We don't use a PIDF-LO in LoST. We use the raw location info.

> send both to the server.  What am I missing?  

None of the proposals ever used a PIDF-LO as input; just location info.

> It's the LoST server's job to pick one, not the client's.

At the PSAP and the emergency routing proxy I agree with you.

> Rx' LoST client SHALL query with either civic or geo.

That's fine.

> first.  The LoST server response SHALL indicate which data was used

I guess you will not support for this one based on the response I saw on 
the list so far.

Ciao
Hannes

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 5 Jun 2006 17:39:01 -0400

I agree, the LoST client submits one location at a time.  No decisions made
by LoST server/service.

-Marc-

> Sent: Monday, June 05, 2006 5:24 PM
> To: Roger Marshall
> Cc: [email-masked]
> Subject: Re: [Ecrit] [issue2] Is it allowed to specify 
> civicand geospatialinfointo the query?
> 
> Hi Roger,
> 
> Roger Marshall wrote:
> * You can send as many queries as you want but not with the 
> same message. Different location information => different query
> 
> > Since the client can have both civic and geo in the PIDF-LO, it can 
> > also send both to the server.  What am I missing?
> 
> > server receives both civic and geo, the server SHOULD try 
> to use the 
> > geo first.  The LoST server response SHALL indicate which data was 
> > used (either geo or civic).
> 
> I guess you will not support for this one based on the 
> response I saw on the list so far.
> 
> Ciao
> Hannes
> 
> > 
> > -roger.
> > 
> > 
> > 
> >>I think the current suggestion is that the LoST client just picks 
> >>whatever he wants and then uses the mapping protocol to trigger the 
> >>resolution.
> >>
> just be an 
> >>optimization. The LoST client can always trigger separate 
> queries with 
> >>all the location info it has.
> >>
> >>Ciao
> >>Hannes
> >>
> >>Roger Marshall wrote:
> >>

---

From: Andrew Newton <[email-masked]>
Date: Mon, 5 Jun 2006 17:58:11 -0400

I think we'd have a protocol more capable of adapting to unforeseen,  
real world issues if both were sent and the server had the  
opportunity to determine which type of location it preferred.  I must  
admit that it seems a bit of a stretch, but I think it is just as  
possible as Henning's idea that the client will have the same type of  
notion.  It almost always seems to me that if ever there is a  
question about preference, it should fall to the LoST service  
operators and their jurisdictional considerations.

It also seems to me that if a client or seeker does, in some odd way,  
have a notion of a preferred type of location when it possesses both,  
that it can always just send the query with only the type of location  
it prefers.  For clients that don't have this strong notion, send  
both and see if the server has a preference.

-andy

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 5 Jun 2006 18:23:20 -0400

Andy,

The problem is that the 'preferred' location is the accurate one.  No LoST
server/service will be able to determine which one is most accurate.  You
may equate the same problem to the client, but IMO, it's better that the
client make the decision since it's closer to the human that 'should' know.

-Marc-

> From: Andrew Newton [mailto:[email-masked]] 
> Sent: Monday, June 05, 2006 5:58 PM
> To: Marc Linsner
> Cc: 'Hannes Tschofenig'; [email-masked]
> I think we'd have a protocol more capable of adapting to 
> unforeseen, real world issues if both were sent and the 
> server had the opportunity to determine which type of 
> location it preferred.  I must admit that it seems a bit of a 
> stretch, but I think it is just as possible as Henning's idea 
> that the client will have the same type of notion.  It almost 
> always seems to me that if ever there is a question about 
> preference, it should fall to the LoST service operators and 
> their jurisdictional considerations.
> 
> It also seems to me that if a client or seeker does, in some 
> odd way, have a notion of a preferred type of location when 
> it possesses both, that it can always just send the query 
> with only the type of location it prefers.  For clients that 
> don't have this strong notion, send both and see if the 
> server has a preference.
> 
> -andy
> 
> 
> > I agree, the LoST client submits one location at a time.  
> No decisions 
> > made by LoST server/service.
> >
> > -Marc-
> >
> >> Subject: Re: [Ecrit] [issue2] Is it allowed to specify civicand 
> civic and