Subject: Re: [Ecrit] What is an uninitialized device - draft-ietf-ecrit-phonebcp-03

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Dec 2007 21:25:06 +0100

This should be removed from the document per decision made at IETF#69

Cullen Jennings wrote:
>
> The more I think about this uniitialized device stuff, the less clear 
> I am. I understand about the cell phones use before activation. 
> However, the issue here is that there is no billing set up with the 
> device. I'm not sure that would work as a definition we want.
>
> My test case is say I get some phone with 802.11 wireless, set it up 
> with an account on iptel.org, then dial an emergency number. Should 
> this work or not? I can imagine arguments for yes or no and it's not 
> that I have an opinion on which it should be but I think the advice 
> should be clear on this.
>
> Cullen <with my individual contributor hat on>
>
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Sun, 2 Dec 2007 20:09:15 -0500

It depends where you are.  Right at the moment, because iptel is not
classified as a VoIP carrier by the FCC. It would NOT be required that it
work in the U.S..  If the calling network was, say, Verizon rather than
iptel, then it would.

This gets murky really quick.  Suppose you bought the same phone a year or
so from now, and it was certified to work on the Verizon network, but you
got it from fones-r-us and did not activate it.  If you could decide to
activate it at iptel or Verizon, then I suspect it doesn't have to support
emergency calls until you activate it on Verizon.  On the other hand, I
suspect if Verizon sold it to you it would have to.  See how weird it gets?

Then there is the access network.  Suppose, for the sake of argument, that
you are in range of two 802.11 networks.  One of them is operated by
T-Mobile, and the other is operated by some network that Verizon contracts
with to allow access.  I believe T-Mobile doesn't have to give you access,
but the other one does (for emergency calls only).  Conflate that with the
discussion above, and I have no idea what has to happen.

In the IETF we don't really have to do anything, but providing information
is useful.  In this case, see my prior email; the access network knows, the
calling network probably has to be told.  This would be another form of
verification of legitimate emergency call at call time; the carrier proxy
would query LoST with the location it had, and could get the indication of
whether uninitialized device support was required for the location of the
device.

Brian

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Thursday, November 29, 2007 10:41 PM
> To: ECRIT
> Subject: [Ecrit] What is an uninitialized device -draft-ietf-ecrit-
> phonebcp-03
> 
>

---

From: "Brian Rosen" <[email-masked]>
Date: Sun, 2 Dec 2007 20:09:15 -0500

An unitialized device does not have permission to use the access and/or
calling network, but is required, by regulation to permit such access for
the sole purpose of making emergency calls.

It's a fact that there are regulations that require such access, so we have
to mention it in some way.  It's also a source of a lot of difficulty, so
the usual advice is to not do it unless regulations require it.

In the access network, the regulations can be known by the access network,
but the calling network, generally, doesn't have a way to know it.  We've
discussed putting something in LoST which would state whether uninitialized
devices should be allowed to place emergency calls.

Brian

> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Saturday, December 01, 2007 3:25 PM
> To: Cullen Jennings
> Cc: ECRIT
> Subject: Re: [Ecrit] What is an uninitialized device- draft-ietf-ecrit-
> phonebcp-03
>

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 2 Dec 2007 21:30:31 -0800

> the sole purpose of making emergency calls.

I like that definition. Cullen <with my individual contributor hat on>

---

From: "Dawson, Martin" <[email-masked]>
Date: Sun, 2 Dec 2007 23:34:18 -0600

Does it actually scan?

Was the intent to say that the *access network* is required to permit
such a device to have access for the purpose of making emergency calls?

It reads as if it's the device that has the requirement upon it...

Cheers,
Martin

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: Monday, 3 December 2007 4:31 PM
To: Brian Rosen
Cc: ECRIT
Subject: Re: [Ecrit] What is an uninitializeddevice-
draft-ietf-ecrit-phonebcp-03

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 12:28:36 -0500

Yeah, slight reword.

An uninitialized device does not have permission to use the access and/or
calling network but local regulation requires the access and calling
networks to grant such permission for the sole purpose of making emergency
calls.

> From: Dawson, Martin [mailto:[email-masked]]
> Sent: Monday, December 03, 2007 12:34 AM
> To: Cullen Jennings; Brian Rosen
> Cc: ECRIT
> Subject: RE: [Ecrit] What is an uninitializeddevice- draft-ietf-ecrit-
> phonebcp-03
> 
> Does it actually scan?
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 03 Dec 2007 18:35:19 +0100

Are you going to remove that text from the document?

The entire subject is far more complicated....

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 12:37:44 -0500

Doesn't improve things from my point of view.  "Authorization" is slightly better in formal terms, but I think that gets confused with mechanisms (crypto, ...).

Brian

> From: GOLDMAN, STUART O (STUART) [mailto:[email-masked]]
> Sent: Monday, December 03, 2007 12:33 PM
> To: Brian Rosen; Dawson, Martin; Cullen Jennings
> Cc: ECRIT
> Subject: RE: [Ecrit] What is anuninitializeddevice- draft-ietf-ecrit-
> phonebcp-03
> 
> Brian,
> 
> Would the definition be better if "permission" were changed to
> "arrangement"?
> 
> Stuart Goldman
> Alcatel-Lucent
> [email-masked]
> +1 602 493 8438
>  please save a tree by not printing this e-mail.
> 
> 
> 
> 
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Monday, December 03, 2007 10:29 AM
> To: 'Dawson, Martin'; 'Cullen Jennings'
> Cc: 'ECRIT'
> Subject: RE: [Ecrit] What is anuninitializeddevice- draft-ietf-ecrit-
> phonebcp-03
> 
> Yeah, slight reword.
> 
> > ------------------------------------------------------------------------
> --
> > ----------------------
> > ------------------------------------------------------------------------
> --
> > ----------------------
> > [mf2]
> 
>

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 12:43:07 -0500

No Hannes, I am not planning to remove it.

It's something any proxy/calling network/access network needs to know.  It's
"best current practice".

If it's more complicated, we need to add text, not remove it.

Brian

> Sent: Monday, December 03, 2007 12:35 PM
> To: Brian Rosen
> Cc: 'Dawson, Martin'; 'Cullen Jennings'; 'ECRIT'
> Subject: Re: [Ecrit] What is an uninitializeddevice- draft-ietf-ecrit-
> phonebcp-03
> 
> >> -----------------------------------------------------------------------
> ---
> >> ----------------------
> >> -----------------------------------------------------------------------
> ---
> >> ----------------------
> >> [mf2]
> >>
> >
> >

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 03 Dec 2007 10:26:22 +0100

There is terminology proposals in a separate document.
http://tools.ietf.org/wg/ecrit/draft-schulzrinne-ecrit-unauthenticated-access-01.txt

This terminology was discussed with Wimax Forum members.

Ciao
Hannes

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 13:46:58 -0500

That dices and slices the problem in many ways.  A simple term is needed for the big picture.

Brian

> Sent: Monday, December 03, 2007 4:26 AM
> To: Brian Rosen
> Cc: 'GOLDMAN, STUART O (STUART)'; 'Dawson, Martin'; 'Cullen Jennings';
> 'ECRIT'
> Subject: Re: [Ecrit] What is anuninitializeddevice- draft-ietf-ecrit-
> phonebcp-03
> 
> > Doesn't improve things from my point of view.  "Authorization" is
> slightly better in formal terms, but I think that gets confused with
> mechanisms (crypto, ...).
> >
> > Brian
> >
> >

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 03 Dec 2007 11:02:36 +0100

Hi Brian

there are two issues:

a) Do we want to talk about this issue in the current framework document?

In the past the group decided to postpone it. We have compiled a 
separate document that deals with this issue.

b) What are the specific terms we should use? Can we just use one term 
that covers all these aspects?

This is something we should discuss once we got the framework/phone BCP 
document done.
There is a set of terminology proposal available and I am more than 
happy to discuss the different aspects. I do not believe that all the 
different cases can be addressed by a single term.

Ciao
Hannes

Brian Rosen wrote:
>>>> An uninitialized device does not have permission to use the access
>>>>         
>> and/or
>>     
>>>> networks to grant such permission for the sole purpose of making
>>>>         
>> emergency
>>     
>>>> calls.
>>>>
>>>>
>>>>
>>>>
>>>>         
>>>>> such a device to have access for the purpose of making emergency
>>>>>           
>> calls?
>>     
>>>>> ----------------------------------------------------------------------
>>>>>           
>> --
>>     
>>>> --
>>>>
>>>>         
>>>>> ----------------------
>>>>> ----------------------------------------------------------------------
>>>>>           
>> --
>>     
>>>> --
>>>>
>>>>         
>>>>> ----------------------
>>>>> [mf2]
>>>>>
>>>>>

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 14:24:55 -0500

Hannes

Could you point me to the meeting minutes, chair consensus call, etc where the group "decided to postpone it"?

Brian

> Sent: Monday, December 03, 2007 5:03 AM
> To: Brian Rosen

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 03 Dec 2007 11:29:59 +0100

Hi Brian,

see the discussion at IETF#69:
http://www3.ietf.org/proceedings/07jul/minutes/ecrit.txt

The meeting minutes are short but indicate what we discussed:

> Brian - considers that the framework/bcp are the last documents out of ECRIT as they document how this works and to go to a RFC status then 

> Hannes - argues that they are orthogonal  

> Hannes - QoS how is this done is another, e.g., so this is just for the base protocol

> Brian - can do it.

> James - just going to second Hannes

> Consensus to go for WGLC 

If you want then we can use this meeting again to ask the question about
* Location Hiding
* Unauthenticated Emergency Services
being addressed in this document.
There are most likely other things to consider (such as QoS) in the 
future but we don't even have a document about it.

I strongly argued that we should deal with these issues after we got the 
current documents done.

Ciao
Hannes

Brian Rosen wrote:
>>> That dices and slices the problem in many ways.  A simple term is needed
>>>       
>> for the big picture.
>>     
>>> Brian
>>>
>>>
>>>       
>>>>>>> Subject: RE: [Ecrit] What is an uninitializeddevice- draft-ietf-
>>>>>>>               
>> ecrit-
>>     
>>>>>>> phonebcp-03
>>>>>>>
>>>>>>> Does it actually scan?
>>>>>>>
>>>>>>> Was the intent to say that the *access network* is required to
>>>>>>>               
>> permit
>>     
>>>>>>> I like that definition. Cullen <with my individual contributor hat
>>>>>>>               
>> on>
>>     
>>>>>>> --------------------------------------------------------------------
>>>>>>>               
>> --
>>     
>>>> --
>>>>
>>>>         
>>>>>> --
>>>>>>
>>>>>>
>>>>>>             
>>>>>>> ----------------------
>>>>>>> --------------------------------------------------------------------
>>>>>>>               
>> --
>>     
>>>> --
>>>>
>>>>         
>>>>>> --
>>>>>>
>>>>>>
>>>>>>             
>>>>>>> ----------------------
>>>>>>> [mf2]
>>>>>>>
>>>>>>>
>>>>>>>

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 15:26:18 -0500

I understand you argued, but I don't think we got consensus.  

I think without location hiding and unauthenticated access we don't have a solution. 

QoS can wait

Brian

> Sent: Monday, December 03, 2007 5:30 AM
> To: Brian Rosen
> > Brian - considers that the framework/bcp are the last documents out of
> ECRIT as they document how this works and to go to a RFC status then
> 
> > Could you point me to the meeting minutes, chair consensus call, etc
> where the group "decided to postpone it"?
> >
> > Brian
> >
> >
> >>>> http://tools.ietf.org/wg/ecrit/draft-schulzrinne-ecrit-
> unauthenticated-
> >>>> access-01.txt
> >>>>

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 03 Dec 2007 12:36:29 +0100

Hi Brian,

I am a bit reluctant to open this discussion again given that we had 
already agreement.
Our current status is that we deal with these issues in separate 
documents -- we will investigate them but it will take time.

Ciao
Hannes

Brian Rosen wrote:
>>> Hannes - QoS how is this done is another, e.g., so this is just for the
>>>       
>> base protocol
>>
>>     
>>> Brian - can do it.
>>>       
>>>> a) Do we want to talk about this issue in the current framework
>>>>         
>> document?
>>     
>>>>> That dices and slices the problem in many ways.  A simple term is
>>>>>           
>> needed
>>     
>>>> for the big picture.
>>>>
>>>>         
>>>>> Brian
>>>>>
>>>>>
>>>>>
>>>>>           
>>>>>> Cc: 'GOLDMAN, STUART O (STUART)'; 'Dawson, Martin'; 'Cullen
>>>>>>             
>> Jennings';
>>     
>>>>>> 'ECRIT'
>>>>>>>> From: GOLDMAN, STUART O (STUART) [mailto:sgoldman@alcatel-
>>>>>>>>                 
>> lucent.com]
>>     
>>>>>>>> Subject: RE: [Ecrit] What is anuninitializeddevice- draft-ietf-
>>>>>>>>                 
>> ecrit-
>>     
>>>>>>>> phonebcp-03
>>>>>>>>
>>>>>>>> Brian,
>>>>>>>>
>>>>>>>> Subject: RE: [Ecrit] What is anuninitializeddevice- draft-ietf-
>>>>>>>>                 
>> ecrit-
>>     
>>>>>>>> phonebcp-03
>>>>>>>>
>>>>>>>> Yeah, slight reword.
>>>>>>>>
>>>>>>>> calling network but local regulation requires the access and
>>>>>>>>                 
>> calling
>>     
>>>>>>>>> ------------------------------------------------------------------
>>>>>>>>>                   
>> --
>>     
>>>> --
>>>>
>>>>         
>>>>>> --
>>>>>>
>>>>>>
>>>>>>             
>>>>>>>> --
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>                 
>>>>>>>>> ----------------------
>>>>>>>>> ------------------------------------------------------------------
>>>>>>>>>                   
>> --
>>     
>>>> --
>>>>
>>>>         
>>>>>> --
>>>>>>
>>>>>>
>>>>>>             
>>>>>>>> --
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>                 
>>>>>>>>> ----------------------
>>>>>>>>> [mf2]
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 16:43:02 -0500

I think the chairs should ask for a hum on whether uninitialized devices/unathenticated access and location hiding must be described in -phonebcp before we WGLC it.

Brian

> Sent: Monday, December 03, 2007 6:36 AM
> To: Brian Rosen
> >>>>>>>>>> An unitialized device does not have permission to use the
> access
> >>>>>>>>>> and/or

---

From: Ted Hardie <[email-masked]>
Date: Mon, 3 Dec 2007 16:11:16 -0800

>I think the chairs should ask for a hum on whether uninitialized devices/unathenticated access and location hiding must be described in -phonebcp before we WGLC it.

Not to nit-pick, but this would be a terrible hum question.  I hope if the working
group chairs need to call consensus on these issues, we do so in a more granular
way and with at least some of the possible options.

For example, it might be possible to note the existence of location hiding scenarios in
phonebcp but to point to a specific document on location hiding that lays out
the available mechanisms; that would likely be informational.  I would strongly
support that, since recognizing reality is a good thing.  But BCP-level discussion
of whether location hiding is a good idea or not seems like starting a flamewar
in a rathole, and I don't see that as a really good thing.

Two cents,
				Ted

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Dec 2007 19:22:27 -0500

The hum was to see if we can dismiss the notion that we can release
-phonebcp and -framework before dealing with these two issues.  I don't
think we can.  You are suggesting HOW we go about dealing with the issues.
I am certainly open to anything that works.  I just don't think we can
implement -phonebcp without solving those problems.

Hannes seems to have a different opinion.  I wanted to see if we could get a
work group consensus on the issue.

Brian

> From: Ted Hardie [mailto:[email-masked]]
> Sent: Monday, December 03, 2007 7:11 PM
> To: Brian Rosen; 'Hannes Tschofenig'
> Cc: 'Dawson, Martin'; 'GOLDMAN, STUART O (STUART)'; 'ECRIT'
> >I think the chairs should ask for a hum on whether uninitialized
> devices/unathenticated access and location hiding must be described in -
> phonebcp before we WGLC it.
> >
> >Brian
>

---

From: Ted Hardie <[email-masked]>
Date: Mon, 3 Dec 2007 16:37:16 -0800

At 7:22 PM -0500 12/3/07, Brian Rosen wrote:
>think we can. 

Thanks for the clarification; I didn't understand that you saw text saying "Text forthcoming *here*" as one of the options that dealt with the issues for
-phonebcp and -framework.   I'm glad to hear that it is for you as well.

				Ted

>You are suggesting HOW we go about dealing with the issues.