Subject: [Ecrit] Request for clarification: Dave Provider ID / Data Provider ID Series Usage (and Type of Data Provider)

From: Matt Serra <[email-masked]>
Date: Mon, 11 May 2015 15:24:13 +0000

Group:

In the Additional Call Data draft, the Data Provider ID and Data Provider ID Series fields within the Data Provider Information Block are shown as Required.

In addition to coming from a Service or Access provider, the Additional Call Data can also be provided by the device or user agent.

In the case of the Device or User Agent, how should these blocks be populated?  The device or UA would not have a NENA or EENA assigned Data Provider ID.  While the spec allow for a "domain" to be used as a Provider ID, the domain alone would not uniquely identify the device or User agent.  That language seems to exist to accommodate Service and Access Network providers.

So - it seems like we should EITHER provide guidance on how to populate these fields in this case (perhaps populate the Data Provider ID with From URI or PAI? And Data Provider ID Series with "domain" or maybe "URI"?!?!)  OR make these fields optional where provided by a device or user agent and allow the From URI/PAI in the INVITE to speak for themselves?

This also has ramifications on "Type of Data Provider" as well.  There should be "Device" and "User Agent" value(s) I'd think.

Thanks,

[rave_email_signature]

  Matthew A. Serra, ENP
  Sr. Director, Product Management
  Mobile:  201.245.1557
  [email-masked]<mailto:[email-masked]>

---

From: Matt Serra <[email-masked]>
Date: Tue, 26 May 2015 22:41:20 +0000

I have not seen any comment on this, so I'll try to bring the issue into sharper focus.

I'd appreciate knowing if there is support for the Preferred Solution or Alternate Solution I outline below (or if you have better idea).

Problem:

*         Within the Data Provider Block, Data Provider ID and Provider ID Series are required fields.

*         Per the DRAFT, there are cases where an entity providing the Data Provider Block would not be able to fill out these required fields as they are defined, which in North America calls for populating a NENA Company ID which an end-user would not have.

*         Examples of entities that could not meet this requirement are end-user managed devices or a user agent used to place an emergency call.

Preferred Solution:

*         Instruct the Device or User Agent to populate Data Provider ID with the PAI or From URI from the SIP INVITE

*         Instruct the Device or User Agent to populate Data Provider ID Series with 'End-User' or a similar string.  Update the Provider ID registry with this new value

*         Add a value to the Type of Data Provider to read as "End User" "User Agent" or similar

Alternate Solution:

*         Make the Data Provider ID and Provider ID Series Conditional (optional where provided by end-user device or user agent, otherwise required)

*         Add a value to the Type of Data Provider to read as "End User" "User Agent" or similar to provide some context to the reader of the XML document.

Thanks,

Matt.

From: Matt Serra
Sent: Monday, May 11, 2015 11:24 AM
To: [email-masked]
Subject: Request for clarification: Dave Provider ID / Data Provider ID Series Usage (and Type of Data Provider)

Group:

Thanks,

[rave_email_signature]

  Matthew A. Serra, ENP