Subject: Re: [Ecrit] Liaison Statement from IETF ECRIT WG to 3GPP

From: Randall Gellens <[email-masked]>
Date: Tue, 5 May 2015 12:26:53 -0700

I think Ivo makes a good point and I agree that the current text has 
some details that are out of scope of the draft.  Accordingly, I 
suggest we simply say "in which SIP is used" and not get into these 
out of scope details.

Here is a link to the PDF version of the revised text:
https://www.dropbox.com/s/sk2vg5yllx7z8kp/Liaison%20Statement%20from%20IETF%20ECRIT%20WG%20to%203GPP%20%5Bclean%5D.pdf?dl=0

Here is a plain text version of the revised text:

------------------
Title:  Liaison Statement on NG eCall support for the EU
Date:   xxxx
Source: IETF Ecrit WG
To: 3GPP SA1, SA2, CT1

Contact Person:
     Name:   Randall Gellens
     Affiliation:    Qualcomm Inc.
     Tel. Number:    +1-858-651-5115
     E-mail Address: [email-masked]

1. Overall Description:

The IETF ECRIT WG would like to inform 3GPP of IETF work enabling
eCall over IETF SIP.  The IETF has been developing a specification
to support this (mainly in the EU but not limited to it). The
document is still in a draft state and describes how an eCall placed
using SIP is identified, transfers the MSD and supports other
necessary interaction between an eCall IVS and a PSAP. IETF ECRIT
intends the eventual RFC to define the necessary SIP protocol
conventions and mechanisms that will be needed to support any
solution (e.g., such as a solution defined later by 3GPP) in which
SIP is used. The IETF draft has been referenced by ETSI in their
report Mobile Standards Group (MSG); eCall for VoIP (TR 103 140
V1.1.1).

The IETF would like to be sure that 3GPP is aware of the work, and
welcomes 3GPP review of the work including any comments concerning
possible omissions or other defects.

The latest version of the document may be accessed at:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-ecall/

Respectfully,

The IETF ECRIT WG

2. Actions:

To 3GPP SA1, SA2, CT1 groups.

ACTION:     Please provide any feedback to IETF Ecrit that may be
useful or necessary to enable IETF Ecrit to complete their
specification on support of NG eCall in the EU.

3. Date of Next IETF Ecrit Meeting:

IETF#93 Dates: 19-24 July, 2015 Location: Prague, Czech Republic
------------------

At 8:04 AM +0000 4/30/15, Ivo Sedlacek wrote:

>  Hello,
>
>  the following sentence of the LS is misleading.
>
>                  IETF ECRIT intends the eventual RFC to define the 
> necessary SIP protocol convensions and mechanisms that will be 
> needed to support any end-to-end solution
>                  (e.g. such as a solution defined later by 3GPP) in 
> which both ends (IVS adn PSAP) are IP capable or in which one end 
> is IP capable with interworking being used.
>
>  RFC will specify solely SIP based eCall between two SIP UAs.
>  RFC will not specify interworking of the SIP based eCall to the 
> existing circuit switched based eCall.
>
>  Thus, I propose to modify the statement as follows:
>
>                  IETF ECRIT intends the eventual RFC to define the 
> necessary SIP protocol convensions and mechanisms that will be 
> needed to support any solution
>                  (e.g. such as a solution defined later by 3GPP) in 
> which both ends are IP and SIP capable.
>
>  Other than the above, I think the LS tooks OK.
>
>  Kind regards
>
>  Ivo Sedlacek
>

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
If you would look up bad labor relations in the dictionary, you
would have an American Airlines logo beside it.
    --U.S. District Judge Joe Kendall, issuing a restraining order
against an American Airlines APA pilot union sick out, 10 Feb 1999.

---

From: Ivo Sedlacek <[email-masked]>
Date: Mon, 11 May 2015 07:17:01 +0000

OK for me. Thank you for addressing my comment.

Kind regards

Ivo Sedlacek

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: 5. května 2015 21:27
To: Ivo Sedlacek; Roger Marshall; Randall Gellens; [email-masked]
Cc: [email-masked]
Subject: RE: [Ecrit] Liaison Statement from IETF ECRIT WG to 3GPP

I think Ivo makes a good point and I agree that the current text has some details that are out of scope of the draft.  Accordingly, I suggest we simply say "in which SIP is used" and not get into these out of scope details.

------------------

Contact Person:
     Name:   Randall Gellens

1. Overall Description:

The IETF ECRIT WG would like to inform 3GPP of IETF work enabling eCall over IETF SIP.  The IETF has been developing a specification to support this (mainly in the EU but not limited to it). The document is still in a draft state and describes how an eCall placed using SIP is identified, transfers the MSD and supports other necessary interaction between an eCall IVS and a PSAP. IETF ECRIT intends the eventual RFC to define the necessary SIP protocol conventions and mechanisms that will be needed to support any solution (e.g., such as a solution defined later by 3GPP) in which SIP is used. The IETF draft has been referenced by ETSI in their report Mobile Standards Group (MSG); eCall for VoIP (TR 103 140 V1.1.1).

The IETF would like to be sure that 3GPP is aware of the work, and welcomes 3GPP review of the work including any comments concerning possible omissions or other defects.

Respectfully,

The IETF ECRIT WG

2. Actions:

ACTION:     Please provide any feedback to IETF Ecrit that may be
useful or necessary to enable IETF Ecrit to complete their specification on support of NG eCall in the EU.

At 8:04 AM +0000 4/30/15, Ivo Sedlacek wrote:

> necessary SIP protocol convensions and mechanisms that will be needed 
> to support any end-to-end solution
> which both ends (IVS adn PSAP) are IP capable or in which one end is 
> IP capable with interworking being used.
>
> necessary SIP protocol convensions and mechanisms that will be needed 
> to support any solution

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: --------------- If you would look up bad labor relations in the dictionary, you would have an American Airlines logo beside it.
    --U.S. District Judge Joe Kendall, issuing a restraining order against an American Airlines APA pilot union sick out, 10 Feb 1999.