Subject: [Emailcore] Ticket #23: Erratum 1683: Additional-Registered-Clauses syntax is incorrect

From: Alexey Melnikov <[email-masked]>
Date: Mon, 14 Dec 2020 11:28:55 +0000

Hi,

I just want to confirm consensus on the following change:

-------------

Roberto Javier Godoy wrote:

Section 4.4 says:

   Additional-Registered-Clauses = CFWS Atom FWS String

It should say:
   Additional-Registered-Clauses = 1*(CFWS Atom FWS String)

Notes:

The rule Additional-Registered-Clauses is used by the rule Opt-info 
(also in section 4.4, page 59) as:
   Opt-info = [Via] [With] [ID] [For] [Additional-Registered-Clauses]
The ABNF comment for Additional-Registered-Clauses states that 
"Additional standard clauses may be added in this location by future 
standards and registration with IANA."
Each sequence (CFWS Atom FWS String) represents a single clause.

-------------

John has already applied this correction to rfc5321bis and I believe it 
is correct. If I don't hear any objections to the above change, this 
ticket will be resolved as "fixed" on December 28th.

Thank you,

Alexey

---

From: Alessandro Vesely <[email-masked]>
Date: Mon, 14 Dec 2020 12:48:24 +0100

On Mon 14/Dec/2020 12:28:55 +0100 Alexey Melnikov wrote:
> The rule Additional-Registered-Clauses is used by the rule Opt-info (also in 
> section 4.4, page 59) as:
> The ABNF comment for Additional-Registered-Clauses states that "Additional 
> standard clauses may be added in this location by future standards and 
> registration with IANA."
> John has already applied this correction to rfc5321bis and I believe it is 
> correct. If I don't hear any objections to the above change, this ticket will 
> be resolved as "fixed" on December 28th.

Works for me, albeit the "1" looks redundant (Additional-Registered-Clauses are 
optional, but if you use them, you have to put at least one of them).

Best
Ale
--