Subject: [Emailcore] Ticket #41: G.7.3. Resolvable FQDN in SMTP and private domain names

From: Alexey Melnikov <[email-masked]>
Date: Mon, 14 Dec 2020 11:23:18 +0000

Hi all,

I split of the following from the original ticket #9:

Splitting the part about "private domain names" from the discussion on 
whether "resolvable" needs to be in the definition of domain names 
(ticket #9)

2.3.5. Domain Names

   Only resolvable, fully-qualified domain names (FQDNs) are permitted
   when domain names are used in SMTP.

John Klensin:
   Does "in the public DNS" or equivalent need to be added to 
"resolvable"???

Strawman proposal: I believe "in the public DNS" doesn't reflect how 
SMTP servers operate, due to existence of private DNS servers/split DNS. 
So my proposal is to close this ticket as "no change". Comments?

Thank you,

Alexey

---

From: Alessandro Vesely <[email-masked]>
Date: Mon, 14 Dec 2020 12:30:44 +0100

On Mon 14/Dec/2020 12:23:18 +0100 Alexey Melnikov wrote:
> Splitting the part about "private domain names" from the discussion on whether 
> "resolvable" needs to be in the definition of domain names (ticket #9)
> 
> 2.3.5. Domain Names
> 
>    Does "in the public DNS" or equivalent need to be added to "resolvable"???
> 
> Strawman proposal: I believe "in the public DNS" doesn't reflect how SMTP 
> servers operate, due to existence of private DNS servers/split DNS. So my 
> proposal is to close this ticket as "no change". Comments?

+1, /resolvable/ is enough to relay.

Best
Ale
--

---

From: "John Levine" <[email-masked]>
Date: 14 Dec 2020 13:29:32 -0500

>So my proposal is to close this ticket as "no change". Comments?

No change is fine with me since I think that agrees with the practice.

R's,
John