Subject: [Emailcore] Bug-compatibility

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 14 May 2021 10:43:42 +1000

I ran into a great fun little issue the other day - I sent an email to a few people including an IETF expander ([email-masked]).  I'm on that expander, and the email I got back was truncated at the work ASAP from this line of my much longer email, which was quoted-printable encoded:

> ACTION: discussion on list to confirm cases work, then clear AUTH48 ASAP=
.

I'm planning to change our QP encoder to not wrap if there's just one character left in the line, which will avoid this particular bug ever happening again.  Guidance of this sort (don't include a dot on a line by itself in your email for maximum safety) would be useful! to others I suspect!

(and yes, I will report this bug to the IETF tools team)

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Viktor Dukhovni <[email-masked]>
Date: Mon, 17 May 2021 14:40:38 -0400

> On May 13, 2021, at 8:43 PM, Bron Gondwana <[email-masked]> wrote:
> 

Somebody's forwarding messages via sendmail(1) without the "-i" option...
They need to fix that.  It is not only dot on a line by itself that breaks,
but also all leading dots get stripped from all lines.

-- 
	Viktor.