Subject: [Emailcore] Ticket #10: Meaning of "resolvable FQDN" in Section 2.3.5

From: Todd Herr <[email-masked]>
Date: Fri, 9 Jul 2021 14:48:54 -0400

Greetings.

I would like to start a discussion on ticket #10, which reads:

In other words, names that can be resolved to MX RRs or address (i.e., A or
> AAAA) RRs (as discussed in Section 5) are permitted, as are CNAME RRs
> whose targets can be resolved, in turn, to MX or address RRs.
>

> It is not clear whether "In other words" really meant "for example" or it
> is was (sic) intended that the only labels permitted are those that own
> records in one of the above RR types.

The proposal here is to change the text, replacing "In other words" with
"In particular", as follows:

OLD:

  Only resolvable, fully-qualified domain names (FQDNs) are permitted
   when domain names are used in SMTP.  *In other words*, names that can
   be resolved to MX RRs or address (i.e., A or AAAA) RRs (as discussed
   in Section 5
<https://datatracker.ietf.org/doc/html/rfc5321#section-5>) are
permitted, as are CNAME RRs whose targets can be
   resolved, in turn, to MX or address RRs.  Local nicknames or
   unqualified names MUST NOT be used.  There are two exceptions to the

   rule requiring FQDNs:

NEW:

   Only resolvable, fully-qualified domain names (FQDNs) are permitted
   when domain names are used in SMTP.  *In particular,* names that can
   be resolved to MX RRs or address (i.e., A or AAAA) RRs (as discussed
   in Section 5
<https://datatracker.ietf.org/doc/html/rfc5321#section-5>) are
permitted, as are CNAME RRs whose targets can be
   resolved, in turn, to MX or address RRs.  Local nicknames or
   unqualified names MUST NOT be used.  There are two exceptions to the

   rule requiring FQDNs:

Thoughts?

-- 

*Todd Herr* | Technical Director, Standards and Ecosystem
*e:* [email-masked]
*m:* 703.220.4153

This email and all data transmitted with it contains confidential and/or
proprietary information intended solely for the use of individual(s)
authorized to receive it. If you are not an intended and authorized
recipient you are hereby notified of any use, disclosure, copying or
distribution of the information included in this transmission is prohibited
and may be unlawful. Please immediately notify the sender by replying to
this email and then delete it from your system.

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 10 Jul 2021 11:27:15 +0100

Hi Todd,

> On 9 Jul 2021, at 19:49, Todd Herr <todd.herr=[email-masked]> wrote:
> 
> Greetings.
> 
>> In other words, names that can be resolved to MX RRs or address (i.e., A or AAAA) RRs (as discussed in Section 5) are permitted, as are CNAME RRs whose targets can be resolved, in turn, to MX or address RRs.
>  
>> It is not clear whether "In other words" really meant "for example" or it is was (sic) intended that the only labels permitted are those that own records in one of the above RR types.
> 
> 
> The proposal here is to change the text, replacing "In other words" with "In particular", as follows:
> 
> OLD:
> 
>    when domain names are used in SMTP.  In other words, names that can
>    in Section 5) are permitted, as are CNAME RRs whose targets can be
>    when domain names are used in SMTP.  In particular, names that can
>    in Section 5) are permitted, as are CNAME RRs whose targets can be

(As a participant)
I like this change, as it changes the text from an example to the definitive list.

Best Regards,
Alexey
> 
> -- 
> Todd Herr | Technical Director, Standards and Ecosystem
> e: [email-masked] 
> m: 703.220.4153
> 
> This email and all data transmitted with it contains confidential and/or proprietary information intended solely for the use of individual(s) authorized to receive it. If you are not an intended and authorized recipient you are hereby notified of any use, disclosure, copying or distribution of the information included in this transmission is prohibited and may be unlawful. Please immediately notify the sender by replying to this email and then delete it from your system.
> -- 
> Emailcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emailcore

---

From: Ned Freed <[email-masked]>
Date: Sat, 10 Jul 2021 05:55:57 -0700 (PDT)

> I like this change, as it changes the text from an example to the definitive list.

I like it as well.

					Ned

---

From: Alessandro Vesely <[email-masked]>
Date: Tue, 13 Jul 2021 13:27:40 +0200

>> I like this change, as it changes the text from an example to the definitive list.

+1, good disambiguation.

Best
Ale
--