Subject: Re: [Emailcore] Ticket #8: Need a registry of header fields that are Ok to add after submission

From: Alexey Melnikov <[email-masked]>
Date: Mon, 2 Aug 2021 20:18:45 +0100

Dear all,
Looking through this thread I don’t see any obvious conclusion or consensus.

Possible options to move forward:

1) Postpone this ticket till later (after rfc5321bis/rfc5322bis are done), as suggestions to alter existing IANA Header Fields registry is not going to be feasible as is, as needs coordination with other users of the Header Fields registry. I think this will take months. It might be worth doing eventually, but I don’t have enough patience to drive this at the moment. (This option might end up being “no change”.)

2) Carry on and try to produce some example entries under the latest proposal (see below). Hopefully this will clarify the intent.

3) Scale down the proposal to only register trace header fields. Information about MSA/MTA/MDA would probably go, but can be added as a comment.

Anybody would like to speak in favour options #2 or #3?

Best Regards,
Alexey

> On 23 Jul 2021, at 13:22, Alexey Melnikov <[email-masked]> wrote:
> 
> Dear WG participants,
> 
> I would like to get closure on this ticket, which was briefly discussed on the mailing list and also during IETF 109 & 110. Below is a updated strawman text:
> 
> ===============
> 
> Add to the IANA Considerations of rfc5321bis:
> 
> IANA is requested to create a new subregistry for email header fields that can be added to a message header section by a MSA/MTA/MDA. The new subregistry would show whether a header field can be added by a "message submission", “relay”, “delivery” system or some combination of them. Headers appearing in this subregistry SHOULD also be registered in <https://www.iana.org/assignments/message-headers/message-headers.xhtml <https://www.iana.org/assignments/message-headers/message-headers.xhtml>> (whether it is registered as a Permanent Message Header Field Name or as a Provisional Message Header Field Name). The registration template has the following fields:
> 
> 1) Name of the header field name
> 
> 2) Can be added by an MSA?
> 
> 3) Can be added by an MTA?
> 
> 4) Can be added by an MDA?
> 
> 5) Optional reference field that points to one or more document describing the header field.
> 
> 6) Optional comment
> 
> Registration policy for this new subregistry is “Expert Review”. Designated Experts should only check correctness of the information in the registration template without passing any judgement on usuability of a specific header field being registered.
> 
> Updates to existing entries undergo the same process as registration of new header fields.
> 
> ===============
> 
> Let me know your thoughts.
> 
> 
> Best Regards,
> 
> Alexey
> 
> 
> -- 
> Emailcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emailcore

---

From: Ned Freed <[email-masked]>
Date: Mon, 02 Aug 2021 16:44:23 -0700 (PDT)

> Looking through this thread I don’t see any obvious conclusion or consensus.

I disagree with this assessment. I think there's consensus that creating a
separate header field registry just to document this piece of information is a
bad idea. I also predict that if you ask the question directly, there's a
consensus that this doesn't belong in RFC 5321bis.

I don't think there's a consensus on anything else.

This leaves us with three paths forward:

(1) Abandon the idea of gathering this information somewhere entirely.

(2) Recast the idea as an optional additional information item to be
    gathered as part of registering header fields. Note that this can be
    presented as a separate table on the web page if having an email-specific
    column in the current table is deemed to be too confusing.

(3) Your (3).

Your (3) actually brings up an additional point - it's arguably more
important to note whether or not a given field is a trace field in the 
registry than it is to document where it's supposed to be inserted. Right
now tracking down all the trace fields is a real PITA.

				Ned

---

From: "Alexey Melnikov" <[email-masked]>
Date: Thu, 05 Aug 2021 17:38:07 +0100

Hi Ned,

> I don't think there's a consensus on anything else.

Fair enough.

>     column in the current table is deemed to be too confusing.

Right, I offered my choice (1) as your #2, possibly falling back to your #1. My apologies for not separating them properly.

> now tracking down all the trace fields is a real PITA.

Right. I am happy to see if we can get consensus around (3), irrespective of which document includes it. After that we can decide on the document.

Best Regards,
Alexey

---

From: "John Levine" <[email-masked]>
Date: 5 Aug 2021 15:59:25 -0400

>Right. I am happy to see if we can get consensus around (3), irrespective of which document includes it. After that we can decide on the document.

Sounds good to me.

My inclination is to update RFC 3864 and add "mail trace" as a value in the Protocol column
of the existing Message Headers registry.

R's,
John