Subject: [Emailcore] How to send email to [email-masked] ?

From: Toerless Eckert <[email-masked]>
Date: Mon, 7 Mar 2022 14:01:05 +0100

Sorry to send a question to the list that is purely operational in nature,
but i wouldn't know a better list to ask such as question.
if gmail was not free, they wouldn't answe...

Since a few weeks ? I am having more and more trouble to do IETF work because
many colleagues i need to send email to have gmail accounts, and i am more and
more often getting the error message below from gmail, and the URL that google
points to has the whole kitchen sink of possible anti-spam precautions that
gmail seemingly would like to offload to senders of email. Which seems to me
like a nice abuse of market power on behalv of gmail. That email was just a test
email i sent to my own gmail account. And interestingly, the first email i sent made it through
to my mailbox, and when i sent an email again a few minutes later it failed.

Oh: bonus question: Any recommendations for another email service to use instead of gmail ?
(this is not the only problem i encountered, gmail also announced they are shutting down
 supposedly "insecure" access to sending mail, so i can not even send emails from my
 service provider installed home router...).

Thanks & cheers
    Toerless

In-Reply-To: <[email-masked]>

On Mon, Mar 07, 2022 at 01:54:30PM +0100, Mail Delivery System wrote:
> This is the mail system at host faui40.informatik.uni-erlangen.de.
> 
> I'm sorry to have to inform you that your message could not
> be delivered to one or more recipients. It's attached below.
> 
> For further assistance, please send mail to postmaster.
> 
> If you do so, please include this problem report. You can
> delete your own text from the attached returned message.
> 
>                    The mail system
> 
> <[email-masked]>: host
>     gmail-smtp-in.l.google.com[2a00:1450:400c:c0a::1a] said: 550-5.7.26 This
>     message does not have authentication information or fails to 550-5.7.26
>     pass authentication checks. To best protect our users from spam, the
>     550-5.7.26 message has been blocked. Please visit 550-5.7.26
>     https://support.google.com/mail/answer/81126#authentication for more 550
>     5.7.26 information. n13-20020a056000170d00b001f1eb289340si4396727wrc.790 -
>     gsmtp (in reply to end of DATA command)

> Reporting-MTA: dns; faui40.informatik.uni-erlangen.de
> X-Postfix-Queue-ID: 48F455499E9
> X-Postfix-Sender: rfc822; [email-masked]
> Arrival-Date: Mon,  7 Mar 2022 13:54:27 +0100 (CET)
> 
> Final-Recipient: rfc822; [email-masked]
> Original-Recipient: rfc822;[email-masked]
> Action: failed
> Status: 5.7.26
> Remote-MTA: dns; gmail-smtp-in.l.google.com
> Diagnostic-Code: smtp; 550-5.7.26 This message does not have authentication
>     information or fails to 550-5.7.26 pass authentication checks. To best
>     protect our users from spam, the 550-5.7.26 message has been blocked.
>     Please visit 550-5.7.26
>     https://support.google.com/mail/answer/81126#authentication for more 550
>     5.7.26 information. n13-20020a056000170d00b001f1eb289340si4396727wrc.790 -
>     gsmtp

> Date: Mon, 7 Mar 2022 13:54:27 +0100
> From: Toerless Eckert <[email-masked]>
> To: [email-masked]
> Subject: Test 2 from [email-masked]
> 
> 
> -- 
> ---
> [email-masked]

-- 
---
[email-masked]

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 07 Mar 2022 07:56:19 -0800

Sounds like your sending host doesn't have DKIM and/or SPF, or it's set up incorrectly.  You'll have issues with a lot more than just gmail.

You appear to be sending via IPV6.  Are your connections coming from inside the range `2001:638:a000::/48` ?  Also, are your emails DKIM signed?

Gmail is significantly more strict about authentication for mail over IPv6.  I see that your sending domain doesn't provide a DMARC record, so this could be the issue since it's sending over IPV6.

And yes, "supposedly insecure" is flat out insecure - there's no way to authenticate that your home router isn't somebody else's home router in the general sense.

Regards,

Bron.

On Mon, Mar 7, 2022, at 05:01, Toerless Eckert wrote:
> Emailcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emailcore
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Claus Assmann <[email-masked]>
Date: Mon, 7 Mar 2022 16:39:55 +0000

On Mon, Mar 07, 2022, Toerless Eckert wrote:

> I am having more and more trouble to do IETF work because
> many colleagues i need to send email to have gmail accounts,

Maybe use the "matching" IETF mailing list, so it's their
server, not yours, which contacts gmail?

>  Which seems to me
> like a nice abuse of market power on behalv of gmail.

"We don't care, we don't have to, we are the phone company."

Agreed -- I am also getting more rejects even though I had
communicated with the same people before.

(No, I won't set up all the stuff that gmail requires...
it's more and more -- where/when will it stop?
- when you pay them money?)

-- 
Address is valid for this mailing list only, please do not reply
to it directly, but to the list.

---

From: "John R. Levine" <[email-masked]>
Date: 7 Mar 2022 14:21:50 -0500

> more often getting the error message below from gmail, ...

They have been tightening up their validation rules.  Your SPF record 
seems to be OK but I agree that DKIM signing is likely to help a lot.

> Oh: bonus question: Any recommendations for another email service to use instead of gmail ?

If you want a free mail provider, you get what you pay for.  Among paid 
providers, Fastmail has a good reputation and Bron would never tout his 
own service.

> service provider installed home router...).

To send mail through Gmail you need to authenticate with oauth.  This is 
tedious but it does work. I set up my gmail account in my copy of Alpine 
yesterday.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Steffen Nurpmeso <[email-masked]>
Date: Mon, 07 Mar 2022 23:22:21 +0100

John R. Levine wrote in

[I left you off To:, right.  I hate that bouncing.]

 <[email-masked]>:
 |> Since a few weeks ? I am having more and more trouble to do IETF \
 |> work because
 |> many colleagues i need to send email to have gmail accounts, and \
 |> i am more and
 |> more often getting the error message below from gmail, ...
 |
 |They have been tightening up their validation rules.  Your SPF record 
 |seems to be OK but I agree that DKIM signing is likely to help a lot.
 ...
 |> (this is not the only problem i encountered, gmail also announced \
 |> they are shutting down
 |> supposedly "insecure" access to sending mail, so i can not even send \
 |> emails from my
 |> service provider installed home router...).
 |
 |To send mail through Gmail you need to authenticate with oauth.  This is 
 |tedious but it does work. I set up my gmail account in my copy of Alpine 
 |yesterday.

You can use 2-factor with an application-specific password, and
that works with authentication schemes which do not need JSON and
HTTP 1/[2/3] and a browser (but for setup).

I hope they do not shut that down?

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---

From: Steffen Nurpmeso <[email-masked]>
Date: Mon, 07 Mar 2022 23:24:48 +0100

Steffen Nurpmeso wrote in
 <[email-masked]>:
 |John R. Levine wrote in
 | <[email-masked]>:
 ||> Since a few weeks ? I am having more and more trouble to do IETF \
 ||> work because
 ||> many colleagues i need to send email to have gmail accounts, and \
 ||> i am more and
 ||> more often getting the error message below from gmail, ...
 ||
 ||They have been tightening up their validation rules.  Your SPF record 
 ||seems to be OK but I agree that DKIM signing is likely to help a lot.
 | ...
 ||> (this is not the only problem i encountered, gmail also announced \
 ||> they are shutting down
 ||> supposedly "insecure" access to sending mail, so i can not even send \
 ||> emails from my
 ||> service provider installed home router...).
 ||
 ||To send mail through Gmail you need to authenticate with oauth.  This is 
 ||tedious but it does work. I set up my gmail account in my copy of Alpine 
 ||yesterday.
 |
 |You can use 2-factor with an application-specific password, and
 |that works with authentication schemes which do not need JSON and
 |HTTP 1/[2/3] and a browser (but for setup).

Not to mention that it seems impossible to get an OAUTH "client
secret" (?) for a normal console based application at GMail.

 |I hope they do not shut that down?

--steffen
|