Subject: [eman] feedback on drafts

From: "Michael Suchoff" <[email-masked]>
Date: Thu, 24 Feb 2011 15:13:42 -0500

All,

I have been a silent observer of this group for about a month.

By way of introduction, I am a principal engineer at Raritan.  Raritan
manufactures rack power distribution units and is an industry leader in
outlet level metered rack PDUs.  Our products contain a billing grade AC
energy metering chip for each outlet and our devices contain a networked
SNMP agent.  Raritan also develops and sells SNMP data center power
management software - and our management software is designed to work
with any vendor's PDU - not just our own.  I learned of this group
through our client Cisco that outfits their data centers with our PDUs
and power management software.

As an "implementer" of AC energy management products and as someone that
has experience with many vendors' implementation of SNMP energy
management, here are two thoughts on the MIBs produced by the eman ietf
group.

1.	Timestamps

When taking power measurements, there is no indication of the time when
the measurement occurred.  The major vendors of metered power
distribution units and panel energy meters all include time stamped data
logs.  These data logs typically contain 100+ time stamped measurements
per sensor (voltage/current/power, etc.).

The proposed MIBs do not take time of measurement into consideration and
this will be a problem.  Assume we want to get readings on an hourly
basis from an SNMP manager that must communicate with many thousands of
devices.  Without data logging, it isn't possible to get accurately get
timed measurements due to the variable delay times in the manager,
network and agents.  Our experience supporting every major vendor's PDU
SNMP agent indicates variable SNMP GET delays of 2-45 seconds.

2.	AC Power Terminology

There is a bit of a lack of understanding of AC power in the MIBs.  Here
are some examples:

*         AC power is not an RMS measurement, it is an average reading.
AC power is sinusoidal at 2x the AC line frequency, so use of the term
"instantaneous AC power" is misleading and power meters do not report
it.

*         Voltage & current RMS measurements are by definition averaged
values, they are not "instantaneous RMS" measurements

*         3-phase PDUs are not black and white either Wye or Delta.  In
North American 208V systems, power distribution units contain a
combination of delta wired circuits (208V) and wye wired circuits
(120V).

*         The nameplate MIB objects use names such as "max voltage" and
have fixed single numeric values.  Actual device nameplate values follow
the UL (or IEC) 60950-1 conventions and are rated (not max) ranges (not
single values).  Example:  "Rated Voltage: "190-240V 3-phase".

*         There are many IEC and ANSI standards for AC energy meters.
The attempts in the MIB to define energy metering accuracy are
nonstandard.

*         A major concern in AC data center management is detection of
tripped circuit breakers (or blown fuses).  The MIB contains no modeling
for over current devices.

I hope the above are taken as constructive help. I mean no disrespect to
the members that have put in long hours developing the MIBs.  I am
available to help improve the group's efforts.

Regards,

Michael Suchoff
Principal Engineer 

Raritan * 801 Jones Franklin Rd * Raleigh, NC 27606 USA
Tel: 1.919.851.3663 ext.1371

[email-masked]

Visit our blog: blog.raritan.com <http://blog.raritan.com/>

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 25 Feb 2011 08:36:08 +0100

Dear Michael,

Thanks a lot for becoming active on this list.
Your comments are very helpful.

Are the MIB module that you are using publicly available?
If yes, could you give us a pointer to them?
It would be great if we could study them and learn from them.

Thanks,

    Juergen

Am 24.02.2011 um 21:13 schrieb Michael Suchoff:

> By way of introduction, I am a principal engineer at Raritan.  Raritan manufactures rack power distribution units and is an industry leader in outlet level metered rack PDUs.  Our products contain a billing grade AC energy metering chip for each outlet and our devices contain a networked SNMP agent.  Raritan also develops and sells SNMP data center power management software – and our management software is designed to work with any vendor’s PDU – not just our own.  I learned of this group through our client Cisco that outfits their data centers with our PDUs and power management software.
>  
> As an “implementer” of AC energy management products and as someone that has experience with many vendors’ implementation of SNMP energy management, here are two thoughts on the MIBs produced by the eman ietf group.
>  
> Timestamps
>  
> When taking power measurements, there is no indication of the time when the measurement occurred.  The major vendors of metered power distribution units and panel energy meters all include time stamped data logs.  These data logs typically contain 100+ time stamped measurements per sensor (voltage/current/power, etc.).
>  
> The proposed MIBs do not take time of measurement into consideration and this will be a problem.  Assume we want to get readings on an hourly basis from an SNMP manager that must communicate with many thousands of devices.  Without data logging, it isn’t possible to get accurately get timed measurements due to the variable delay times in the manager, network and agents.  Our experience supporting every major vendor’s PDU SNMP agent indicates variable SNMP GET delays of 2-45 seconds.
>  
> AC Power Terminology
>  
> There is a bit of a lack of understanding of AC power in the MIBs.  Here are some examples:
>  
> ·         AC power is not an RMS measurement, it is an average reading.  AC power is sinusoidal at 2x the AC line frequency, so use of the term “instantaneous AC power” is misleading and power meters do not report it.
> ·         Voltage & current RMS measurements are by definition averaged values, they are not “instantaneous RMS” measurements
> ·         3-phase PDUs are not black and white either Wye or Delta.  In North American 208V systems, power distribution units contain a combination of delta wired circuits (208V) and wye wired circuits (120V).
> ·         The nameplate MIB objects use names such as “max voltage” and have fixed single numeric values.  Actual device nameplate values follow the UL (or IEC) 60950-1 conventions and are rated (not max) ranges (not single values).  Example:  “Rated Voltage: “190-240V 3-phase”.
> ·         There are many IEC and ANSI standards for AC energy meters.  The attempts in the MIB to define energy metering accuracy are nonstandard.
> ·         A major concern in AC data center management is detection of tripped circuit breakers (or blown fuses).  The MIB contains no modeling for over current devices.
>  
> I hope the above are taken as constructive help. I mean no disrespect to the members that have put in long hours developing the MIBs.  I am available to help improve the group’s efforts.
>  
> Regards,
> Michael Suchoff
> Principal Engineer 
> Raritan • 801 Jones Franklin Rd • Raleigh, NC 27606 USA
> Visit our blog: blog.raritan.com
>  
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman