Subject: [eman] Terminology: Awareness

From: Juergen Quittek <[email-masked]>
Date: Wed, 16 Mar 2011 00:18:16 +0100

Hi all,

in some recent emails on this list I read "If the device is energy-aware"
Also we have a draft called draft-ietf-eman-energy-aware-mib containing
a MIB module called ENERGY-AWARE-MIB.

My question is: What do we mean when we say "aware"?

Is it a term to which we give a clear technical meaning 
or does it just sound sexy and is good for marketing?

According to Merriam-Webster aware means

    "having or showing realization, perception, or knowledge"

This rather sounds like a cognitive performance that most of the 
devices we are talking about will never be able to show. 

So what else would "aware" mean for us? 
And is it OK to re-define it?

Is a switch that measures its own energy consumption "energy-aware"?
Then it would be as well packet-aware if it has a counter for packets.
It would be flow-aware if it supports NetFlow, and of course it would
be TCP-aware if it implements the TCP-MIB and IP aware with the IF-MIB.

According to draft-ietf-eman-energy-aware-mib a device can even become
energy-aware if an external meter measures its power and reports it to 
a management station. In this case, the "energy-aware" device does never
get any access to its power and energy values. This is terribly misleading.
Let's please stop such nonsense.

Considering that the IETF creates technical specifications
and not marketing brochures, I suggest replacing this term 
in all our documents with other terms that are technically accurate.

Which term to be used depends on the context. In many cases, just
calling them "monitored" devices or entities is fine. But in other cases 
the replacement is more difficult. For example, MIB module
ENERGY-AWARE-MIB could more appropriately be called 
EMAN-ENTITY-ID-MIB or  EMAN-RELATIONSHIP-MIB, etc., 
depending on which feature of the module we consider most 
important.

Thanks,

    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 15 Mar 2011 17:05:19 -0700

Hi Jeurgen,

The idea for energy aware was to distinguish between a device that is capable of reporting it's power consumption, or has delagated that to something that can, versus one without.

So if you are metered by a device and not aware that that meter is reporting your power (you don't defer or aggregate to it) then it doesn't fit the definition. It has technical merit IMO because it covers both those cases.

That's a term that other standards groups are using as well see:
http://odva.org/Portals/0/Library/Publications_Numbered/PUB00246_ODVA_Optimization_of_Energy_Usage_R0.pdf

Energy Aware packet routing is a term and field of cs research as is thermal aware scheduling for data centers and routing. So I don't see this as a stretch at all.

As for packet aware sounding ridiculous etc one can pair any two terms out of context like that and sound ridiculous - like capable or secure - and say a device is packet capbable or packet secure etc. So that's a bit specious IMO.

The point for us is to have a distinction between something that can report it's power and cannot/did not delegate it.

Before we partitioned the mib into two portions aware meant power reporting but since the usage object got factored into the monitor at the split it's probably not the best name for the draft anymore (although it applies for context). That's a relic of this process not modeling.

As a meta item a call for a WG glossary does sound in order though.
Jp

-----Original Message-----
From: [email-masked] on behalf of Juergen Quittek
Sent: Tue 3/15/2011 4:18 PM
To: eman mailing list
Subject: [eman] Terminology: Awareness
 
Hi all,

Thanks,

    Juergen

_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 16 Mar 2011 02:13:48 +0100

Hi John,

> The idea for energy aware was to distinguish between a device that is capable of reporting it's power consumption, or has delagated that to something that can, versus one without.
OK. Then let's call it "monitored" device instead of "aware" device. 
> http://odva.org/Portals/0/Library/Publications_Numbered/PUB00246_ODVA_Optimization_of_Energy_Usage_R0.pdf
As I said in my previous email: The IETF produces technical specifications and not marketing brochures.
> Energy Aware packet routing is a term and field of cs research as is thermal aware scheduling for data centers and routing. So I don't see this as a stretch at all.
I have no problem with the term energy aware packet routing. This is a reasonable use of the term "aware" (in contrast to how we have been using it so far in the EMAN WG).
> The point for us is to have a distinction between something that can report it's power and cannot/did not delegate it.
I don't think that these devices "delegate" anything. The desktop phone does not delegate power metering to the PoE switch. Typically, the PoE switch measures without any delegation request from the phone. 

The device is either monitored or it is not monitored. the term "awareness" is terribly misleading.
> Before we partitioned the mib into two portions aware meant power reporting but since the usage object got factored into the monitor at the split it's probably not the best name for the draft anymo…
I don't care about draft names. They are ephemeral. But their technical content is not when turned into an RFC.
> As a meta item a call for a WG glossary does sound in order though.
Great, let's start working on it.

Thanks,

    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 15 Mar 2011 19:09:57 -0700

Hi Jeurgen,

inline...

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: Tue 3/15/2011 6:13 PM
To: John Parello (jparello)
Cc: eman mailing list
Subject: Re: [eman] Terminology: Awareness
 
Hi John,

[jp] I think the concept of aware covers the fact that a device knows it's being metered versus metered without it. If I were to monitor you there's then a later distinction of whether you know about it or not. So there's a clear difference between the two.

[jp] Neither do I and this as a pure modeling distinction. The ODVA produces the CIP specification which produces an energy aware object with data and services. I can point to other where this is a clear technical term. There's a very big difference between monitored and aware of the monitoring.

[jp] See above I've sited a clear difference for the term.

[jp] They do in fact delegate to the switch through PoE negotiation, time of day control and metering. They are distinct and we find the distinction needed in lines of devices we ship. I can send you details off thread if needed. Monitored versus monitored and aware of the monitoring is clearly different.

[jp] ACK  on that

[jp] ACK on that as well.

Jp

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 16 Mar 2011 03:48:03 +0100

Hi John,

Again inline ...

> [jp] I think the concept of aware covers the fact that a device knows it's being metered versus metered without it. If I were to monitor you there's then a later distinction of whether you know abo…
So you define a device to be "energy-aware", if there is the information that it is being metered available to it.
Hence, devices that are being metered, but do not have this information are not energy-aware.
What is this distinction useful for?

I just think about a device that knows its traffic is being monitored by a probe attached to one of its links and another device that does not know it.
What makes the difference. I think it is important that the management system knows which device is monitored. Why would we tell this all devices?

According to this definition, IP phones attached to a PoE switched and metered by it are not energy-aware, if not the PoE switch tells them. Why should the switch do so?
What would be different if it did so?
> [jp] Neither do I and this as a pure modeling distinction. The ODVA produces the CIP specification which produces an energy aware object with data and services. I can point to other where this is a…
OK. What is the big difference. I am curious to understand it. I have not found it explained in any of our drafts.
> [jp] See above I've sited a clear difference for the term.
See above. What makes the difference? What use makes a device of the knowledge that it is being metered?
> [jp] They do in fact delegate to the switch through PoE negotiation, time of day control and metering. They are distinct and we find the distinction needed in lines of devices we ship. I can send y…
Is this part of the PoE standard or a proprietary extension? 
I don't remember reading anything about a metering delegation request in the PoE specification. 

Thanks,

    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 15 Mar 2011 20:24:28 -0700

Hi Jeurgen,

trimmed see inline...

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: Tue 3/15/2011 7:48 PM
To: John Parello (jparello)
Cc: eman mailing list
Subject: Re: [eman] Terminology: Awareness

[jp] Yes that's right. If a PoE is not capable of reporting its usage and is metered by the switch and doesn't know about it - it is not aware. Let's look at that same device if it is aware but can't report it's own usage. If the PoE phone is aware that the switch can report it's usage when asked it can defer the question to its switch versus saying I don't know. That's a very useful pattern of precessing. I don't know, versus hold on I'll find out, or ask this person - very distinct processing from indicating aware versus monitored. You use the difference yourself "probe". There is no difference in probing and monitoring (observer) but there is very much a difference if the device itself is capable of reporting a value or knowing where to direct you (observed). 

Management of devices in this space reply on making the distinction of what is probed and what is capable of reporting itself or via a proxy. It's the nature of the problem domain.

Now let's shift to correlation of data from sets of devices. When an NMS is processing data there is quite an advantage in the correlation of the data.  Example in an enterprise or data center deployment you have setups where meters (ok probes) are set up for sections of distribution (panels, racks, plugs, device) and may or may not be redundant. These monitored/probed values all have difference accuracy and capabilities. A device that reports it's consumption and is aware of the device(s) metering it can indicate as such and the data can be correlated to resolve (in)accuracies and accounted.

Monitoring is not sufficient alone as that is an attribute based upon the observer not the observed.  

[jp] Sorry if I wasn't clear, yes proprietary, and they exist as I stated that. "we find the distinctions in lines of devices we ship". This pattern of processing does exist in other lines of devices and not a standard.

Jp

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 15 Mar 2011 23:28:47 -0700

I'll not try to insert myself into the exact back/forth of this, but
the "aware" term has also puzzled me from the start.

>From the perspective of the NMS, I would think that the level
of self-awareness of the device being monitored might be
unimportant, or at best a detail that could be noted (a flag).

The reference model document notes that the functionality of
reporting is divided into three parts: power supply, power
metering, and power status.  A device may report some or
all of these itself, and a separate device may report some or
all.  Thus, "awareness" would seem to be disaggregated,
not unitary.

I have wondered if this disaggregation suggests that the
MIBs should be divided up along these lines, since initially
at least, different devices (in principle three) might be
reporting the different types of information.  In addition,
control signals (not my usual concern) will then also travel
to different entities, depending on whether it is supply,
meter, or status that is in question.

Finally, I think that data about identity and context are
distinct from the above three types of energy-specific
data, so may suggest one or two additional MIBs
(otherwise, they are most closely related to status).

--Bruce

..

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 16 Mar 2011 07:03:52 -0500

Hi Juergen,

It is possible to argue, Awareness of Energy Usage (being conscious of
energy usage) can possibly lead to conservation of energy. 
One is conscious ( or aware) of the energy usage only when they get the
electricity bill. The bill is generated based on energy measurement.
In a sense, awareness is a result of measurement. Energy
measurement/monitoring is the focus of the WG. 

Energy-aware device is probably is a acronym for a energy measurement
capable device (measurement obtained directly or indirectly).
Perhaps it may be useful to define the concept what is an energy-aware
device in some draft. 

Regarding the particular question, the name of MIB module you have
referenced focuses on identification, context of the device that is
monitoring its own energy usage or reporting energy usage on behalf of
other device devices. 
If other names are better suited for the MIB module such as
EMAN-ENTITY-MIB, that is a good discussion point for the WG. 

Thanks
Mouli

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Juergen Quittek
Sent: Wednesday, March 16, 2011 4:48 AM
To: eman mailing list
Subject: [eman] Terminology: Awareness

Hi all,

in some recent emails on this list I read "If the device is
energy-aware"
Also we have a draft called draft-ietf-eman-energy-aware-mib containing
a MIB module called ENERGY-AWARE-MIB.

get any access to its power and energy values. This is terribly
misleading.

Thanks,

    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 16 Mar 2011 11:14:41 -0700

Hi Bruce,

I'll sum up my thinking here on aware versus monitored.

I think the term aware is more precise than monitor for the work of this
group but both are necessary. It's unfortunate monitor  was used from
the start when the requirements were specified. 

 If a device implements the objects we are defining here we can say the
device is aware of its power and energy. Whether it is monitored or not
is a different attribute.  Monitored assumes the existence of an
observer. Let's anthropomorphize this as an example.

Device  = Person

Energy = spending

If your spending is monitored you would assume from that there exists
some external observer.

If you are aware of your spending you are tracking your spending with or
without an observer.

Back to our work.

IF you implement a set of objects we define in this WG you are aware of
your energy. You may or may not be monitored by someone accessing the
object. You can't assume just because you implement the objects there's
some miraculous observer making SNMP request to you or monitoring you.
You may never be contacted but you are still aware.

They are distinct terms.

In this space where there are non telecommunications devices the term
monitoring with an implied observer would be perceived as a setup where
some external metering device or physical probe was attached to a
device. This is ambiguous and misleading.

Juergen proposes swapping out the term aware for monitored . I
completely disagree with that as they are not synonyms and describe two
very different use.

AS for the idea this was marketing driven or that the use cases I
proposed were proprietary (I'd say running code looking for consensus)
those are arguments to the messenger not the message so I don't see how
that even needs consideration.

This distinction has been adopted by another standards body so it merits
consideration in this WG.

Jp

From: Bruce Nordman [mailto:[email-masked]] 
Sent: Tuesday, March 15, 2011 11:29 PM
To: Juergen Quittek
Cc: John Parello (jparello); eman mailing list
Subject: Re: [eman] Terminology: Awareness

--Bruce

..

-- 
Bruce Nordman

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 17 Mar 2011 09:52:36 +0100

Hi John,

Let's start defining terms.
According you your email below and our discussions before I assume the following:

"energy-metered" 
A device is energy-metered if some entity measures the energy consumption of the device. This may happen internally or externally of the device. 

"energy-aware" 
A device is enerhy-aware if the information that the devices is metered is available at the device even if metering is conducted externally.

"energy-monitored"
A device is energy-monitored if some energy monitoring system observes metered energy values of a device. For self-managed devices, it may be the device itself that monitors it.

Would you agree on these definitions or do you have other ones?

If yes, I am still waiting for someone explaining me what we need the concept of "energy-awareness" for if we have "metered" and "monitored".

Thanks,

    Juergen

Am 16.03.2011 um 19:14 schrieb John Parello (jparello):

> Hi Bruce,
>  
> I’ll sum up my thinking here on aware versus monitored.
>  
> I think the term aware is more precise than monitor for the work of this group but both are necessary. It’s unfortunate monitor  was used from the start when the requirements were specified.
>  
>  If a device implements the objects we are defining here we can say the device is aware of its power and energy. Whether it is monitored or not is a different attribute.  Monitored assumes the existence of an observer. Let’s anthropomorphize this as an example.
>  
> Device  = Person
> Energy = spending
>  
> If your spending is monitored you would assume from that there exists some external observer.
> If you are aware of your spending you are tracking your spending with or without an observer.
>  
> Back to our work.
>  
> IF you implement a set of objects we define in this WG you are aware of your energy. You may or may not be monitored by someone accessing the object. You can’t assume just because you implement the objects there’s some miraculous observer making SNMP request to you or monitoring you. You may never be contacted but you are still aware.
>  
> They are distinct terms.
>  
> In this space where there are non telecommunications devices the term monitoring with an implied observer would be perceived as a setup where some external metering device or physical probe was attached to a device. This is ambiguous and misleading.
>  
> Juergen proposes swapping out the term aware for monitored . I completely disagree with that as they are not synonyms and describe two very different use.
>  
> AS for the idea this was marketing driven or that the use cases I proposed were proprietary (I’d say running code looking for consensus) those are arguments to the messenger not the message so I don’t see how that even needs consideration.
>  
> This distinction has been adopted by another standards body so it merits consideration in this WG.
>  
> Jp
>  
>  
>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 17 Mar 2011 10:54:08 -0700

Hi Juergen,

Inline...

From: Juergen Quittek [mailto:[email-masked]] 
Sent: Thursday, March 17, 2011 1:53 AM
To: John Parello (jparello)
Cc: Bruce Nordman; eman mailing list
Subject: Re: [eman] Terminology: Awareness

Hi John,

According you your email below and our discussions before I assume the
following:

[jp] we'll have to cover the separate values of power and energy?

"energy-metered" 

A device is energy-metered if some entity measures the energy
consumption of the device. This may happen internally or externally of
the device. 

"energy-aware" 

A device is enerhy-aware if the information that the devices is metered
is available at the device even if metering is conducted externally.

"energy-monitored"

A device is energy-monitored if some energy monitoring system observes
metered energy values of a device. For self-managed devices, it may be
the device itself that monitors it.

If yes, I am still waiting for someone explaining me what we need the
concept of "energy-awareness" for if we have "metered" and "monitored".

[jp] Well someone other than me I assume ;)   - Aware covers your case
of defining monitoring as being monitored and self-metered (monitored?)
which would make your definition non terminal.  We can discuss offline
if you like for efficiency.  

Jp

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 17 Mar 2011 23:21:22 +0100

Hi John,

Let's rather discuss here on the list than privately.

If we have the terms "monitored" and "metered" as defined below,
in what cases would we need the term "aware"?

Can you give an example for such a case or scenario?

Thanks,

    Juergen

Am 17.03.2011 um 18:54 schrieb John Parello (jparello):

> Inline…
> [jp] we’ll have to cover the separate values of power and energy?
>  
> "energy-metered" 
> [jp] Well someone other than me I assume ;)   - Aware covers your case of defining monitoring as being monitored and self-metered (monitored?) which would make your definition non terminal.  We can discuss offline if you like for efficiency. 
> Jp
>  
>  
>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 17 Mar 2011 16:23:21 -0700

Fine see my previous emails.  I've explained it with use cases already.

Jp

Sent: Thursday, March 17, 2011 3:21 PM

Hi John,

Thanks,

    Juergen

Hi Juergen,

Inline...

Hi John,

"energy-metered" 

"energy-aware" 

"energy-monitored"

Jp

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 18 Mar 2011 07:22:03 +0100

Hi John,

Am 18.03.2011 um 00:23 schrieb John Parello (jparello):

> Fine see my previous emails.  I’ve explained it with use cases already.

> IF you implement a set of objects we define in this WG you are aware of your energy. You may or may not be monitored by someone accessing the object. You can’t assume just because you implement the…

This is just a definition of "aware" not a use case. I still would like to have someone pointing me at any case where it is useful to know whether a devices is "aware" or not "aware".  I see cases where it is important to know if a device is "metered" or "monitored" (as defined below), but I fail to see a cases where  it is useful to know if a device is "aware".

Without a good case for it  we do not need the term "aware".

BTW: I don't think your definition above is 100% correct. You say "IF you implement a set of objects we define in this WG you are aware of your energy". But you may implement the objects as a "parent" and report on other devices energy. You can do so without having your own energy metered, i.e. without being "aware of your energy". You would then be just "aware" of OTHER devices energy. 

Thanks,

    Juergen

---

From: Benoit Claise <[email-masked]>
Date: Fri, 18 Mar 2011 14:05:23 +0100

Dear all,

In my mind, awareness means that you have the information to take an action.
Juergen, you mentioned below: "It would be flow-aware if it supports 
NetFlow". For example, a device that only reports flow, is not really 
flow aware. However, if that device is able to do flow based routing (or 
whatever feature based on flow), it's flow-aware.

Coming back to our EMAN situation:
     if you are a parent, you're obviously aware (of the children)
     if you are a child, you might or not be aware (does the child 
monitors its power/energy or it's done by someone else?)

The possible different points of views come from:
1. the charter speaks multiple times about "energy-aware". So the term 
was reused
2. in the EMAN community, we have different groups with different 
interests. One group cares about parent (called Power Monitor Aggregator 
or Power Monitor Proxy in the drafts, with the example of PDU or 
switch), while some people care about the end devices (called Power 
Monitor Child in the drafts, with examples such as PC).  The first group 
asserts that the network is energy-aware, while the second one is not 
convinced.
3. the charter doesn't speak about much configuration. It's true that 
there are a couple of read-write OIDs, but nothing about policies or 
services (btw, not the IETF typical job). And we know that we're not 
monitoring power/energy for the sake of monitoring: we have to save 
energy. So the awareness will have to come from somewhere, whether it's 
the network, or the NMS.  Personally, I believe that future networks, 
looking at their complexity,  will not necessarily be managed from a 
centralized NMS. So I was inclined to go in the direction of the 
energy-aware network term when we defined the charter.

So now, how do we solve this?

Regards, Benoit.

---

From: "John Parello (jparello)" <[email-masked]>
Date: Fri, 18 Mar 2011 07:47:24 -0700

Hi Juergen,

Yes as below I prefer the term as a distinction as to whether the device
is implementing the objects as we define. The distinction is need
because there will be devices that will not implement the object and
still join in the managed community, 

They can still be metered or monitored by a the parent.

For example In  the case below you can have  parent that is aware that
is acting on behalf of children that are or are not aware. 

I think your origination of this thread was to indicate that you thought
the term was superfluous. I do not.

I completely agree we need more terminology definitions in the framework
drafts and will put those in there to show the distinctions a long side
the use cases in the draft.

As it's too late to publish a revision before Prague I will update my
drafts with definitions sections.

Thanks I see your concerns and I will make sure to clarify it in the
drafts and we can continue the discussion of terms and uses cases in
that context.

Jp 

Sent: Thursday, March 17, 2011 11:22 PM

Hi John,

	IF you implement a set of objects we define in this WG you are
aware of your energy. You may or may not be monitored by someone
accessing the object. You can't assume just because you implement the
objects there's some miraculous observer making SNMP request to you or
monitoring you. You may never be contacted but you are still aware.

This is just a definition of "aware" not a use case. I still would like
to have someone pointing me at any case where it is useful to know
whether a devices is "aware" or not "aware".  I see cases where it is
important to know if a device is "metered" or "monitored" (as defined
below), but I fail to see a cases where  it is useful to know if a
device is "aware".

 

BTW: I don't think your definition above is 100% correct. You say "IF
you implement a set of objects we define in this WG you are aware of
your energy". But you may implement the objects as a "parent" and report
on other devices energy. You can do so without having your own energy
metered, i.e. without being "aware of your energy". You would then be
just "aware" of OTHER devices energy. 

Thanks,

    Juergen

	Jp

	Hi John,

	Thanks,

	    Juergen

	

	Hi Juergen,

	Inline...

	Hi John,

	According you your email below and our discussions before I
assume the following:

	[jp] we'll have to cover the separate values of power and
energy?

	"energy-metered" 

	"energy-aware" 

	A device is enerhy-aware if the information that the devices is
metered is available at the device even if metering is conducted
externally.

	"energy-monitored"

	A device is energy-monitored if some energy monitoring system
observes metered energy values of a device. For self-managed devices, it
may be the device itself that monitors it.

	If yes, I am still waiting for someone explaining me what we
need the concept of "energy-awareness" for if we have "metered" and
"monitored".

	[jp] Well someone other than me I assume ;)   - Aware covers
your case of defining monitoring as being monitored and self-metered
(monitored?) which would make your definition non terminal.  We can
discuss offline if you like for efficiency. 

	Jp