Subject: [eman] draft-ietf-eman-requirements-00 review

From: Patrick Grossetete <[email-masked]>
Date: Wed, 2 Mar 2011 12:47:49 +0100 (CET)

Benoit, 

Please, find my comments regarding draft-ietf-eman-requirements-00. I wrote them while reading the doc, so there is no priority order. 

Best Regards 
Patrick 

- page 4-5, it should be added that environmental conditions may also impact the potential reduction of power consumption. There is often a link between 
temperature/RH and power...for example, see ASHRAE specifications for DataCenter (PUE and DCIE metrics). It may also be noticed that side effects may occur. 
For example, I have seen people increasing the temperature in their datacenter to comply with PUE metric but in fact getting fan speed increase on their servers 
and leading to false conclusion of metrics since the power consumption was seen as "good" for PUE computation. Clearly, the capability to monitor 
energy consumption of servers would have indicated that. 

- page 5, monitoring energy consumption can also help to check compliancy with mandates/regulations/recommendations such as ASHRAE or NTIA 

- page 6, I would have split this category as "servers and hosts" already implement some power consumption metrics such as IPMI on servers, 

and new generation CPU offers different power state level . 
Section 2 is incomplete if we don't introduce in the scenario, services such as Demand/Response and Load Shedding which may apply to different 2.x sections 

- page 8, section 2.7 - obviously not mentioning ASHRAE recommendations (PUE/DCIE) is not acknowledging industry standards for energy monitoring 
in datacenters. 

- page 9, section 3.2 - aggregation of energy data is really what helps facility managers to understand where they could save money. 
in fact, there would be a need to discuss how aggregation can be done. It could be as simple as monitoring all physical distribution circuits 
but could also be aggregated by categories such as engineering/sales/marketing departments or heating/cooling/IT/lights,... 
To fully understand the consumption, you also need to define the "aggregation point" to consider what is counted downstream and upstream. 
For example, data retrieved on a server or router will be a portion of data retrieved on a smart plug connecting all these devices which will be a portion 
of data retrieved at a smart circuit breaker level, and so on. 

- page 11, section 3.4.2, you could also indicate: line frequency, power factor, apparent power, reactive power,... as metrics being available on certain 
category of devices. 

- page 12, section 3.4.4, you may want to compare with existing MIB such as UPS vendor's MIBs

---

From: Benoit Claise <[email-masked]>
Date: Thu, 03 Mar 2011 14:22:22 +0100

Hi Patrick,

Thanks for a lot for your review.
See inline for one particular point.
>
>     Benoit,
>
>     Please, find my comments regarding
>     draft-ietf-eman-requirements-00. I wrote them while reading the
>     doc, so there is no priority order.
>
>     Best Regards
>     Patrick
>
>
>     - page 4-5, it should be added that environmental conditions may
>     also impact the potential reduction of power consumption. There is
>     often a link between
>     temperature/RH and power...for example, see ASHRAE specifications
>     for DataCenter (PUE and DCIE metrics). It may also be noticed that
>     side effects may occur.
>     For example, I have seen people increasing the temperature in
>     their datacenter to comply with PUE metric but in fact getting fan
>     speed increase on their servers
>     and leading to false conclusion of metrics since the power
>     consumption was seen as "good" for PUE computation. Clearly, the
>     capability to monitor
>     - page 5, monitoring energy consumption can also help to check
>     compliancy with mandates/regulations/recommendations such as
>     ASHRAE or NTIA
>
>     - page 6, I would have split this category as "servers and hosts"
>     already implement some power consumption metrics such as IPMI on
>     servers,
>
>     Section 2 is incomplete if we don't introduce in the scenario,
>     services such as Demand/Response and Load Shedding which may apply
>     to different 2.x sections
>
Right, we could add them as they will _influence _the different use 
cases in

      2.1  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.1>.  Scenario 1: Routers, switches, middleboxes, and hosts  . .6  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-6>
      2.2.  Scenario 2: PoE sourcing equipment and PoE powered
            devices  . . . . . . . . . . . . . . . . . . . . . . . . .7  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-7>
      2.3  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.3>.  Scenario 3: Power probes and Smart meters  . . . . . . . .7  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-7>
      2.4  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.4>.  Scenario 4: Mid-level managers . . . . . . . . . . . . . .7  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-7>
      2.5  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.5>.  Scenario 5: Gateways to building networks  . . . . . . . .7  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-7>
      2.6  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.6>.  Scenario 6: Home energy gateways . . . . . . . . . . . . .8  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-8>
      2.7  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.7>.  Scenario 7: Data center devices  . . . . . . . . . . . . .8  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-8>
      2.8  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#section-2.8>.  Scenario 8: Battery powered devices  . . . . . . . . . . .8  <http://tools.ietf.org/html/draft-ietf-eman-requirements-00#page-8>

By influencing, I mean that the demand/response for policies in these use cases .
However, I would not list demand/response at the same level as these use cases, as the section 2 introduction explains:

    2. Scenarios and target devices

    This section describes a selection of scenarios for the application
    of energy management.  For each scenario a list of target devices is
    given in the headline, for which IETF energy management standards are
    needed.

And the EMAN WG will not be solving the demand/response problem: it will 
"just" produce one piece of the puzzle

Regards, Benoit.
>
>
>     - page 8, section 2.7 - obviously not mentioning ASHRAE
>     recommendations (PUE/DCIE) is not acknowledging industry standards
>     for energy monitoring
>     in datacenters.
>
>     - page 9, section 3.2 - aggregation of energy data is really what
>     helps facility managers to understand where they could save money.
>     in fact, there would be a need to discuss how aggregation can be
>     done. It could be as simple as monitoring all physical
>     distribution circuits
>     but could also be aggregated by categories such as
>     engineering/sales/marketing departments or
>     heating/cooling/IT/lights,...
>     To fully understand the consumption, you also need to define the
>     "aggregation point" to consider what is counted downstream and
>     upstream.
>     For example, data retrieved on a server or router will be a
>     portion of data retrieved on a smart plug connecting all these
>     devices which will be a portion
>     - page 11, section 3.4.2, you could also indicate: line frequency,
>     power factor, apparent power, reactive power,... as metrics being
>     available on certain
>     category of devices.
>