Subject: [eman] IETF EMAN request to address printers...

From: "Ebner, Fritz" <[email-masked]>
Date: Fri, 18 Mar 2011 11:11:41 -0700

Hello,

Please make sure that any power control or monitoring MIBs or drafts
that the EMAN WG produces can cover the use cases, power controls, and
power monitoring features provided in the printer working group.
Details are below:

The IEEE/ISTO Printer Working Group has published their Candidate
Standard for Power Management and the associate protocol binding for
SNMP.  Below are the links to the abstract model and MIB.

PWG 5106.4 - PWG Power Management Model for Imaging Systems 1.0:

The PWG Power Management Model for Imaging Systems 1.0 specification was

recently approved as a PWG Candidate Standard and is now available at:

 http://www.pwg.org/standards.html

and

 ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspower10-20110214-5106.4.pdf
/ doc

PWG 5106-5 - PWG Imaging System Power MIB v1.0

The PWG Imaging System Power MIB v1.0 specification was recently
approved
as a PWG Candidate Standard and is now available at:

 http://www.pwg.org/standards.html

and

ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.p
df / doc / mib
 - PDF, MS Word, and ASN.1 source in plaintext

ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5-m
ib.pdf
 - ASN.1 source in color highlighted PDF

Thanks,

Fritz Ebner

---

From: Benoit Claise <[email-masked]>
Date: Tue, 22 Mar 2011 10:42:36 +0100

Hi Fritz,

Thanks for your participation to this WG.
May I ask you a favor? Can you please provide your feedback the 
requirements draft: 
http://datatracker.ietf.org/doc/draft-ietf-eman-requirements/.
I'm wondering if this draft addresses for "your" printer issues, or if 
we need to adapt it.

Regards, Benoit.

> ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspower10-20110214-5106.4.pdf / 
> doc
>
> The PWG Imaging System Power MIB v1.0 specification was recently approved
> ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.pdf 
> / doc / mib
> ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5-mib.pdf
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 23 Mar 2011 22:15:00 +0100

Hi Fritz,

Thank you for your input.

We will consider printers and the document your referred to in the next revision of the requirements.
I don't think many changes will need to be made here.

But for the MIB documents, we now have another set of PWG power/functional states next to DMTF and ACPI states.

Thanks,

    Juergen

Am 18.03.2011 um 19:11 schrieb Ebner, Fritz:

> Hello,
> Please make sure that any power control or monitoring MIBs or drafts that the EMAN WG produces can cover the use cases, power controls, and power monitoring features provided in the printer working group.  Details are below:
>  
> The IEEE/ISTO Printer Working Group has published their Candidate Standard for Power Management and the associate protocol binding for SNMP.  Below are the links to the abstract model and MIB.
>  
>  ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspower10-20110214-5106.4.pdf / doc
>  
>  ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.pdf / doc / mib

---

From: Ira McDonald <[email-masked]>
Date: Thu, 24 Mar 2011 11:55:11 -0400

Hi Juergen,

Speaking as the author of the IEEE-ISTO PWG Power
Model (PWG 5106.4) and Power MIB (PWG 5106.5):

No, there are not a new set of states to deal with for
IETF EMAN.

The enumerated states in the PWG Power Model are
exactly the DMTF states from the DMTF CIM Power
Management Profile (DMTF DSP 1027) multiplied by
ten (see section 9.7 of PWG 5106.4), to allow our PWG
vendor extension states (that collapse to the base states
for CIM mapping).

Except that the PWG power states use more common
names (e.g., CIM Sleep-Light becomes PWG Standby
and CIM Sleep-Deep becomes PWG Suspend).

Also the normative mappings to the equivalent ACPI
states (and intermediate state transitions for resets)
are taken from the DMTF CIM Power Management
Profile.

The PWG has been an alliance partner with DMTF CIM
for some years and coherence with CIM was a primary
design requirement for our PWG Power Model.

Cheers,
- Ira (Technical Lead of PWG Power Management)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Hardcopy WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Christmas through April:
  579 Park Place  Saline, MI  48176
  734-944-0094
May to Christmas:
  PO Box 221  Grand Marais, MI 49839
  906-494-2434

On Wed, Mar 23, 2011 at 5:15 PM, Juergen Quittek <[email-masked]> wrote:

> Please make sure that any power control or monitoring MIBs or drafts that
> the EMAN WG produces can cover the use cases, power controls, and power
> monitoring features provided in the printer working group.  Details are
> below:
>
> The IEEE/ISTO Printer Working Group has published their Candidate Standard
> for Power Management and the associate protocol binding for SNMP.  Below are
> the links to the abstract model and MIB.
>