Subject: [eman] I-D Action:draft-ietf-eman-battery-mib-00.txt

From: [email-masked]
Date: Fri, 08 Apr 2011 09:45:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Energy Management Working Group of the IETF.

	Title           : Definition of Managed Objects for Battery Monitoring
	Author(s)       : J. Quittek, et al.
	Filename        : draft-ietf-eman-battery-mib-00.txt
	Pages           : 22
	Date            : 2011-04-08

This memo defines a portion of the Management Information Base (MIB)
for use with network management protocols in the Internet community.
In particular, it defines managed objects that provide information on
the status of batteries in managed devices.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-eman-battery-mib-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 8 Apr 2011 18:59:36 +0200

Dear all,

As you can see from the previous posting, we now have a WG draft on the battery MIB. 

It is a revision of draft-quittek-eman-batter-mib-00. Changes are based on comments received as four reviews on the mailing list and at our session in Prague. Please find a summary of all changes at the end of this message. 

I look forward to your comments and questions on the new version.

And I would be grateful for proposals on how to solve the remaining open issues listed in Section 8.

Changes between draft-quittek-eman-battery-mib-00
and draft-ietf-eman-battery-mib-00 are:

  - addressed relation to eman-framework
  - addressed monitoring of multiple batteries in a device
  - clarified that CMOS batteries are not explicitly in scope
  - change use of Entity MIB index from RECOMMENDED to REQUIRED
  - moved battery types from enumeration to IANA registration
      - this required some new text in new section 4 and in
        the IANA considerations
  - moved enumeration values 'unknown' and 'other' to the top
    of all enumerations
  - renamed batteryState to batteryChargingState
  - removed battery stated 'full' and 'empty'
  - mentioned that primary batteries are not re-chargeable
  - renamed batteryRemainingCapacity to batteryActualCapacity
  - fixed data types o some managed objects
  - added object batteryTemperature
  - removed object batteryCurrentChargePercentage
      - just using batteryCurrentCharge should be sufficient
  - changed object batteryLowAlarmPercentage to
    batteryLowAlarmCharge
  - changed MAX-ACCESS of all four objects with notifications
    thresholds from read-only to read-write
      - batteryLowAlarmCharge
      - batteryLowAlarmVoltage
      - batteryReplacementAlarmCapacity
      - atteryReplacementAlarmCycles
  - made implementation of batteryAlarmThresholdsGroup optional
  - fixed wrong group names in compliance statements
  - removed all old open issues except "Define Charging Cycle"
  - added new open issues
      - Writable Notification Thresholds
      - Re-arming batteryLowNotification
      - Add Charging Data of Batteries?
      - Add batteryHealth?
      - Battery Identifier

Thanks,

    Juergen

Am 08.04.2011 um 18:45 schrieb [email-masked]:

> <Mail-Anhang>_______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman