Subject: [eman] Review ODVA preso from IETF80 meeting

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 6 Apr 2011 11:37:53 -0700

Hi,

During our EMAN session at IETF80 I presented the work that the ODVA is
doing on energy management. The time was very limited but I'd think it's
very useful to see what a group of primarily electrical engineers are
doing to address the same problem we are looking at.  Given their
request for a formal liaison we should look more closely at their
information model and implementation.

Unfortunately the draft spec is not available as yet but my presentation
does have a summary. I think it would be well worth everyone's time to
take a look at it.

The presentation is here:
http://www.ietf.org/proceedings/80/slides/eman-1.pdf

More information on the ODVA is here:
http://www.odva.org

Summary of important items:

- Division of information model into electrical and non-electrical
objects
- Electrical objects models with attributes: context, power, energy,
demand and relationship information
- Need for aggregation and parent child pattern with capabilities.
- Standardization on units
- Focus on devices that may not be able to implement the entire
information model.

Would love to have a discussion on the points and merge to our
framework.

Thanks
Jp

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 7 Apr 2011 11:36:33 +0200

Hi John

I think that the work done in ODVA is very interesting and it will be great
if we could merge it to our framework!

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of John Parello (jparello)
> Sent: woensdag 6 april 2011 20:38
> To: eman mailing list
> Subject: [eman] Review ODVA preso from IETF80 meeting
> 
> Hi,
> 
> During our EMAN session at IETF80 I presented the work that 
> the ODVA is doing on energy management. The time was very 
> limited but I'd think it's very useful to see what a group of 
> primarily electrical engineers are doing to address the same 
> problem we are looking at.  Given their request for a formal 
> liaison we should look more closely at their information 
> model and implementation.
> 
> Unfortunately the draft spec is not available as yet but my 
> presentation does have a summary. I think it would be well 
> worth everyone's time to take a look at it.
> 
> - Division of information model into electrical and 
> non-electrical objects
> - Electrical objects models with attributes: context, power, 
> energy, demand and relationship information
> - Focus on devices that may not be able to implement the 
> entire information model.
> 
> Would love to have a discussion on the points and merge to 
> our framework.
> 
> Thanks
> Jp
> 
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>

---

From: Bruce Nordman <[email-masked]>
Date: Sat, 9 Apr 2011 12:54:03 -0700

John--
  Thanks much for putting together the presentation.
  I am unfamiliar with Liaison processes within the IETF, but this seems
well worth
pursuing and you, Benoit, and I should pursue that.
  Below I have listed the WG items in your slides.  I assume that in some
cases we are
already aligned with ODVA, but in other cases there are things to discuss
and/or consider
changes.  I think we could use more clarity on what the open issues are so
that we don't
lose track of them.  You might prefer that some of these should be deferred
until some sort\
of liaison is set up.
--Bruce

"Define power units in Watts with exponent."
  I am not sure if we need an exponent, but that seems possible.  W
definitely.
I don't remember hearing anyone argue for a different power unit.

"X Assumes all are electrical objects;
Contains same optional power quality values'
X No modeling of non-electrical devices"
  Seems like Wh should be our base energy unit (not kWh).
Any action items from this slide?

"Same constructs for power reporting;
Same recognition that states provide context and control."
  Any action items from this slide?  It says that power is a floating point
value.
I would have thought our energy and power values would be integers.
I agree that negative values should be allowed for some values to
account for net generation or withdrawal from storage.

"Demand object covers this as optional one value field. This approach is
clever for small devices"
  Are you proposing the 5-array odometer?  or just noting it for reference.
I had assumed a large integer counter for accumulated energy.

"Same recognition for devices that are unable to report power or energy"
(simple devices)
"Recognition of same problem with same solution for fixed devices"
(nominal/fixed energy usage)
  Any action items here?  or are we already covered?

"Congruent solution to the caliber field which rates the reading.
(This rates the devices capability of producing a reading versus the caliber
of a reading)
Same identification of Aggregator"
"Same identification of accuracy for non fixed readings."
  Agree we need accuracy metric.  Is what we have OK or is any adjustment
called for?

"Same identification of need for Aggregator and/or Proxy;
Expressed as Parent/Child"
  Any action items here?

"Same recognition of Parent/Child for Aggregation (Implemented as a sort of
URI)"
  Does this slide refer just to data aggregation, or is it assumed that
there is also
an electrical distribution topology that matches the data aggregation?

On Wed, Apr 6, 2011 at 11:37 AM, John Parello (jparello) <[email-masked]
> wrote:

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Benoit Claise <[email-masked]>
Date: Thu, 21 Apr 2011 14:20:06 +0200

Hi John,

Thanks for the presentation.
 >  Would love to have a discussion on the points and merge to our 
framework.
What would be great is a review of the EMAN requirements draft by the 
OVDA experts and also the insertion of the ODVA use cases in the 
applicability statement.
So basically, even if there is some obvious synergy, we should first 
focus on the common requirements and common use cases before merging the 
solution ;-)

Regards, Benoit.

---

From: Benoit Claise <[email-masked]>
Date: Thu, 21 Apr 2011 14:21:15 +0200

Bruce,
>   I am unfamiliar with Liaison processes within the IETF, but this 
> seems well worth
Let's follow up off line.

Regards, Benoit.