Subject: [eman] two questions to draft-claise-power-management-arch-02 draft

From: Duanxiaoling <[email-masked]>
Date: Thu, 12 May 2011 01:35:26 +0000

1,The protocol between NMS and device is SNMP, but how about other protocol, such as FTP, TL1 or Qx ?  Is these protocol prohibited  or out of eman's scope?  Now lots of SDH, MSTP devices is managed by NMS in protocol Qx or TL1. Also, lots of core network device is  managed by NMS in protocol MML, and so on.  Will our draft fit for these devices(wireless device, core network device, transfer device )?

2,The power level is defind in the draft is [0...12], how will we use it? All device must have all the power level? or different NE can select different part of them. For example, A can select [0...7], B can select [8,10,12], and so on.

How about other memeber's thought?

best regards!
email:[email-masked]
Phone number:+086-0755-13751010110
******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

---

From: Brad Schoening <[email-masked]>
Date: Thu, 12 May 2011 21:18:09 +0000

Yes, the EMAN data model uses the Simple Network Management Protocol (SNMP).  Our draft management information base (MIB) inherits data types and textual conventions from the SNMP standard.  It's not really adaptable to other protocols that don't support SNMP data types.

There is no standard data format for FTP, hence its not useful by itself as a data transfer protocol without another layer of interpretation such as an XML schema or CSV format.  As for the other protocols you mention, they seem to be domain specific, but I'm not familiar with them.

Regards,

Brad Schoening

From: [email-masked] [mailto:[email-masked]] On Behalf Of Duanxiaoling
Sent: Wednesday, May 11, 2011 9:35 PM
To: [email-masked]
Cc: eman mailing list
Subject: [eman] two questions to draft-claise-power-management-arch-02 draft

best regards!

---

From: Duanxiaoling <[email-masked]>
Date: Wed, 18 May 2011 02:03:24 +0000

Thanks for your answer!

I recognize that other protocols besides SNMP are not in our scope from your answer.

But how about the second question? Would you like to give us an answer?

Thanks!

best regards!
notes:duanxiaoling [email-masked]
Phone number:13751010110
******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

________________________________
发件人: Brad Schoening [[email-masked]]
发送时间: 2011年5月13日 5:18
到: Duanxiaoling; [email-masked]
Cc: eman mailing list
主题: RE: [eman] two questions to draft-claise-power-management-arch-02 draft

Yes, the EMAN data model uses the Simple Network Management Protocol (SNMP).  Our draft management information base (MIB) inherits data types and textual conventions from the SNMP standard.  It’s not really adaptable to other protocols that don’t support SNMP data types.

There is no standard data format for FTP, hence its not useful by itself as a data transfer protocol without another layer of interpretation such as an XML schema or CSV format.  As for the other protocols you mention, they seem to be domain specific, but I’m not familiar with them.

Regards,

Brad Schoening

best regards!

---

From: Brad Schoening <[email-masked]>
Date: Wed, 18 May 2011 02:38:21 +0000

The power levels are designed to be sparse.   So, your platform can implement those EMAN levels 1..12 which made sense for it.  Figure 6 of the EMAN Framework v-01 gives an example of this mapping to a device supporting four fictitious power states:

              Power State / Name       Manufacturer Power State / Name
               1 / Mech Off             0 / none
               2 / Soft Off             0 / none
               3 / Hibernate            0 / none
               4 / Sleep, Save-to-RAM   0 / none
               5 / Standby              0 / none
               6 / Ready                1 / short
               7 / LowMinus             1 / short
               8 / Low                  1 / short
               9 / MediumMinus          2 / tall
               10 / Medium              2 / tall
               11 / HighMinus           3 / grande
               12 / High                4 / venti

                          Figure 6: Mapping Example 3

This is similar to the DMTF and ACPI models which define many states, but devices are not required to implement them all.

Reference:

http://tools.ietf.org/html/draft-ietf-eman-framework-01

From: Duanxiaoling [mailto:[email-masked]]
Sent: Tuesday, May 17, 2011 10:03 PM
To: Brad Schoening; [email-masked]
Cc: eman mailing list
Subject: Re: [eman] two questions to draft-claise-power-management-arch-02 draft

Thanks for your answer!

Thanks!

best regards!

Regards,

Brad Schoening

best regards!

---

From: Benoit Claise <[email-masked]>
Date: Tue, 24 May 2011 10:01:47 +0200

Hi,

At our last meeting, we decided to go for multiple power states series.
Therefore, the Manufacturer Power State are not necessary any longer.
This has been reflected in the latest version of the MIB (still an 
individual draft), i.e. draft-claise-energy-monitoring-mib-08

Regards, Benoit.
>
> The "Manufacturer Power State" described at the device, however, is it 
> necessary to map that to "12 levels state"?
>
> If there is a "short" state, what is the precise "power state(12 
> levle)"? Either 7 or 8 will be OK?
>
>
> 在2011-05-18 10:38:21，"Brad Schoening" <[email-masked]> 写道：
>
>     The power levels are designed to be sparse. So, your platform can
>     implement those EMAN levels 1..12 which made sense for it. Figure
>     6 of the EMAN Framework v-01 gives an example of this mapping to a
>     device supporting four fictitious power states:
>
>     This is similar to the DMTF and ACPI models which define many
>     states, but devices are not required to implement them all.
>
>     Reference:
>
>     *From:*Duanxiaoling [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     *Sent:* Tuesday, May 17, 2011 10:03 PM
>     *To:* Brad Schoening; [email-masked] <mailto:[email-masked]>
>     *Cc:* eman mailing list
>     *Subject:* Re: [eman] two questions to
>     draft-claise-power-management-arch-02 draft
>
>     Thanks for your answer!
>
>     <mailto:[email-masked]>
>     Phone number:13751010110
>     This email and its attachments contain confidential information
>     from HUAWEI, which is intended only for the person or entity whose
>     address is listed above. Any use of the information contained
>     herein in any way (including, but not limited to, total or partial
>     disclosure, reproduction, or dissemination) by persons other than
>     the intended recipient(s) is prohibited. If you receive this
>     e-mail in error, please notify the sender by phone or email
>     immediately and delete it!
>     ------------------------------------------------------------------------
>
>     *发件人**:*Brad Schoening [[email-masked]
>     <mailto:[email-masked]>]
>     *发送时间**:*2011年5月13日5:18
>     *到**:*Duanxiaoling; [email-masked] <mailto:[email-masked]>
>     *Cc:* eman mailing list
>     *主题**:*RE: [eman] two questions to
>     draft-claise-power-management-arch-02 draft
>
>     Yes, the EMAN data model uses the Simple Network Management
>     Protocol (SNMP). Our draft management information base (MIB)
>     inherits data types and textual conventions from the SNMP
>     standard. It’s not really adaptable to other protocols that don’t
>     support SNMP data types.
>
>     There is no standard data format for FTP, hence its not useful by
>     itself as a data transfer protocol without another layer of
>     interpretation such as an XML schema or CSV format. As for the
>     other protocols you mention, they seem to be domain specific, but
>     I’m not familiar with them.
>
>     Regards,
>
>     Brad Schoening
>
>     *From:[email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>] *On
>     Behalf Of *Duanxiaoling
>     *Sent:* Wednesday, May 11, 2011 9:35 PM
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Cc:* eman mailing list
>     *Subject:* [eman] two questions to
>     draft-claise-power-management-arch-02 draft
>
>     1,The protocol between NMS and device is SNMP, but how about other
>     protocol, such as FTP, TL1 or Qx ? Is these protocol prohibited or
>     out of eman's scope? Now lots of SDH, MSTP devices is managed by
>     NMS in protocol Qx or TL1. Also, lots of core network device is
>     managed by NMS in protocol MML, and so on. Will our draft fit for
>     these devices(wireless device, core network device, transfer device )?
>
>     2,The power level is defind in the draft is [0...12], how will we
>     use it? All device must have all the power level? or different NE
>     can select different part of them. For example, A can select
>     [0...7], B can select [8,10,12], and so on.
>
>     email:[email-masked] <mailto:[email-masked]>
>
>     This email and its attachments contain confidential information
>     from HUAWEI, which is intended only for the person or entity whose
>     address is listed above. Any use of the information contained
>     herein in any way (including, but not limited to, total or partial
>     disclosure, reproduction, or dissemination) by persons other than
>     the intended recipient(s) is prohibited. If you receive this
>     e-mail in error, please notify the sender by phone or email
>     immediately and delete it!

---

From: Benoit Claise <[email-masked]>
Date: Tue, 24 May 2011 09:59:47 +0200

Hi,

Please comment on the official EMAN document, i.e.
http://tools.ietf.org/html/draft-ietf-eman-framework-01
draft-claise-power-management-arch-02 draft is old.
Let me addresse your questions below
> protocol, such as FTP, TL1 or Qx ? Is these protocol prohibited or out
> of eman's scope? Now lots of SDH, MSTP devices is managed by NMS in
> protocol Qx or TL1. Also, lots of core network device is managed by
> NMS in protocol MML, and so on. Will our draft fit for these
> devices(wireless device, core network device, transfer device )?
>
The decision for the WG was to create MIB modules, to be used with SNMP.
However, if we do our job right in terms of information modelling,
multiple data models could be deduced from it.
Reference: RFC3444
>
> 2,The power level is defind in the draft is [0...12], how will we use
> it? All device must have all the power level? or different NE can
> select different part of them. For example, A can select [0...7], B
> can select [8,10,12], and so on.
>
Yes, EMAN doesn't impose that you support all power states.

Regards, Benoit
> This email and its attachments contain confidential information from
> HUAWEI, which is intended only for the person or entity whose address
> is listed above. Any use of the information contained herein in any
> way (including, but not limited to, total or partial disclosure,
> reproduction, or dissemination) by persons other than the intended
> recipient(s) is prohibited. If you receive this e-mail in error,
> please notify the sender by phone or email immediately and delete it!