Subject: [eman] Charge Cycle Definition

From: Steven Chew <[email-masked]>
Date: Tue, 28 Jun 2011 12:05:27 -0700

I would like to comment about "8.1.  Define Charging Cycle" in draft-ietf-eman-battery-mib-01.txt.

I think it is good to keep definition in line with that of Apple's, as given in the MIB document. Counting the number of times the discharged energy equal to the battery's capacity is commonly how battery manufacturers count charge cycles. I refer to the Smart Battery Data Specification Revision 1.10.

5.1.22. CycleCount() (0x17)
Description:
Returns the number of cycles the battery has experienced. A cycle is defined as:
An amount of discharge approximately equal to the value of DesignCapacity.
Purpose:
The CycleCount() function provides a means to determine their battery's wear. It may be used to give
advanced warning that the battery is nearing its end of life. The CycleCount returned value multiplied by
the DesignCapacity value can give an approximate "odometer" reading for the total capacity delivered by
the Smart Battery.
SMBus Protocol: Read Word
Output: unsigned int -- count of charge/discharge cycles the battery has experienced
Units: cycle
Range: 0 to 65,534 cycles
65,535 indicates battery has experienced 65,535 or more
cycles.
Granularity: 1 cycle
Accuracy: absolute count

This is a quantity already tracked and supplied by Smart Batteries. It would make sense for this MIB to align with this definition.

Regards,
Steven.

---

From: Rolf Winter <[email-masked]>
Date: Tue, 28 Jun 2011 20:17:57 +0000

Hi Steven,

great input. Thanks a lot. Are you aware of any other definition in use?

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Steven Chew
> Sent: Dienstag, 28. Juni 2011 21:05
> To: [email-masked]
> Subject: [eman] Charge Cycle Definition
> 
> I think it is good to keep definition in line with that of Apple's, as
> given in the MIB document. Counting the number of times the discharged
> energy equal to the battery's capacity is commonly how battery
> manufacturers count charge cycles. I refer to the Smart Battery Data
> Specification Revision 1.10.
> 
> 
> 
> This is a quantity already tracked and supplied by Smart Batteries. It
> would make sense for this MIB to align with this definition.
> 
> 
> 
> Regards,
> 
> Steven.

---

From: Steven Chew <[email-masked]>
Date: Tue, 28 Jun 2011 14:56:36 -0700

I work in the battery industry. This is the only definition of which I am aware. I know it is not possible for the end user to keep track of fractional charges and discharges, but this is why smart batteries do this accounting automatously.

-----Original Message-----
From: Rolf Winter [mailto:[email-masked]] 
Sent: Tuesday, June 28, 2011 4:18 PM
To: Steven Chew; [email-masked]
Subject: RE: Charge Cycle Definition

Hi Steven,

Best,

Rolf

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Steven Chew

---

From: Rolf Winter <[email-masked]>
Date: Wed, 29 Jun 2011 06:54:18 +0000

Steven,

again, thanks for the valuable input. Is there anything you think is missing in the current MIB module definition that you think should be added? Any opinion about any of the open issues?

Best,

Rolf

> From: Steven Chew [mailto:[email-masked]]
> Sent: Dienstag, 28. Juni 2011 23:57
> To: Rolf Winter; [email-masked]
> I work in the battery industry. This is the only definition of which I
> am aware. I know it is not possible for the end user to keep track of
> fractional charges and discharges, but this is why smart batteries do
> this accounting automatously.
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> 
>