Subject: Re: [eman] Outlet Gang addition to draft-ietf-eman-requirements-00

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 27 Jul 2011 11:08:52 -0700

Hi Chris, and list...

Following up on this wrt to the new framework draft and recent activity
on the list. We've added a set of relationships like metering, powered
by.

Do you think it would be good to add a relationship like 'ganged' to map
managed elements to the same gang?

The relationship methphor is quite simple and if we cal this out it
could model what you have in mind.

Jp

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Friday, March 04, 2011 11:02 AM
To: [email-masked]
Subject: [eman] Outlet Gang addition to draft-ietf-eman-requirements-00

Hi Juergen,

I wrote an additon to the various scenarios described in
draft-ietf-eman-requirements-00 to address the "Outlet Gang" scenario
found on Smart PDUs.  Please let me know if you have any questions while
integrating it.

$ diff draft-ietf-eman-requirements-00.txt
draft-ietf-eman-requirements-01.txt
416a417,449
> 2.9.  Scenario 9: Ganged outlets on a Smart Power Strip
>
>    Some PDUs allow physical entities like outlets to be "ganged"
together as a
>    logical entity for simplified management purposes.  This is
particularly
>    useful for servers with multiple power supplies, where each power
supply is
>    connected to a different physical outlet.  Other implementations
allow
>    "gangs" to be created based on common ownership of outlets, such as
>    business units or load shed priority or other non-physical
relationships.
>
>    Current implementations allow for an "M-to-N" mapping between
outlet
>    "gangs" and physical outlets.  An example of this mapping includes
the
>    following:
>
>       Outlet 1             (physical entity)
>       Outlet 2             (physical entity)
>       Outlet 3             (physical entity)
>       Outlet 4             (physical entity)
>       Outlet Gang A        (virtual entity)
>       Outlet Gang B        (virtual entity)
>
>       Gang A -> Outlets 1, 2 and 3
>       Gang B -> Outlets 3 and 4
>
>    Note the allowed overlap on Outlet 3, where Outlet 3 belongs to
both
>    "gangs."
>
>    Each "Outlet Gang" entity reports the aggregated data from the
individual
>    outlet entities that comprise it and enables a single point of
control for
>    all the individual outlet entities.  For example, turning "Outlet
Gang A"
>    to the "off" state would turn outlets 1, 2, and 3 "off" in some
>    implementations.  (The impact of this action on "Outlet Gang B" is
to be
>    defined by the equipment manufacturer.)
>

Thanks,
Chris

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 27 Jul 2011 14:13:51 -0400

Dear all,

Would we have a requirement for output gangs to be added to the requirements draft?

Thanks,

    Juergen

Am 27.07.2011 um 14:08 schrieb John Parello (jparello):

> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Benoit Claise <[email-masked]>
Date: Thu, 28 Jul 2011 00:39:12 -0400

> Would we have a requirement for output gangs to be added to the requirements draft?
Actually, I thought we had this already but, after checking, it's not in 
the latest version...
After some investigation, I found it back in the version 01, 
http://tools.ietf.org/html/draft-ietf-eman-requirements-01

2.9  <http://tools.ietf.org/html/draft-ietf-eman-requirements-01#section-2.9>.  Scenario 9: Ganged outlets on a smart power strip  . . . .9  <http://tools.ietf.org/html/draft-ietf-eman-requirements-01#page-9>  

But this scenario moved to the 
http://tools.ietf.org/html/draft-tychon-eman-applicability-statement-02#section-2.8

To make a long story short, I believe we should clearly mention it in 
[EMAN-REQ], covering the request from PDU vendors on the list.

Regards, Benoit.

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 28 Jul 2011 08:47:20 -0400

I agree.

Can please somebody who was involved in the discussion about outlet gangs come up with a text proposal for this missing requirement?

Thanks,

    Juergen

Am 28.07.2011 um 00:39 schrieb Benoit Claise:

> Actually, I thought we had this already but, after checking, it's not in the latest version...
> After some investigation, I found it back in the version 01, http://tools.ietf.org/html/draft-ietf-eman-requirements-01
> 2.9.  Scenario 9: Ganged outlets on a smart power strip  . . . .  9 
> But this scenario moved to the http://tools.ietf.org/html/draft-tychon-eman-applicability-statement-02#section-2.8
> 
> To make a long story short, I believe we should clearly mention it in [EMAN-REQ], covering the request from PDU vendors on the list.
> 
> Regards, Benoit.
>> 
>> Thanks,
>> 
>>     Juergen
>> 
>>