Subject: Re: [eman] IETF EMAN request to address printers... -> draft-ietf-eman-requirements-04

From: Benoit Claise <[email-masked]>
Date: Sun, 24 Jul 2011 16:20:23 -0400

Juergen,

Reading this old email, I believe that we should mention "printer" 
somewhere in the requirements draft, as a device type addressed by the 
EMAN WG, and not only in the appendix.

Regards, Benoit.
> Hi Fritz,
>
> Thank you for your input.
>
> We will consider printers and the document your referred to in the 
> next revision of the requirements.
> I don't think many changes will need to be made here.
>
> But for the MIB documents, we now have another set of PWG 
> power/functional states next to DMTF and ACPI states.
>
> Thanks,
>
>     Juergen
>
>
> Am 18.03.2011 um 19:11 schrieb Ebner, Fritz:
>
>> Hello,
>> Please make sure that any power control or monitoring MIBs or drafts 
>> that the EMAN WG produces can cover the use cases, power controls, 
>> and power monitoring features provided in the printer working group.  
>> Details are below:
>> The IEEE/ISTO Printer Working Group has published their Candidate 
>> Standard for Power Management and the associate protocol binding for 
>> SNMP.  Below are the links to the abstract model and MIB.
>> PWG 5106.4 - PWG Power Management Model for Imaging Systems 1.0:
>> The PWG Power Management Model for Imaging Systems 1.0 specification was
>> recently approved as a PWGCandidateStandardand is now available at:
>>
>> http://www.pwg.org/standards.html
>>
>> and
>>
>> ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspower10-20110214-5106.4.pdf/ 
>> doc
>> PWG 5106-5 - PWG Imaging System Power MIB v1.0
>> The PWG Imaging System Power MIB v1.0 specification was recently approved
>> as a PWGCandidateStandardand is now available at:
>>
>> http://www.pwg.org/standards.html
>>
>> and
>>
>> ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.pdf/ 
>> doc / mib
>>  - PDF, MS Word, and ASN.1 source in plaintext
>>
>> ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5-mib.pdf
>>  - ASN.1 source in color highlighted PDF
>> Thanks,
>> Fritz Ebner
>> _______________________________________________
>> eman mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/eman
>
>
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 25 Jul 2011 00:26:23 -0400

Hi Benoit,

Currently, there is the following paragraph in section 1 of draft-ietf-eman-requirements-04:

>   The main subject of energy management are powered entities that
>   consume electric energy.  Powered entities include devices that have
>   an IP address and can be addressed directly, such as hosts, routers,
>   and middleboxes, as well as devices indirectly connected to an IP
>   network, for which a proxy with an IP address provides a management
>   interface, for example, devices in a building management
>   infrastructure using BACNET or MODBUS protocols.

You see that we already address all kinds of IP devices: hosts, routers, and middleboxes.
There is no list of special hosts, such as servers, PCs, smart phones, printers, webcams, etc. 
I do not see a need to introduce it. Since a printer is a device that can either be directly addressed with IP or that can be addressed via a host connected to it, I see no need to add a special comment on it, particularly not since I do not see any special requirements for a printer compared to other hosts.

Rather I see a need in the framework draft to discuss if and how alignment with the IEEE ISTO-PWG is realized.

Thanks,

    Juergen

Am 24.07.2011 um 16:20 schrieb Benoit Claise:

> Juergen,
> 
> Reading this old email, I believe that we should mention "printer" somewhere in the requirements draft, as a device type addressed by the EMAN WG, and not only in the appendix.
> 
> Regards, Benoit.
>> Hi Fritz,
>> 
>> We will consider printers and the document your referred to in the next revision of the requirements.
>> But for the MIB documents, we now have another set of PWG power/functional states next to DMTF and ACPI states.
>> 
>> Thanks,
>> 
>>     Juergen
>> 
>> 
>>> Please make sure that any power control or monitoring MIBs or drafts that the EMAN WG produces can cover the use cases, power controls, and power monitoring features provided in the printer working group.  Details are below:
>>>  
>>> The IEEE/ISTO Printer Working Group has published their Candidate Standard for Power Management and the associate protocol binding for SNMP.  Below are the links to the abstract model and MIB.
>>>  
>>> recently approved as a PWG Candidate Standard and is now available at:
>>> 
>>>  ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspower10-20110214-5106.4.pdf / doc
>>>  
>>> as a PWG Candidate Standard and is now available at:
>>> 
>>>  ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.pdf / doc / mib

---

From: Benoit Claise <[email-masked]>
Date: Mon, 25 Jul 2011 00:55:35 -0400

Hi Juergen,

So why is there an "IEEE-ISTO Printer WG" appendix if printers are not 
mentioned a single time in the document?

Regards, Benoit.
> I do not see a need to introduce it. Since a printer is a device that 
> can either be directly addressed with IP or that can be addressed via 
> a host connected to it, I see no need to add a special comment on it, 
> particularly not since I do not see any special requirements for a 
> printer compared to other hosts.
>
> Rather I see a need in the framework draft to discuss if and how 
> alignment with the IEEE ISTO-PWG is realized.
>
> Thanks,
>
>     Juergen
>
>
>> somewhere in the requirements draft, as a device type addressed by 
>> the EMAN WG, and not only in the appendix.
>>
>> Regards, Benoit.
>>> Hi Fritz,
>>>
>>>> Please make sure that any power control or monitoring MIBs or 
>>>> drafts that the EMAN WG produces can cover the use cases, power 
>>>> controls, and power monitoring features provided in the printer 
>>>> working group.  Details are below:
>>>> Standard for Power Management and the associate protocol binding 
>>>> for SNMP.  Below are the links to the abstract model and MIB.

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 25 Jul 2011 01:31:18 -0400

Hi Benoit,

I think the entire Appendix can go away. 
It does not contribute at all to the requirements. At least not so far.

Analyzing what standard is available to meet a requirement 
is rather the task of a solution draft, such as the framework 
or the MIB modules, but not of a requirement draft.

My proposal would be moving the standards analysis to the framework
and discuss there also 
  - which of these standards are used for covering requirements, for example, 
    Entity MIB for identification (if we do so)
  - which parts of these standards are supported, such as, for example,
    ACPI and DMTF power sets
  - to which standards our work is aligned, for example 
    ODVA, IEEE-ISTO PWD, SBS, etc. and how we do so.
  - from which standards we deviate

Thanks,

    Juergen

Am 25.07.2011 um 00:55 schrieb Benoit Claise:

> Hi Juergen,
> 
> So why is there an "IEEE-ISTO Printer WG" appendix if printers are not mentioned a single time in the document?
> 
> Regards, Benoit.
>> 
>> Hi Benoit,
>>

---

From: "William Wagner" <[email-masked]>
Date: Mon, 25 Jul 2011 12:23:41 -0400

Gentlemen,

As chairman of the IEEE-ISTO PWG workgroup that produced the  PWG Power
Management Model for Imaging Systems and the associated MIB
(ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.mib)
, I must say that the "printer" industry has been following the  'eman'
activites with interest and perhaps some apprehension. Although we  intend
to be compliant with industry standards, and anticipate our customers to
require that, we believe that the PWG Power Management Model best addresses
the unique power characteristics of hardcopy imaging equipment.  We realize
that all suppliers tend to regard their products as unique; but it must be
recognized that "printers" , particularly in the enterprise, have long
ceased to be little peripheral devices. They are now reasonably called
Multifunction Devices; perform copy, scan and facsimile functions as well as
printing; and have significant computing, storage and communication
components as well as electromechanical and often thermal processing
components. The power characteristics of these components and the somewhat
different duty cycle requirements compared with other networked devices
predicate the need for some special management elements, and we have spent
significant time and effort agreeing on these. 

The emergence of a separate IETF energy standard (or set of standards) that
does not recognize the existence of a power standard developed by and custom
to a particular industry would create confusion and act contrary to ensuring
interoperability. We would hope that in the 'eman' documentation, the PWG
Imaging Systems Power Management MIB is referenced and considered with
respect to applicability, coverage, and compatibility with 'eman'
objectives, so that users see that the eman and PWG products can complement
rather than substitute for each other. 

Thank you,

Bill Wagner, Chair WIMS/PWG

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Juergen Quittek
Sent: Monday, July 25, 2011 1:31 AM
To: Benoit Claise
Cc: [email-masked]; Ebner, Fritz
Subject: Re: [eman] IETF EMAN request to address printers... ->
draft-ietf-eman-requirements-04

Hi Benoit,

and discuss there also 

  - which of these standards are used for covering requirements, for
example, 

    ACPI and DMTF power sets

Thanks,

    Juergen

Hi Juergen,

Regards, Benoit. 

Hi Benoit,

Currently, there is the following paragraph in section 1 of

>   infrastructure using BACNET or MODBUS protocols.

You see that we already address all kinds of IP devices: hosts, routers, and
middleboxes.

There is no list of special hosts, such as servers, PCs, smart phones,
printers, webcams, etc. 

I do not see a need to introduce it. Since a printer is a device that can
either be directly addressed with IP or that can be addressed via a host
connected to it, I see no need to add a special comment on it, particularly
not since I do not see any special requirements for a printer compared to
other hosts.

Rather I see a need in the framework draft to discuss if and how alignment
with the IEEE ISTO-PWG is realized.

Thanks,

    Juergen

Juergen,

Reading this old email, I believe that we should mention "printer" somewhere
in the requirements draft, as a device type addressed by the EMAN WG, and
not only in the appendix.

Regards, Benoit.

Hi Fritz, 

We will consider printers and the document your referred to in the next
revision of the requirements.

But for the MIB documents, we now have another set of PWG power/functional
states next to DMTF and ACPI states.

Thanks,

    Juergen

Hello,

Please make sure that any power control or monitoring MIBs or drafts that
the EMAN WG produces can cover the use cases, power controls, and power
monitoring features provided in the printer working group.  Details are
below:

The IEEE/ISTO Printer Working Group has published their Candidate Standard
for Power Management and the associate protocol binding for SNMP.  Below are
the links to the abstract model and MIB.

and

 ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspower10-20110214-5106.4.pdf /
doc

and

 ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.pdf
/ doc / mib
 - PDF, MS Word, and ASN.1 source in plaintext

ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5-mib.p
df
 - ASN.1 source in color highlighted PDF

Thanks,

Fritz Ebner

---

From: Benoit Claise <[email-masked]>
Date: Mon, 25 Jul 2011 21:53:00 -0400

Hi Bill,

Thanks for your feedback.
See inline.
>
> Gentlemen,
>
> As chairman of the IEEE-ISTO PWG workgroup that produced the  PWG 
> Power Management Model for Imaging Systems and the associated MIB 
> (ftp://ftp.pwg.org/pub/pwg/candidates/cs-wimspowermib10-20110214-5106.5.mib), 
> I must say that the "printer" industry has been following the  'eman' 
> activites with interest and perhaps some apprehension. Although we 
>  intend to be compliant with industry standards, and anticipate our 
> customers to require that, we believe that the PWG Power Management 
> Model best addresses the unique power characteristics of hardcopy 
> imaging equipment.  We realize that all suppliers tend to regard their 
> products as unique; but it must be recognized that "printers" , 
> particularly in the enterprise, have long ceased to be little 
> peripheral devices. They are now reasonably called Multifunction 
> Devices; perform copy, scan and facsimile functions as well as 
> components. The power characteristics of these components and the 
> somewhat different duty cycle requirements compared with other 
> networked devices predicate the need for some special management 
> elements, and we have spent significant time and effort agreeing on 
> these.
>
> The emergence of a separate IETF energy standard (or set of standards) 
> that does not recognize the existence of a power standard developed by 
> and custom to a particular industry would create confusion and act 
> contrary to ensuring interoperability.
>
The consensus so far is that multiple power state sets would be 
supported by the EMAN framework. Obviously a device doesn't have to 
support all them.
Note that, to be compliant with the IETF, an IANA registration of the 
power state series will be required... but we're not at that stage yet.

Regards, Benoit, EMAN co-chair.

> We would hope that in the 'eman' documentation, the PWG Imaging 
> Systems Power Management MIB is referenced and considered with respect 
> to applicability, coverage, and compatibility with 'eman' objectives, 
> so that users see that the eman and PWG products can complement rather 
> than substitute for each other.
>
> Thank you,
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Juergen Quittek
> *Sent:* Monday, July 25, 2011 1:31 AM
> *To:* Benoit Claise
> *Cc:* [email-masked]; Ebner, Fritz
> *Subject:* Re: [eman] IETF EMAN request to address printers... -> 
> that the EMAN WG produces can cover the use cases, power controls, and 
> power monitoring features provided in the printer working group.  
> Details are below:
>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 25 Jul 2011 21:49:08 -0400

Hi Juergen,

Keep in mind that we need a place to describe why what exists today is 
not good enough for our requirements
For example, the ENTITY-SENSOR MIB.
I believe the right place is the requirement draft.

Regards, Benoit.
>> So why is there an "IEEE-ISTO Printer WG" appendix if printers are 
>> not mentioned a single time in the document?
>>
>> Regards, Benoit.
>>> Hi Benoit,
>>>
>>> I do not see a need to introduce it. Since a printer is a device 
>>> that can either be directly addressed with IP or that can be 
>>> addressed via a host connected to it, I see no need to add a special 
>>> comment on it, particularly not since I do not see any special 
>>> requirements for a printer compared to other hosts.
>>>

---

From: Juergen Quittek <[email-masked]>
Date: Tue, 26 Jul 2011 11:59:57 -0400

Hi Benoit,

That is a question of the scope of the requirements draft.

Definitely the requirements draft should state requirements.

But should it also discuss how to meet them?
That's typically the task of a solution/framework/architecture draft.

If we have a requirement to use another standards it should be in the requirements draft
If we have a requirement NOT to use another standard, it should be in as well.
But so far we have not stated any requirement on other standards.

    Juergen

Am 25.07.2011 um 21:49 schrieb Benoit Claise:

> Hi Juergen,
> 
> Keep in mind that we need a place to describe why what exists today is not good enough for our requirements