Subject: [eman] [EMAN-BATTERY]: power state set

From: Benoit Claise <[email-masked]>
Date: Wed, 27 Jul 2011 23:22:45 -0400

Dear all,

A quick review of the battery-mib leads me to this observation

    batteryChargingState OBJECT-TYPE
        SYNTAX      INTEGER {
                        unknown(1),
                        charging(2),
                        maintainingCharge(3),
                        noCharging(4),
                        discharging(5)
                    }

This is power state set, right? Ok, battery specific, but a power state 
set anyway, right?
Since we will have three power state sets in IANA (IEEE1621, DMTF, and 
EMAN), why not register this one in IANA? Maybe in the future, we might 
need an extra battery state.

Next question: is this power state set comparable to the existing power 
state set?
I mean, should a powered device (in the case a battery) advertise that 
it support the battery charging state power state set?
This would have the advantage that a NMS would discover powered devices, 
components, and batteries exactly the same way.

Regards, Benoit.

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 27 Jul 2011 20:32:31 -0700

That would be good. That solves and issue we discussed in Prague about a
device that has a battery but does not want to expose it as a component
or part. Like a tablet with non removable battery.

The device could simply support the power state series at the same time.

Nice

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Benoit Claise (bclaise)
Sent: Wednesday, July 27, 2011 8:23 PM
To: eman mailing list
Subject: [eman] [EMAN-BATTERY]: power state set

Dear all,

Regards, Benoit.

_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: Benoit Claise <[email-masked]>
Date: Wed, 27 Jul 2011 23:37:17 -0400

Yes, and the UUID is the only thing that is important.
So an UUID whatever the powered device (or whatever the right term is): 
a device, a port, a component, a battery, or something.

Regards, Benoit (as a contributor)

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 28 Jul 2011 08:42:54 -0400

Hi Benoit,

I like the idea. 

However, before fully committing to it I would like to think more about the following:

pro: It IS a power state because it describes the power-relevant behavior/state of the battery.

con: It is NOT a power state, because it dies not yet cover something like an "off" state.
Maybe we can solve this by adding non-operational states to the current list of battery states.
Also we may have to rename it. Because then it is not just a charging state anymore.

Thanks,

    Juergen

Am 27.07.2011 um 23:22 schrieb Benoit Claise:

> This is power state set, right? Ok, battery specific, but a power state set anyway, right?
> Since we will have three power state sets in IANA (IEEE1621, DMTF, and EMAN), why not register this one in IANA? Maybe in the future, we might need an extra battery state.
> 
> Next question: is this power state set comparable to the existing power state set?
> I mean, should a powered device (in the case a battery) advertise that it support the battery charging state power state set?
> This would have the advantage that a NMS would discover powered devices, components, and batteries exactly the same way.
> 
> Regards, Benoit.
>

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 28 Jul 2011 08:46:15 -0400

Hi John,

> The device could simply support the power state series at the same time.

I disagree.

I don't think that this is in line with the idea of supporting multiple power states.

If a device supports multiple power state series, they must carry the same 
of at least equivalent semantics. Otherwise you would have to read all series
in order to understand the device's state.

Thanks,

    Juergen

---

From: Rolf Winter <[email-masked]>
Date: Thu, 28 Jul 2011 13:07:35 +0000

+1 

The problem is that the power states of a "regular" device conflate operational state information and energy related state information. The battery charging state does not I in the same way. So the tablet can be on/sleeping and off but charging in all these states. So that will be a little inconsistent. I think calling this a power state for a battery is in principle OK, but I's like to think about it a little longer.

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> Juergen Quittek
> Sent: Donnerstag, 28. Juli 2011 14:46
> To: John Parello (jparello)
> Cc: eman mailing list
> Subject: Re: [eman] [EMAN-BATTERY]: power state set
> 
> Hi John,
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 28 Jul 2011 11:34:44 -0400

Rolf,
> +1
>
> The problem is that the power states of a "regular" device conflate operational state information and energy related state information. The battery charging state does not I in the same way.
This is actually my question.
Is the battery power state set orthogonal to the other 3 power state sets?

Regards, Benoit.

> So the tablet can be on/sleeping and off but charging in all these states. So that will be a little inconsistent. I think calling this a power state for a battery is in principle OK, but I's like to think about it a little longer.
>
> Best,
>
>
> Rolf
>
>

---

From: Bruce Nordman <[email-masked]>
Date: Thu, 28 Jul 2011 12:12:48 -0400

On Thu, Jul 28, 2011 at 11:34 AM, Benoit Claise <[email-masked]> wrote:

> Rolf,
>
>  +1
>>
>> The problem is that the power states of a "regular" device conflate
>> operational state information and energy related state information. The
>> battery charging state does not I in the same way.
>>

A power state is (in principle) something independent of the device (or
component) type.
It is universal.

The battery state is specific to a single type of component

I can imagine setting a power state for a battery to "off": to electrically
disconnect it to prevent charging or discharging (this might be done
prior to removal for example).  In this case, a battery would want both
a power state and a charging state (the power state variable would be
in the other MIB so not added to the Battery MIB).

If new battery states might be needed, how about simply having a registry
of the current states so that individual states could be added, rather than
entire new series as we have with power states.  This would give flexibility
to add in future with minimal complexity, and not conflate with power
states.

--Bruce

> ...
-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 28 Jul 2011 09:28:47 -0700

OK but thinking about it. I'm not sure the battery state is independent of the device in all cases.

Tablet example. We refer to them as on, off, charging, etc. We don't say the device is on and the battery is off. It's merged.

So while I agree they can be separate we have to allow for the case when they are combined as well.

Jp

-----Original Message-----
From: [email-masked] on behalf of Bruce Nordman
Sent: Thu 7/28/2011 9:12 AM
To: Benoit Claise (bclaise)
Cc: eman mailing list
Subject: Re: [eman] [EMAN-BATTERY]: power state set

--Bruce

---

From: Rolf Winter <[email-masked]>
Date: Thu, 28 Jul 2011 16:50:13 +0000

I think these states are completely independent. Take the three power states on, sleep, off and the charging states charging, discharging, maintaining charge. Which ones are dependent on each other? I think any of these combinations work. Answering Benoit's question, I believe these are orthogonal.

> John Parello (jparello)
> Sent: Donnerstag, 28. Juli 2011 18:29
> To: Bruce Nordman; Benoit Claise (bclaise)
> Cc: eman mailing list
> Tablet example. We refer to them as on, off, charging, etc. We don't
> say the device is on and the battery is off. It's merged.
> 
> >> operational state information and energy related state information.
> >> The battery charging state does not I in the same way.
> >>
> I can imagine setting a power state for a battery to "off": to
> electrically disconnect it to prevent charging or discharging (this
> might be done prior to removal for example).  In this case, a battery
> would want both a power state and a charging state (the power state
> variable would be in the other MIB so not added to the Battery MIB).
> 
> If new battery states might be needed, how about simply having a
> registry of the current states so that individual states could be added,
> rather than entire new series as we have with power states.  This would
> give flexibility to add in future with minimal complexity, and not
> conflate with power states.
> 
> --Bruce
> 
> >
> > Regards, Benoit.
> >
> > ...
> >
> --
> *Bruce Nordman*

---

From: "Mielke, William F (Bill)" <[email-masked]>
Date: Thu, 28 Jul 2011 12:12:47 -0500

+1  I believe that the two sets of states are orthogonal.

When people talk about a device charging they are simply being imprecise and conflating the two.  It is an artifact of informal speech.

William F. Mielke
Alcatel-Lucent
Distinguished Member of Technical Staff
6200 East Broad Street
Room: 4B01-1V
Columbus, OH  43213-1530
Email: [email-masked]
Phone: 614 367 5628
Fax: 614 367 5965

"Live like you're going to die tomorrow.
 Learn like you're going to live forever."

    - Albert Einstein

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Rolf Winter
> Sent: Thursday, July 28, 2011 12:50 PM
> To: John Parello (jparello); Bruce Nordman; Benoit Claise (bclaise)
> Cc: eman mailing list
> I think these states are completely independent. Take the 
> three power states on, sleep, off and the charging states 
> charging, discharging, maintaining charge. Which ones are 
> dependent on each other? I think any of these combinations 
> work. Answering Benoit's question, I believe these are orthogonal.
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria 
> Road, London W3 6BL | Registered in England 2832014 
> 
> 
> > OK but thinking about it. I'm not sure the battery state is 
> independent
> > of the device in all cases.
> > 
> > > Is the battery power state set orthogonal to the other 3 
> power state
> > sets?
> > >
> >