Subject: [eman] terminology Energy Managed Object versus Powered Device

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 27 Jul 2011 11:59:55 -0700

Hi,

I saw a few threads where we discussed this and I want to pull it to its
own thread.

In the framework I referred to an Energy Managed Object. I got some
feedback and in the alternate ref draft Theresa notion of powered
device.

I like the concept of having a device and power interface similar to the
communication notion of device and interface.

When managing these element however we typically use the term managed
object. That boils down to something you give a unique identifier to and
then manage. This can be interfaces, virtual interfaces, devices,
motherboards etc.

I'd like to use that same notion here with an generic Energy Managed
Object. That was we can model and uniquely identify logical objects
(outlets, inlets, interfaces, etc) as well as physical.

So I think EMO is a better term.

Thoughts?
Jp

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 27 Jul 2011 15:53:31 -0400

The current definition of an EMO begins:

An Energy Managed Object (EMO) is a device that is part of or
        attached to a communications network...

So, I took that to mean an integral device, like a computer, switch, router,
etc. that
has a power cord and network interfaces.  I use "device" to refer to this
concept.
I know that EMAN Is to report on either entire devices, or components of
devices,
and "entity" can be used to reference the combination of devices and
components
in line with the Entity MIB name.  A Power Interface is also a type of
entity, since
it is a component and there is measurement and control for that just as with
any
other component.

*So, regardless of what terms are used, we need terms that are synonyms for
powered device, component, entity, and power interface.*
An assumption I am making is that an entire device has some characteristics
(important ones reflected in the MIB structure) different from a component.

I think it is very easy for people to accidentally misinterpret what EMO is
referring to - a device, a component, an entity, or even a software object.
I also prefer shorter terms.

A cross-cutting question would seem to be whether things are named based
on what they are, or by what is being done to them.  Dictionary.com
indicates
that management is about control.  Many EMAN entities will support control
and others will not.  Are the ones that don't do control being managed?
Not using the 'manage' term avoids that question.

On Wed, Jul 27, 2011 at 2:59 PM, John Parello (jparello) <[email-masked]
> wrote:

> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Benoit Claise <[email-masked]>
Date: Thu, 28 Jul 2011 12:12:30 -0400

Dear all,

If I have to compare "powered device" versus "energy managed object", I 
tend to prefer the latter, as:
1. managed object is a well known term. It's "just" that we deal with 
power/energy. So we have to be more specific.
2. energy managed object is more generic. For example, we will model a 
meter. Is this a "powered device"? It's more a "energy managed device" 
that meter something for someone.
> So, I took that to mean an integral device, like a computer, switch, 
> router, etc. that
> has a power cord and network interfaces.  I use "device" to refer to 
> this concept.
> I know that EMAN Is to report on either entire devices, or components 
> of devices,
> it is a component and there is measurement and control for that just 
> as with any
> other component.
>
So your point is that we need a generic term, right?
I believe we should have a generic term, and if you want to know if this 
is box, a line card, a port, a battery, etc... then you refer to the 
ENTITY-MIB
> (important ones reflected in the MIB structure) different from a 
Yes.

Regards, Benoit.
> On Wed, Jul 27, 2011 at 2:59 PM, John Parello (jparello) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     [email-masked] <mailto:[email-masked]>
> eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
> [email-masked]
> 510-486-7089
> m: 510-501-7943
>
>
>

---

From: "Mielke, William F (Bill)" <[email-masked]>
Date: Thu, 28 Jul 2011 12:03:15 -0500

+1 for what Bruce said.

William F. Mielke
Alcatel-Lucent
Distinguished Member of Technical Staff
6200 East Broad Street
Room: 4B01-1V
Columbus, OH  43213-1530
Email: [email-masked]<mailto:[email-masked]>
Phone: 614 367 5628
Fax: 614 367 5965

"Live like you're going to die tomorrow.
 Learn like you're going to live forever."

    - Albert Einstein

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, July 28, 2011 12:13 PM
To: Bruce Nordman
Cc: [email-masked]
Subject: Re: [eman] terminology Energy Managed Object versus Powered Device

Dear all,

If I have to compare "powered device" versus "energy managed object", I tend to prefer the latter, as:
1. managed object is a well known term. It's "just" that we deal with power/energy. So we have to be more specific.
2. energy managed object is more generic. For example, we will model a meter. Is this a "powered device"? It's more a "energy managed device" that meter something for someone.
The current definition of an EMO begins:

So, I took that to mean an integral device, like a computer, switch, router, etc. that
has a power cord and network interfaces.  I use "device" to refer to this concept.
I know that EMAN Is to report on either entire devices, or components of devices,
and "entity" can be used to reference the combination of devices and components
in line with the Entity MIB name.  A Power Interface is also a type of entity, since
it is a component and there is measurement and control for that just as with any
other component.

So, regardless of what terms are used, we need terms that are synonyms for
powered device, component, entity, and power interface.
So your point is that we need a generic term, right?
I believe we should have a generic term, and if you want to know if this is box, a line card, a port, a battery, etc... then you refer to the ENTITY-MIB
An assumption I am making is that an entire device has some characteristics
(important ones reflected in the MIB structure) different from a component.
Yes.

Regards, Benoit.

on what they are, or by what is being done to them.  Dictionary.com indicates

On Wed, Jul 27, 2011 at 2:59 PM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thoughts?
Jp
_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman<http://eetd.lbl.gov/ea/nordman>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

---

From: "Mielke, William F (Bill)" <[email-masked]>
Date: Thu, 28 Jul 2011 12:04:41 -0500

Oops, I mean what Benoit said.  :)

William F. Mielke
Alcatel-Lucent

    - Albert Einstein

________________________________
From: Mielke, William F (Bill)
Sent: Thursday, July 28, 2011 1:03 PM
To: 'Benoit Claise'; Bruce Nordman
Cc: [email-masked]
Subject: RE: [eman] terminology Energy Managed Object versus Powered Device

+1 for what Bruce said.

William F. Mielke
Alcatel-Lucent

    - Albert Einstein

Dear all,

Regards, Benoit.

Thoughts?
Jp