Subject: [eman] Comments on eman requirements

From: JinHyeock Choi <[email-masked]>
Date: Wed, 6 Jul 2011 12:43:33 +0900

Dear Juergen and all

thanks for the update and here are some comments.

1. Clarification of ‘Power’ and ‘Energy’
The relationship between power and (electric) energy is
Power is the energy consumption rate (measured with watt) and
energy is the integral of power over time (measured with joule or watthour).

Energy management concerns both ‘power’ and ‘energy’ and
now the term ‘energy consmption’ is used for both,
and sometimes brings forth confusion.

Maybe we can make it more clear
by attaching the unit to be measured (either watt or watthour).
For example such as
“amount of consumed energy measured by joule or watthour.”

2. Power/ Energy and Time
Both power and energy are time dependent parameter.

Power can be measured at a specific moment
or averaged over a certain time interval.
Energy is measured over a time interval.

When reporting ‘power’ or ‘energy’ value,
i) a specific moment or ii) a time interval
with which the measurement is made also should be provided.

3. Power state and Energy consumption

> 5.5.3. Energy per power state
>
> The energy management standard must provide means for reporting the
> consumed energy individually for each power state.

Energy consumption depends on
not only ‘power state’ but also ‘traffic load’.

To make sense out of the monitored ‘power’ or ‘energy’ value,
energy management system should also take into consideration
corresponding  ‘traffic rate (measured by bps)’ or ‘accumulated
traffic (measured by bits)’.

Otherwise it can’t determine
whether high power consumption is from low energy efficiency
or high data traffic.

4. Power profile of powered entity

> The basic objective of energy management is operating communication
> networks and other equipment with minimal amount of energy, while
> maintaining a certain level of service.

For the above purpose, it would be of help
for energy management system to be aware of
the energy efficiency of each powered device (or entity),
i.e. how much energy (joule) each device consumes per bit.

Ideally energy efficiency would be provided as
a power profile (or power model), a function
which maps served traffic (bits or bps) into consumed energy (joule/ watt).

For example, as a linear function of

P = a*T + b,

where P is energy consumption rate (watt)
T is traffic rate (bps)
and a, b are constant.

I recommend
energy efficiency or power profile
to be included to the required information in Sec 5.

Here are some more

> 1. Introduction
>
> All requirements in this document must be
> reflected by standards specifications to be developed based on these
> requirements.

Looks circular. We may do rid of ‘based on these requirements.’

> 2.1. Energy
>
>  The term 'energy consumption' is commonly used for both, for
>  referring to the amount of consumed energy and also for referring to
>  the process of consuming energy.

‘process of consuming energy’ means
‘rate of consuming enegy’ right?

> In the first case it addresses
> consumed energy, in the second one it addresses power, typically an
> average power.

For clarification, we may modify
‘consumed energy’ with ‘consumed energy measured by joule or watthour’
and
‘power’ with ‘power measured by watt’

> 4.2. Identifying components of powered devices
>
> The energy management standard must provide means for identifying not
> just entire devices as powered entities, but also individual
> components of powered devices.

Shall we also identify (or represent) the (subordinate) relationship
between powered device and its individual components?

> 5.2.6. Maximum and average power per power state
>
> The energy management standard must provide means for retrieving the
> maximum power and the average power as a typically static property
> for each supported power state.

Maximum power at maximum capacity?

Average power in which sense?
Just a arithmetic mean value between maximum and minimum power?

> 5.4. Power
>
> For some network management tasks, it is required to obtain time
> series of power values (or energy consumption values).

I assume energy consumption value measured by watt.
Am I right?

> 5.5. Energy
>
> In order to monitor energy consumption in different power states, it
> is useful if entities record their energy consumption per power state
> and report these quantities.

Energy consumption varies according to power state and traffic load.
How do you take ‘traffic load’ into consideration?

> 5.5.4. Time series of energy values
>
> The energy management standard must provide means for collecting time
> series of energy values for each power inlet and for each power
> outlet of an entity

Energy would be measured over time interval.

Would time series of energy values be measured
over the sequence of time intervals in 5.5.2?

> 8.1.1. Control of power states of other entities
>
> The energy management standard must provide means for an energy
> management system to send power state control commands to entity that
> concern the power states of other entities than the one the command
> was send to.

Is this always the case?
Can’t control command be sent to an entity that concern the power
state of itself?

> 8.1.4. List of all power state controllers
>
>   The energy management standard must provide means for an entity that
>   has receives commands controlling its power state from other entities
>   to report the list of all those entities.

Typo
sub ‘receives’ with ‘received’

> 9. Security Considerations
>
> Secondly, it should be possible to prevent
> malicious entities exercising control over entities.

sub ‘prevent malicious entities exercising’ with
‘prevent malicious entities from exercising’

Thanks for your kind consideration.

Best regards

JinHyeock

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 6 Jul 2011 02:25:57 -0500

Hi JinHyeock,

Thanks for your detailed comments. 

As Juergen has mentioned in another email thread, perhaps, the terminology section may be revised and updated. 

Regarding your point on energy profile should take into consideration traffic (bps) for network devices 

 - there are benchmarking studies of networking devices based on TEER standard 

http://www.3gpp.org/ATIS-Standards-helping-network

That statistic can be derived by an NMS for a networking device by polling the energy MIB and ifMIB counters. 

Thanks
Mouli

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of JinHyeock Choi
Sent: Wednesday, July 06, 2011 9:14 AM
To: Juergen Quittek
Cc: eman mailing list
Subject: [eman] Comments on eman requirements

Dear Juergen and all

1. Clarification of 'Power' and 'Energy'
The relationship between power and (electric) energy is
Power is the energy consumption rate (measured with watt) and
energy is the integral of power over time (measured with joule or watthour).

Energy management concerns both 'power' and 'energy' and
now the term 'energy consmption' is used for both,
and sometimes brings forth confusion.

Maybe we can make it more clear
by attaching the unit to be measured (either watt or watthour).
For example such as
"amount of consumed energy measured by joule or watthour."

When reporting 'power' or 'energy' value,
i) a specific moment or ii) a time interval
with which the measurement is made also should be provided.

Energy consumption depends on
not only 'power state' but also 'traffic load'.

To make sense out of the monitored 'power' or 'energy' value,
energy management system should also take into consideration
corresponding  'traffic rate (measured by bps)' or 'accumulated
traffic (measured by bits)'.

Otherwise it can't determine
whether high power consumption is from low energy efficiency
or high data traffic.

P = a*T + b,

I recommend

Here are some more

> reflected by standards specifications to be developed based on these

Looks circular. We may do rid of 'based on these requirements.'

>  the process of consuming energy.

'process of consuming energy' means
'rate of consuming enegy' right?

For clarification, we may modify
'consumed energy' with 'consumed energy measured by joule or watthour'
and
'power' with 'power measured by watt'

Energy consumption varies according to power state and traffic load.
How do you take 'traffic load' into consideration?

> concern the power states of other entities than the one the command

Is this always the case?
Can't control command be sent to an entity that concern the power
state of itself?

>   to report the list of all those entities.

Typo
sub 'receives' with 'received'

> malicious entities exercising control over entities.

sub 'prevent malicious entities exercising' with
'prevent malicious entities from exercising'

Best regards

JinHyeock
_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 6 Jul 2011 15:52:04 +0200

Dear JinHyeock,

Thank you for your detailed review.
Please find replies inline.

> “amount of consumed energy measured by joule or watthour.”

I see your point. The alternative would be adding a clarification to
the terminology section. What about appending

   However, in this document the term "consumed energy" always refers
   to an energy quantity and not to a power quantity. 

to section 2.1 Energy? 

> with which the measurement is made also should be provided.

Yes, that's a good point. I think for energy measurements this is covered 
by requirement 5.5.2.  Time intervals, but for power monitoring this is missing.

What about adding the following requirement?
5.4.2.  Power measurement interval

   The energy management standard must provide means for reporting the
   corresponding time interval for which a power value is reported.  A
   time interval can be very short for reporting approximations of
   instantaneous power or rather long for reporting demand values.

> whether high power consumption is from low energy efficiency

What would be the requirement?

A comment on the issue: 
Proportionality between traffic and energy is a tricky thing. 
I read reports on measurements at low-end routers that show
decreasing energy consumption with increasing traffic.

> to be included to the required information in Sec 5.

This would be a requirement for switches, routers, etc. only.
For PCs, displays, light bulbs, it would not be applicable.

Would it not be sufficient to just report the power and have the joule/bit
be computed by a management system that reads the interface MIB modules if available?

> Looks circular. We may do rid of ‘based on these requirements.’

Right.

> ‘rate of consuming enegy’ right?

Yes, I'll fix it.

> ‘power’ with ‘power measured by watt’

Good. Let's apply this change.

> between powered device and its individual components?

There are already standards for this available.
Shall we still make a requirement out of it in order to clarify that this is 
needed for energy management as well?
> Maximum power at maximum capacity?

We do not have a general definition of capacity.
This varies too much among the range of devices that we intend to support.

> Just a arithmetic mean value between maximum and minimum power?

I was thinking about the average expected energy consumption in a particular power state.
I admit that this may be difficult to predict. But before asking an entity to switch to another
power state it would make sense to have information about the chances of saving power
and for avoiding to bring the device into a state that even consumes more power.

> I assume energy consumption value measured by watt.

No here it is either or: power or energy time series. But I see this is confusing.
What about removing "(or energy consumption values)"?

> How do you take ‘traffic load’ into consideration?

We do not have any generic term for load. If you can provide one, please send it.

> over the sequence of time intervals in 5.5.2?

Yes. There are different ways to do so.

A time series can contain values that give the total energy since the last re-start 
up to an indicated measurement time. Alternatively, you can have time series of energy
consumption for consecutive time intervals, one value each. Or you can have this for
overlapping time intervals. 5.5.2 shows all of them.

> Can’t control command be sent to an entity that concern the power

We have the scenario of building networks that do not use IP. 
In such a case a gateway or proxy will be addressed by control 
commands for devices in the non-IP network.

> sub ‘receives’ with ‘received’

Fixed. But the fix was deleting "has"

> ‘prevent malicious entities from exercising’

Fixed.

Many thanks,

    Juergen

---

From: JinHyeock Choi <[email-masked]>
Date: Thu, 7 Jul 2011 12:08:18 +0900

Dear Mouli

> Thanks for your detailed comments.

thanks for the draft to comment on. :-)

> As Juergen has mentioned in another email thread, perhaps, the terminology section may be revised and updated.

ok.

> http://www.3gpp.org/ATIS-Standards-helping-network

thanks for the inforamiton.

> That statistic can be derived by an NMS for a networking device by polling the energy MIB and ifMIB counters.

This will do and perhaps is the way to compute power profile (or
energy efficiency)

thanks for your kind consideration.

Best regards

JinHyeock

---

From: JinHyeock Choi <[email-masked]>
Date: Thu, 7 Jul 2011 12:08:51 +0900

Dear Juergen

thanks for kind and thoughtful reply.

>   to an energy quantity and not to a power quantity.

fine with me.

Sometimes people have trouble distinguishng ‘power’ and ‘energy’
at least that’s the case for me.
(it has been a long while since I pored over Physics textbook.)

Though ‘power’ and ‘energy’ have different meanings
clearly defined in Physics,
their everyday usage can be intermingling
such as ‘power efficiency’ and ‘energy efficiency’

>   instantaneous power or rather long for reporting demand values.

In principle,
power itself is an instantateous value
and measured at a moment (not over interval).

So how about rephrasing

    The energy management standard must provide means for reporting the
    corresponding time or time interval for which a power value is reported.
    The power value can be measured at the corresponding time or averaged
    over the corresponding time interval.

> What would be the requirement?

How about

    The energy management standard must provide means for reporting the
    consumed energy individually for each power state,
    with which enegy management system can derive an average expected
    energy consumption for each power state.

to clarify the reason behind per-power state reporting
> decreasing energy consumption with increasing traffic.

Interesting.
Power consumption remaining the same irrespective of traffic load
is not unusual but power consumption inversely proportional
to traffic load is a novelty.
Can you give me a pointer?

> For PCs, displays, light bulbs, it would not be applicable.

I see.

ok.

For energy management,
power profile would be needed
but maybe better be acquired indirectly
via a kind of resolution scheme.

> needed for energy management as well?

Such representatin of subordinate relationship would be useful
but I’m not sure about making it a requirement.
If WG doesn’t have a strong opinion about it,
let’s leave it as it is. :-)

> I admit that this may be difficult to predict.

yes,
even at the same power state,
enrgy consumption can vary substantially depending on traffic load.

> But before asking an entity to switch to another

agree.

> What about removing "(or energy consumption values)"?

ok. thanks for clarificaiton.

> We do not have any generic term for load. If you can provide one, please send it.

‘bps’ or ‘(accumulated) bit’ would do for network equipments
such as router or switich.

However, for more generic work load,
I don’t have a good idea.

ok.

Please allow me to split hairs
cocnerning the terms ‘series’ and ‘sequence’
which are currently both used in in 5.5.2 and 5.5.4.

Precisely speaking, in mathematics,
‘series’ is the sum of the terms of ‘sequence’,
so in our context, ‘sequence’ is better.

Bets regards

JinHyeock

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 7 Jul 2011 05:39:50 +0200

Dear JinHyeock,

Thanks for the constructive suggestions.
Please find replies inline.

> such as ‘power efficiency’ and ‘energy efficiency’

OK. I will add units as you suggested above:

   However, in this document the term "consumed energy" always refers to
   an energy quantity (measured in joule, watthour, etc.) and not to a
   power quantity (measured in watt).

>    over the corresponding time interval.

Fine with me.

>    energy consumption for each power state.

This sounds like a good proposal.
I'll check it and come back on it later.

> Can you give me a pointer?

http://www.irit.fr/~Georges.Da-Costa/cse09.pdf

> so in our context, ‘sequence’ is better.

I'd be fine with using sequence.
Would it be OK to say "time sequence of power values" instead of "time series of power values"?

Thanks,

    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 6 Jul 2011 20:51:11 -0700

Hi,

In general we should not be making up terms that we mutually agree on. I
agree with the other threads that taking definitions from well
established source is much better.

For the basic things like Power and Energy etc there are well
established definition in IEC for utility meters and like devices,
ASHRAE, and IMO the new ISO50001 - which defines Energy Management and
constituent parts - has a concise normative reference for these. 

http://www.iso.org/iso/catalogue_detail?csnumber=51297

You can also refer to the ODVA CIP presentation I did at IETF-80 which
discussed just this topic on Power Energy and Demand definitions etc

For the discussion below on 'Energy' the definitions from the above
sources just say time (no need to add series, sequence or interval)
unless you are referring to Demand or taking Energy and Power reading
over time (which already have time in them). In fact adding those will
make Demand more confusing.

Again there's quite some years of precedence for these values in utility
and industrial devices.

Jp

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Juergen Quittek
Sent: Wednesday, July 06, 2011 8:40 PM
To: JinHyeock Choi
Cc: eman mailing list
Subject: Re: [eman] Comments on eman requirements

Dear JinHyeock,

> ok. thanks for clarificaiton.
<snio>
>>> Energy would be measured over time interval.

Just "over time" no need to say series or interval.

Jp

> cocnerning the terms 'series' and 'sequence'
> 'series' is the sum of the terms of 'sequence',
> so in our context, 'sequence' is better.

I'd be fine with using sequence.
Would it be OK to say "time sequence of power values" instead of "time
series of power values"?

Thanks,

    Juergen

---

From: JinHyeock Choi <[email-masked]>
Date: Thu, 7 Jul 2011 13:41:30 +0900

Dear Juergen

> Thanks for the constructive suggestions.

thanks for your kind words.

> http://www.irit.fr/~Georges.Da-Costa/cse09.pdf

thanks for a prompt reply.

> Would it be OK to say "time sequence of power values" instead of "time series of power values"?

That would be great.
Thanks for your putting my mind at ease. :-)
This is just a small issue
which I can live with but would rather without.

Best regards

JinHyeock

---

From: JinHyeock Choi <[email-masked]>
Date: Thu, 7 Jul 2011 14:16:41 +0900

Dear John

> http://www.iso.org/iso/catalogue_detail?csnumber=51297

Unfortunately the above demands to pay for the document. :-(
Would you kindly provide the definitions for ‘power’ and ‘energy’?

> sources just say time (no need to add series, sequence or interval)

Allow me to quote Bruce’s mail for ‘energy’ definition.

    Energy in the context of "metering" is:
     "The integral of active power with respect to time."

The integral implies
the domain over which integration is taken,
which I represent with the term ‘time interval’.

Also the statement below also mentions ‘time interval’

   "The electric energy delivered by an electric circuit during a time interval
      is the integral with respect to time of the instantaneous power at the
      terminals of entry of the circuit to a delineated region."

Maybe this is from the ambiguity inherent in the word ‘time’.

‘Time’ may imply a specific moment as in ‘on time’
or some period or interval as in ‘long time.’
(Actually Korean language has two different words for those.)

‘(Electric) energy’, as its unit ‘watthour’ indicates,
concerns ‘time’ in the second sense.

Best regards

JinHyeock

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 7 Jul 2011 15:25:07 +0200

Hi Paul,

> In general we should not be making up terms that we mutually agree on. I

I fully agree. But I would like to make the point that there we do not yet have an 
agreement on this issue. I like the terms from IEC as well as the ones from IEEE.
Both are competent standards bodies in this area. But so far the discussions 
with contributions from many people have not converged. I see a clear trend 
towards adopting terms defined by other standards bodies and being in use 
for many years.

Still, seeing Bruce's mail on this topic who , for example, gave us four 
commonly used definitions of demand, there are still choices to be made.
I'll be glad seeing us reaching a final agreement on which terms to choose
very soon.

> make Demand more confusing.

The discussion on the requirement to store time series/sequences of 
measured values at the entity seems to be independent of our base terminology.

The discussion over time intervals was very useful for me.
Particularly, when I came to the point that I am not sure anymore
that we want to have instantaneous power reported for AC power.
As you know, the instantaneous power for AC is alternating and 
typically has a value of zero for 50 or 60 times a second. So we definitely
want to have a power value that is not instantaneous, but at least averaged
over half a period of alternation. Thus all power/demand values we are
dealing with are average values.

> Again there's quite some years of precedence for these values in utility

That's great and highly appreciated.

Thanks,

    Juergen

---

From: "Michael Suchoff" <[email-masked]>
Date: Thu, 7 Jul 2011 11:14:28 -0400

AC power is not reported as an instantaneous value but as an average - the minimum averaging time being 1/2 AC cycle.

A plot of the instantaneous AC power is a sinusoidal waveform at 2X the AC power frequency.  For example, assume V = 100V RMS, I = 1A RMS, F=60Hz with power factor 1.0.  The power waveform would be a 120Hz sinusoidal with amplitude 200 and average value 100.  The average value is the active (real) power.

The power waveform can be explained mathematically using the product to sum formula we learned in high school trigonometry class....

Sin(a) * sin(b) = .5 * (cos(a-b) - cos(a+b)

"a" and "b" are frequency (phase term not shown for simplicity) which are identical.  Cos(a-b) = 0 which is the real component of power and whose average value is shown on a watt meter.  Cos(a+b) is the 2X frequency component whose average value is 0.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of JinHyeock Choi
Sent: Wednesday, July 06, 2011 11:09 PM
To: Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] Comments on eman requirements

Dear Juergen

fine with me.

Sometimes people have trouble distinguishng 'power' and 'energy'
at least that's the case for me.
(it has been a long while since I pored over Physics textbook.)

Though 'power' and 'energy' have different meanings
clearly defined in Physics,
their everyday usage can be intermingling
such as 'power efficiency' and 'energy efficiency'

In principle,

So how about rephrasing

How about

Interesting.

I see.

ok.

For energy management,

Such representatin of subordinate relationship would be useful
but I'm not sure about making it a requirement.
If WG doesn't have a strong opinion about it,
let's leave it as it is. :-)

yes,

agree.

> We do not have any generic term for load. If you can provide one, please send it.

'bps' or '(accumulated) bit' would do for network equipments
such as router or switich.

However, for more generic work load,
I don't have a good idea.

ok.

Bets regards

JinHyeock

---

From: "Michael Suchoff" <[email-masked]>
Date: Thu, 7 Jul 2011 15:40:56 -0400

Correction to my prior e-mail.

Cos(a-b) = 1 when a == b.

This first term is where power factor is derived.  If there is a phase difference between voltage and current, then this first term will evaluate to cos(p) where p is the phase difference between voltage and current.  When p = 0 (no phase shift) power factor = cos(0) = 1.  In a purely inductive or capacitive load, the phase shift of current is 90 degrees relative to voltage, so this first term is cos(90) which is 0 - power factor is 0 and no power is delivered to load.

The main point of my original comment is the instantaneous power varies between 0 and 2*power - so it would not be correct to define power as the instantaneous value.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of JinHyeock Choi
Sent: Wednesday, July 06, 2011 11:09 PM
To: Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] Comments on eman requirements

Dear Juergen

fine with me.

In principle,

So how about rephrasing

How about

Interesting.

I see.

ok.

For energy management,

yes,

agree.

ok.

Bets regards

JinHyeock

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 8 Jul 2011 10:46:37 +0200

Dear Michael,

You are absolutely right. 
And I wrote the same story already in an earlier message:

For AC power measurement there is always a reporting interval.

Thanks,

    Juergen

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 13 Jul 2011 03:51:37 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
JinHyeock Choi
Sent: Thursday, July 07, 2011 10:12 AM
To: Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] Comments on eman requirements

Dear Juergen

series of power values"?

Hi JinHyeock,

A small nit. 

"Time Series" is the classical statistical term (many text books) for
any data collected over time, which is probably what is meant here
Energy data collected over time. 

Sequences and Series are terms used in Real Analysis.  

Sorry.  Could not resist my karma from my previous incarnation as a
mathematician !

Thanks
Mouli

---

From: JinHyeock Choi <[email-masked]>
Date: Wed, 13 Jul 2011 18:01:17 +0900

Hi Mouli

thanks for the clarificaiton.

> Energy data collected over time.

ok. If that’s the well established term, I’m fine with that.

> Sequences and Series are terms used in Real Analysis.

that’s what I have in mind.
In Analysis, there is a clear difference.

> Sorry. Could not resist my karma from my previous incarnation as a

The same here. Neither could I resist it.
We fret over definitions like a princess over a pea. :-)

best regards

JinHyeock

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 13 Jul 2011 04:27:28 -0500

Hi Juergen,

As evident in this email thread, there is a clear need for on consensus
in terminology - which I had initially expressed 
http://www.ietf.org/mail-archive/web/eman/current/msg00554.html

Power and Energy are not new concepts. A mathematical definition of
Energy and Power should be available in standard Physics text books.
Perhaps, in IETF EMAN WG drafts, it is possible to reuse a definition
from other electrical standards - IEC, ISO or IEEE.

For the benefit, it would be good to have the snippet (posted in the
email list) of these definitions from these other standards and then we
can converge on the definition soon.

Thanks
Mouli

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Juergen Quittek
Sent: Thursday, July 07, 2011 6:55 PM
To: John Parello (jparello)
Cc: eman mailing list
Subject: Re: [eman] Comments on eman requirements

Hi Paul,

> In general we should not be making up terms that we mutually agree on.
I

I fully agree. But I would like to make the point that there we do not
yet have an 
agreement on this issue. I like the terms from IEC as well as the ones
from IEEE.
Both are competent standards bodies in this area. But so far the
discussions 
with contributions from many people have not converged. I see a clear
trend 
towards adopting terms defined by other standards bodies and being in
use 
for many years.

commonly used definitions of demand, there are still choices to be made.
I'll be glad seeing us reaching a final agreement on which terms to
choose
very soon.

The discussion on the requirement to store time series/sequences of 
measured values at the entity seems to be independent of our base
terminology.

The discussion over time intervals was very useful for me.
Particularly, when I came to the point that I am not sure anymore
that we want to have instantaneous power reported for AC power.
As you know, the instantaneous power for AC is alternating and 
typically has a value of zero for 50 or 60 times a second. So we
definitely
want to have a power value that is not instantaneous, but at least
averaged
over half a period of alternation. Thus all power/demand values we are
dealing with are average values.

Thanks,

    Juergen

>>> A time series can contain values that give the total energy since
the
> last re-start
>>> up to an indicated measurement time. Alternatively, you can have
time
> series of energy

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Wed, 13 Jul 2011 05:09:20 -0500

Hi Juergen,

I think there is some confusion on measurement - what is meant by
instantaneous power measurement. 

For the sake of clarity, let us assume there is an external meter, which
measures the power of the electrical device at a given time instant and
it is possible to read the meter reading. The reported value is the
power consumed by the device at that time - 100 watts...

I do not think the intent is to measure Alternating Current at the
granularity of 50 or 60 sinusoidal cycles per second. Not sure if there
are even devices to measure current at that level. 

So, the meter does the averaging internally and reports the power
consumed at a given time. From a energy monitoring or planning
perspective, that would seem to be adequate. 

Any thoughts. 

Thanks
Mouli

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Juergen Quittek
Sent: Friday, July 08, 2011 2:17 PM
To: Michael Suchoff
Cc: eman mailing list
Subject: Re: [eman] Comments on eman requirements

Dear Michael,

Thanks,

    Juergen

Am 07.07.2011 um 17:14 schrieb Michael Suchoff:

> AC power is not reported as an instantaneous value but as an average -
the minimum averaging time being 1/2 AC cycle.
> 
> A plot of the instantaneous AC power is a sinusoidal waveform at 2X
the AC power frequency.  For example, assume V = 100V RMS, I = 1A RMS,
F=60Hz with power factor 1.0.  The power waveform would be a 120Hz
sinusoidal with amplitude 200 and average value 100.  The average value
is the active (real) power.
> 
> The power waveform can be explained mathematically using the product
to sum formula we learned in high school trigonometry class....
> "a" and "b" are frequency (phase term not shown for simplicity) which
are identical.  Cos(a-b) = 0 which is the real component of power and
whose average value is shown on a watt meter.  Cos(a+b) is the 2X
frequency component whose average value is 0.
>> be computed by a management system that reads the interface MIB
modules
>> if available?

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 13 Jul 2011 14:57:09 +0200

Mouli,

I fully agree. That's why in the terminology section of the last two drafts that I posted, you will find under "Power" and "Energy" not a definition but: "To be agreed on in the EMAN WG."

I will start a compilation of proposals we have for each of them. Then we can discuss which is the best candidate.

    Juergen

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 13 Jul 2011 14:58:49 +0200

Hi Mouli,

Let's come back to this after we have agreed on a definition for power.
Meanwhile I will look up how IEEE and IEC define "instantaneous power", particularly in case of AC.

Thanks,

    Juergen

---

From: "Michael Suchoff" <[email-masked]>
Date: Wed, 13 Jul 2011 11:39:19 -0400

A root cause for confusion may be WG's selection of IEC 61850 as power
quality standard.  61850 is used by power stations and utilities for
medium and high voltage systems - this is not appropriate for low
voltage AC systems where this group's work will be used.

A better choice would be IEC 61000-4-30 "Testing and Measuring
Techniques - Power Quality Measurement Methods".  An examination of
power quality meters will show this is the standard to which they are
designed.

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]] 
Sent: Wednesday, July 13, 2011 8:59 AM
To: Mouli Chandramouli (moulchan)
Cc: Michael Suchoff; eman mailing list
Subject: Re: [eman] Comments on eman requirements

Hi Mouli,

Let's come back to this after we have agreed on a definition for power.
Meanwhile I will look up how IEEE and IEC define "instantaneous power",
particularly in case of AC.

Thanks,

    Juergen

Am 13.07.2011 um 12:09 schrieb Mouli Chandramouli (moulchan):

>>>> which maps served traffic (bits or bps) into consumed energy
(joule/
> watt).
>>> power state it would make sense to have information about the
chances
> of saving power
the
time

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 13 Jul 2011 21:59:11 -0700

I have also had difficulty with the 61850 reference.
The 61000 standard sounds promising.

Also relevant is IEC 62301 (Ed 2) which is commonly
referenced in energy efficiency standards and test
procedures.  It is intended for products of the voltage
and power levels of those mentioned in the use cases
we have discussed.

I fully agree we should have good definitions for power
and energy, but I don't think we actually have a difference
of opinion in what we want these terms to mean in practice.
I do not think that we should be particularly specific about
details of the power meaning, e.g. how many cycles the
measurement covers.  Different products may have reasons
to reference fewer or more cycles in determining the power
level.  I think we need to trust the define mfr to determine
something that is useful in addition to being correct by some
reasonable definition.  One the other hand, energy should
not have any such uncertainty.

--Bruce

On Wed, Jul 13, 2011 at 8:39 AM, Michael Suchoff <
[email-masked]> wrote:

> ...

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "Mielke, William F (Bill)" <[email-masked]>
Date: Mon, 25 Jul 2011 13:07:30 -0500

A few thoughts provided inline.

William F. Mielke
Alcatel-Lucent
Distinguished Member of Technical Staff
6200 East Broad Street
Room: 4B01-1V
Columbus, OH  43213-1530
Email: [email-masked]
Phone: 614 367 5628
Fax: 614 367 5965

"Live like you're going to die tomorrow.
 Learn like you're going to live forever."

    - Albert Einstein

> Sent: Tuesday, July 05, 2011 11:44 PM
> To: Juergen Quittek
> Cc: eman mailing list

> Just a arithmetic mean value between maximum and minimum power?

I agree that "average power" needs some clarification as the arithmetic mean of the minimum and maximum values does not seem to be the correct value here.  I believe that the intent is

Average Power for an Interval = Total Energy Consumed in that Interval / Length of the Interval

Example:

Average Power = 10 Watt-Hour / 1 Hour = 10 Watts

Whereas the observed Max Power during that hour may have been 15 Watts and the observed Min Power may have been 9 Watts which would yield an arithmetic mean of (15 + 9) / 2 = 12 Watts which is not what I think most people expect or want.

This begs the question of what interval the object should be reporting.

Do others agree?

> How do you take 'traffic load' into consideration?

This raises a very important point and one that I am not certain is within scope of EMAN but which is certainly an important point for Energy Management in general.  I would generalize this point from the networking example a bit as the fundamental point is about efficiency.

Let us define efficiency in this context as follows:

Energy Efficiency = Total Energy Consumed per Unit of Useful Work

In the example discussed above the "Unit of Useful Work" is the transmission of a bit (i.e. a unit of traffic).  But in other domains the units will be different.  For example, in the case of light bulbs the interesting unit would be the number of Lumens emitted.  So as you can see "Unit of Useful Work" is application domain dependent.

Given that EMAN wishes to be application domain agnostic this presents a problem for us to provide a meaningful definition of Energy Efficiency because we would need to provide definitions for an endless number of domains.  I do not believe that the concept of "Unit of Useful Work" can be reasonably abstracted to the point of having a consistent set of units across disparate application domains.

This is a thorny issue IMHO, and I am not sure how best to address it.

> over the sequence of time intervals in 5.5.2?

I am assuming that we would be reporting the relevant values for each of a sequence of contiguous and non-overlapping intervals where each interval is identified with a timestamp that corresponds to either the start or the end of that interval.

Is this the correct understanding?