Subject: Re: [eman] Do we need power state transition count and time in state?

From: Benoit Claise <[email-masked]>
Date: Sun, 24 Jul 2011 23:31:02 -0400

Dear all,

I'm not sure what is the conclusion regarding this old email about "Do 
we need power state transition count and time in state?"
Currently, the EMAN requirements draft contains:

        5.2.7. Power state statistics The energy management standard
        must provide means for monitoring statistics per power state
        including at least the total time spent in a power state, the
        number of times a state was entered and the last time a state
        was entered. More power state statistics are addressed by
        requirement 5.5.3.

Is this the consensus on the mailing list?

Regards, Benoit.
> Am 13.04.2011 um 17:19 schrieb Russ White:
>>>>> I assume people find it important to know the percentage of time a
>>>>> device spends in a certain power state. Approximating this by active
>>>>> polling of the current state is pretty inefficient and inaccurate
>>>>> since you can miss state changes. If the device records the time spent
>>>>> in each state, you get a precise breakdown of the time spend in each
>>>>> power state between each poll, which means you can safely poll at a
>>>>> much lower frequency.
>>>> It seems like this should be put into an extension, rather than in the
>>>> base spec... Or as a device specific option (given we build the branches
>>>> of information we had discussed on list before).
>>> And the reason is?
>> Because this doesn't seem to be useful for all devices... And because we
>> should try and keep the MIB size down, with extensions, rather than
>> trying to bundle everything possible into the base MIB.
> What about having it in the same MIB, but making it optional to implement?
>
>      Juergen
>
>
>> :-)
>>
>> Russ
>>
>>
>>
>> -- 
>> [email-masked] :: CCIE :: CCDE ::<><  Grace Alone
>>
>> Belief is a wise wager. Granted that faith cannot be proved, what harm
>> will come to you if you gamble on its truth and it proves false? If you
>> gain, you gain all; if you lose, you lose nothing. Wager, then, without
>> hesitation, that He exists. Blaise Pascal
>>
>>
>> _______________________________________________
>> eman mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/eman
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Thomas Dietz <[email-masked]>
Date: Mon, 25 Jul 2011 08:26:03 +0000

Hi Benoit, all,

I support having those objects in the MIB. The only point where those values
can be measured accurate is the device itself, and the values can be useful
for a number of use cases. We still can make those objects optional as
Juergen already suggested so that they don't need to be implemented if the
device does not or cannot support them.

Best Regards,

Thomas

-- 

Thomas Dietz

NEC Europe Ltd., NEC Laboratories, Network Research Division, 69115
Heidelberg, Germany

NEC Europe Limited, Registered in England 2832014

Registered Office: NEC House, 1 Victoria Road, London W3 6BL

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Benoit Claise
Sent: Montag, 25. Juli 2011 05:31
To: Juergen Quittek
Cc: [email-masked]
Subject: Re: [eman] Do we need power state transition count and time in
state?

Dear all,

I'm not sure what is the conclusion regarding this old email about "Do we
need power state transition count and time in state?"
Currently, the EMAN requirements draft contains:

5.2.7.  Power state statistics

   The energy management standard must provide means for monitoring

   statistics per power state including at least the total time spent in

   a power state, the number of times a state was entered and the last

   time a state was entered.  More power state statistics are addressed

   by requirement 5.5.3.

Regards, Benoit.

And the reason is?

 
    Juergen

:-)
 
Russ

-- 
[email-masked] :: CCIE :: CCDE :: <>< Grace Alone

---

From: Benoit Claise <[email-masked]>
Date: Mon, 25 Jul 2011 14:04:47 -0400

Hi Thomas,
>
> Hi Benoit, all,
>
> I support having those objects in the MIB. The only point where those 
> values can be measured accurate is the device itself, and the values 
> can be useful for a number of use cases. We still can make those 
> objects optional as Juergen already suggested so that they don't need 
> to be implemented if the device does not or cannot support them.
>
Optional is fine with me.

Regards, Benoit (as a contributor)
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Benoit Claise
> *Sent:* Montag, 25. Juli 2011 05:31
> *To:* Juergen Quittek
> *Cc:* [email-masked]
> *Subject:* Re: [eman] Do we need power state transition count and time 
> in state?
>
> Dear all,
>
>     [email-masked]  <mailto:[email-masked]>  :: CCIE :: CCDE ::<><  Grace Alone
>
>       
>
>     [email-masked]  <mailto:[email-masked]>
>
> [email-masked]  <mailto:[email-masked]>