Subject: Re: [eman] new revision of eman requirements - open issue 12.3:timeseries of energy/power values

From: Benoit Claise <[email-masked]>
Date: Tue, 02 Aug 2011 17:07:04 +0200

Dear all,

Trying to combine all the different arguments (discussed on the mailing 
list and during the meeting), why do we have to have to specify which 
time series the EMAN standard must support as a pull model?

Why not have a generic requirement, such as:
The EMAN tandard must not limit time series (for example Power, Energy, 
Demand) to a pull mechanism; the push mechanism must be considered.

Regards, Benoit.

> An energy time series is can be reported as an odometer reading.  I 
> think you'll need to be adaptable to allow either an absolute value 
> like instantaneous kW, kWh over a sample period or odometer sampling 
> for kWh.
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Michael Suchoff
> *Sent:* Thursday, July 28, 2011 2:25 PM
> *To:* John Parello (jparello); Juergen Quittek; Juergen Quittek
> *Cc:* eman mailing list
> *Subject:* Re: [eman] new revision of eman requirements - open issue 
> 12.3:timeseries of energy/power values
>
> I would add current to the series as well.  Most AC devices presently 
> don't have circuitry to report power or energy, they simply report AC 
> current.  Also, for capacity planning, current is very useful (it is 
> current that limits how many devices can be placed on an electrical 
> branch circuit or PDU -- not power).
>
> Ideally, the time series would be structured as a table with the 
> columns being measurements (i.e. column 1 = time stamp, 2 = power, 3 = 
> energy, 4 = current, 5 = voltage, etc).  The columns could be 
> partitioned into SNMP augmented tables (tables sharing same index). 
>  This would allow easy addition of new columns for products that offer 
> more information.
>
> I don't see reason for demand as a special table.  Demand (watts) is 
> easily computed from the energy readings.  For example, if kWh = 1000 
> at 1PM and kWh = 2000 at 1:15PM, then average power over the 15 minute 
> interval is (2000kWh -- 1000kWh) * 60minutes/15minutes = 4kW.  Doesn't 
> it seem a lot simpler for management program to compute demand based 
> on polled energy readings (i.e. a simple SQL query) -- rather than 
> having to write a procedure to configure the power agent to perform 
> demand computations?
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *John Parello (jparello)
> *Sent:* Thursday, July 28, 2011 2:06 PM
> *To:* Juergen Quittek; Juergen Quittek
> *Cc:* eman mailing list
> *Subject:* Re: [eman] new revision of eman requirements - open issue 
> 12.3:timeseries of energy/power values
>
> I can't vote  no when there'sand or and more on the bill.
>
> I don't see any reason to restrict to just power. IMO a series of 
> power, energy, and demand is useful if a device can support it.
>
> So no don't restrict it to just power and please allow series for 
> power, demand, and energy
>
> Jp
>
>
> -----Original Message-----
> From: Juergen Quittek [mailto:[email-masked]]
> Sent: Wed 7/27/2011 7:13 AM
> To: John Parello (jparello); Juergen Quittek
> Cc: eman mailing list
> Subject: Re: [eman] new revision of eman requirements - open issue 
> 12.3:time series of energy/power values
>
> Hi John,
>
> my Question was
>
> "Do I understand right that you would support a requirement for specifying
> a standard for time series of power but not for time series of energy?"
>
>
> I take you answer as a no. This would mean we keep both requirements (time
> series of power and time series of energy). Is this correct?
>
> Thanks,
>
>     Juergen
>
>
> On 26.07.11 18:10, "John Parello (jparello)" <[email-masked]> wrote:
>
> >
> >Hi Jeurgen,
> >
> >We need to express power, energy as a measurement (scalar).
> >
> >For time series (vector) IMO having the capability of providing power
> >over time series (which is demand) or energy over time is valuable and
> >should not be excluded.  Even though for energy an odometer can suffice I
> >see no need to prevent this for devices that have this capability.
> >
> >
> >Please take a look at the draft-claise-energy-monitoring-mib.  I think
> >they did a good job of providing time series modeling that covers this.
> >
> >thanks
> >Jp
> >
> >
> >
> >
> >
> >
> >
> >
> >-----Original Message-----
> >From: Juergen Quittek [mailto:[email-masked]]
> >Sent: Tue 7/26/2011 12:39 PM
> >To: John Parello (jparello)
> >Cc: Mouli Chandramouli (moulchan); eman mailing list
> >Subject: Re: [eman] new revision of eman requirements - open issue
> >12.3:time series of energy/power values
> >
> >Hi John,
> >
> >We are currently not discussing optional or mandatory implementation.
> >
> >The question is whether or not we have a requirement for specifying a
> >standard for reporting both, energy time series and power time series, or
> >just one of them. What compliant devices must implement is an issue to be
> >discussed later.
> >
> >Do I understand right that you would support a requirement for specifying
> >a standard for time series of power but not for time series of energy?
> >
> >Thanks,
> >
> >    Juergen
> >
> >Am 26.07.2011 um 13:08 schrieb John Parello (jparello):
> >
> >> Hi Jeurgen,
> >>
> >> I tend to agree, for simple devices an energy odometer(s) as describe
> >> from the comments and what I presented from the ODVA suffices.
> >>
> >> For time series of data like historical demand devices such as PDUs very
> >> typically store this. Some our as long as a year's worth of data on the
> >> device. For the very reason that Bill pointed out.
> >>
> >> So it would seem that a power value and an energy odometer could be a
> >> required minimum and then time series of power or demand can be
> >> optional.
> >>
> >> We specified a power value as required in the monitoring mib with time
> >> series of power and demand as optional.
> >>
> >> Jp
> >>
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> >> Juergen Quittek
> >> Sent: Wednesday, July 13, 2011 5:53 AM
> >> To: Mouli Chandramouli (moulchan)
> >> Cc: eman mailing list
> >> Subject: Re: [eman] new revision of eman requirements - open issue
> >> 12.3:time series of energy/power values
> >>
> >> Dear Mouli,
> >>
> >> Thank you for commenting on this issue. I would like to have a look at
> >> the following point of view:
> >>
> >> So far, storing time series of measurements on managed nodes is rarely
> >> standardized and rarely available as implementation.
> >>
> >> Typically, it is the job of a network management system to collect time
> >> series and store them.
> >>
> >> Take for example byte and packet counters at line cards. You see many
> >> curves showing time series of traffic rate/volume in the Internet, but
> >> almost all of them were collected at management stations or data
> >> collector modules, but not within MIB modules. (Please correct me if I'm
> >> wrong.)
> >>
> >> Now the question is: Is energy management so much different from other
> >> network management tasks, that we need the rarely used mechanism of
> >> storing time series in MIB modules?
> >>
> >> If not, it would be sufficient to just report the number of total energy
> >> consumed since the last re-start as you do it with packet and byte
> >> counters.
> >> This would be just a single managed object to be specified and
> >> implemented.
> >>
> >> Thanks,
> >>
> >>    Juergen
> >>
>
>
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Brad Schoening <[email-masked]>
Date: Wed, 3 Aug 2011 01:28:39 +0000

Energy & demand are an essential measurement of smart meters and similar devices.  It's usually computed at the meter by sampling at the millisecond level.  Sampling kW by polling and then averaging values will never be close to an actual metered value.  The draft-claise-energy-monitoring-mib has such a table based upon IEC 61850's demand measurement table.  It can be empty, since device that don't support kWh aren't required to implement it.

Existing Building Management Systems and Energy Management Systems already use the IEC 61850 data model, so by leveraging this model our data can be used and shared with these existing management systems.

When pmEnergyParametersIntervalMode = 'total' the table works as an odometer.

Regards,

Brad

From: Benoit Claise [mailto:[email-masked]]
Sent: Tuesday, August 02, 2011 11:07 AM
To: Brad Schoening
Cc: Michael Suchoff; John Parello (jparello); Juergen Quittek; Juergen Quittek; eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue 12.3:timeseries of energy/power values

Dear all,

Trying to combine all the different arguments (discussed on the mailing list and during the meeting), why do we have to have to specify which time series the EMAN standard must support as a pull model?

Why not have a generic requirement, such as:
The EMAN tandard must not limit time series (for example Power, Energy, Demand) to a pull mechanism; the push mechanism must be considered.

Regards, Benoit.

An energy time series is can be reported as an odometer reading.  I think you'll need to be adaptable to allow either an absolute value like instantaneous kW, kWh over a sample period or odometer sampling for kWh.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Michael Suchoff
Sent: Thursday, July 28, 2011 2:25 PM
To: John Parello (jparello); Juergen Quittek; Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue 12.3:timeseries of energy/power values

I would add current to the series as well.  Most AC devices presently don't have circuitry to report power or energy, they simply report AC current.  Also, for capacity planning, current is very useful (it is current that limits how many devices can be placed on an electrical branch circuit or PDU - not power).

Ideally, the time series would be structured as a table with the columns being measurements (i.e. column 1 = time stamp, 2 = power, 3 = energy, 4 = current, 5 = voltage, etc).  The columns could be partitioned into SNMP augmented tables (tables sharing same index).  This would allow easy addition of new columns for products that offer more information.

I don't see reason for demand as a special table.  Demand (watts) is easily computed from the energy readings.  For example, if kWh = 1000 at 1PM and kWh = 2000 at 1:15PM, then average power over the 15 minute interval is (2000kWh - 1000kWh) * 60minutes/15minutes = 4kW.  Doesn't it seem a lot simpler for management program to compute demand based on polled energy readings (i.e. a simple SQL query) - rather than having to write a procedure to configure the power agent to perform demand computations?

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of John Parello (jparello)
Sent: Thursday, July 28, 2011 2:06 PM
To: Juergen Quittek; Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue 12.3:timeseries of energy/power values

I don't see any reason to restrict to just power. IMO a series of power, energy, and demand is useful if a device can support it.

So no don't restrict it to just power and please allow series for power, demand, and energy

Jp

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: Wed 7/27/2011 7:13 AM
To: John Parello (jparello); Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue 12.3:time series of energy/power values

Hi John,

my Question was

Thanks,

    Juergen

On 26.07.11 18:10, "John Parello (jparello)" <[email-masked]><mailto:[email-masked]> wrote:

>> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of
>> Juergen Quittek

eman mailing list

[email-masked]<mailto:[email-masked]>

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 3 Aug 2011 09:05:51 +0000

Hi all,

Our current requirements just talk about reporting of time series.
They do not talk about pull or push and thus could be met with push only.
Of course pull only would also meet it.

Is there an explicit requirement for having pull or for having push
for time series of power and energy values? I don't see it.

Thanks,

    Juergen

On 02.08.11 17:07, "Benoit Claise" <[email-masked]> wrote:

>
>  
>  
>    Dear all,
>    
>    Trying to combine all the different arguments (discussed on the
>    mailing list and during the meeting), why do we have to have to
>    specify which time series the EMAN standard must support as a pull
>    model? 
>    
>    The EMAN tandard must not limit time series (for example Power,
>    Energy, Demand) to a pull mechanism; the push mechanism must be
>    considered.
>    
>    Regards, Benoit.
>    
>    
>      
>      
>      
>      RE: [eman] new revision of eman requirements - open issue
>        An
>            energy time series is can be reported as an odometer
>            reading.  I think you¹ll need to be adaptable to allow
>            either an absolute value like instantaneous kW, kWh over a
>            sample period or odometer sampling for kWh.
>         
>        
>          
>            From:
>                [email-masked] [mailto:[email-masked]] On
>                  Behalf Of Michael Suchoff
>                Subject: Re: [eman] new revision of eman
>                requirements - open issue 12.3:timeseries of
>                energy/power values
>          
>        
>         
>        I
>            would add current to the series as well.  Most AC devices
>            presently don¹t have circuitry to report power or energy,
>            they simply report AC current.  Also, for capacity planning,
>            current is very useful (it is current that limits how many
>            devices can be placed on an electrical branch circuit or PDU
>             not power).
>         
>        Ideally,
>            the time series would be structured as a table with the
>            columns being measurements (i.e. column 1 = time stamp, 2 =
>            power, 3 = energy, 4 = current, 5 = voltage, etc).  The
>            columns could be partitioned into SNMP augmented tables
>            (tables sharing same index).  This would allow easy addition
>            of new columns for products that offer more information.
>         
>        I
>            don¹t see reason for demand as a special table.  Demand
>            (watts) is easily computed from the energy readings.  For
>            example, if kWh = 1000 at 1PM and kWh = 2000 at 1:15PM, then
>            average power over the 15 minute interval is (2000kWh 
>            1000kWh) * 60minutes/15minutes = 4kW.  Doesn¹t it seem a lot
>            simpler for management program to compute demand based on
>            polled energy readings (i.e. a simple SQL query)  rather
>            than having to write a procedure to configure the power
>            agent to perform demand computations?
>         
>        
>          
>            ________________________________________
>
>          From:
>              [email-masked] [mailto:[email-masked]] On
>                Behalf Of John Parello (jparello)
>              Subject: Re: [eman] new revision of eman
>              requirements - open issue 12.3:timeseries of energy/power
>              values
>        
>         
>         
>        I
>            can't vote  no when there'sand or and more on the bill.
>            
>            I don't see any reason to restrict to just power. IMO a
>            series of power, energy, and demand is useful if a device
>            can support it.
>            
>            Subject: Re: [eman] new revision of eman requirements - open
>            issue 12.3:time series of energy/power values
>            
>            Hi John,
>            
>            my Question was
>            
>            On 26.07.11 18:10, "John Parello (jparello)"
>            <[email-masked]> <mailto:[email-masked]> wrote:
>            
>            >
>            >Hi Jeurgen,
>            >
>            >Please take a look at the
>            draft-claise-energy-monitoring-mib.  I think
>[email-masked]://www.ietf.org/mailman/listinfo/eman
>    
>
>    
>  
>

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 3 Aug 2011 11:18:49 +0200

Hi Brad,

It is interesting to receive explanations what the current version of the MIB module specifies. 

However, we are not reverse engineering our requirements from the draft of the MIB module. 
We are rather investigating the requirements first and will then specify the MIB module accordingly.

Thanks,

    Juergen

Am 03.08.2011 um 03:28 schrieb Brad Schoening:

> Energy & demand are an essential measurement of smart meters and similar devices.  It’s usually computed at the meter by sampling at the millisecond level.  Sampling kW by polling and then averaging values will never be close to an actual metered value.  The draft-claise-energy-monitoring-mib has such a table based upon IEC 61850’s demand measurement table.  It can be empty, since device that don’t support kWh aren’t required to implement it.
>  
> When pmEnergyParametersIntervalMode = ‘total’ the table works as an odometer.
>  
> Regards,
>  
> Brad
>  
> An energy time series is can be reported as an odometer reading.  I think you’ll need to be adaptable to allow either an absolute value like instantaneous kW, kWh over a sample period or odometer sampling for kWh.
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Suchoff
> I would add current to the series as well.  Most AC devices presently don’t have circuitry to report power or energy, they simply report AC current.  Also, for capacity planning, current is very useful (it is current that limits how many devices can be placed on an electrical branch circuit or PDU – not power).
>  
> I don’t see reason for demand as a special table.  Demand (watts) is easily computed from the energy readings.  For example, if kWh = 1000 at 1PM and kWh = 2000 at 1:15PM, then average power over the 15 minute interval is (2000kWh – 1000kWh) * 60minutes/15minutes = 4kW.  Doesn’t it seem a lot simpler for management program to compute demand based on polled energy readings (i.e. a simple SQL query) – rather than having to write a procedure to configure the power agent to perform demand computations?
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of John Parello (jparello)

---

From: Brad Schoening <[email-masked]>
Date: Wed, 3 Aug 2011 12:37:41 +0000

Hi Juergen,

Perhaps I wasn't clear, I was suggesting we consider the existing model for timeseries data as used in IEC 61850.  That is already widely used by both energy management systems and devices in the field such as revenue grade smart meters.

Regards,

Brad

From: Juergen Quittek [mailto:[email-masked]]
Sent: Wednesday, August 03, 2011 5:19 AM
To: Brad Schoening; eman mailing list
Cc: Benoit Claise; Michael Suchoff; John Parello (jparello); Juergen Quittek
Subject: Re: [eman] new revision of eman requirements - open issue 12.3:timeseries of energy/power values

Hi Brad,

Thanks,

    Juergen

Regards,

Brad

Dear all,

Regards, Benoit.

Jp

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: Wed 7/27/2011 7:13 AM
To: John Parello (jparello); Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue 12.3:time series of energy/power values

Hi John,

my Question was

Thanks,

    Juergen

eman mailing list

---

From: Juergen Quittek <[email-masked]>
Date: Wed, 3 Aug 2011 17:05:08 +0200

Hi Brad,

Am 03.08.2011 um 14:37 schrieb Brad Schoening:

> Hi Juergen,
>  
> Perhaps I wasn’t clear, I was suggesting we consider the existing model for timeseries data as used in IEC 61850.  That is already widely used by both energy management systems and devices in the field such as revenue grade smart meters.

OK. I understand. I am not against this time series data model, 
but I would like to make one more comment:

The implication you make:
    "IEC is 61850 commonly used"  => "the IEC 61850 timeseries data model is commonly used"
is not necessarily valid.

IEC 61850 is a series of document of which several are widely used. 
If some are it does not mean that all are widely used.
The time series model is specified in IEC 61850-7-4 ed. 2.0.
This has just been published a few months ago. 
I would not take it for granted that this is widely used already.

Thanks,

    Juergen

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 4 Aug 2011 15:28:51 -0700

+1 on this.

As per our charter we should be investigating existing standards. The
standard used by revenue grade meters around the world should be
examined.

Having time series of power (demand) which matches existing standards
used by a preponderance of utility meters should be a requirement.

Jp

From: Brad Schoening [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2011 6:29 PM
To: Benoit Claise (bclaise)
Cc: Michael Suchoff; John Parello (jparello); Juergen Quittek; Juergen
Quittek; eman mailing list
Subject: RE: [eman] new revision of eman requirements - open
issue12.3:timeseries of energy/power values

Energy & demand are an essential measurement of smart meters and similar
devices.  It's usually computed at the meter by sampling at the
millisecond level.  Sampling kW by polling and then averaging values
will never be close to an actual metered value.  The
draft-claise-energy-monitoring-mib has such a table based upon IEC
61850's demand measurement table.  It can be empty, since device that
don't support kWh aren't required to implement it.

Existing Building Management Systems and Energy Management Systems
already use the IEC 61850 data model, so by leveraging this model our
data can be used and shared with these existing management systems.

When pmEnergyParametersIntervalMode = 'total' the table works as an
odometer.

Regards,

Brad

From: Benoit Claise [mailto:[email-masked]] 
Sent: Tuesday, August 02, 2011 11:07 AM
To: Brad Schoening
Cc: Michael Suchoff; John Parello (jparello); Juergen Quittek; Juergen
Quittek; eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue
12.3:timeseries of energy/power values

Dear all,

Regards, Benoit.

An energy time series is can be reported as an odometer reading.  I
think you'll need to be adaptable to allow either an absolute value like
instantaneous kW, kWh over a sample period or odometer sampling for kWh.

Michael Suchoff

branch circuit or PDU - not power).

Ideally, the time series would be structured as a table with the columns
being measurements (i.e. column 1 = time stamp, 2 = power, 3 = energy, 4
= current, 5 = voltage, etc).  The columns could be partitioned into
SNMP augmented tables (tables sharing same index).  This would allow
easy addition of new columns for products that offer more information.

I don't see reason for demand as a special table.  Demand (watts) is
easily computed from the energy readings.  For example, if kWh = 1000 at
1PM and kWh = 2000 at 1:15PM, then average power over the 15 minute
interval is (2000kWh - 1000kWh) * 60minutes/15minutes = 4kW.  Doesn't it
seem a lot simpler for management program to compute demand based on
polled energy readings (i.e. a simple SQL query) - rather than having to
write a procedure to configure the power agent to perform demand
computations?

John Parello (jparello)

I don't see any reason to restrict to just power. IMO a series of power,
energy, and demand is useful if a device can support it.

So no don't restrict it to just power and please allow series for power,
demand, and energy

Jp

-----Original Message-----
From: Juergen Quittek [mailto:[email-masked]]
Sent: Wed 7/27/2011 7:13 AM
To: John Parello (jparello); Juergen Quittek
Cc: eman mailing list
Subject: Re: [eman] new revision of eman requirements - open issue

Hi John,

my Question was

"Do I understand right that you would support a requirement for
specifying
a standard for time series of power but not for time series of energy?"

I take you answer as a no. This would mean we keep both requirements
(time
series of power and time series of energy). Is this correct?

Thanks,

    Juergen

---

From: "Mielke, William F (Bill)" <[email-masked]>
Date: Mon, 15 Aug 2011 14:34:55 -0500

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Juergen Quittek
> 
> ...
>

>From my perspective I think that the fundamental requirement is that there must be a means of reporting time series data for power and/or energy values as measured at the device (and perhaps optionally some load and quality metrics as well).  Either a push or a pull mechanism can be used to satisfy this requirement.  I don't believe that there is a requirement to support specifically either one or both of these mechanisms.  I do believe, however, that there is value in having the framework and the MIBs specifying how each of these mechanisms (push or pull) should work IF a given device chooses to support them.

For Pull the mechanism is obvious and is nothing more that SNMP applied to a table of values defined by some MIB that we specify.

Push is less obvious given the state of SNMP.  IPFIX has been posited as a possible solution for Push and I don't have a problem with our articulating that as one possible solution for Push, possibly even the preferred solution, but I would like to keep the door open to alternatives in this case (but that is just my personal preference).

William F. Mielke
Alcatel-Lucent
Distinguished Member of Technical Staff
6200 East Broad Street
Room: 4B01-1V
Columbus, OH  43213-1530
Email: [email-masked]
Phone: 614 367 5628
Fax: 614 367 5965

"Live like you're going to die tomorrow.
 Learn like you're going to live forever."

    - Albert Einstein