Subject: [eman] Temperature

From: Bruce Nordman <[email-masked]>
Date: Mon, 10 Oct 2011 16:59:42 -0700

In the battery MIB, we enable reporting of temperature, since
temperature is an important indicator in assessing battery health.

For energy management, ambient temperature can affect the
energy required for many devices (particularly those that require
cooling or heating to maintain a satisfactory internal temperature)
so can be important to know.  In addition, large amounts of energy
are expended by buildings to maintain ambient room temperatures
within acceptable ranges, and many systems would benefit from
more building temperature data than they have.

Thus, it seems to me that adding a single optional temperature variable
to EMAN reporting for ambient temperature would be very useful
for energy management purposes.  The increasing number of devices
that have such internal sensors could then readily make this information
available to the EMS.  One prominent example is data centers so
this would be an appropriate use case to drive a requirement.

There may always be a need for dedicated temperature sensor
devices, but ones integrated into larger products will be cheaper
to purchase, install, and maintain, and so be more widely available.
The suggestion is NOT to support stand-alone sensors - only sensors
integral to a EMAN device.

Units would be Celsius.  Probably integral degrees is sufficient,
but certainly tenths of a degree would satisfy any ordinary use.

Proposal is for a single optional value only.

Comments?

--Bruce

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Ira McDonald <[email-masked]>
Date: Mon, 10 Oct 2011 21:27:34 -0400

Hi Bruce,

I like this simple ambient temperature element.

It's certainly relevant in hardcopy devices that have tight
limits on operational temperatures for their markers and
scanners.

It's also noteworthy that many off-the-shelf motherboards
will fry completely if operated much above their desired
ambient temperatures - dead devices are only energy
efficient in the most primitive sense...

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Oct 10, 2011 at 7:59 PM, Bruce Nordman <[email-masked]> wrote:

> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>
>

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 11 Oct 2011 05:35:01 +0000

Hi Bruce

I agree that adding optional temperature variables
to EMAN reporting for ambient temperature are useful for energy
management purposes.

I am not sure if only one variable is enough (e.g., set of average,
maximum, minimum values might be needed)!

Best regards,
Georgios

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 11 Oct 2011 13:07:11 -0700

I have in mind just a single ambient temperature value for the entire device
(not for components that is).  A management system could query the device
as often as it cares to track max, min, average, etc.

If someone else wants to propose *internal* temperatures, which would then
be appropriate by component, they can - but that is distinct from what I
have raised.

Thanks,

--Bruce

---

From: Ira McDonald <[email-masked]>
Date: Tue, 11 Oct 2011 16:45:53 -0400

Hi Bruce,

I agree - whole device ambient temperature - not internal
temperature at or near components (they have their own
operational sensors where needed in hardcopy devices).

Cheers,
- Ira

---

From: "William Wagner" <[email-masked]>
Date: Wed, 12 Oct 2011 12:23:20 -0400

Hi Bruce,

Your suggestion for including an ambient temperature variable brings up an
interesting point. As you observe, ambient temperature can affect the energy
required by a device (or in the case of batteries, energy available, as
those of us in the North can attest when starting cars in the winter).
However, the idea of using this variable to help temperature profile a
location, even when ambient temperature has little relation to the use of
the EMAN device itself, reflects a more "holistic" approach to energy
management. In considering whether to support this optional variable, it
would be useful to learn how much EMS providers would espouse such an
approach.

Thanks,

Bill Wagner

Co-Chair, IEEE-ISTO PWG  Workgroup for Imaging Management Solutions

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira
McDonald
Sent: Tuesday, October 11, 2011 4:46 PM
To: Bruce Nordman; Ira McDonald
Cc: eman mailing list
Subject: Re: [eman] Temperature

Hi Bruce,

Cheers,
- Ira

 <http://sites.google.com/site/blueroofmusic>
 <http://sites.google.com/site/highnorthinc>

If someone else wants to propose internal temperatures, which would then
be appropriate by component, they can - but that is distinct from what I
have raised.

Thanks,

--Bruce

On Mon, Oct 10, 2011 at 10:35 PM, Georgios Karagiannis
<[email-masked]> wrote:

Hi Bruce

Best regards,
Georgios

-- 
Bruce Nordman