Subject: Re: [eman] Remote facilities - EMAN

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Mon, 3 Oct 2011 02:42:05 -0500

Hi Elwyn,

Thanks for the use case on off-grid devices. It is definitely
interesting.

How are these devices connected to the network ? Only then it would be
possible to monitor or report power consumption of these devices. 

Thanks
Mouli

-----Original Message-----
From: Elwyn Davies [mailto:[email-masked]] 
Sent: Friday, September 30, 2011 2:39 PM
To: Bruce Nordman
Cc: Mouli Chandramouli (moulchan); [email-masked]
Subject: Re: Remote facilities - EMAN

Hi.

I have no problem with you editing down the text.  I probably got a bit
carried away anyway ;-)

You can't 'control' the 'grid' in this case either! The input is
entirely at the mercy of the weather.  Perhaps the difference here is
that the 'grid' output is very finite and variable.  This is arguably an
extension of the 'power quality' discussion in some recent emails.  

Section 2.9 speaks about battery powered/backed up devices.  I think
there is a bit more to it than the statements in the last para of s2.9.
The devices which I have been involved with use the energy management
system to control the availability of the consuming device with longer
term aims rather than just running the device and reporting when it is
going to run out of power.  This requires a rather more nuanced view of
the battery state and the scavenged power availability, possibly
together with controllable power consumption levels (e.g., turning
up/down processor speeds in computers).  Thus the use case is a
combination of the battery power and the demand/response cases, with
rather different drivers and optimization aims.  The description of the
power source and the battery state  are key inputs into the control
algorithm.

Regards,
Elwyn

On Thu, 2011-09-29 at 23:53 -0700, Bruce Nordman wrote:
> Elwyn--
> 
>   Hi.  This use case does seem perfectly in scope.  I do wonder
> though, if it is
> a new use case, or simply an annotation to one of the other ones.
> That is,
> in EMAN we don't speak of any coordination or communication with the
> grid, so the fact that you don't have a grid to talk to isn't changed.
>   That said, we do have a residential use case that is separate from
> the
> commercial one, even though no new requirements are introduced by it,
> so we are on the path of including such use cases.
> 
>   If this is included, could we edit down the text some, while
> retaining all
> the key points?
> 
>   Finally, what you have I would call a "Nanogrid" and I have a paper
> describing
> this on my web page.  I think that a local electricity price is what
> you need
> as a control mechanism.  This is not something EMAN is designed to do,
> but
> there is a draft on pricing from Cullen Jennings on myself proposing a
> simple
> price distribution protocol (key is for a forecast of future prices).
> 
>   Cheers,
> 
> --Bruce
> 
> On Thu, Sep 29, 2011 at 7:06 AM, Elwyn Davies <[email-masked]>
> wrote:
>         Hi, Mouli.
>         
>         Sorry for the late delivery.
>         
>         Text for Section 2 of the applicability draft (in xml2rfc
>         format which I
>         hope is useful):
>         
>
========================================================================
=
>         
>         <section title="Off-grid Devices">
>         
>         <t>
>         This use case concerns self-contained devices that use energy
>         but are
>         not connected to an infrastructure power delivery grid.  These
>         devices
>         typically scavenge energy from environmental sources such as
>         solar
>         energy or wind power.  The device generally contains a closely
>         coupled
>         combination of
>         <list style="symbols">
>         <t>
>         power scavenging or generation component(s)
>         </t>
>         <t>
>         power storage component(s) (e.g., battery)
>         </t>
>         <t>
>         power consuming component(s)
>         </t>
>         </list>
>         </t>
>         
>         <t>
>         With scavenged power, the energy input is often dependent on
>         the random
>         variations of the weather. These devices therefore require
>         energy
>         management both for internal control and remote reporting of
>         their state
>         and history.  In order to optimize the performance of these
>         devices and
>         minimize the costs of the generation and storage components,
>         it is
>         desirable to vary the activity level, and, hopefully, the
>         energy
>         requirements of the consuming components in order to make best
>         use of
>         the available stored and instaneously generated energy.  With
>         appropriate energy management, the overall device can be
>         optimized to
>         deliver an appropriate level of service without over
>         provisioning the
>         generation and storage components.
>         </t>
>         
>         <t>
>         In many cases these devices are expected to operate
>         autonomously, as
>         continuous communications for the purposes of remote control
>         is either
>         impossible or would result in excessive power consumption.
>          Whether or
>         not continuous monitoring is possible, it is essential that
>         the energy
>         management system provides reports of the behaviour of the
>         system in
>         order to demonstrate that the service requirements are being
>         met and to
>         allow the administrators to check that the sizing of the
>         generation and
>         storage capacity are adequate for the specified service duty
>         cycle given
>         the prevailing environmental conditions.
>         </t>
>         
>         <t>
>         Overall, the energy management system in an off-grid device
>         has to
>         ensure that the storage components remain healthy, limiting
>         the charge
>         and discharge so that damage is not caused and adequate energy
>         is
>         available to ensure that the management system itself can
>         remain active
>         at all times.  It may also be necessary to consider provision
>         of an
>         reserve that will allow the device to operate at full capacity
>         for a
>         brief time in the event of an emergency when it would normally
>         expect to
>         have powered down due to lack of energy.
>         </t>
>         
>         </section>
>         
>
=====================================================================
>         
>         Having read through the rest of the document, I don't think
>         there is any
>         change to Section 3 needed - the patterns cover this case I
>         believe.
>         
>         Regards,
>         Elwyn
>         
>

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 5 Oct 2011 09:37:48 -0700

Elwyn--
  I don't think any of EMAN speaks to communication with
or coordination with the grid, so being off-grid does not
in itself bring any new issues.  However, I think you do
or may raise points that should be considered for possible
new requirements and look forward to clarification of these.

  Does your use case describe a single device which
generates energy and uses it, or are you speaking to
a local microgrid which has both generation and
consumption, though in separate groups of devices?
  This relates to an assumption I have made about EMAN,
that it does model the power distribution topology (or at
least can) between devices, but does not (and can not)
do so within a device.  This is a key distinction between
an entire device and components within a device in what
is possible for reporting.
  In other use cases we have not considered electricity
generating devices as needing to be modeled.  It may be
that they are not modeled differently, and only report more
power going out than coming in, but noting that possibility
is important.
  I would encourage you to clarify what requirements you
see coming out of this use case that may not be covered
by the others.  One possibility is the generation angle as
above.  Another is the speed of operation as system
stability may require faster response times in this case
than in the grid-connected case.  Another could be modeling
a device whose sole function is storage, though it may be
that the EMAN battery MIB covers all that is needed.
  I do agree that local power distribution networks will
likely be early adopters of EMAN due to various constraints
on their operation not present in the generic case, whether
or not the local network is grid-connected.
  Thanks,
--Bruce

On Fri, Sep 30, 2011 at 2:09 AM, Elwyn Davies <[email-masked]> wrote:

> =========================================================================
> >

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 12 Oct 2011 13:21:06 +0200

Hi.

Looking at the open issues in the requirements draft and the temperature
discussion, I think there are a number of refinements in the
requirements, but AFAICS nothing actually new comes out of this scenario.

   1. Temperature... very useful to have in autonomous devices
      especially where they are deployed in arctice conditions where
      very low temperatures affect the effective storage capacity and
      the ability to charge.  Note that the temperature range must be
      signed and go down to something like -100 deg C.
   2. Power states... Autonomous devices are increasingly using low
      power chips (e.g., latest generations of Intel Atom) with highly
      controllable power levels.  There may even be continuum of states
      (clock speeds) rather than just a set of discrete states.  But at
      least a configurable set of states is needed.
   3. Power source DC output voltage... For solar cell sources this is
      the critical figure.  Both for monitoring and for battery charging
      circuitry to decide what to do. The output current would be nice
      to know also.
   4. Time series.. for an autonomous device that is only
      periodically/occasionally connected to the management station,
      time series are a vital resource.
   5. Inlet/Outlet Combinations... the battery management system in this
      kine of autonomous system is a prime example of this sort of
      inlet/outlet combination.  This will also be involved in
      controlling the power level of the powered device.

Regards,
Elwyn
> On Wed, Oct 5, 2011 at 9:37 AM, Bruce Nordman <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Elwyn--
>     On Fri, Sep 30, 2011 at 2:09 AM, Elwyn Davies <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Hi.
>
>         > On Thu, Sep 29, 2011 at 7:06 AM, Elwyn Davies
>         <[email-masked] <mailto:[email-masked]>>
>         > wrote:
>         >         Hi, Mouli.
>         >
>     eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
>     [email-masked]
>     510-486-7089 <tel:510-486-7089>
>     m: 510-501-7943 <tel:510-501-7943>
>
>
>
>
> -- 
> *Bruce Nordman*
> eetd.lbl.gov/ea/nordman <http://eetd.lbl.gov/ea/nordman>
> [email-masked]
> 510-486-7089
> m: 510-501-7943
>