Subject: [eman] entity/device type

From: Juergen Quittek <[email-masked]>
Date: Wed, 26 Oct 2011 17:53:33 +0000

Dear all,

Here comes another open issue of the requirements document:

Do we want to require that the EMAN standards suite provides means for reporting the type of a powered device or entity?

The issue has already been discussed on this list, but so far without resulting in rough consensus.

Thanks,

    Juergen

---

From: Ira McDonald <[email-masked]>
Date: Wed, 26 Oct 2011 14:33:55 -0400

Hi,

I suggest the answer is yes, we want device type.

But implementation as an unregistered site-specific string
seems largely useless.  That is, a router should be a
router, everywhere.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Oct 26, 2011 at 1:53 PM, Juergen Quittek <[email-masked]> wrote:

>  Do we want to require that the EMAN standards suite provides means for
> reporting the type of a powered device or entity?
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>
>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 26 Oct 2011 11:48:14 -0700

+1

I recall a thread on this from Bruce. Where I thought there was rough
consensus that we need type, species, instance information in the
context. So yes type is very necessary.

Jp

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ira McDonald
Sent: Wednesday, October 26, 2011 11:34 AM
To: Juergen Quittek; Ira McDonald
Cc: eman mailing list
Subject: Re: [eman] entity/device type

Hi,

Cheers,
- Ira

<http://sites.google.com/site/blueroofmusic> 
<http://sites.google.com/site/highnorthinc> 

On Wed, Oct 26, 2011 at 1:53 PM, Juergen Quittek <[email-masked]>
wrote:

Dear all,

The issue has already been discussed on this list, but so far without
resulting in rough consensus.

Thanks,

    Juergen

---

From: Benoit Claise <[email-masked]>
Date: Wed, 26 Oct 2011 22:47:45 +0200

Dear all,

I would question that this device type is a EMAN specific job!

Regards, Benoit.
> *From:[email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Ira McDonald
> *Sent:* Wednesday, October 26, 2011 11:34 AM
> *To:* Juergen Quittek; Ira McDonald
> *Cc:* eman mailing list
> *Subject:* Re: [eman] entity/device type
>
> Hi,
>
> mailto:[email-masked] <mailto:[email-masked]>
> On Wed, Oct 26, 2011 at 1:53 PM, Juergen Quittek <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> Dear all,
>
> [email-masked] <mailto:[email-masked]>

---

From: Ira McDonald <[email-masked]>
Date: Wed, 26 Oct 2011 17:42:05 -0400

Hi Benoit,

I agree - it's not EMAN's problem.

But I have yet to find the IETF MIB enumeration of common network
node types (router, bridge, etc.) - so I think it *is* EMAN's problem
(or at least an issue to ignore, but I don't like that approach).

Cheers,
- Ira

On Wed, Oct 26, 2011 at 4:47 PM, Benoit Claise <[email-masked]> wrote:

>  +1****
> ** **
> consensus that we need type, species, instance information in the context.
> So yes type is very necessary.****
>
> ** **
>
> Jp****
>
> ** **
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Ira McDonald
> *Subject:* Re: [eman] entity/device type****
>
> ** **
>
> Hi,
>
> Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434****
>
>
>
> ****
>
> wrote:****
> Dear all,****
> ** **
> Here comes another open issue of the requirements document:****
>
> ** **
>
> reporting the type of a powered device or entity?****
>
> ** **
>
> resulting in rough consensus.****
>
> ** **
>
> Thanks,****
>
> ** **
>
>     Juergen****
>
>
> https://www.ietf.org/mailman/listinfo/eman****
>
> ** **
>
>
> eman mailing [email-masked]://www.ietf.org/mailman/listinfo/eman
>
>
>

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Thu, 27 Oct 2011 01:41:14 -0500

Hi,

There was a long discussion on this topic before the last IETF. 

http://www.ietf.org/mail-archive/web/eman/current/msg00551.html

In my view, the intent of the requirement is identification/ description
of a device to be monitored analogous to Entity MIB 

entPhysicalDescr  - "A textual description of physical entity.  This
object

            should contain a string that identifies the manufacturer's

            name for the physical entity ..."

Enumeration of device type of all devices would not be an easy task and
perhaps not in scope of EMAN. 

Thanks

Mouli

 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ira McDonald
Sent: Thursday, October 27, 2011 3:12 AM
To: Benoit Claise (bclaise); Ira McDonald
Cc: eman mailing list
Subject: Re: [eman] entity/device type

Hi Benoit,

Cheers,
- Ira

On Wed, Oct 26, 2011 at 4:47 PM, Benoit Claise <[email-masked]>
wrote:

Dear all,

Regards, Benoit.

+1

Jp

Hi,

Cheers,
- Ira

Dear all,

Thanks,

    Juergen

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 27 Oct 2011 11:35:33 +0200

So what is wrong in using exactly the object in the Entity MIB?
(assuming the that WG reaches the consensus that the object is needed).
I do not think that we should go beyond a textual description. An
enumeration is problematic, one of the reasons being that it requires
strict definitions of 'router, bridge, etc.' - and these are only the
simplest examples. This is beyond the scope and maybe the expertise of
EMAN. 

Dan

(speaking as contributor). 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mouli Chandramouli (moulchan)
Sent: Thursday, October 27, 2011 8:41 AM
To: Ira McDonald; Benoit Claise (bclaise)
Cc: eman mailing list
Subject: Re: [eman] entity/device type

Hi,

Thanks

Mouli

 

Hi Benoit,

Cheers,
- Ira

Dear all,

Regards, Benoit.

+1

Jp

Hi,

Cheers,
- Ira

Dear all,

Thanks,

    Juergen

---

From: Bruce Nordman <[email-masked]>
Date: Thu, 27 Oct 2011 23:42:40 -0700

Yes - I presented the topic to OPSAWG in Prague:
   http://www.ietf.org/proceedings/80/opsarea.html
One result was that I used the term "identity" which
was problematic; I have shifted to "classification".

And, a few days ago I posted:
   https://datatracker.ietf.org/doc/draft-nordman-classification/
which I would like to raise in the APS area meeting
in Taipei.  I would much appreciate help with this.

Data that seem relevant are:
  Type: (e.g. router, computer, printer, refrigerator, ...
  Brand and Model
  Local name (human readable, arbitrary)
As Mouli notes, the model and local name already
exist in one or more MIBs, but "type" does not.

--Bruce

On Wed, Oct 26, 2011 at 11:48 AM, John Parello (jparello) <
[email-masked]> wrote:

> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Ira McDonald

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Benoit Claise <[email-masked]>
Date: Fri, 28 Oct 2011 09:06:31 +0200

Dear all,

Note that there is already a pointer to the entPhysIndex in the EMAN 
ENERGY AWARE MIB, if the ENTITY-MIB is supported.

Regards, Benoit.
> (assuming the that WG reaches the consensus that the object is 
> needed). I do not think that we should go beyond a textual 
> description. An enumeration is problematic, one of the reasons being 
> that it requires strict definitions of 'router, bridge, etc.' -- and 
> these are only the simplest examples. This is beyond the scope and 
> maybe the expertise of EMAN.
>
> Dan
>
> Of *Mouli Chandramouli (moulchan)
> *Sent:* Thursday, October 27, 2011 8:41 AM
> *To:* Ira McDonald; Benoit Claise (bclaise)
> *Cc:* eman mailing list
> In my view, the intent of the requirement is identification/ 
> description of a device to be monitored analogous to Entity MIB
>
> Enumeration of device type of all devices would not be an easy task 
> and perhaps not in scope of EMAN.
>
> Thanks
>
> Mouli
>
> *Sent:* Thursday, October 27, 2011 3:12 AM
> *To:* Benoit Claise (bclaise); Ira McDonald
> *Cc:* eman mailing list
> On Wed, Oct 26, 2011 at 4:47 PM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> Dear all,
>
> *From:[email-masked] <mailto:[email-masked]> 
> [mailto:[email-masked]] *On Behalf Of *Ira McDonald
> Winter  579 Park Place  Saline, MI  48176 734-944-0094 <tel:734-944-0094>
> Summer  PO Box 221  Grand Marais, MI 49839 906-494-2434 <tel:906-494-2434>
>