Subject: Re: [eman] Request to review ODVA document forElectricalCharacteristics

From: "John Parello (jparello)" <[email-masked]>
Date: Sat, 12 Nov 2011 11:34:44 -0800

Hi All,

I don't have the link form ODVA as yet on their standard definitions.
Waiting for a reply for the exact link.

My understanding  of Conditional is a field that may be present if an
optional field(s) were used. They typically footnote the conditional
fields with the exact criteria in the other drafts. So you'd see a field
Conditional with a footnote and the footnote would say "if optional
field a and b are present then this field must be present."

HTH!
Jp

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, October 27, 2011 3:37 AM
To: Mouli Chandramouli (moulchan); John Parello (jparello);
[email-masked]
Subject: RE: [eman] Request to review ODVA document
forElectricalCharacteristics

Thanks. Maybe John can help us with a clarification. I can guess that
Conditional = Mandatory If ... but better to make sure. 

Regards,

Dan

> -----Original Message-----
> From: Mouli Chandramouli (moulchan) [mailto:[email-masked]]
> Sent: Thursday, October 27, 2011 12:27 PM
> To: Romascanu, Dan (Dan); John Parello (jparello); [email-masked]
> Subject: RE: [eman] Request to review ODVA document 
> forElectricalCharacteristics
> 
> Hi Dan,
> 
> ODVA seems to have three thresholds - required, conditional and 
> optional.
> 
> The definitions of those terms are not provided in the document John 
> Parello has provided.
> 
> My guess is that as a requirement -   Optional is weaker than
> Conditional is weaker than required.
> 
> Thanks
> Mouli
> 
> -----Original Message-----
> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Thursday, October 27, 2011 3:34 PM
> To: Mouli Chandramouli (moulchan); John Parello (jparello); 
> [email-masked]
> Subject: RE: [eman] Request to review ODVA document 
> forElectricalCharacteristics
> 
> Hi Mouli,
> 
> What is the difference between 'optional' and 'conditional' in ODVA 
> terminology?
> 
> Thanks and Regards,
> 
> Dan
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
> > Mouli Chandramouli (moulchan)
> > Sent: Thursday, October 27, 2011 11:55 AM
> > To: John Parello (jparello); [email-masked]
> > Subject: Re: [eman] Request to review ODVA document 
> > forElectricalCharacteristics
> >
> > Thanks for sharing this document. The ODVA information model for 
> > measurement of power characteristics is relatively simple.
> >
> > In summary, there energy meters (directional) for total, reactive
and
> > apparent energy
> >
> > There are measurements for each phase of 3-phase AC
> > - Current
> > - Line to Neutral Voltage for every phase  - average Line to neutral

> > voltage
> > - Line to Line Voltage  - average Line to Line voltage
> > - Real Power  and Total real power
> > - Apparent Power
> > - Reactive Power
> > - Power Factor
> >
> > Almost all fields are optional - except - NetEnergyOdometer and 
> > TotalRealPower - are conditional
> >
> > The difference between EMAN information model and ODVA would be that

> > EMAN information model has more attributes.
> >
> > Thanks
> > Mouli
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
> > John Parello (jparello)
> > Sent: Wednesday, October 26, 2011 10:26 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: [eman] Request to review ODVA document for 
> > ElectricalCharacteristics
> >
> > Hi Chairs and Members
> >
> > As you know there has been a lot of conversation on defining the 
> > electrical characteristics (quality etc) for energy objects in the 
> > requirements and information models drafts.
> >
> > Simultaneous to our efforts, there is also considerable work going
on
> > at
> > the ODVA on the CIPSE-001-172 specification for energy management.
> The
> > working group there is ready to publish a public document in 
> > mid-November, which may fall after IETF-82
> >
> > Consequently, Katherine Voss from the ODVA has graciously allowed me
> to
> > publish an excerpt of a draft companion document for their 
> > specification which gives background on the work in progress. It is 
> > an excerpt of work in progress.
> >
> > You may not be aware but the working group for energy management at
> the
> > ODVA is composed of around a dozen individuals representing member 
> > organizations. Many of whom are also in the working group  SPC201P
at
> > ASHREA (http://spc201.ashraepcs.org/). In fact Rich Morgan the WG
> chair
> > for the ODVA energy group is a voting member of SPC201P. As you can 
> > imagine there is a lot of overlap in the work.
> >
> > In the attached excerpt there is a wonderful set of attributes for 
> > electrical characteristics which is apropos to our discussions. I've

> > also included some related points on non-electrical energy which I 
> > think this group ignores due to our inherent communication networks 
> > expertise.
> > I think these items are a concise set of values for electrical 
> > characteristics.
> >
> > EMAN would be greatly amiss to ignore the information model work
> >
> > For everyone on the list it's a good read in our problem domain. I
> urge
> > the chairs to ensure the authors of requirements  / information
model
> > drafts to review, merge and/or apply the information presented
herein
> > in
> > its entirety or at a minimum w.r.t electrical characteristics.
> >
> > Please see http://www.odva.org for more information and again many 
> > thanks to the ODVA and their WG.
> >
> > Jp
> >
> >
> > _______________________________________________
> > eman mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/eman

---

From: Benoit Claise <[email-masked]>
Date: Mon, 14 Nov 2011 16:57:11 +0800

Hi Mouli,
> In summary, there energy meters (directional) for total, reactive and
> apparent energy
>
I would like to make sure I understand this point.
1. Each attributes of the EMAN information model is consistent with the 
ODVA information model
     AND
2. The EMAN information model is a superset of the ODVA information model

Correct?

Regards, Benoit.
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> John Parello (jparello)
> Simultaneous to our efforts, there is also considerable work going on at
> the ODVA on the CIPSE-001-172 specification for energy management. The
> Consequently, Katherine Voss from the ODVA has graciously allowed me to
> publish an excerpt of a draft companion document for their specification
> which gives background on the work in progress. It is an excerpt of work
> in progress.
>
> You may not be aware but the working group for energy management at the
> organizations. Many of whom are also in the working group  SPC201P at
> ASHREA (http://spc201.ashraepcs.org/). In fact Rich Morgan the WG chair
> also included some related points on non-electrical energy which I think
> this group ignores due to our inherent communication networks expertise.
> For everyone on the list it's a good read in our problem domain. I urge
> the chairs to ensure the authors of requirements  / information model
> drafts to review, merge and/or apply the information presented herein in

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Mon, 14 Nov 2011 04:03:54 -0600

-----Original Message-----
From: Benoit Claise (bclaise) 
Sent: Monday, November 14, 2011 2:27 PM
To: Mouli Chandramouli (moulchan)
Cc: John Parello (jparello); [email-masked]
Subject: Re: [eman] Request to review ODVA document for

Hi Mouli,

... snip 

I would like to make sure I understand this point.
1. Each attributes of the EMAN information model is consistent with the 
ODVA information model
     AND
2. The EMAN information model is a superset of the ODVA information
model

Correct?

YCM>>> This comment was in the context of what are the important metrics
of power quality/characteristics that need to measured.
YCM>>> So, EMAN has more attributes than ODVA  in terms power
quality/characteristics (apparent power, reactive power, power factor,
....). 

YCM>>> The one big difference between ODVA and EMAN is the directional
meters (EnergyConsumed, Energy Produced, EnergyNEt) for measurement of
energy, 
YCM>>> which has been captured in the
draft-ietf-eman-energy-monitoring-mib-01 

Regards, Benoit.

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 15 Nov 2011 18:27:32 -0800

On Tue, Oct 25, 2011 at 9:56 PM, John Parello (jparello) <[email-masked]
> wrote:

> ...
> ...
John--

  Thanks much for sending this over.

  Is the detailed document mentioned in the 2nd paragraph on the 'ODVA
Vision'
the one to be release later in November?  Regardless, it sounds like that
would
be well worth our reviewing as well.

  Page 2 suggests that at this time they are only doing monitoring (1.) and
will address control (2.) and grid integration (3.) at a later time.  Is
that correct?

  Their energy values are positive for consumption and negative for
generation.
I think this makes sense.  What this implies is that entry of power into a
device
would be positive and that exiting of power to other devices would be
negative.
I realize that generation inside of a device has not been a priority for
any of us,
but a component that consumes negative energy would readily represent
internal generation within an EMAN device and so I think we implicitly cover
generation already.

  They speak to three basic energy values for an entire device: Consumed,
generated,
and net.  I think we should have a different three: Input, output, and net.

  I agree with their referencing odometers as an analogy to help people
understand
what an energy meter does (though the meter on the side of a building also
seems
like a good reference), but "odometer" is a meter for distance, not for
energy.
Seems like they should just say "energy meters".  No matter for us
regardless.

  I suppose that extending EMAN to other fuels should be something to
consider
for future EMAN work after our initial charter is finished.

--Bruce

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943