Subject: Re: [eman] Feedback regarding the EMAN monitoring

From: <[email-masked]>
Date: Thu, 24 Nov 2011 13:18:26 +0900

Hi, Benoit
cc  Mouli

Thank you for providing me with the opportunity to talk with you.
I enjoyed newcomer's meeting and had a good time with you.

Following are the minutes which we discuss about. 

1,
Discussion
  Why the following object is Counter64? 
  ・eoPowerStateEnterCount

Actions/Decisions      
  Ask Mouli.

2, 
Discussion
  How to update eoEnergyIntervalMaxConsumed(periodical).
  ・eoEnergyIntervalMaxConsumed is updated below (fig.2-A,2-B) in case eoEnergyParametersIntervalMode is period, 
　　 Would that be OK?
  ・Does eoEnergyParametersIntervalNumber indicate the number of intervals maintained in eoEnergyTable 
   such as fig.2-A and fig.2-B? 

      <condition>
      ・eoEnergyParametersIntervalMode   : period 
 　  　 ・eoEnergyIntervalStartTime        : see fig.1
      ・eoPowerIndex                     : 100
      ・eoEnergyParametersIntervalNumber : 3

          |             |             | =========== |
          |============ |             |             |
          |             |             |             |
  　   　　  |             |============ |             | ・・・・・
          |             |             |             |
          | <--- L ---> | <--- L ---> | <--- L ---> |
          |             |             |             |
         S1            S2            S3             S4 
             
         <fig.1> Period eoEnergyParametersIntervalMode

        eoPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     390     |      390
              100     |      －     |             |        0
              100     |      －     |             |        0
       --------------------------------------------------------
                                  ↓
        eoPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     390     |      390
              100     |      S2     |     380     |      380
              100     |      －     |       0     |        0
       --------------------------------------------------------
                                  ↓
        eoPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     390     |      390
              100     |      S2     |     380     |      380
              100     |      S3     |     420     |      420
       --------------------------------------------------------
                                  ↓
        eoPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S2     |     380     |      380
              100     |      S3     |     420     |      420
              100     |      S4     |     490     |      490
       --------------------------------------------------------
                                  
       <fig.2-A> The oldest measurement were not to be the maximum eoEnergyIntervalMaxConsumed.

        pmPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     490     |      490
              100     |      －     |       0     |        0
              100     |      －     |       0     |        0
       --------------------------------------------------------
                                  ↓
        pmPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     490     |      490
              100     |      S2     |     380     |      380
              100     |      －     |       0     |        0
       --------------------------------------------------------
                                  ↓
        pmPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     490     |      490
              100     |      S2     |     380     |      380
              100     |      S3     |     420     |      420
       --------------------------------------------------------
                                  ↓
        pmPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       --------------------------------------------------------
              100     |      S1     |     490     |      490
              100     |      S3     |     420     |      420
              100     |      S4     |     390     |      390
       --------------------------------------------------------
                                  
       <fig.2-B> The oldest measurement were to be the maximum eoEnergyIntervalMaxConsumed. 

Actions/Decisions      
  ・eoEnergyIntervalMaxConsumed is updated below (fig.2-A,2-B) in case eoEnergyParametersIntervalMode is period, 
　　 Would that be OK?
  → Yes
  ・Does eoEnergyParametersIntervalNumber indicate the number of intervals maintained in eoEnergyTable 
   such as fig.2-A and fig.2-B?
  → Yes

3,
Discussion
  How to update eoEnergyIntervalMaxConsumed(total).
　　・eoEnergyIntervalMaxConsumed is updated below (fig.4) in case eoEnergyParametersIntervalMode is total, 
　　　Would that be OK?
　 ・Does eoEnergyIntervalMaxConsumed have an entry in the eoEnergyTable when eoEnergyIntervalMode is total? 　　
  ・Besides, the value of eoEnergyIntervalMaxConsumed equals to that of eoEnergyIntervalEnergyConsumed?   　 
 　
      <condition>
      ・eoEnergyParametersIntervalMode   : total 
 　　   ・eoEnergyIntervalStartTime        : see fig.3
      ・eoPowerIndex                     : 100
      ・eoEnergyParametersIntervalNumber : 1

        |                          |
        |========================= |
        |                          |
        |                          |
        |                          |
        |  <--- Total length --->  |
        |                          |
        S1
             
        <fig.3> Total eoEnergyParametersIntervalMode

        pmPowerIndex  |  StartTime  | MaxConsumed |  EnergyCons  
       ---------------------------------------------------------
              100     |      S1     |   11,290    |    11,290
       ---------------------------------------------------------

        <fig.4> Updating the eoEnergyIntervalMaxConsumed when Mode is total. 

Actions/Decisions  
　　・eoEnergyIntervalMaxConsumed is updated below (fig.4) in case eoEnergyParametersIntervalMode is total, 
　　　Would that be OK?
  → Yes
　 ・Does eoEnergyIntervalMaxConsumed have an entry in the eoEnergyTable when eoEnergyIntervalMode is total? 　　
  → Yes
  ・Besides, the value of eoEnergyIntervalMaxConsumed equals to that of eoEnergyIntervalEnergyConsumed?  
  → Yes

4,
Discussion
  MIBObject has a tabel missing.  
  ・"energyObjectMibObjects 3" can be non-existent?      
  
     eoPowerStateTable OBJECT-TYPE
      ::= { energyObjectMibObjects 2 }

     eoEnergyParametersTable OBJECT-TYPE
      ::= { energyObjectMibObjects 4 }.

  eoPowerStateEntry has a object missing.
  ・"eoPowerStateEntry 2" can be non-existent?

     eoPowerStateIndex OBJECT-TYPE
      ::= { eoPowerStateEntry 1 }

     eoPowerStateMaxPower OBJECT-TYPE
      ::= { eoPowerStateEntry 3 }

Actions/Decisions 
  Yes, both of them are mistakes.
  Mouli shall correct those texts. 

5,
Discussion
  eoEnergyTable about when Read-Create objects are modified.
  ・An Object whose syntax is Read-Create such as eoEnergyParametersIntervalLength is changed by snmp manager,
   eoEnergyTable is reset once?     

Actions/Decisions
  maybe yes,
　　Confirm to mouli.

6,
Discussion
  Power State about whole chassis.
　　・Following case, How do I define Power State of whole chassis?  
  
   - whole chassis includes two line cards. 
   - each of line cards is different Power State, such as high(Power on) and sleep(Power off).
  
Actions/Decisions
  It's depends on implementation.

Best regards, 
Hiroto

---------------------------------
 Hiroto Ogaki 
 ALAXALA Networks, Corp.
 E-mail:[email-masked]
 URL:http://www.alaxala.com
---------------------------------

>Hiroto-san,
>
>As we discussed, can you please post your feedback on the list.
>
>Regards, Benoit.
>

---

From: <[email-masked]>
Date: Thu, 24 Nov 2011 13:32:20 +0900

Re-forwarding because of correcting encording.
--

Hi, Benoit
cc  Mouli

1,
Discussion

Actions/Decisions      
  Ask Mouli.

2, 
Discussion

      <condition>

          |             |             | =========== |
          |============ |             |             |
          |             |             |             |

              100     |      −     |             |        0
              100     |      −     |             |        0
              100     |      −     |       0     |        0

              100     |      −     |       0     |        0
              100     |      −     |       0     |        0
              100     |      −     |       0     |        0

Actions/Decisions      

3,
Discussion
 　
      <condition>

        |                          |

Actions/Decisions  

4,
Discussion

Actions/Decisions 

5,
Discussion

Actions/Decisions
  maybe yes,
　Confirm to mouli.

6,
Discussion

Actions/Decisions

Best regards, 
Hiroto