Subject: Re: [eman] draft-ietf-eman-energy-monitoring-mib-01.txt

From: <[email-masked]>
Date: Fri, 11 Nov 2011 17:16:26 +0900

Hi Mouli,

I have some comments on the draft draft-ietf-eman-energy-monitoring-mib-01.

>      5. Architecture Concepts Applied to the MIB Module
<snip>
>         The energyObjectMib MIB module consists of four tables.  The
>         first table eoPowerTable is indexed by eoPowerIndex. The second
>         table eoPowerStateTable indexed by eoPowerIndex,and
>         eoPowerStateIndex. . The eoEnergyParametersTable and
>         eoEnergyTable are indexed by eoPowerIndex.

Is only a main index written here? If so, it's no problem.
Strictly speaking, I assume that eoEnergyTable has other indices such as
'StartTime', 'IntervalMode'.

<snip>
>           +eoEnergyTable(1)
>           +---eoEnergyEntry(1) [eoPowerIndex]
>           |
>           |   +-- r-n TimeInterval  eoEnergyIntervalStartTime (1)
>           |   +-- r-n Integer32     eoEnergyIntervalEnergyConsumed (2)
>           |   +-- r-n Integer32     eoEnergyIntervalEnergyProduced (3)
>           |   +-- r-n Integer32     eoEnergyIntervalEnergyNet (4)
>           |   +-- r-n UnitMultiplier
>           |                eoEnergyIntervalEnergyUnitMultiplier (5)
>           |   +-- r-n Integer32     eoEnergyIntervalEnergyAccuracy(6)
>           |   +-- r-n Integer32     eoEnergyIntervalMaxConsumed (7)
>           |   +-- r-n Integer32     eoEnergyIntervalMaxProduced (8)
>           |   +-- r-n TimeTicks
>           |                   eoEnergyIntervalDiscontinuityTime(9)
>           |   +-- r-n RowStatus     eoEnergyParametersStatus (10)

The eoEnergyParametersStatus may be unnecessary here.

>        eoEnergyTable OBJECT-TYPE
>            SYNTAX          SEQUENCE OF EoEnergyIntervalEntry
>            MAX-ACCESS      not-accessible
>            STATUS          current
>            DESCRIPTION
>               "This table lists Energy Object energy measurements.
>               Entries in this table are only created if the
>               corresponding value of object eoPowerMeasurementCaliber
>               is active(2), i.e., if the power is actually metered."

actual(3)?

>         eoEnergyParametersEntry OBJECT-TYPE
>             SYNTAX          EoEnergyParametersEntry
>             MAX-ACCESS      not-accessible
>             STATUS          current
>             DESCRIPTION
>                "An entry controls an energy measurement in
>                eoEnergyTable."
>             INDEX  { eoPowerIndex }
<snip>
>         eoEnergyIntervalEntry OBJECT-TYPE
>             SYNTAX          EoEnergyIntervalEntry
>             MAX-ACCESS      not-accessible
>             STATUS          current
>             DESCRIPTION
>                 "An entry describing energy measurements."
>             INDEX  { eoPowerIndex, eoEnergyParametersIntervalMode,
>         eoEnergyIntervalStartTime }

I agree to using period(1) and total(3) at the same time.
When eoEnergyTable has multiple entries that are the same eoPowerIndex
and different eoEnergyParametersIntervalMode, eoEnergyParametersTable
would need to have another index.  Is my understanding correct?

Best regards,
Minoru

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Mouli Chandramouli (moulchan)
> Sent: Tuesday, November 01, 2011 3:29 AM
> To: [email-masked]
> Subject: [eman] draft-ietf-eman-energy-monitoring-mib-01.txt
> 
> Hello all,
> 
> A new version of the Monitoring MIB has been submitted.
> 
> http://tools.ietf.org/html/draft-ietf-eman-energy-monitoring-mib-01
> 
> 
> 
> Firstly, the definitions and terminology are consistent with
> http://tools.ietf.org/rfcdiff?url2=draft-parello-eman-definitions-03
> 
> 
> The prefix of the MIB variables have been revised -'eo' instead of 'pm'.
> 
> Juergen Schoenwaelder's proposal for the textual convention for Power
> State Sets has used adopted
> based on feedback from the mailing list.  IANA considerations section
> updated.
> 
> Directional meters for measurement have been added analogous to the ODVA
> model.
> 
> http://www.ietf.org/mail-archive/web/eman/current/msg00888.html
> 
> 
> Open Issues section has been updated and (we have addressed some of the
> comments from the list).
> Still some open issues remain.
> 
> Many thanks to Juergen Schoenwaelder, Ira McDonald, Michael Suchoff,
> William Meilke Mielke for the comments.
> 
> 
> Feedback from the WG welcome.
> 
> Thanks
> Benoit, Brad, Juergen, Thomas and Mouli
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, October 31, 2011 6:15 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [eman] I-D Action: draft-ietf-eman-energy-monitoring-mib-01.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Energy Management Working
> Group of the IETF.
> 
> 	Title           : Power and Energy Monitoring MIB
> 	Author(s)       : Mouli Chandramouli
>                           Brad Schoening
>                           Juergen Quittek
>                           Thomas Dietz
>                           Benoit Claise
> 	Filename        : draft-ietf-eman-energy-monitoring-mib-01.txt
> 	Pages           : 77
> 	Date            : 2011-10-31
> 
>         This document defines a subset of the Management Information
>         Base (MIB) for power and energy monitoring of devices.
> 
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-eman-energy-monitoring-
> mi
> b-01.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-eman-energy-monitoring-m
> ib
> -01.txt
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Mon, 14 Nov 2011 20:59:22 -0600

Hi Minoru,

Thanks for reviewing the draft and your comments. 

Mouli

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] 
Sent: Friday, November 11, 2011 1:46 PM
To: Mouli Chandramouli (moulchan); [email-masked]
Subject: RE: draft-ietf-eman-energy-monitoring-mib-01.txt

Hi Mouli,

I have some comments on the draft
draft-ietf-eman-energy-monitoring-mib-01.

<snip>

YCM>>> Yes, you are right, we shall correct this text. 

<snip>
>           +---eoEnergyEntry(1) [eoPowerIndex]

YCM>>> Thanks for catching this, shall be corrected.

actual(3)?

YCM>>>  Thanks for catching this. Shall be correct.

<snip>

YCM>>>> Right now, energy measurement collection is either periodic (1)
or sliding (2) or total (3). 
YCM>>>  Do we need multiple windowing schemes at the same time for
measurement of energy ? 
YCM>>>  If there is a need, then, we need to have one more index. 

Best regards,
Minoru

Thanks
Mouli

> Subject: [eman] I-D Action:
draft-ietf-eman-energy-monitoring-mib-01.txt