Subject: [eman] I-D Action: draft-ietf-eman-rfc4133bis-00.txt

From: [email-masked]
Date: Mon, 17 Sep 2012 08:12:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Energy Management Working Group of the IETF.

	Title           : Entity MIB (Version 4)
	Author(s)       : Andy Bierman
                          Dan Romascanu
                          Juergen Quittek
                          Mouli Chandramouli
	Filename        : draft-ietf-eman-rfc4133bis-00.txt
	Pages           : 68
	Date            : 2012-09-17

Abstract:
This memo defines a portion of the Management Information Base (MIB) for
use with network management protocols in the Internet community.  In
particular, it describes managed objects used for managing multiple
logical and physical entities managed by a single SNMP agent. This
document specifies version of the Entity MIB, which obsoletes version 3
[RFC4133].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-eman-rfc4133bis

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-eman-rfc4133bis-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Mon, 17 Sep 2012 17:20:15 +0000

Hello all,

Here is the updated version rfc4133bis draft.  

The changes from the previous version are: 

1.  added a new MIB object - entPhysicalUUID  - based on WG consensus.  

2.  IANA considerations section for entPhysicalClass is included 

3.  Now, the draft is a EMAN WG item 

Please let us know if you have comments.

Thanks
Mouli
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 17, 2012 8:43 PM
To: [email-masked]
Cc: [email-masked]
Subject: [eman] I-D Action: draft-ietf-eman-rfc4133bis-00.txt

Abstract:

_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: Nevil Brownlee <[email-masked]>
Date: Tue, 25 Sep 2012 17:50:00 +1200

Hi Moiuli:

Great to see this, thank-you.

I spotted one typo, on page 48:  in the text
   The enumeration 'energyObjec' is applicable if the
     shouldn;t that be 'energyObject'  ?

Also, looking back at our Vancouver minutes, they said
   . add a new MIB oid specifically for UUID,
       instead of reusing the ENTITY-MIB URI OID
   . repeat that there is persistence,
       even if it's implicit from RFC4122
The new version certainly has the UUID OID, but I couldn't
find anything said about persistence.

Could you have a look at that, and publish a new version of the draft,
please?  With that done, I'll start the WG Last Call for this draft.

Cheers, Nevil

-- 
---------------------------------------------------------------------
  Nevil Brownlee                    Computer Science Department | ITS
  Phone: +64 9 373 7599 x88941             The University of Auckland
  FAX: +64 9 373 7453   Private Bag 92019, Auckland 1142, New Zealand

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 25 Sep 2012 09:50:02 +0200

Hi Nevil,

Do you (or somebody else) remember what the persistence issue exactly
was? The newly created object entPhysicalUUID is read-only, so that
there can be no issue with persistence. 

Regards,

Dan

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Nevil Brownlee
> Sent: Tuesday, September 25, 2012 7:50 AM
> To: Mouli Chandramouli (moulchan)
> Cc: [email-masked]
> Subject: Re: [eman] I-D Action: draft-ietf-eman-rfc4133bis-00.txt
> 
> 
> Hi Moiuli:
> 
>        even if it's implicit from RFC4122 The new version certainly
has
> the UUID OID, but I couldn't find anything said about persistence.
> 
> >   This draft is a work item of the Energy Management Working Group
of
> the IETF.
> > This memo defines a portion of the Management Information Base (MIB)
> > for use with network management protocols in the Internet community.
> > In particular, it describes managed objects used for managing
multiple
> > document specifies version of the Entity MIB, which obsoletes
version
> > 3 [RFC4133].

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Tue, 25 Sep 2012 09:04:20 +0000

Hi Dan and Nevil, 

The way I understood - persistence of UUID - discussion was that 

RFC 4122 has persistence specified already and as long as the new MIB object entPhysicalUUID conforms to RFC 4122, persistence should be automatically obtained. 

Currently, the description clause of entPhysicalUUID contains that text. 

Please let us know if you have any suggestions. 

Thanks
Mouli 

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Tuesday, September 25, 2012 1:20 PM
To: Nevil Brownlee; Mouli Chandramouli (moulchan)
Cc: [email-masked]
Subject: RE: [eman] I-D Action: draft-ietf-eman-rfc4133bis-00.txt

Hi Nevil,

Regards,

Dan

Of
has
> > Of [email-masked]
of
multiple
version

---

From: Nevil Brownlee <[email-masked]>
Date: Thu, 27 Sep 2012 10:44:19 +1200

Hi Mouli:

Yes, that's how I remember it too.  Since 1433bis now defines
entPhysicalUUID as a read-only object, we have answered that question.

Would you and Juergen now publish a new revision with Juergen's
suggested TC and its MIB included, please?

Once that's published we can start its WG Last Call.

Cheers, Nevil

On 25/09/12 9:04 PM, Mouli Chandramouli (moulchan) wrote:
> RFC 4122 has persistence specified already and as long as the new MIB
> object entPhysicalUUID conforms to RFC 4122, persistence should be
> automatically obtained.
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 27 Sep 2012 10:05:57 +0200

I will update the MIB modules including the one with the new TC
suggested by Juergen. 

Regards,

Dan

> From: Nevil Brownlee [mailto:[email-masked]]
> Sent: Thursday, September 27, 2012 12:44 AM
> Cc: Romascanu, Dan (Dan); [email-masked]
> >> Could you have a look at that, and publish a new version of the
> >> draft, please?  With that done, I'll start the WG Last Call for
this
> draft.