Subject: [eman] #36: Consider whether MeteredBy relationship is needed

From: "eman issue tracker" <[email-masked]>
Date: Thu, 23 May 2013 20:00:05 -0000

#36: Consider whether MeteredBy relationship is needed

 EMAN requirements seem to be met by
 PoweredBy relationship so unnecessary
 to add MeteredBy.

-- 
------------------------------+-------------------
 Reporter:  [email-masked]  |      Owner:  Bruce
     Type:  defect            |     Status:  new
 Priority:  major             |  Milestone:
Component:  framework         |    Version:
 Severity:  -                 |   Keywords:
------------------------------+-------------------

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/36>
eman <http://tools.ietf.org/eman/>

---

From: "eman issue tracker" <[email-masked]>
Date: Thu, 23 May 2013 20:49:17 -0000

Comment (by [email-masked]):

 Sub-meters almost never provide power.  So, MeteredBy is required to
 support submeters.  Q.E.D.

-- 
------------------------------+--------------------
 Reporter:  [email-masked]  |       Owner:  Bruce
     Type:  defect            |      Status:  new
 Priority:  major             |   Milestone:
Component:  framework         |     Version:
 Severity:  -                 |  Resolution:
 Keywords:                    |
------------------------------+--------------------

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/36#comment:1>
eman <http://tools.ietf.org/eman/>

---

From: Bruce Nordman <[email-masked]>
Date: Fri, 24 May 2013 16:08:19 -0700

Per the framework (4.1) - "A meter is a type of device and any device can
perform metering."
There is no separate type of entity that is a meter.
Thus, metered-by is indicating that there is a direct (one-hop) or indirect
(multi-hop)
powered-by relationship from the end device to the metering device so it is
an
elaboration of powered-by, not something with distinct meaning.
The other relationships are distinct from powered-by; only
metering is duplicative.
--Bruce

On Thu, May 23, 2013 at 1:49 PM, eman issue tracker <
[email-masked]> wrote:

> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
*nordman.lbl.gov*
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "John Parello (jparello)" <[email-masked]>
Date: Sun, 26 May 2013 21:10:53 +0000

Metering in not duplicative of powering. It's analogous to layer 3 and layer 2 topologies respectively.

whether a meter is a type,of device device or any device can perform metering has nothing to do with the topologies between devices.

So as stated 4.1 is not a reason to drop a layer 3 topology feature in preference to a layer 2 topology. In fact such a feature it has nothing to do with it 4.1

Jp

Sent from my iPad
(expect ridiculous spelling mistakes)

On May 24, 2013, at 4:08 PM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

Per the framework (4.1) - "A meter is a type of device and any device can perform metering."
There is no separate type of entity that is a meter.
Thus, metered-by is indicating that there is a direct (one-hop) or indirect (multi-hop)
powered-by relationship from the end device to the metering device so it is
elaboration of powered-by, not something with distinct meaning.
The other relationships are distinct from powered-by; only
metering is duplicative.
--Bruce

On Thu, May 23, 2013 at 1:49 PM, eman issue tracker <[email-masked]<mailto:[email-masked]>> wrote:
#36: Consider whether MeteredBy relationship is needed

Comment (by [email-masked]<mailto:[email-masked]>):

 Reporter:  [email-masked]<mailto:[email-masked]>  |       Owner:  Bruce

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
nordman.lbl.gov<http://nordman.lbl.gov>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943
_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

---

From: Bruce Nordman <[email-masked]>
Date: Mon, 27 May 2013 21:22:13 -0700

Specifying that the the dedicated meter functionality you describe
is at a layer above the basic EMAN one of devices reporting about
themselves or devices they are connected to is intriguing, and one
I am quite sympathetic to, as a lot of system architectures these days
lack a good sense of layering and so become overly complex.

This approach to a meter seems to then be properly part of an Energy
Management System that used EMAN and not part of the EMAN
protocol itself.

In re-reviewing the Requirements document, I can't find reference to
dedicated meters as are being described here in a way that would
suggest that any special EMAN content is needed.  I do think it would be
helpful to have a document describing EMS functions and how they
use EMAN and what else they do.  That seems like the right place
for this dedicated meter proposal.

It does seem clear that at the EMAN layer, the variety of energy
objects that we have - devices, components, and power interfaces -
are sufficient to fully implement it.

Thanks,

--Bruce

On Sun, May 26, 2013 at 2:10 PM, John Parello (jparello) <[email-masked]
> wrote:

>  whether a meter is a type,of device device or any device can perform
> metering has nothing to do with the topologies between devices.
>
>  So as stated 4.1 is not a reason to drop a layer 3 topology feature in
> preference to a layer 2 topology. In fact such a feature it has nothing to
> do with it 4.1
>
>  Jp
>
>
> Sent from my iPad
> On May 24, 2013, at 4:08 PM, "Bruce Nordman" <[email-masked]> wrote:
>

---

From: "eman issue tracker" <[email-masked]>
Date: Wed, 29 May 2013 13:38:56 -0000

Other standards groups view !MeterBy and !PoweredBy as distinct logical
 functions.  For example, NIST Framework and Roadmap for Smart Grid
 Interoperability Standards, Release 1.0 states:

 3.5.1 Distinction between the Meter and the Energy Services Interface

     The meter and the ESI (Energy Services Interface) have very different
 characteristics and functions. The logical separation of the meter and the
 ESI is a very important forward-looking aspect of the reference model.
     ..
     While the ESI and meter are logically viewed as separate devices, this
 does not preclude the
     possibility for manufacturers to implement the meter and ESI in one
 physical device, provided
     that the flexibility and extensibility to support the Smart Grid
 vision can be achieved. Most smart
     meters currently integrate the ESI and meter functionality in one
 device due to cost
     considerations. Looking forward, logical separation of the two
 functions, even if physically
     integrated, is essential to avoid having the meter become an
 impediment to innovation in energy
     services enabled by the Smart Grid."

 Full Text here:
 http://www.nist.gov/public_affairs/releases/upload/smartgrid_interoperability_final.pdf

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/36#comment:2>
eman <http://tools.ietf.org/eman/>

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 29 May 2013 21:12:03 -0700

I don't follow why the ESI would be relevant to EMAN.
EMAN does not address coordination with the grid as
many standards do.  Standards designed for grid
coordination (e.g. the FSGIM) have different purposes
than EMAN and different fundamental models.  The
question at hand is what EMAN needs.
--Bruce

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 30 May 2013 15:50:16 +0000

Hi Bruce,

I'm not sure what you mean by EMAN protocol?
What protocol are you referring to?

We mention snmp then building protocols in the framework draft but we stated we are protocol agnostic. Is there some other draft we should be looking at?

Jp

Sent from my iPad

On May 27, 2013, at 9:22 PM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

--Bruce

On Sun, May 26, 2013 at 2:10 PM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Metering in not duplicative of powering. It's analogous to layer 3 and layer 2 topologies respectively.

Jp

Sent from my iPad

--
Bruce Nordman
Lawrence Berkeley National Laboratory
nordman.lbl.gov<http://nordman.lbl.gov>
[email-masked]<mailto:[email-masked]>
510-486-7089<tel:510-486-7089>
m: 510-501-7943<tel:510-501-7943>
_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

---

From: Bruce Nordman <[email-masked]>
Date: Thu, 30 May 2013 08:58:26 -0700

I am referencing the data model that
EMAN specifies -- the content in the EMAN
documents.  I was using protocol in a generic
sense but can use a different term if you prefer.
--Bruce

On Thu, May 30, 2013 at 8:50 AM, John Parello (jparello) <[email-masked]

>  We mention snmp then building protocols in the framework draft but we
> stated we are protocol agnostic. Is there some other draft we should be
> looking at?
>
>  Jp
>
> Sent from my iPad
> On May 27, 2013, at 9:22 PM, "Bruce Nordman" <[email-masked]> wrote:
>
> On Sun, May 26, 2013 at 2:10 PM, John Parello (jparello) <
> [email-masked]> wrote:
>
>>> Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/36#comment:1
>>> >

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 30 May 2013 22:18:16 +0000

Hi Bruce,

Ok thanks. Well "protocol" even in a general sense doesn't mean" information model" or "data model."

For the framework we are not specifying a data model either, we are specifying an information model. So when you said protocol and meant data model I hope you meant information model.

I'll re-read assuming you meant information model for but reference please see
http://www.ietf.org/rfc/rfc3444.txt which summarizes nicely.

Jp

Sent from my iPad

On May 30, 2013, at 8:58 AM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

On Thu, May 30, 2013 at 8:50 AM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bruce,

Jp

Sent from my iPad

Thanks,

--Bruce

Jp

Sent from my iPad

---

From: "John Parello (jparello)" <[email-masked]>
Date: Thu, 30 May 2013 22:32:50 +0000

Hi Bruce,

Yes, We are not chartered to specify coordination with the grid which would be a protocol. FSGIM  (201p) from ashrae most certainly specifies information models not just for the grid but for facility devices as well so you are mistaken there.

I think you confused protocol and information models again.

We are chartered for models for device management and we would be amiss not to model information that ultimately would be used by EnMS' and grid coordination systems (load summaries)

 I find Brad's reference quite relevant. Both our existing taget EnMS users (with running code) and  the quote he sites suggest imminent need for modeling relationships between devices for power and metering.

Also we've recognized the need for power, metering and aggregation topologies prior to the draft of the requirements. So if your are citing that as missing from the requirements I think you've uncovered an error in the requirements not a justification for removing information models pertaining to relationships between devices.

Are you suggesting we remove power, metering, and aggregation topology modeling?

Jp

Sent from my iPad

On May 29, 2013, at 9:12 PM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, May 29, 2013 at 6:38 AM, eman issue tracker <[email-masked]<mailto:[email-masked]>> wrote:
#36: Consider whether MeteredBy relationship is needed

 Full Text here: