Subject: Re: [eman] #36: Consider whether MeteredBy relationship is needed

From: Bruce Nordman <[email-masked]>
Date: Sun, 2 Jun 2013 23:11:14 -0700

Jon--

You brought aggregation to this discussion -- I did not do so and do
not see it as directly connected to powering/measurement.

I am not sure what you see as missing from the requirements.

You mention removing powering and metering topology modeling.
I never suggested this.  I did observe that there is one topology
of power flows and so Powered-By and Metered-By address
the same issue so redundant to have both.  We can
have a simpler structure which meets our needs which is
only good news

Thanks,

--Bruce

On Thu, May 30, 2013 at 3:32 PM, John Parello (jparello) <[email-masked]
> wrote:

>  Hi Bruce,
>
>  Yes, We are not chartered to specify coordination with the grid which
> would be a protocol. FSGIM  (201p) from ashrae most certainly specifies
> information models not just for the grid but for facility devices as well
> so you are mistaken there.
>
>  I think you confused protocol and information models again.
>
>  We are chartered for models for device management and we would be amiss
> not to model information that ultimately would be used by EnMS' and grid
> coordination systems (load summaries)
>
>   I find Brad's reference quite relevant. Both our existing taget EnMS
> users (with running code) and  the quote he sites suggest imminent need for
> modeling relationships between devices for power and metering.
>
>  Also we've recognized the need for power, metering and aggregation
> topologies prior to the draft of the requirements. So if your are citing
> that as missing from the requirements I think you've uncovered an error in
> the requirements not a justification for removing information models
> pertaining to relationships between devices.
>

>  Are you suggesting we remove power, metering, and aggregation topology
> modeling?
>

>  Jp
>
> Sent from my iPad
> (expect ridiculous spelling mistakes)
>
> On May 29, 2013, at 9:12 PM, "Bruce Nordman" <[email-masked]> wrote:
>
>    I don't follow why the ESI would be relevant to EMAN.
> EMAN does not address coordination with the grid as
> many standards do.  Standards designed for grid
> coordination (e.g. the FSGIM) have different purposes
> than EMAN and different fundamental models.  The
> question at hand is what EMAN needs.
>  --Bruce
>
>
> On Wed, May 29, 2013 at 6:38 AM, eman issue tracker <
> [email-masked]> wrote:
>
>> #36: Consider whether MeteredBy relationship is needed
>>
>>
>>  Comment (by [email-masked]):
>>
>>  Other standards groups view !MeterBy and !PoweredBy as distinct logical
>>  functions.  For example, NIST Framework and Roadmap for Smart Grid
>>  Interoperability Standards, Release 1.0 states:
>>
>>  3.5.1 Distinction between the Meter and the Energy Services Interface
>>
>>      The meter and the ESI (Energy Services Interface) have very different
>>  characteristics and functions. The logical separation of the meter and
>> the
>>  ESI is a very important forward-looking aspect of the reference model.
>>      ..
>>      While the ESI and meter are logically viewed as separate devices,
>> this
>>  does not preclude the
>>      possibility for manufacturers to implement the meter and ESI in one
>>  physical device, provided
>>      that the flexibility and extensibility to support the Smart Grid
>>  vision can be achieved. Most smart
>>      meters currently integrate the ESI and meter functionality in one
>>  device due to cost
>>      considerations. Looking forward, logical separation of the two
>>  functions, even if physically
>>      integrated, is essential to avoid having the meter become an
>>  impediment to innovation in energy
>>      services enabled by the Smart Grid."
>>
>>
>>  Full Text here:
>>
>> http://www.nist.gov/public_affairs/releases/upload/smartgrid_interoperability_final.pdf
>>
>>
>> --
>> ------------------------------+--------------------
>>  Reporter:  [email-masked]  |       Owner:  Bruce
>>      Type:  defect            |      Status:  new
>>  Priority:  major             |   Milestone:
>> Component:  framework         |     Version:
>>   Severity:  -                 |  Resolution:
>>  Keywords:                    |
>> ------------------------------+--------------------
>>
>>  Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/36#comment:2
>> >
>>
>>  eman <http://tools.ietf.org/eman/>
>>
>> _______________________________________________
>> eman mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/eman
>>
>
>
>
> --
> *Bruce Nordman*
> Lawrence Berkeley National Laboratory
> *nordman.lbl.gov*
> [email-masked]
> 510-486-7089
> m: 510-501-7943
>
>  _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
*nordman.lbl.gov*
[email-masked]
510-486-7089
m: 510-501-7943

---

From: "John Parello (jparello)" <[email-masked]>
Date: Mon, 3 Jun 2013 17:57:52 +0000

Hi Bruce,

Ah ok, so The core of your premise it that you think powered by and metered by are redundant.

Given 1) the analogyy in modeling indescribes to layer-2 and layer-3 that I described  2) working systems that have this separated out and 3) the alignment with standard that recognize this that brad cited - I can't conclude that they are redundant.

You posited that they are redundant so the burden is yours to show that and so far I don't see it.

Jp

Sent from my iPad

On Jun 2, 2013, at 11:11 PM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

Jon--

Thanks,

--Bruce

On Thu, May 30, 2013 at 3:32 PM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bruce,

Yes, We are not chartered to specify coordination with the grid which would be a protocol. FSGIM  (201p) from ashrae most certainly specifies information models not just for the grid but for facility devices as well so you are mistaken there.

We are chartered for models for device management and we would be amiss not to model information that ultimately would be used by EnMS' and grid coordination systems (load summaries)

 I find Brad's reference quite relevant. Both our existing taget EnMS users (with running code) and  the quote he sites suggest imminent need for modeling relationships between devices for power and metering.

Also we've recognized the need for power, metering and aggregation topologies prior to the draft of the requirements. So if your are citing that as missing from the requirements I think you've uncovered an error in the requirements not a justification for removing information models pertaining to relationships between devices.

Are you suggesting we remove power, metering, and aggregation topology modeling?

Jp

Sent from my iPad

On May 29, 2013, at 9:12 PM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, May 29, 2013 at 6:38 AM, eman issue tracker <[email-masked]<mailto:[email-masked]>> wrote:
#36: Consider whether MeteredBy relationship is needed

Comment (by [email-masked]<mailto:[email-masked]>):

 characteristics and functions. The logical separation of the meter and the
     While the ESI and meter are logically viewed as separate devices, this

 Full Text here:

 Reporter:  [email-masked]<mailto:[email-masked]>  |       Owner:  Bruce

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/36#comment:2>

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
nordman.lbl.gov<http://nordman.lbl.gov>
[email-masked]<mailto:[email-masked]>
510-486-7089<tel:510-486-7089>
m: 510-501-7943<tel:510-501-7943>
_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
nordman.lbl.gov<http://nordman.lbl.gov>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943

---

From: Bruce Nordman <[email-masked]>
Date: Mon, 3 Jun 2013 11:43:41 -0700

On Mon, Jun 3, 2013 at 10:57 AM, John Parello (jparello) <[email-masked]

> metered by are redundant.
Metered by is redundant to powered by, but I would not say the reverse is
true, so
step to solve this issue is to drop powered by.

>
>  Given 1) the analogyy in modeling indescribes to layer-2 and layer-3
> that I described  2) working systems that have this separated out and 3)
> the alignment with standard that recognize this that brad cited - I can't
> conclude that they are redundant.
>

We are definitely going in circles here.
I addressed 1) in:
http://www.ietf.org/mail-archive/web/eman/current/msg01871.html
and have reproduced the text from that below.
I don't doubt 2), but that doesn't mean that doing so is something that EMAN
needs to do or should do.
For 3), per my response a few minutes ago at:
http://www.ietf.org/mail-archive/web/eman/current/msg01882.html
my comment has nothing to do with the NIST definitions or to the utility
grid.

Would you say that a device should be able to reference the utility meter
that
is ultimately upstream from it?

Thanks,

--Bruce
-------------------------------------
My text from:
http://www.ietf.org/mail-archive/web/eman/current/msg01871.html

Specifying that the the dedicated meter functionality you describe
is at a layer above the basic EMAN one of devices reporting about
themselves or devices they are connected to is intriguing, and one
I am quite sympathetic to, as a lot of system architectures these days
lack a good sense of layering and so become overly complex.

This approach to a meter seems to then be properly part of an Energy
Management System that used EMAN and not part of the EMAN
protocol itself.

In re-reviewing the Requirements document, I can't find reference to
dedicated meters as are being described here in a way that would
suggest that any special EMAN content is needed.  I do think it would be
helpful to have a document describing EMS functions and how they
use EMAN and what else they do.  That seems like the right place
for this dedicated meter proposal.

It does seem clear that at the EMAN layer, the variety of energy
objects that we have - devices, components, and power interfaces -
are sufficient to fully implement it.

Thanks,

--Bruce

---

From: Brad Schoening <[email-masked]>
Date: Mon, 3 Jun 2013 19:29:34 +0000

BN: Would you say that a device should be able to reference the utility meter that
is ultimately upstream from it?

Yes, absolutely.  We did exactly that at Noveda.

Consider the following:

Building Smart Meter  ---->  Raritan Smart PDU (but no metering)  --->  Cisco Switch

#1) How would you use MeteredBy for the PDU which doesn't have a meter?  CiscoSwitch Powered-by RaritanPDU seems necessary.
#2) Do you believe "utility meters" are functionally different from "smart sub-meters"?  I'm not sure I see any distinction.

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Mon, 3 Jun 2013 11:43:41 -0700
To: "John Parello (jparello)" <[email-masked]<mailto:[email-masked]>>
Cc: eman mailing list <[email-masked]<mailto:[email-masked]>>, eman issue tracker <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] #36: Consider whether MeteredBy relationship is needed

On Mon, Jun 3, 2013 at 10:57 AM, John Parello (jparello) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Bruce,

Ah ok, so The core of your premise it that you think powered by and metered by are redundant.
Metered by is redundant to powered by, but I would not say the reverse is true, so
step to solve this issue is to drop powered by.

We are definitely going in circles here.
I addressed 1) in:  http://www.ietf.org/mail-archive/web/eman/current/msg01871.html
and have reproduced the text from that below.
I don't doubt 2), but that doesn't mean that doing so is something that EMAN
needs to do or should do.
For 3), per my response a few minutes ago at: http://www.ietf.org/mail-archive/web/eman/current/msg01882.html
my comment has nothing to do with the NIST definitions or to the utility grid.

Would you say that a device should be able to reference the utility meter that
is ultimately upstream from it?

Thanks,

--Bruce
-------------------------------------
My text from: http://www.ietf.org/mail-archive/web/eman/current/msg01871.html

Thanks,

--Bruce

Jp

Sent from my iPad

--
Bruce Nordman
Lawrence Berkeley National Laboratory
nordman.lbl.gov<http://nordman.lbl.gov>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943
_______________________________________________ eman mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/eman

---

From: "John Parello (jparello)" <[email-masked]>
Date: Mon, 3 Jun 2013 22:36:10 +0000

Hi Bruce,

Definitely not going in circles. I considered it and I don't agree the relationships are redundant in any order for the reasons I outlined.

Jp

Sent from my iPad

On Jun 3, 2013, at 11:43 AM, "Bruce Nordman" <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,

--Bruce

Thanks,

--Bruce

Jp

Sent from my iPad

---

From: <[email-masked]>
Date: Tue, 4 Jun 2013 09:57:03 +0000

Hi all,

I agree with John, the MeteredBy relationship is needed for the support of several scenarios, see e.g.,   "Home energy gateways" scenario in section 2.7 of:
http://www.ietf.org/id/draft-ietf-eman-applicability-statement-03.txt

Best regards,
Georgios

From: [email-masked] [mailto:[email-masked]] On Behalf Of John Parello (jparello)
Sent: dinsdag 4 juni 2013 0:36
To: Bruce Nordman
Cc: eman mailing list; eman issue tracker
Subject: Re: [eman] #36: Consider whether MeteredBy relationship is needed

Hi Bruce,

Jp

Sent from my iPad

Thanks,
--Bruce

--Bruce

Jp

Sent from my iPad

---

From: Brad Schoening <[email-masked]>
Date: Tue, 4 Jun 2013 21:08:19 +0000

Bruce,

I'm not sure I understand which relationship you are suggesting is redundant.  Below you use the PowerBy relationship, while on Monday, you stated "so step to solve this issue is to drop powered by."

Regards,

Brad

Brad Schoening
Engineering | Coraid
Tel: +1 917 304 7190
[email-masked] | www.coraid.com<http://www.coraid.com>
Coraid: Redefining Storage

From: Bruce Nordman <[email-masked]<mailto:[email-masked]>>
Date: Tue, 4 Jun 2013 13:34:01 -0700
To: Brad Schoening <[email-masked]<mailto:[email-masked]>>
Cc: "John Parello (jparello)" <[email-masked]<mailto:[email-masked]>>, eman mailing list <[email-masked]<mailto:[email-masked]>>, eman issue tracker <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] #36: Consider whether MeteredBy relationship is needed

< A few minutes ago I sent a blank reply by accident; apologies >

For referencing the utility meter, we have the Domain part of the EMAN Framework,
which notes that it is "... recommended to map 1:1 with a metered or sub-metered portion of the site."
Problem solved.  My comment did not question the inclusion of Domain.

#1. For the Building-meter -> PDU -> Switch case, the Switch is Powered-by the PDU and the PDU
is Powered-by the Building-meter.  Plus, both specify that they are in the Domain of the
Building-meter, so we have double referencing to the utility meter even without the Metered-by
concept.

#2. I agree with you that for EMAN there is no functional difference between a utility
meter and a sub-meter.  Furthermore, any meter is just a device in the EMAN context.
It is a device with metering as its primary function but not different for EMAN purposes.

Thanks,

--Bruce

On Mon, Jun 3, 2013 at 12:29 PM, Brad Schoening <[email-masked]<mailto:[email-masked]>> wrote:
BN: Would you say that a device should be able to reference the utility meter that
is ultimately upstream from it?

Consider the following:

Thanks,

--Bruce

Thanks,

--Bruce

Jp

Sent from my iPad

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 4 Jun 2013 13:34:01 -0700

*< A few minutes ago I sent a blank reply by accident; apologies >*

For referencing the utility meter, we have the Domain part of the EMAN
Framework,
which notes that it is "... recommended to map 1:1 with a metered or
sub-metered portion of the site."
Problem solved.  My comment did not question the inclusion of Domain.

#1. For the Building-meter -> PDU -> Switch case, the Switch is Powered-by
the PDU and the PDU
is Powered-by the Building-meter.  Plus, both specify that they are in the
Domain of the
Building-meter, so we have double referencing to the utility meter even
without the Metered-by
concept.

#2. I agree with you that for EMAN there is no functional difference
between a utility
meter and a sub-meter.  Furthermore, any meter is just a device in the EMAN
context.
It is a device with metering as its primary function but not different for
EMAN purposes.

Thanks,

--Bruce

On Mon, Jun 3, 2013 at 12:29 PM, Brad Schoening <[email-masked]> wrote:

>  #1) How would you use MeteredBy for the PDU which doesn't have a meter?
>  CiscoSwitch Powered-by RaritanPDU seems necessary.
> #2) Do you believe "utility meters" are functionally different from "smart
> sub-meters"?  I'm not sure I see any distinction.
>
>   From: Bruce Nordman <[email-masked]>
> To: "John Parello (jparello)" <[email-masked]>
> Cc: eman mailing list <[email-masked]>, eman issue tracker <
> [email-masked]>
> On Mon, Jun 3, 2013 at 10:57 AM, John Parello (jparello) <
> [email-masked]> wrote:
>
>>  Hi Bruce,
>>
>  _______________________________________________ eman mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/eman
>

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 4 Jun 2013 13:24:37 -0700

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 4 Jun 2013 13:37:24 -0700

Georgios--
  In re-reading that section of the Applicability Statement, I don't see
what is not covered by using Powered-by (possibly supplemented
by Domain).  A specific example would be helpful, as would some
pointers to content in the Requirements draft.
Thanks,
--Bruce

On Tue, Jun 4, 2013 at 2:57 AM, <[email-masked]> wrote:

>  Hi all,****
>
> ** **
>
> I agree with John, the MeteredBy relationship is needed for the support of
> several scenarios, see e.g.,   “Home energy gateways” scenario in section
> 2.7 of:****
>
> http://www.ietf.org/id/draft-ietf-eman-applicability-statement-03.txt****
>
> ** **
>
> Best regards,****
>
> Georgios****
>
> ** **
>
> ** **
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *John Parello (jparello)
> *Sent:* dinsdag 4 juni 2013 0:36
> *To:* Bruce Nordman
> *Cc:* eman mailing list; eman issue tracker
> *Subject:* Re: [eman] #36: Consider whether MeteredBy relationship is
> needed****
>
> ** **
>
> Hi Bruce,****
>
> ** **
>
> Definitely not going in circles. I considered it and I don't agree the
> relationships are redundant in any order for the reasons I outlined. ****
>
> ** **
>
> Jp****
>
> ** **
>
> ** **
>
> Sent from my iPad  ****
>
> (expect ridiculous spelling mistakes) ****
>
>
> On Jun 3, 2013, at 11:43 AM, "Bruce Nordman" <[email-masked]> wrote:****
>
>  ** **
>
> ** **
>
> [email-masked]> wrote:****
>
> Hi Bruce,****
>
> ** **
>
> Ah ok, so The core of your premise it that you think powered by and
> metered by are redundant.****
>
> true, so****
> step to solve this issue is to drop powered by.****
>
>  ** **
>
> Given 1) the analogyy in modeling indescribes to layer-2 and layer-3 that
> I described  2) working systems that have this separated out and 3) the
> alignment with standard that recognize this that brad cited - I can't
> conclude that they are redundant. ****
>
>  ** **
>
> We are definitely going in circles here.****
>
> I addressed 1) in:
> http://www.ietf.org/mail-archive/web/eman/current/msg01871.html****
>
> and have reproduced the text from that below.****
>
> needs to do or should do.****
>
> http://www.ietf.org/mail-archive/web/eman/current/msg01882.html****
>
> grid.****
> that****
> is ultimately upstream from it?****
>
> ** **
>
> Thanks,****
>
> --Bruce
> -------------------------------------****
>
> My text from:
>  ****
> lack a good sense of layering and so become overly complex.  ****
>
> protocol itself.****
> for this dedicated meter proposal.****
>
> are sufficient to fully implement it.  ****
>
> Thanks,****
>
> ** **
>
> --Bruce****
>
>  ** **
>
> You posited that they are redundant so the burden is yours to show that
> and so far I don't see it.****
>
> ** **
>
> Jp****
>
> ** **
>
>
> Sent from my iPad  ****
>
> (expect ridiculous spelling mistakes) ****
>
>
>
> --
> *Bruce Nordman*
> m: 510-501-7943****

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 4 Jun 2013 14:15:20 -0700

That would be a typo in my Monday email - should have been "metered by".

Ticket is:  "Consider whether MeteredBy relationship is needed" and
the full sentence from my Monday email is:
    Metered by is redundant to powered by, but I would not say the reverse
is true,
    so step to solve this issue is to drop powered by.
(and last two words should of course be "metered by").

I hope that makes it clear what I am identifying is redundant.

Thanks,

--Bruce

On Tue, Jun 4, 2013 at 2:08 PM, Brad Schoening <[email-masked]> wrote:

>   Bruce,
>
>  I'm not sure I understand which relationship you are suggesting is
> redundant.  Below you use the PowerBy relationship, while on Monday, you
> stated "so step to solve this issue is to drop powered by."
>
>  Regards,
>
>  Brad
> ..
>

---

From: "eman issue tracker" <[email-masked]>
Date: Tue, 11 Jun 2013 22:34:02 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

-- 
------------------------------+---------------------
 Reporter:  [email-masked]  |       Owner:  Bruce
     Type:  defect            |      Status:  closed
 Priority:  major             |   Milestone:
Component:  framework         |     Version:
 Severity:  -                 |  Resolution:  fixed
 Keywords:                    |
------------------------------+---------------------

Ticket URL: <https://tools.ietf.org/wg/eman/trac/ticket/36#comment:3>
eman <http://tools.ietf.org/eman/>