Subject: Re: [eman] #31: Clarify what is optional to implment in the UML

From: "eman issue tracker" <[email-masked]>
Date: Tue, 11 Jun 2013 18:45:00 -0000

#31: Clarify what is optional to implment in the UML

Comment (by [email-masked]):

 Proposed UML to date

 EMAN INFORMATION MODEL

 class EnergyObject {

 // identification

    index        : int
    identifier   : uuid
    alternatekey : string
    eotype       : enum { device, component, inlet, outlet }
    eocategory   : enum { producer, consumer, meter }   // NOTE:
 Distributor?

 // context

    domainName      : string
    role            : string
    keywords [0..n] : string
    importance      : int

 // relationship

    relationships [0..n] : Relationship

 // measurements

    nameplate    : Nameplate

 // power and energy

    power     : PowerMeasurement
    energy    : EnergyMeasurment
    demand    : DemandMeasurement

 // power states

    powerControl [0..n] : PowerStateSet

 }

 class Relationship {
       relationshipType    : enum { meters, meteredby, powers, poweredby,
 aggregates, aggregatedby }
       relationshipObject  : uuid
 }

 // NOTE: No consensus on Proxy so I didn't put it in . Remove? Yes no
 consensus.
 //       Should this be IANA. See Gellish.
 //       Can drop discussion on generic Parent/Child
 //  General: information model registry

 class Nameplate {
       nominalPower : PowerMeasurement
       details      : URI
 }

 class Measurement {
       multiplier: enum { -24..24}
       caliber   : enum { actual, estimated, trusted, assumed } // IANA??
       accuracy  : enum { 0..10000} // hundreds of percent
 }

 class PowerMeasurement extends Measurement {
       value          : long
       units          : "W"
       rate           : enum { 0, milliseconds, seconds, minutes, hours}
            // Brad find out what the rate was not in mib delete this.
       powerAttribute : PowerAttribute
 }

 class EnergyMeasurement extends Measurement {
       startTime : time
       units     : "Wh"
       provided  : long
       used      : long
       produced  : long
 }

 class TimedMeasurement extends Measurement {
       startTime  : timestamp
       value      : Measurement
       maximum    : Measurement
 }

 class TimeInterval {
       value      : long
       units      : enum { seconds, miliseconds,...}
 }

 class DemandMeasurement extends Measurement {
       intervalLength : TimeInterval
       interval       : long
       intervalMode   : enum { periodic, sliding, total }
       intervalWindow : TimeInterval
       sampleRate     : TimeInterval
       status         : enum { active, inactive }
       measurements[0..n] : TimedMeasurements
 }

 class PowerStateSet {
       powerSetIdentifier : int
       name               : string
       powerStates [0..n] : PowerState
       operState          : int
       adminState         : int
       reason             : string
       configuredTime     : timestamp
 }

 class PowerState {
       powerStateIdentifier  : int
       name             : string
       cardinality      : int
       maximumPower     : PowerMeasurement
       totalTimeInState : time
       entryCount       : long
 }

 // Power Attributes for next week should be identical as in doc now...

 jparello 6/9/2013

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-eman-applicability-
  [email-masked]     |  [email-masked]
     Type:  defect       |      Status:  new
 Priority:  major        |   Milestone:
Component:               |     Version:
  applicability-         |  Resolution:
  statement              |
 Severity:  -            |
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/31#comment:2>
eman <http://tools.ietf.org/eman/>

---

From: "eman issue tracker" <[email-masked]>
Date: Tue, 11 Jun 2013 22:22:08 -0000

Comment (by [email-masked]):

 Benoit will check this further.  We will need to register our Textual
 Convention and its types with IANA; the TC is IANAPowerStateSet, defined
 in the EMAN Monitoring MIB.

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/31#comment:3>
eman <http://tools.ietf.org/eman/>

---

From: "eman issue tracker" <[email-masked]>
Date: Tue, 11 Jun 2013 22:26:25 -0000

Question: what's the 'rate' in the PowerMeasurement class?  Brad to check
 this.

 Another thought: we agreed that the Information Model needs to be
 expressed in UML within the Framework document.  Would it also be useful
 to include the above as an appendix?  It's in Gellic English, which
 Wikipedia tells me is a formal language for defining Information Models;
 Wikipedia also gives a reference for it.

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/31#comment:4>
eman <http://tools.ietf.org/eman/>

---

From: "eman issue tracker" <[email-masked]>
Date: Tue, 11 Jun 2013 22:32:35 -0000

Ongoing activities:
 - discuss this on the EMAN list
 - check it with Brian Hedstrom (Cable Labs)
 - John will add ACQuality to the Gellish description

Ticket URL: <http://trac.tools.ietf.org/wg/eman/trac/ticket/31#comment:5>
eman <http://tools.ietf.org/eman/>