Subject: [eman] Fwd: New Version Notification for draft-nordman-eman-er-framework-01.txt

From: Bruce Nordman <[email-masked]>
Date: Tue, 16 Jul 2013 15:30:27 -0700

I have updated the Energy Reporting Framework (ERF) draft that I posted
last week.

The -01 version:
--has some wording changes to clarify some points,
--fixes reference formatting,
--adds brand and model fields to the basic data, and
--adds and drops some outstanding issues.

I believe that this document is the best one we have available that meets
the charter needs for the framework for EMAN.

Compared to content of draft-ietf-eman-framework-08, the ERF is
simpler while having more capabilities, and so should be easier
to implement and use.  Compared to the presentation of
draft-ietf-eman-framework-08, the ERF is much shorter and I
believe much more accessible to a variety of audiences - which
will be important for EMAN to be successful.

I look forward to comments on the list on how to improve this
draft for a version -02.  I am unable to be in Berlin but this draft
will be presented there and so I look forward to the minutes from
the meeting and any improvements to the draft that arise from that.
(I will be off email the week of the IETF meeting).

Thanks,

--Bruce

---------- Forwarded message ----------
From: <[email-masked]>
Date: Mon, Jul 15, 2013 at 3:41 PM
Subject: New Version Notification for draft-nordman-eman-er-framework-01.txt
To: Bruce Nordman <[email-masked]>

A new version of I-D, draft-nordman-eman-er-framework-01.txt
has been successfully submitted by Bruce Nordman and posted to the
IETF repository.

Filename:        draft-nordman-eman-er-framework
Revision:        01
Title:           Energy Reporting Framework
Creation date:   2013-07-16
Group:           Individual Submission
Number of pages: 28
URL:
http://www.ietf.org/internet-drafts/draft-nordman-eman-er-framework-01.txt
Status:
http://datatracker.ietf.org/doc/draft-nordman-eman-er-framework
Htmlized:
http://tools.ietf.org/html/draft-nordman-eman-er-framework-01
Diff:
http://www.ietf.org/rfcdiff?url2=draft-nordman-eman-er-framework-01

Abstract:
   Managing energy consumption of devices presents new challenges and
   issues.  The EMAN Requirements draft identifies essential
   capabilities needed to accomplish this.  This draft describes how an
   energy management system can use EMAN to gather and interpret data
   from individual devices, and how some of the Requirements are
   implemented in the model.  This document focuses on Energy Reporting,
   though acknowledges and fully includes the limited control functions
   specified in the Requirements draft.  Topics addressed in detail
   include the topology of power distribution, reporting mechanisms, and
   the various roles of devices, power interfaces, and components.

The IETF Secretariat

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
*nordman.lbl.gov*
[email-masked]
510-486-7089
m: 510-501-7943

---

From: joel jaeggli <[email-masked]>
Date: Wed, 17 Jul 2013 10:48:36 -0700

I'd like to thank you for staking out your argument with what's wrong 
with the current document out with text. Doing so is not a small effort.

joel

On 7/16/13 3:30 PM, Bruce Nordman wrote:
> I have updated the Energy Reporting Framework (ERF) draft that I 
> posted last week.
>
> The -01 version:
> From: <[email-masked] <mailto:[email-masked]>>
> To: Bruce Nordman <[email-masked] <mailto:[email-masked]>>
>
>
>
> Status: http://datatracker.ietf.org/doc/draft-nordman-eman-er-framework
> Htmlized: http://tools.ietf.org/html/draft-nordman-eman-er-framework-01
> Diff: http://www.ietf.org/rfcdiff?url2=draft-nordman-eman-er-framework-01
>
> Abstract:
> *nordman.lbl.gov <http://nordman.lbl.gov>*
> [email-masked]
> 510-486-7089 <tel:510-486-7089>
> m: 510-501-7943 <tel:510-501-7943>
>
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Quittek <[email-masked]>
Date: Sun, 21 Jul 2013 21:38:53 +0000

Hi Bruce,

I have reviewed the draft version -01. 

Indeed this framework is using a "keep it simple" approach.
It needs less concepts and much less text than our current 
WG draft. The introduction of concepts in sections 2 and 3
is amazingly easy to read (considering the lengthy and complex
discussions we had on the "right" concepts).

Even with a reduced number of concepts it is still complete.
And it still meets (at least almost) all requirements as stated 
in our requirements draft (which has good chances to become 
RFC before IETF#87). How requirements are met is described
for each requirement.

Section 3
This section give a good overview of power distribution and 
reporting topologies. It lacks a discussion of the metering 
topology. You list this as open issue #3 in section 8 and I think
it is the most important of the open issues.

Sections 4+5: purpose of the sections
These sections serves two purposes at the same time. 
One is listing which requirements are met and how they are met. 
The other one is elaborating the framework and adding small
features where needed to meet the requirements. This is not a
straight forward approach, but the results seems to be compact
and efficient.

Sections 4+5: requirements and options
There is a lack of clarity about requirements, recommendations
and options in these two sections. It is often not clear which features 
are MANADATORY, RECOMMENDED, or OPTIONAL, or something else,
see the following examples:
   Section 4.1: "a widely useful feature is ..."
   Section 4.2: "the first item needed is ..."
   Section 4.2: "will typically be of the form ..."
   Section 4.3: "Each device provides a list of ..."
   Section 4.4: "They can be represented  by ..."
... and so on.
It would be helpful to state more clearly what the framework sees 
as MUST, SHOULD or MAY, respectively. The introductions of
section 4 says the "basic" features are "required". If they are 
required it would be useful to clearly identify what is basic. It looks
like even basic features have options. This does not mean that I 
disagree with the proposed features, but I would like to better 
understand which are essential and which not.

Sections 4+5: data formats
In section 4.2 you suggest using a string of the form "name=value".
In section 5.1 you suggest using "type:value".
I am not sure these two fit well together.

Detailed comments:
Section 4.2, line 4: "will typically" -> "can be"
Section 5.1, line 3: ", with each having" -> ". They can have"
Section 8.2, line 1: "Framework draft" -> "Framework and Battery MIB drafts"

Cheers,
    Juergen

Looking at the open issues listed in section 8, there is one
That I think is most essential: 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Bruce Nordman
> Sent: Mittwoch, 17. Juli 2013 00:30
> To: eman mailing list
> Subject: [eman] Fwd: New Version Notification for draft-nordman-eman-er-
> framework-01.txt
> 
> I have updated the Energy Reporting Framework (ERF) draft that I posted last
> week.
> 
> 
> The -01 version:
> --has some wording changes to clarify some points, --fixes reference
> formatting,
> 
> I believe that this document is the best one we have available that meets the
> charter needs for the framework for EMAN.
> 
> 
> simpler while having more capabilities, and so should be easier to implement
> and use.  Compared to the presentation of draft-ietf-eman-framework-08,
> the ERF is much shorter and I believe much more accessible to a variety of
> audiences - which will be important for EMAN to be successful.
> 
> 
> I look forward to comments on the list on how to improve this draft for a
> version -02.  I am unable to be in Berlin but this draft will be presented there
> and so I look forward to the minutes from the meeting and any
> improvements to the draft that arise from that.
> 
> has been successfully submitted by Bruce Nordman and posted to the IETF
> repository.
> 
> URL:             http://www.ietf.org/internet-drafts/draft-nordman-eman-er-
> framework-01.txt
> Bruce Nordman
> nordman.lbl.gov

---

From: Bruce Nordman <[email-masked]>
Date: Thu, 25 Jul 2013 15:55:19 -0700

Juergen--

These are all good comments I can incorporate into the next version.
I look forward to review of this draft on the list by others to gather
additional useful input.

The only item I would disagree with is on metering topology.
One cannot meter power differently from how it is distributed.
Metering is something that occurs at a subset of points in
a power distribution topology, so it is an aspect of power
distribution, not separate.

Thanks,

--Bruce

On Sun, Jul 21, 2013 at 2:38 PM, Juergen Quittek <[email-masked]> wrote:

> last