Subject: [eman] eman framework issue: Lacking differentiation between devices, components, and interfaces

From: Juergen Quittek <[email-masked]>
Date: Fri, 30 Aug 2013 19:37:01 +0200

Dear all, 

Here is another framework issue: Do we report the same Information for devices, interfaces, and components?

Our framework draft (draft-ietf-eman-framework-08) uses an object-oriented model for describing the Information model for eman. The model has classes for devices, components, meters and the classes have attributes for carrying information on UUIDs, power values, etc. 

My issue with the model is that it uses the same set of attributes for all kinds of energy objects (device, component, power interface).

The only exception is a single category/type object that varies among the different classes. (Ironically, here I would use the same attribute for all classes in oder to use the same mechanism for all energy objects to retrieve their type.)

In the requirements document (draft-ietf-eman-requirements-14) there are clear differences between the sets of information elements to be reported for devices, components, and interfaces. The current model does not reflect this.

This is different for the model in draft-nordman-eman-er-framework-01. Here the model is fully aligned with the requirements and supports different sets of information provided for different kinds of energy objects. It uses simple tables to show which information needs to be reported for which type of energy object. 

I think the differentiation between devices, components, and power interfaces as it is made in the requirements draft needs to be reflected by the eman framework. 

Cheers,
 Juergen

---

From: Brad Schoening <[email-masked]>
Date: Fri, 30 Aug 2013 18:04:26 +0000

Juergen,

The framework uses a UML-like model, similar to ASHRAE 201 and IEC 6180.
As we've discussed, we could also produce syntactically corrected UML if
that is the consensues.

On 8/30/13 1:37 PM, "Juergen Quittek" <[email-masked]> wrote:

>Our framework draft (draft-ietf-eman-framework-08) uses an
>object-oriented model for describing the Information model for eman. The
>model has classes for devices, components, meters and the classes have
>attributes for carrying information on UUIDs, power values, etc.
>
>My issue with the model is that it uses the same set of attributes for
>all kinds of energy objects (device, component, power interface).
>
>The only exception is a single category/type object that varies among the
>different classes. (Ironically, here I would use the same attribute for
>all classes in oder to use the same mechanism for all energy objects to
>retrieve their type.)
>
>In the requirements document (draft-ietf-eman-requirements-14) there are
>clear differences between the sets of information elements to be reported
>for devices, components, and interfaces. The current model does not
>reflect this.
>
>This is different for the model in draft-nordman-eman-er-framework-01.
>Here the model is fully aligned with the requirements and supports
>different sets of information provided for different kinds of energy
>objects. It uses simple tables to show which information needs to be
>reported for which type of energy object.
>
>I think the differentiation between devices, components, and power
>interfaces as it is made in the requirements draft needs to be reflected
>by the eman framework.
>
>Cheers,
> Juergen
>_______________________________________________
>eman mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/eman