Subject: Re: [eman] Should the framework cover devices in which we can not measure energy consumption directly?

From: Satoru Izumi <[email-masked]>
Date: Fri, 23 Aug 2013 16:16:04 +0900

Hi John,

I understand your concept. However, for devices with serial
connection or ip connection or no connection i.e. devices
which do not have some means of measuring power consumption
directly, what will happen? Will these devices be out of
scope? Unless the devices are supplemented with energy
measurement mechanisms?

Does the framework cover the existing devices which do not
have functions to translate data from serial to ip networks?

For the devices with no serial connection or ip connection, could
we estimate their energy consumption without using energy meters?
(e.g., I can see the light is on, I may or may not know its wattage,
there is no energy meter, but I know it is consuming energy. That is
valuable information. Estimating the energy consumption is another
step from there. Same for the TV, the fan, etc. etc.). The act of seeing
that a device is on can be automated using simpler indirect
mechanisms. This is much simpler than introducing energy meters in
the devices themselves.

Is it not better to separate the device on/off detection mechanism
from the energy estimation and the energy control mechanisms? That
way we have a wider scope of the devices within the energy management
framework, today.

Makes sense?

Satoru Izumi
Research Institute of Electrical Communication
Tohoku University
[email-masked]

-------- Original Message --------
Subject: Re: [eman] Should the framework cover devices in which we can 
not measure energy consumption directly?
From: John Parello (jparello) <[email-masked]>
To: Satoru Izumi <[email-masked]>
CC: "[email-masked]" <[email-masked]>
Date: Tue Jul 30 2013 21:23:47 GMT+0900

> Hi Satoru,
>
> I think I miss understood your question during the session. I thought you were asking if we modeled connectivity (network information) in our framework information model.
>
> For your question below I take it that you are asking about devices that are not network (ip) connected.
>
> The framework defines an information model that we would like devices to implement. If they are not ip connected they may be accessible via other serial protocol like knx, mod-bus, bacnet etc.
>
> If these devices implement the information model they can then be easily managed via gateways that translate data from serial to ip networks.
>
> The reason we want a common information model is so that manufacturers of these gateways can have a clear understanding of what to translate and the semantics of the information they translate.
>
> I run such a program with Cisco and we have lots of partners who translate bacnet for example to our information model. Take a look at a company call FieldServer and their Energywise gateway.
>
> For devices with no serial connection or ip connection, then we have no direct visibility to those devices. If we measure the meter readings from an area and some portion are readable then there is benefit from the simple subtraction of your total energy and the energy you can monitor.
>
> Does that help?
> Jp
>
> Sent from my iPad
> (expect ridiculous spelling mistakes)
>
> On Jul 30, 2013, at 9:14 AM, "Satoru Izumi" <[email-masked]> wrote:
>
>> John,
>>
>> This is Izumi, I asked you about device connectivity at yesterday's
>> Eman meeting.
>>
>> At this time, I would like to reconfirm, that you said that the
>> framework does not cover devices for which we can not measure
>> energy consumption directly.
>>
>> Is this O.K.? Note, there are several ways in which we can infer
>> that a device is consuming energy, but few devices offer means of
>> measuring how much energy is consumed. Almost all electrical devices
>> of today fall in this category. Lights, heaters, mobile devices,
>> home appliances, computer devices just name them. We may figure
>> out that the device is on but the devices do offer means of
>> measuring energy consumption. (Not without introducing additional
>> devices.)
>>
>> The above restriction will severly constrain the applicability of
>> the framework in todays environment.
>>
>> What do you think this?
>>
>> Regard,
>> Satoru Izumi, Ph.D
>> Research Fellow
>> Research Institute of Electrical Communication, Tohoku University
>> Tel&FAX: +81-22-217-5080
>> [email-masked]
>> _______________________________________________
>> eman mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/eman

---

From: Bruce Nordman <[email-masked]>
Date: Tue, 27 Aug 2013 22:18:38 -0700

Satoru--
  If a device does not have the ability to measure its energy
use, it may have ways to estimate it.  The framework includes
an assessment of accuracy.  Some devices may be able
to make fairly accurate estimates - some much less so, but for
many purposes, even a rough estimate is much better than
having no information at all.
  A device could also usefully report its power state, but not
report any power levels or energy values.  You mention the
example of a switch would might not know the consumption
level of the attached device; power state covers this case.
  Finally, one could even just report characteristics of products
and so know that they are present, even if no power, energy,
or power state information available.
  John already mentioned the proxy cases for non-IP devices,
and devices measured by second devices.
  In summary, the framework does not need to exclude any
device.
  Thanks,
--Bruce

On Fri, Aug 23, 2013 at 12:16 AM, Satoru Izumi <
[email-masked]> wrote:

> [email-masked].**ac.jp <[email-masked]>
>
>
> Subject: Re: [eman] Should the framework cover devices in which we can not
> measure energy consumption directly?
> To: Satoru Izumi <[email-masked].**ac.jp<[email-masked]>
> >
>> I think I miss understood your question during the session. I thought you
>> were asking if we modeled connectivity (network information) in our
>> framework information model.
>>
>> The framework defines an information model that we would like devices to
>> implement. If they are not ip connected they may be accessible via other
>> serial protocol like knx, mod-bus, bacnet etc.
>>
>> If these devices implement the information model they can then be easily
>> managed via gateways that translate data from serial to ip networks.
>>
>> The reason we want a common information model is so that manufacturers of
>> these gateways can have a clear understanding of what to translate and the
>> semantics of the information they translate.
>>
>> I run such a program with Cisco and we have lots of partners who
>> translate bacnet for example to our information model. Take a look at a
>> company call FieldServer and their Energywise gateway.
>>
>> For devices with no serial connection or ip connection, then we have no
>> direct visibility to those devices. If we measure the meter readings from
>> an area and some portion are readable then there is benefit from the simple
>> subtraction of your total energy and the energy you can monitor.
>>
>> Does that help?
>> Jp
>>
>> Sent from my iPad
>> On Jul 30, 2013, at 9:14 AM, "Satoru Izumi" <[email-masked].
>> **ac.jp <[email-masked]>> wrote:
>>
>>  John,
>>>
>>> [email-masked].**ac.jp <[email-masked]>
>>> ______________________________**_________________
>>> eman mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/**listinfo/eman<https://www.ietf.org/mailman/listinfo/eman>
>>>
>>
> ______________________________**_________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/eman<https://www.ietf.org/mailman/listinfo/eman>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
*nordman.lbl.gov*
[email-masked]
510-486-7089
m: 510-501-7943

---

From: <[email-masked]>
Date: Wed, 28 Aug 2013 08:41:49 +0000

Hi Satoru,

I agree with John and Bruce that the framework does not exclude any device, as long as this device supports the eman information model.

Best regards,
Georgios

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bruce Nordman
Sent: woensdag 28 augustus 2013 7:19
To: Satoru Izumi
Cc: [email-masked]
Subject: Re: [eman] Should the framework cover devices in which we can not measure energy consumption directly?

Satoru--

On Fri, Aug 23, 2013 at 12:16 AM, Satoru Izumi <[email-masked]<mailto:[email-masked]>> wrote:
Hi John,

Makes sense?

Satoru Izumi
Research Institute of Electrical Communication
Tohoku University
[email-masked]<mailto:[email-masked]>

-------- Original Message --------
Subject: Re: [eman] Should the framework cover devices in which we can not measure energy consumption directly?
From: John Parello (jparello) <[email-masked]<mailto:[email-masked]>>
To: Satoru Izumi <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tue Jul 30 2013 21:23:47 GMT+0900
Hi Satoru,

Does that help?
Jp

Sent from my iPad

On Jul 30, 2013, at 9:14 AM, "Satoru Izumi" <[email-masked]<mailto:[email-masked]>> wrote:
John,

What do you think this?

Regard,
Satoru Izumi, Ph.D
Research Fellow
Research Institute of Electrical Communication, Tohoku University
Tel&FAX: +81-22-217-5080<tel:%2B81-22-217-5080>
[email-masked]<mailto:[email-masked]>
_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

--
Bruce Nordman
Lawrence Berkeley National Laboratory
nordman.lbl.gov<http://nordman.lbl.gov>
[email-masked]<mailto:[email-masked]>
510-486-7089
m: 510-501-7943