Subject: [eman] Power States != Charging States?

From: Rolf Winter <[email-masked]>
Date: Wed, 25 Sep 2013 13:18:00 +0000

Hi,

this thread attempts to close an open issue in the framework document (v10) where section 9.1.4 reads:

9.1.4. Batteries Power State Set
     
        Batteries have operational and administrational states that
        could be represented as a power state set. Since the work
        for battery management is parallel to this document, we are
        not proposing any Power State Sets for batteries at this
        time.

I argue that batteries have no power states given the power state definition:

        A Power State is a condition or mode of a device that
        broadly characterizes its capabilities, power
        consumption, and responsiveness to input.

There are charging states currently defined in the battery MIB, which seem to be orthogonal to power states. I guess a universal power state set is "on" and "off". Any device can really be in one of these two modes. Even a simple light bulb. What would be "on" for a battery? Maybe charging because it receives energy (like any other device that is actually "on")? But every device that is on, fulfills its primary function. I would argue that the primary function of a battery is to provide energy. Batteries are different and I maybe we should ack this fact and not try to create battery power state sets just because we have this for devices.

I think the Email thread http://www.ietf.org/mail-archive/web/eman/current/msg02000.html seemed to agree that charging states and power states are orthogonal. If they are, why should they be of the same class? The problem is that the power state above as used for devices would suggest that if a device is off, it does not consume any energy. But if the battery is charging, then it does (given that the battery is modeled as part of the device). So if a power state is indeed conflating power consumption and capabilities, then a device would be in two different power states at the same time. But it is not. It is in one power state and the batteries in it are in a certain charging state and each of these can be freely combined. I.e. charging/on, discharging/on, charging/off etc... I guess the main question is, what is the advantage of defining a charging state as a power state (the set of charging states as a power state set)?

Best,

Rolf

NEC Europe Ltd | Registered Office: Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB | Registered in England 2832014

---

From: Ted Ghose <[email-masked]>
Date: Wed, 25 Sep 2013 13:42:37 +0000

Hi Rolf

+1

Thanks for clearly articulating the points. I totally agree the charging state should be orthogonal to power state. 

My position is that battery should _also_ have power state indicating if it is receiving power (charging) or giving power to the electrical network, and how much

This will be useful to account for all the power source and sink

Best

-tg-
Sent from my iPhone

> On Sep 25, 2013, at 6:18 AM, Rolf Winter <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Benoit Claise <[email-masked]>
Date: Mon, 30 Sep 2013 18:09:28 +0200

Hi Ted,
> My position is that battery should _also_ have power state indicating if it is receiving power (charging) or giving power to the electrical network, and how much
That makes sense.

Regards, Benoit
> .