Subject: [eman] Authors - draft-ietf-eman-framework-10: WGLC comments

From: "John Parello (jparello)" <[email-masked]>
Date: Mon, 14 Oct 2013 05:37:21 +0000

Hi,

These are the review comments we had among the authors on 10/8 and applied:

* 10/8 Author's call
Nevil, Benoit, Brad, John

** Discussed specific points from reviews and concluded…..

*** Capitalization
    Move modeling (class) into section 4
        only power / energy not capitalize
        See txt
+ JP : Done, had the option to lower case common terms went with that will review 10/15 before publishing

*** Scalar vs Vector
       Category  - overloaded if vectore { cons, prod, meter, distributor, store }
            Primary is better received
        ex: car { biz, pleasure, commute }
       Role - need semantic not vector
       Location? (new) - clearly not vector but semantic like rfc4776 better geo-priv
       Domain - no problem we discussed and went with single
Experience in filed is that scalar was only needed for these.
ref point lldp : brad

+ JP : Done

*** Section 3.3 Bullet list
   Editing trying to get a sane list not pages. What would we like there?
 put back or better description..

+ JP : Agree with JQ I consolidate those sections to main points and unless we want that section I deleted it. Serves no purpose any longer with requirements draft and applicability IMO.Any objections??

*** Context in device versus in NMS
   Ask and answered we can discuss again

+ JP : nothing to do here agreed on device and not hidden in mms

*** Should state be in a section on control if they can be used for monitoring
   We talked about this in authors call and said ok in control, everything can be monitored and seemed a better location.
we are ok with in control. "add sentence that while power state in control they can be used for monitoring wihout any change ..."

+ JP : Added sentence

*** Demand, Energy when power is not actual
   relates to caliber.
   IF power isn't actual demand and energy is not applicable. Thought exercise that you can report energy and demand and not provide power but that's mental exercise.  could ignore this but that was the point
ask for improvement txt

+ JP : asked in comment and clarified in sections after definition move.

*** Better description of physical
physical strict border between sections on physcal and modelled
Only physical before section 6
physical: inlet outlet "electrical connection"
modeling: power interface

+ JP : used scheme below

*** Section 6.2 Metering
   Should be for a "METER" Case 2 not just because an interface measures energy. That would clear up the controversy.
   S.B. one case not two was confusing people

+ JP : Consolidated to only use for a meter

*** Feedback: lost from uml link to interfaces and components
  Added

+JP: PowerInterface powerInterfaces[0..n]  Component components[0..n]
 Note: Component could sub-class Device. May confuse the non modelers so leaving as siblings and can remove.

*** Make sure the text doesn't read energy object as instance but as class.

+ JP : Done went with this scheme strictly

"""
I) This physical thing IRL,
II)Is described by
III) and represented by this

I)Physical      II) Modeling (Meta Data)  III)Instance
---------------------------------------------------------

equipment        Energy Object (Class)    Energy Object
device           Device (Class)           Device
component        Component (Class)        Component
inlet / outlet   Power Interface (Class)  Power Interface
"""

Thanks!
Jp

---

From: "Mouli Chandramouli (moulchan)" <[email-masked]>
Date: Tue, 15 Oct 2013 13:48:54 +0000

Hello all,

We are working on updating the  draft Applicability Statement draft before this IETF meeting.

We would like to get the input of the WG on a coupe of important points.

Currently, the EMAN Applicability Statement draft as it stands  contains – use cases and relation standards;  and does not have a discussion of how the technologies developed in EMAN WG – EMAN Framework, MIB modules can be implemented.

Should this draft be split in to two drafts  -  (1) use cases and related standards  (2)  Applicability of EMAN Framework

or  a consolidated Applicability statement draft which contains a section of how the Framework can be applied.

Please provide your thoughts.

Thanks
Mouli

---

From: Ira McDonald <[email-masked]>
Date: Tue, 15 Oct 2013 10:02:59 -0400

Hi Mouli,

I prefer a single Applicability Statement - simpler for implementors and
avoids inconsistencies between two documents.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Oct 15, 2013 at 9:48 AM, Mouli Chandramouli (moulchan) <
[email-masked]> wrote:

>  Currently, the EMAN Applicability Statement draft as it stands  contains
> – use cases and relation standards;  and does not have a discussion of how
> the technologies developed in EMAN WG – EMAN Framework, MIB modules can be
> implemented.
>
>  Should this draft be split in to two drafts  -  (1) use cases and
> related standards  (2)  Applicability of EMAN Framework
>
>  or  a consolidated Applicability statement draft which contains a
> section of how the Framework can be applied.
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>
>

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 15 Oct 2013 15:57:37 +0000

+1

Contained in one doc for me.

Jp

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Tuesday, October 15, 2013 7:03 AM
To: Mouli Chandramouli (moulchan); Ira McDonald
Cc: [email-masked]
Subject: Re: [eman] draft-ietf-eman-applicability-statement-03

Hi Mouli,

mailto:[email-masked]<mailto:[email-masked]>

On Tue, Oct 15, 2013 at 9:48 AM, Mouli Chandramouli (moulchan) <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,

Currently, the EMAN Applicability Statement draft as it stands  contains - use cases and relation standards;  and does not have a discussion of how the technologies developed in EMAN WG - EMAN Framework, MIB modules can be implemented.

Thanks
Mouli

_______________________________________________
eman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eman

---

From: Brad Schoening <[email-masked]>
Date: Tue, 15 Oct 2013 19:24:35 +0000

Ira,

The root of the issue is that the "Applicability Statement" begin as a companion documents to the EMAN Framework addressing the applicability of other standards and information models w.r.t. the EMAN framework.   Since then, use cases have also been added to the Applicability Statement document.

Use of the name 'Applicability' has lead to confusion that this document will also provide implementation guidelines and best practices. While such a document would be valuable, its not clear how it relates to abstract use cases and international and national standards bodies.

The Abstract of the Applicability statement claims:

        Abstract

        The objective of Energy Management (EMAN)is to provide an energy
        management framework for networked devices. This document
        presents the applicability of the EMAN framework for a variety
        of scenarios. This document lists use cases and target devices
        that can potentially implement the EMAN framework and associated
        SNMP MIB modules. These use cases are useful for identifying
        monitoring requirements that need to be considered. Further, we
        describe the relationship of the EMAN framework to relevant

other energy monitoring standards and architectures.

So, it might be more useful to think of this as the EMAN Framework Applicability Statement vs. an EMAN MIB Applicability/Implementation Guide.

Regards,

Brad

Brad Schoening
Engineering | Coraid
Tel: +1 917 304 7190
[email-masked]<mailto:[email-masked]> | www.coraid.com<http://www.coraid.com>
Coraid: Redefining Storage

From: Ira McDonald <[email-masked]<mailto:[email-masked]>>
Date: Tue, 15 Oct 2013 10:02:59 -0400
To: "Mouli Chandramouli (moulchan)" <[email-masked]<mailto:[email-masked]>>, Ira McDonald <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [eman] draft-ietf-eman-applicability-statement-03

Hi Mouli,

Cheers,
- Ira

Thanks
Mouli

_______________________________________________ eman mailing list [email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/eman

---

From: Ira McDonald <[email-masked]>
Date: Tue, 15 Oct 2013 16:42:00 -0400

Hi Brad,

Ah - I see (I think) - I was thinking about the implementation guidelines
(for MIBs or
other bindings of the EMAN Model).

I agree that Applicability for the external standards and EMAN use cases
seems
to be an obscure use of the word Applicability.

I'd prefer a different title, such as "EMAN Framework Standards Context".

And a second "EMAN MIBs Implementation Guide" document.

Does that make sense?

Cheers,
- Ira

On Tue, Oct 15, 2013 at 3:24 PM, Brad Schoening <[email-masked]> wrote:

>   Ira,
>
>  The root of the issue is that the "Applicability Statement" begin as a
> companion documents to the EMAN Framework addressing the applicability of
> other standards and information models w.r.t. the EMAN framework.   Since
> then, use cases have also been added to the Applicability Statement
> document.
>
>  Use of the name 'Applicability' has lead to confusion that this document
> will also provide implementation guidelines and best practices. While such
> a document would be valuable, its not clear how it relates to abstract use
> cases and international and national standards bodies.
>
>  So, it might be more useful to think of this as the EMAN Framework
> Applicability Statement vs. an EMAN MIB Applicability/Implementation Guide.
>
>  Regards,
>
>  Brad
>
>  *Brad Schoening*
> Engineering | Coraid
> Tel: +1 917 304 7190
> [email-masked] | www.coraid.com
>  *Coraid: Redefining Storage*
>
>
>   From: Ira McDonald <[email-masked]>
> To: "Mouli Chandramouli (moulchan)" <[email-masked]>, Ira McDonald <
> [email-masked]>
> Cc: "[email-masked]" <[email-masked]>
>>  Currently, the EMAN Applicability Statement draft as it stands
>>  contains – use cases and relation standards;  and does not have a
>> discussion of how the technologies developed in EMAN WG – EMAN Framework,
>> MIB modules can be implemented.
>>
>  _______________________________________________ eman mailing list
> [email-masked]://www.ietf.org/mailman/listinfo/eman
>