Subject: [eman] one-liner for the framework

From: Rolf Winter <[email-masked]>
Date: Wed, 6 Nov 2013 21:03:55 +0000

Hi,

could we add a line to the framework (maybe at the end of the intro or somewhere else but early in the text) that states that the framework does not specify which of these concepts and underlying data elements are mandatory or optional to implement?

Here's a suggestion for it:

Note that not all concepts and data items described in this document are mandatory for implementations. Specifications describing implementation of this framework need to be explicit about which of these are mandatory and which are optional to implement.

...or similar. 

Best,

Rolf

NEC Europe Ltd | Registered Office: Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB | Registered in England 2832014

---

From: "John Parello (jparello)" <[email-masked]>
Date: Wed, 6 Nov 2013 22:03:01 +0000

Awesome.  Thanks!
Jp

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rolf Winter
Sent: Wednesday, November 06, 2013 1:04 PM
To: [email-masked]
Subject: [eman] one-liner for the framework

Hi,

...or similar. 

Best,

Rolf

_______________________________________________
eman mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eman

---

From: Bruce Nordman <[email-masked]>
Date: Wed, 6 Nov 2013 14:07:33 -0800

Probably best to use Rolf's text, but in thinking about this earlier,
I concluded that the only truly mandatory items should be
a UUID and the type of an energy object.  Any implementation
would certainly have more than that, but could be different in
different ones.
--Bruce

On Wed, Nov 6, 2013 at 1:03 PM, Rolf Winter <[email-masked]> wrote:

> Hi,
>
> could we add a line to the framework (maybe at the end of the intro or
> somewhere else but early in the text) that states that the framework does
> not specify which of these concepts and underlying data elements are
> mandatory or optional to implement?
>
> Note that not all concepts and data items described in this document are
> mandatory for implementations. Specifications describing implementation of
> this framework need to be explicit about which of these are mandatory and
> which are optional to implement.
>
> ...or similar.
>
> Best,
>
> Rolf
>
> NEC Europe Ltd | Registered Office: Athene, Odyssey Business Park, West
> End  Road, London, HA4 6QE, GB | Registered in England 2832014
>
>

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
*nordman.lbl.gov <http://nordman.lbl.gov>*
[email-masked]
510-486-7089
m: 510-501-7943