Subject: [eman] DEFINITIONS and MODULE-IDENTITY

From: Benoit Claise <[email-masked]>
Date: Tue, 10 Dec 2013 12:08:12 +0100

MIB doctors,

One question regarding DEFINITIONS and MODULE-IDENTITY

Looking at 
https://datatracker.ietf.org/doc/draft-ietf-eman-energy-aware-mib/, I see

        ENERGY-OBJECT-CONTEXT-MIB  DEFINITIONS ::= BEGIN
          
         IMPORTS
             MODULE-IDENTITY,
             OBJECT-TYPE,
             mib-2,
             Integer32
                 FROM SNMPv2-SMI
             TEXTUAL-CONVENTION, MacAddress, TruthValue
                 FROM SNMPv2-TC
             MODULE-COMPLIANCE,
             OBJECT-GROUP
                 FROM SNMPv2-CONF
             SnmpAdminString
                 FROM SNMP-FRAMEWORK-MIB
             InetAddressType, InetAddress
                FROM INET-ADDRESS-MIB
             entPhysicalIndex
                FROM ENTITY-MIB
             UUIDorZero
                FROM UUID-TC-MIB
             IANAEnergyRelationship
                FROM IANA-ENERGY-RELATION-MIB;
          
         energyAwareMIBMODULE-IDENTITY
             LAST-UPDATED    "201311290000Z"

I guess that ENERGY-OBJECT-CONTEXT-MIB and energyAwareMIB, being 
different, would be flagged as a problem by the MIB doctors, correct?

The closest piece of information is from RFC 4181:

    - The descriptor associated with the MODULE-IDENTITY invocation
      should be of the form xxxMIB, xxxMib, or xxxMibModule, where xxx is
      a mixed-case version of XXX starting with a lowercase letter and
      without any hyphens.  For example, the OPT-IF-MIB uses the prefix
      optIf, and the descriptor associated with its MODULE-IDENTITY
      invocation is optIfMibModule.

Regards, Benoit

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 10 Dec 2013 07:50:36 -0500

I believe that is the convention that I have always used (and witnessed).

	--Tom

> Looking at https://datatracker.ietf.org/doc/draft-ietf-eman-energy-aware-mib/, I see 
> 
>         energyAwareMIB MODULE-IDENTITY 
> I guess that ENERGY-OBJECT-CONTEXT-MIB and energyAwareMIB, being different, would be flagged as a problem by the MIB doctors, correct?
> 
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors