Subject: [eman] Working Group Last Call for draft-ietf-eman-battery-mib-11

From: Thomas Nadeau <[email-masked]>
Date: Thu, 9 Jan 2014 09:54:21 -0800

The starts the Working Group Last call on draft-ietf-eman-battery-mib-11 that completes on Friday, January 24 at 8AM EDT.  Please send comments by responding to this message by no later than this date. 

	Thanks,

	Tom and Nevil

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 24 Jan 2014 12:22:01 +0000

Hi all,

I received a comment from an implementer who is not on this mailing list. He has a case where the use of object batteryIdentifier is not  clear.  

Some batteries are identified by the combination of a model number and a serial number, such as, for example, in the battery information model of ACPI. The issues is that it is not clear how to map these two objects to the single string-type object batteryIdentifier. Only providing the serial number as value of the batteryIdentifier may not be sufficient, because some battery serial numbers are unique only in combination with their model number.

My proposal for addressing this issue is making the following change:

OLD (in DESCRIPTION clause of object batteryIdentifier)
           The identifier is useful when batteries are removed and
           re-installed in the same or other devices. Then the device
           or the network management system can trace batteries and
           achieve continuity of battery monitoring.

           If the battery identifier cannot be represented using the
           ISO/IEC IS 10646-1 character set, then a hexadecimal
           encoding of a binary representation of the battery
           identifier must be used.
NEW
           The identifier is useful when batteries are removed and
           re-installed in the same or other devices. Then the device
           or the network management system can trace batteries and
           achieve continuity of battery monitoring.

           If the battery is identified by more than one value, for example,
           by a model number and a serial number, then the value of this
           object is a concatenation of these values, separated by the colon
           symbol ":". The values should be ordered that a more significant
           value comes before a less significant one. In the example above,
           the (more significant) model number would be first, the serial
           would follow: "<model number>:<serial number>".

           If the battery identifier cannot be represented using the
           ISO/IEC IS 10646-1 character set, then a hexadecimal
           encoding of a binary representation of the entire battery
           identifier must be used.
END

Cheers,
    Juergen

> -----Original Message-----
> From: eman [mailto:[email-masked]] On Behalf Of Thomas Nadeau
> Sent: Donnerstag, 9. Januar 2014 18:54
> To: eman mailing list
> Cc: [email-masked]
> Subject: [eman] Working Group Last Call for draft-ietf-eman-battery-mib-11
> 
> 
> 	The starts the Working Group Last call on draft-ietf-eman-battery-mib-
> 11 that completes on Friday, January 24 at 8AM EDT.  Please send comments
> by responding to this message by no later than this date.
> 
> 	Thanks,
> 
> 	Tom and Nevil
>