Subject: Re: [eman] WG Last Call for draft-ietf-eman-energy-monitoring-mib-08 and draft-ietf-eman-energy-aware-mib-13

From: Juergen Quittek <[email-masked]>
Date: Tue, 4 Feb 2014 12:18:18 +0000

Hi Brad,

I am much in line with what you write.

If a dual-supplied server receives power from two metering domains "supplyA" and "supplyB", then we can claim this server to be member of domain "supplyA,supplyB". A management system that supports only one domain per device would create a new domain called "supplyA,supplyB" (very similar to what you suggested, while a management system supporting multiple domains would model the server as a device with two memberships, one in domain "supplyA" and one in domain "supplyB".

Cheers,
    Juergen

> -----Original Message-----
> From: Brad Schoening [mailto:[email-masked]]
> Sent: Donnerstag, 30. Januar 2014 18:42
> To: Juergen Quittek; Thomas Nadeau; eman mailing list
> Subject: Re: [eman] WG Last Call for draft-ietf-eman-energy-monitoring-
> mib-08 and draft-ietf-eman-energy-aware-mib-13
> 
> Juergen,
> 
> In your dual power supply example, I would think of these as three
> domains: supplyA, supplyB and supplyAB.  The new domain supplyAB is a
> high-reliabliy domain.  You don't mention what the power policy of this new
> combined domain is, but there could be several choices for supplyAB.
> 
> Consider a more complicated example, you have a chassis with three power
> supply modules.  There are at least three different policies that could be
> applied:
> 
> - Power module redundancy - total power allowed is one less than the
> number of supply modules
>   E.g., total power is 2 x.
> 
> - Power module redundancy with throttling - total power allowed is equal to
> available power, but
>   requires consumers to throttle down if one module fails.  E.g., total power is
> between 2x and 3x.
> 
> - Basic power w/o redundancy - total power allowed is equal to all available
> power with no redundancy.  E.g., total power is 3x.
> 
> Combining power domains likely always invokes a policy and thus in the
> eman model, creates a new domain.
> 
> This approach is compatible with the chairs suggestion of MUST.
> 
> Regards,
> 
> 
> Brad
> 
> On 1/29/14 3:41 PM, "Juergen Quittek" <[email-masked]> wrote:
> 
> >1. Having a device limited to a single domain membership is a
> >limitation/feature of Cisco's EnergyWise for which in all the long
> >discussions we had in past year never any technical reason was given
> >(although it was asked for multiple times). In the contrary, I gave use
> >cases where it is REQUIRED to have two or more domains. An obvious
> >example is a highly reliable server that has dual power supply. Its two
> >power supply lines SHOULD be in different domains in order to be better
> >protected from local power supply failures. This server should be given
> >means to report via the MIB that it is member of two domains.

---

From: "John Parello (jparello)" <[email-masked]>
Date: Tue, 4 Feb 2014 16:00:51 +0000

To clarify to the list again JQ you are mistaken and I think this will confuse readers who only look at the email and not the code in the framework.

 This can be exactly modeled via the example i sent to the authors and list. I want to clarify so that anyone reading can get the correct example.

""""
 Domain is an attribute of the super class EnergyObject and available for components and PowerInterfaces. To use the psuedo code in the framework.
 
DeviceX.domain='foo'
DeviceX.powerInterfaces[1].domain='bar'
DeviceX.powerInterfaces[2].domain='bin
""""

This precisely models the case. The device has two power supplies modeled by power interfaces as inlets. Each supply is in a different domain. 

The technical reason for the scalar is that the container object is the vector not the attribute.
Jp

Sent from my iPad 
(expect ridiculous spelling mistakes) 

On Feb 4, 2014, at 4:18 AM, "Juergen Quittek" <[email-masked]> wrote:

> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: <[email-masked]>
Date: Tue, 4 Feb 2014 16:33:10 +0000

Hi John,

Thanks for the explanation!

Best regards,
Georgios

> From: eman [mailto:[email-masked]] On Behalf Of John Parello
> (jparello)
> Sent: dinsdag 4 februari 2014 17:01
> To: Juergen Quittek
> Cc: eman mailing list
> To clarify to the list again JQ you are mistaken and I think this will confuse
> readers who only look at the email and not the code in the framework.
> 
>  This can be exactly modeled via the example i sent to the authors and list. I
> want to clarify so that anyone reading can get the correct example.
> 
> 
> """"
>  Domain is an attribute of the super class EnergyObject and available for
> components and PowerInterfaces. To use the psuedo code in the
> framework.
> 
> DeviceX.domain='foo'
> This precisely models the case. The device has two power supplies modeled
> by power interfaces as inlets. Each supply is in a different domain.
> 
> > If a dual-supplied server receives power from two metering domains
> "supplyA" and "supplyB", then we can claim this server to be member of
> domain "supplyA,supplyB". A management system that supports only one
> domain per device would create a new domain called "supplyA,supplyB"
> (very similar to what you suggested, while a management system supporting
> multiple domains would model the server as a device with two
> memberships, one in domain "supplyA" and one in domain "supplyB".
> >
> > Cheers,
> >    Juergen
> >
> >> high-reliabliy domain.  You don't mention what the power policy of
> >> this new combined domain is, but there could be several choices for
> supplyAB.
> >>
> >> Consider a more complicated example, you have a chassis with three
> >> power supply modules.  There are at least three different policies
> >> that could be
> >> applied:
> >>
> >> number of supply modules  E.g., total power is 2 x.
> >>
> >> - Power module redundancy with throttling - total power allowed is
> >> equal to available power, but  requires consumers to throttle down if
> >> one module fails.  E.g., total power is between 2x and 3x.
> >>
> >> - Basic power w/o redundancy - total power allowed is equal to all
> >> available power with no redundancy.  E.g., total power is 3x.
> >>
> >> Combining power domains likely always invokes a policy and thus in
> >> the eman model, creates a new domain.
> >>
> >>> (although it was asked for multiple times). In the contrary, I gave
> >>> use cases where it is REQUIRED to have two or more domains. An
> >>> obvious example is a highly reliable server that has dual power
> >>> supply. Its two power supply lines SHOULD be in different domains in
> >>> order to be better protected from local power supply failures. This
> >>> server should be given means to report via the MIB that it is member of
> two domains.
> >