Subject: [eman] I-D Action: draft-ietf-eman-battery-mib-12.txt

From: [email-masked]
Date: Thu, 06 Mar 2014 06:39:34 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Energy Management Working Group of the IETF.

        Title           : Definition of Managed Objects for Battery Monitoring
        Authors         : Juergen Quittek
                          Rolf Winter
                          Thomas Dietz
	Filename        : draft-ietf-eman-battery-mib-12.txt
	Pages           : 34
	Date            : 2014-03-06

Abstract:
   This memo defines a portion of the Management Information Base (MIB)
   for use with network management protocols in the Internet community.
   In particular, it defines managed objects that provide information on
   the status of batteries in managed devices.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-eman-battery-mib/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-eman-battery-mib-12

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-eman-battery-mib-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 7 Mar 2014 10:22:41 +0000

Dear all,
This update addresses the comments received during WGLC.
Below please find a list of changes compared to version -11. 
If there are no problems with the way that issues raised 
during WGLC have been addressed, then work on this draft 
is done and we can request publication.
Cheers,
    Juergen

List of changes since version -11:

1. editorial changes improving readability, fixing a typo

2. Types of charge and capacity objects
In Version -09 we changed the type of object batteryActualCharge 
from Unsigned32 to Unsigned64TC in order to batteries with
large capacity. This was fine, but there are other objects dealing
with the same issue:
- batteryDesignCapacity
- batteryActualCapacity
- batteryAlarmLowCharge
- batteryAlarmLowCapacity
They all are defined in units of milliampere hours.
The new version uses Unsigned64TC for all these objects.

3.  Compliance with ACPI
ACPI uses two objects for identifying a battery: model no. and serial no. 
The Battery MIB has just one object, the batteryIdentifier.
We added text to the DESCRIPTION clause of object batteryIdentifier
About how to embed the two ACPI objects into the single object.

4. Limiting notification rates
For two notification we did not have rate limitations, the
batteryTemperatureNotification and the batteryAgingNotification.
We added text on this to the respective DESCRIPTION clauses and

5. Relaxing rate limitations 
For notifications  batteryLowNotification and  batteryCritical Notification
we had rate limitations in place, but these were too strict in some cases.
We relaxed them adding text to the respective DESCRIPTION clauses.

> -----Original Message-----
> From: eman [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Donnerstag, 6. März 2014 15:40
> To: [email-masked]
> Cc: [email-masked]
> Subject: [eman] I-D Action: draft-ietf-eman-battery-mib-12.txt
> 
> 
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman