Subject: [eman] I-D Action: draft-ietf-eman-battery-mib-20.txt

From: [email-masked]
Date: Fri, 17 Apr 2015 05:42:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Energy Management Working Group of the IETF.

        Title           : Definition of Managed Objects for Battery Monitoring
        Authors         : Juergen Quittek
                          Rolf Winter
                          Thomas Dietz
	Filename        : draft-ietf-eman-battery-mib-20.txt
	Pages           : 39
	Date            : 2015-04-17

Abstract:
   This memo defines a portion of the Management Information Base (MIB)
   for use with network management protocols in the Internet community.
   In particular, it defines managed objects that provide information on
   the status of batteries in managed devices.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-eman-battery-mib/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-eman-battery-mib-20

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-eman-battery-mib-20

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 17 Apr 2015 13:03:32 +0000

Dear all,

Draft-ietf-eman-battery-mib has been approved by the IESG and is now ready to be added to the RFC Editor's queue.

We had version -17 in the IESG review for a long time. The main remaining issue to solve from version -17 was to address a DISCUSS from AD Pete Resnick that was related to the abstraction of the battery charging process chosen in the MIB module. We agreed with Pete, that we do not want to support many features from various charging technologies for various battery technologies. We rather want to offer a simple generic model for charging and discharging a battery.

We needed three revisions to converge on a solution that was agreeable by everyone. That's why I describe here the changes from version -17 to the current -20:

1. We added four paragraphs to the introduction explaining that we the Battery MIB module uses a simple common charging model with batteries being in one of the states 'charging', 'maintaining charge', 'not charging', and 'discharging'.

2. We added a new section 3.5 describing this model and how to control it using object batteryChargingAdminState.

3. in the MIB module we modified object batteryChargingOperState by removing state "fastCharging" and we modified object batteryChargingAdminState by removing states "fastCharging" and "maintainingCharge".

Please have a look at the changes and send your comments.

Thanks,
    Juergen

> -----Original Message-----
> From: eman [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Freitag, 17. April 2015 14:43
> To: [email-masked]
> Cc: [email-masked]
> Subject: [eman] I-D Action: draft-ietf-eman-battery-mib-20.txt
> 
> 
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: joel jaeggli <[email-masked]>
Date: Fri, 17 Apr 2015 12:00:30 -0700

FYI, baring any additional commentary I will be approving COB on monday.

Thanks for the effort.
joel