Subject: [eman] energy-specific efforts at IETF?

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 1 Jun 2016 14:34:56 +0200

Hi,

Is there any other effort focusing on energy consumption happening at 
IETF currently?

I am interested in aspects related to energy consumption of IP networks 
used to deliver video streams.

Yours,

Alex Petrescu

Le 09/06/2015 à 05:01, Mouli Chandramouli (moulchan) a écrit :
> Thanks to all the WG chairs for shepherding the IETF drafts and taking
> them to a conclusion.
> I may not be able to travel to Prague.  So, enjoy.
>
> Cheers
> Mouli
>
> From: Nadeau Thomas <[email-masked]
> <mailto:[email-masked]>>
> Date: Saturday, 6 June 2015 2:22 AM
> To: "Benoit Claise (bclaise)" <[email-masked] <mailto:[email-masked]>>
> Cc: eman mailing list <[email-masked] <mailto:[email-masked]>>,
> "[email-masked] <mailto:[email-masked]>"
> <[email-masked] <mailto:[email-masked]>>
> Subject: Re: [eman] Status of the EMAN W.G. effort.
>
>
>     Beers are on you! 8)
>
>
>>     On Jun 5, 2015:4:46 PM, at 4:46 PM, Benoit Claise
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     Yes, thanks to the contributors, document editors, WG chairs,
>>     previous ADs :-), basically the entire EMAN community.
>>     Celebration in Prague? Fine with me.
>>
>>     Regards, Benoit
>>>     Greetings,
>>>
>>>     Now that we've crossed the milstone of having
>>>     draft-ietf-eman-applicability-statement-11 move to the RFC editor queue,
>>>     I think we can pause and reflect on the effort that has completed. It
>>>     took a while to get here and the consensus that we built was hard won
>>>     but I hope durable.
>>>
>>>     It's my intention to close down the working group, maintaining the
>>>     mailing list for a time. The mailing list archive as with other IETF
>>>     mailing lists will be preserved. in the immediate sense if there is work
>>>     around the edges of this space we have the opsawg working group to
>>>     support such activities.
>>>
>>>     Thank you again for your diligent efforts, especially the present and
>>>     former chairs who shepherded this work to the point that it is at now.
>>>
>>>     Regards
>>>     Joel
>>>
>>>
>>>
>>>     _______________________________________________
>>>     eman mailing list
>>>     [email-masked]://www.ietf.org/mailman/listinfo/eman
>>
>>     _______________________________________________
>>     eman mailing list
>>     [email-masked] <mailto:[email-masked]>
>>     https://www.ietf.org/mailman/listinfo/eman
>
>
>
> _______________________________________________
> eman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman
>

---

From: Nadeau Thomas <[email-masked]>
Date: Wed, 1 Jun 2016 14:00:15 -0400

Not that I know of in the form of an official working group. EMAN was shut down something like a year ago.

	--Tom

> On Jun 1, 2016:8:34 AM, at 8:34 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> Hi,
> 
> Is there any other effort focusing on energy consumption happening at IETF currently?
> 
> I am interested in aspects related to energy consumption of IP networks used to deliver video streams.
> 
> Yours,
> 
> Alex Petrescu
>

---

From: Rolf Winter <[email-masked]>
Date: Thu, 2 Jun 2016 10:18:46 +0200

Is there anything that the EMAN work is not addressing or that
requires new protocol work?

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 2 Jun 2016 10:22:15 +0200

> requires new protocol work?

For my clarification - is the battery monitoring MIB RFC7577 using YANG?

Alex

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 2 Jun 2016 09:20:51 +0000

No, RFC 7577 defines an SMIv2 MIB. 

Before engaging in a discussion about 'let us do EMAN data modelling in YANG' I would like to see a use case - i.e. an example of an energy monitoring system that uses YANG for reporting energy information. 

Regards,

Dan

> -----Original Message-----
> From: eman [mailto:[email-masked]] On Behalf Of Alexandre
> Petrescu
> Sent: Thursday, June 02, 2016 11:22 AM
> To: Rolf Winter; Nadeau Thomas
> Cc: [email-masked]
> Subject: Re: [eman] energy-specific efforts at IETF?
> 
> 
> 
> >>>> Thanks to all the WG chairs for shepherding the IETF drafts and
> >>>> taking them to a conclusion.

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 28 Jun 2016 16:54:35 +0200

The SDN paradigm may be applied not just to switches but to smartphones. 
  Further, a tool like CoMI (CoAP Management Interface) may make use of 
YANG models on IoT devices which are typically constrained on battery.

Yesterday I read about an NB-IoT LPWA device from u-blox which runs on a 
battery for 10 years.

Alex

Le 02/06/2016 à 11:20, Romascanu, Dan (Dan) a écrit :
> Before engaging in a discussion about 'let us do EMAN data modelling
> in YANG' I would like to see a use case - i.e. an example of an
> energy monitoring system that uses YANG for reporting energy
> information.
>
> Regards,
>
> Dan
>
>
>> -----Original Message----- From: eman
>> [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
>> Sent: Thursday, June 02, 2016 11:22 AM To: Rolf Winter; Nadeau
>> Thomas Cc: [email-masked] Subject: Re: [eman] energy-specific
>> efforts at IETF?
>>
>>
>>
>>>> Not that I know of in the form of an official working group.
>>>> EMAN was
>> shut down something like a year ago.
>>>>
>>>> --Tom
>>>>
>>>>>> Thanks to all the WG chairs for shepherding the IETF drafts
>>>>>> and taking them to a conclusion. I may not be able to
>>>>>> travel to Prague.  So, enjoy.
>>>>>>
>>>>>> Cheers Mouli
>>>>>>
>>>>>> <mailto:[email-masked]>> Date: Saturday, 6 June
>>>>>> 2015 2:22 AM To: "Benoit Claise (bclaise)"
>>>>>> <[email-masked] <mailto:[email-masked]>> Cc: eman
>>>>>> mailing list <[email-masked] <mailto:[email-masked]>>,
>>>>>> <[email-masked]
>>>>>> <mailto:[email-masked]>> Subject: Re: [eman]
>>>>>> Status of the EMAN W.G. effort.
>>>>>>
>>>>>>
>>>>>> Beers are on you! 8)
>>>>>>
>>>>>>
>>>>>>> Yes, thanks to the contributors, document editors, WG
>>>>>>> chairs, previous ADs :-), basically the entire EMAN
>>>>>>> community. Celebration in Prague? Fine with me.
>>>>>>>
>>>>>>> Regards, Benoit
>>>>>>>> Greetings,
>>>>>>>>
>>>>>>>> draft-ietf-eman-applicability-statement-11 move to the
>>>>>>>> RFC editor
>> queue,
>>>>>>>> I think we can pause and reflect on the effort that has
>>>>>>>> completed.
>> It
>>>>>>>> took a while to get here and the consensus that we
>>>>>>>> built was hard
>> won
>>>>>>>> but I hope durable.
>>>>>>>>
>>>>>>>> It's my intention to close down the working group,
>>>>>>>> maintaining the mailing list for a time. The mailing
>>>>>>>> list archive as with other IETF mailing lists will be
>>>>>>>> preserved. in the immediate sense if there is
>> work
>>>>>>>> around the edges of this space we have the opsawg
>>>>>>>> working group
>> to
>>>>>>>> support such activities.
>>>>>>>>
>>>>>>>> Thank you again for your diligent efforts, especially
>>>>>>>> the present and former chairs who shepherded this work
>>>>>>>> to the point that it is at
>> now.
>>>>>>>>
>>>>>>>> Regards Joel
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 28 Jun 2016 15:10:26 +0000

Sure. But your two statements (in the first paragraph) use each of the conditional 'may'. What is the reason to use YANG on the devices? The SDN paradigm does not AFAIK make assumptions about using a specific protocol or DML at the device management level. YANG comes at a certain cost (bits on wire, memory). Maybe this is affordable, or maybe YANG is needed for other reasons, but this needs to be shown explicitely. 

Regards,

Dan

> From: Alexandre Petrescu [mailto:[email-masked]]
> Sent: Tuesday, June 28, 2016 5:55 PM
> To: Romascanu, Dan (Dan); Rolf Winter; Nadeau Thomas
> Cc: [email-masked]
> > in YANG' I would like to see a use case - i.e. an example of an energy
> > monitoring system that uses YANG for reporting energy information.
> >
> > Regards,
> >
> > Dan
> >
> >
> >> -----Original Message----- From: eman [mailto:[email-masked]]
> >> On Behalf Of Alexandre Petrescu
> >> Sent: Thursday, June 02, 2016 11:22 AM To: Rolf Winter; Nadeau Thomas
> >> Cc: [email-masked] Subject: Re: [eman] energy-specific efforts at
> >> IETF?
> >>
> >>
> >>
> >>>>>> taking them to a conclusion. I may not be able to travel to
> >>>>>> Prague.  So, enjoy.
> >>>>>>
> >>>>>> Cheers Mouli
> >>>>>>
> >>>>>> <[email-masked] <mailto:[email-masked]>> Cc: eman mailing
> >>>>>> list <[email-masked] <mailto:[email-masked]>>,
> >>>>>> <mailto:[email-masked]>> Subject: Re: [eman] Status
> >>>>>> of the EMAN W.G. effort.
> >>>>>>
> >>>>>>
> >>>>>> Beers are on you! 8)
> >>>>>>
> >>>>>>
> >>>>>>>> draft-ietf-eman-applicability-statement-11 move to the RFC
> >>>>>>>> editor
> >> queue,
> >>>>>>>> took a while to get here and the consensus that we built was
> >>>>>>>> hard
> >> won
> >>>>>>>> but I hope durable.
> >>>>>>>>
> >>>>>>>> It's my intention to close down the working group, maintaining
> >>>>>>>> the mailing list for a time. The mailing list archive as with
> >>>>>>>> other IETF mailing lists will be preserved. in the immediate
> >>>>>>>> sense if there is
> >> work
> >>>>>>>> around the edges of this space we have the opsawg working
> group
> >> to
> >>>>>>>> support such activities.
> >>>>>>>>
> >>>>>>>> Thank you again for your diligent efforts, especially the
> >>>>>>>> present and former chairs who shepherded this work to the point
> >>>>>>>> that it is at
> >> now.
> >>>>>>>>
> >>>>>>>> Regards Joel
> >

---

From: joel jaeggli <[email-masked]>
Date: Wed, 29 Jun 2016 21:49:53 -0700

On 6/28/16 8:10 AM, Romascanu, Dan (Dan) wrote:
> Sure. But your two statements (in the first paragraph) use each of
> the conditional 'may'. What is the reason to use YANG on the devices?
> The SDN paradigm does not AFAIK make assumptions about using a
> specific protocol or DML at the device management level. YANG comes
> at a certain cost (bits on wire, memory). Maybe this is affordable,
> or maybe YANG is needed for other reasons, but this needs to be shown
> explicitely.

Signaling presumes in some utility is derived from coordination.

If I have a ten year primary battery or I'm a space probe headed to
alpha centuri I'm not going to devote a lot of electrons to expressing
my power consumption or battery condition.

More active or particularly coordinated groups of devices such as the
elements of a BST or a datacenter might well have information to share.

> Regards,
> 
> Dan
> 
> 
>> -----Original Message----- From: Alexandre Petrescu
>> [mailto:[email-masked]] Sent: Tuesday, June 28, 2016
>> 5:55 PM To: Romascanu, Dan (Dan); Rolf Winter; Nadeau Thomas Cc:
>> [email-masked] Subject: Re: [eman] energy-specific efforts at IETF?
>> 
>> The SDN paradigm may be applied not just to switches but to
>> smartphones. Further, a tool like CoMI (CoAP Management Interface)
>> may make use of YANG models on IoT devices which are typically
>> constrained on battery.
>> 
>> Yesterday I read about an NB-IoT LPWA device from u-blox which runs
>> on a battery for 10 years.
>> 
>> Alex
>> 
>>> Before engaging in a discussion about 'let us do EMAN data
>>> modelling in YANG' I would like to see a use case - i.e. an
>>> example of an energy monitoring system that uses YANG for
>>> reporting energy information.
>>> 
>>> Regards,
>>> 
>>> Dan
>>> 
>>> 
>>>>> Is there anything that the EMAN work is not addressing or
>>>>> that requires new protocol work?
>>>> 
>>>>>> Not that I know of in the form of an official working
>>>>>> group. EMAN was
>>>>>>>> Thanks to all the WG chairs for shepherding the IETF
>>>>>>>> drafts and taking them to a conclusion. I may not be
>>>>>>>> able to travel to Prague.  So, enjoy.
>>>>>>>> 
>>>>>>>> Cheers Mouli
>>>>>>>> 
>>>>>>>> <mailto:[email-masked]>> Date: Saturday, 6
>>>>>>>> June 2015 2:22 AM To: "Benoit Claise (bclaise)" 
>>>>>>>> <mailto:[email-masked]>> Subject: Re:
>>>>>>>> [eman] Status of the EMAN W.G. effort.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Beers are on you! 8)
>>>>>>>> 
>>>>>>>> 
>>>>>>>>>> draft-ietf-eman-applicability-statement-11 move to
>>>>>>>>>> the RFC editor
>>>> queue,
>>>>>>>>>> I think we can pause and reflect on the effort that
>>>>>>>>>> has completed.
>>>> It
>>>>>>>>>> maintaining the mailing list for a time. The
>>>>>>>>>> mailing list archive as with other IETF mailing
>>>>>>>>>> lists will be preserved. in the immediate sense if
>>>>>>>>>> there is
>>>> work
>>>>>>>>>> working
>>>>>>>>>> Thank you again for your diligent efforts,
>>>>>>>>>> especially the present and former chairs who
>>>>>>>>>> shepherded this work to the point that it is at
>>>> now.
>>>>>>>>>> 
>>>>>>>>>> Regards Joel
>>> 
> _______________________________________________ eman mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/eman
>